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Legal information 
Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

 DANGER 
indicates that death or severe personal injury will result if proper precautions are not taken. 

 
 WARNING 

indicates that death or severe personal injury may result if proper precautions are not taken. 
 

 CAUTION 
indicates that minor personal injury can result if proper precautions are not taken. 

 
 NOTICE 

indicates that property damage can result if proper precautions are not taken. 
If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems. 

Proper use of Siemens products 
Note the following: 

 WARNING 
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 
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Introduction 1 
 

Product overview 
 
Product Description Article number 
SIDOOR SOFTWARE KIT The package includes the following components: 

• Installations CD (SOFTWARE KIT) 
– SIDOOR User Software 
– Siemens HCS12 firmware loader 
– SIDOOR USB to UART Bridge Driver 
– SIDOOR Manager 
– Licensing provisions 
– SIDOOR SOFTWARE KIT Operating Instructions 

• 1 x USB adapter 
• 1 x USB connecting cable 
• 1x Sub-D connecting cable (9-pin, plug / socket) 
• 1x Sub-D connecting cable (9-pin, socket / socket) 

6FB1105-0AT01-6SW0 

The entire contents of the installation CD from the SIDOOR SOFTWARE KIT are also available 
Installation package (http://support.automation.siemens.com/WW/view/en/92418945) in the 
Industry Online Support. 

http://support.automation.siemens.com/WW/view/en/92418945
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System requirements 
• PC with Intel x86 compatible processor 

• Windows (XP / Vista / Windows 7 / Windows 8) 

 
  Note 

The SIDOOR SOFTWARE KIT is suitable for Windows 10. 
 

• Microsoft .NET Framework 2.0 / 3.5 (only required for SIDOOR Manager) 
(Internet connection may be required for post-installation). 

• USB port 

• LAN connection (only required for SIDOOR Manager) 

• Minimum screen resolution 1280 x 800 pixels 

• At least 100 MB free hard disk space 

• At least 256 MB RAM 

• Authorization to install hardware and software (administrator rights) 

• CD ROM drive (for installation from CD) 

Microsoft .NET Framework 2.0 / 3.5 

To run the SIDOOR User Software / SIDOOR Manager on Windows XP or Windows 8, post-
installation or activation of Microsoft .NET Framework 2.0 or 3.5 is required, as it is not 
included by default with Windows Vista or Windows 7.  

Further information: 

• Downloading and installing Microsoft .NET Framework 2.0 on Windows XP 
(http://www.microsoft.com/en-US/download/details.aspx?id=1639) 

• Downloading and installing Microsoft .NET Framework 3.5 on Windows XP 
(http://www.microsoft.com/en-US/download/details.aspx?id=25150) 

• Activating Microsoft .NET Framework 2.0 / 3.5 on Windows 8 
(http://support.microsoft.com/kb/2785188/en) 

PDF reader 

A PDF reader is required to open and display .pdf files. "Adobe Reader" is one such program 
and can be downloaded free of charge from: http://get.adobe.com/reader/ 

http://www.microsoft.com/en-US/download/details.aspx?id=1639
http://www.microsoft.com/en-US/download/details.aspx?id=25150
http://support.microsoft.com/kb/2785188/en
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General safety instructions 2 
 

Security information 
Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, systems, machines and networks. 

In order to protect plants, systems, machines and networks against cyber threats, it is 
necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial 
security concept. Siemens’ products and solutions constitute one element of such a concept. 

Customers are responsible for preventing unauthorized access to their plants, systems, 
machines and networks. Such systems, machines and components should only be connected 
to an enterprise network or the internet if and to the extent such a connection is necessary 
and only when appropriate security measures (e.g. firewalls and/or network segmentation) 
are in place.  

For additional information on industrial security measures that can be implemented, please 
visit (https://www.siemens.com/industrialsecurity). 

Siemens' products and solutions undergo continuous development to make them more 
secure. Siemens strongly recommends that product updates are applied as soon as they are 
available and that the latest product versions are used. Use of product versions that are no 
longer supported, and failure to apply the latest updates may increase customers' exposure to 
cyber threats.  

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS 
Feed under (https://www.siemens.com/industrialsecurity). 

https://www.siemens.com/industrialsecurity
https://www.siemens.com/industrialsecurity
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Installation 3 
 

Please note the following prior to installation: 
 

 Note 
If a USB adapter is connected, it can cause a faulty installation. 

Do not connect the USB adapter to the PC until the installation of the "SIDOOR SOFTWARE 
KIT" has been successfully completed. 

 

Start the Setup 
Run the file "setup_SIDOOR_software_kit_complete.exe". The subsequent installation process 
is interactive.  

The following dialog guidance is based on Windows 7. The dialog guidance under other 
Windows versions may differ slightly visually. 

Select the Setup language 

 

Select the language English or German, and confirm with "OK". 
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Setup Wizard 

 

Click "Next" to follow the wizard. 

License agreement 

 

Accept the agreement, and click "Next" to follow the wizard. If you do not accept the terms of 
the license agreement, the installation cannot be continued.  

You can cancel the installation by clicking the "Cancel" button. 



 Installation 
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Select destination location 

 

If you do not want to install the program in the default folder, you can use the "Browse" 
button to select a different folder.  

Click "Next" to continue with the wizard. 
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Select components 

 
 
Component Description 
SIDOOR User Soft-
ware 

This component enables the door control system to be configured, parameter-
ized and analyzed. 

Siemens HCS12 
Firmware Loader 

Installation of this component is only recommended for experienced users.  
It is used to update the door control unit's operating software. 

SIDOOR USB to UART 
Bridge Driver 

This driver is essential for operation of the USB adapter. 

SIDOOR Manager Installation of this component is only recommended for experienced users. 
This component is used for updating the operating software of the door con-
trol unit especially for machine tools with PROFINET connection. 

By setting / clearing the check marks for the individual components, you can select or 
deselect the corresponding installation. The recommended components are selected by 
default. If components previously installed on the computer have not been uninstalled, the 
selection may differ from that shown here.  

Click "Next" to continue with the wizard. 
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Select Start menu folder 

 

You can change the folder or folder name in the Start menu. This is done by clicking the 
"Browse..." button.  

Click "Next" to continue with the wizard. 
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Select additional tasks 

 

Here you select whether a desktop shortcut to the "SIDOOR User Software" should be created. 
If the check mark is not set, the corresponding program can only be started from the entry in 
the Start menu.  

Click "Next" to continue with the wizard. 
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Perform installation 

 

You can check the installation settings here again before starting the actual installation. Click 
the "Install" button to continue the installation. 
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Continue the installation of the "USB to UART Driver" software by clicking "Next". 

 

Click "Finish" to complete the installation of the "USB to UART Driver" software". 

Connect the USB adapter 

 

Connect the USB adapter to the PC.  

Windows automatically detects and installs the new hardware as soon as the USB adapter is 
connected. 
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Finish the installation 

 

Now click the "Finish" button to successfully complete the installation.  
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Uninstalling the software 4 
 

The SIDOOR SOFTWARE KIT can be uninstalled via the corresponding Start menu entry from 
the SIDOOR SOFTWARE KIT with the entry "Remove SIDOOR SOFTWARE KIT". 
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SIDOOR User Software 5 
5.1 Introduction 

"SIDOOR User Software" enables the configuration, parameterization and analysis of the door 
control system.  

This documentation describes in compact form the main functions of the SIDOOR User 
Software as well as the essential operating options. 

5.2 Starting SIDOOR User Software 

Prerequisites 
The USB adapter must be connected to the USB port on the PC in order to establish 
communication successfully. The door control unit must also be connected to the USB 
adapter by the 9-pin connecting cable. The door control unit has to be switched on, as 
otherwise only the driving parameters can be selected. 

Start the software 
You start the SIDOOR User Software via the Start menu "SIDOOR SOFTWARE KIT" > "SIDOOR 
User Software" or via the desktop link "SIDOOR User Software". 

When the program is started, the door control unit is automatically searched for in order to 
establish communication. If the controller is not automatically detected, click the "Connect to 
the door control unit" button. 
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Structure of the user interface 
After starting the "SIDOOR User Software" program, the following window appears on the 
screen if communication has been successfully established. 

The title bar displays the firmware version of the connected controller. The status of the 
connection is shown in the status bar. 

 

Set the language 
Select the language required using the appropriate flag. 

Main functions of SIDOOR User Software 
You can call up the main functions of the SIDOOR User Software using the "Service Tool 
emulation", "Driving parameters", "Oscilloscope" or "Door commands" buttons. 
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5.3 Connect to the door controller 
Clicking the "Connect to the door controller" button again opens a list box. The list displays all 
the free serial interfaces on the PC.  

If a particular serial port is not displayed, it is probably being used by another program. The 
port currently being used by the door controller is shown as "presently in use".  

Clicking the "No com" entry disconnects the door controller.  

The list box closes automatically once a port has been selected and connection established 
successfully. 
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5.4 SIDOOR SERVICE TOOL Emulation 
The SIDOOR SERVICE TOOL emulation emulates the SERVICE TOOL. 

 

The "Main menu" button brings you back to the main menu of the "SIDOOR User Software". 
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5.5 Driving parameters 
When the Driving parameters are started, the parameters are read out automatically from the 
door controller if communication has been established. 
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Select a profile 

 

You can select and activate a defined profile in the "Profile selection" window. The profiles are 
stored in the door controller. 

If you click a driving value on the left-hand side of the Driving parameters menu, this value is 
highlighted in the motion curve mapped on the right. Similarly, clicking a ramp or another 
value in the driving curve diagram highlights the associated value in the parameter list so it 
can be easily found. 

Changing a value immediately changes the shape of the driving curve displayed. 

Help is provided in the top right-hand window of the menu. This shows the adjustment limits 
of the current parameter and also indicates when a limit is exceeded. 

Loading and saving parameter data 
In the Driving parameters, you can easily load, modify, and save again all adjustable 
parameters. Parameters can be loaded and saved in both the door controller and in a text file 
on the PC. 

This means you can use the driving curves stored on the PC to commission another door of 
the same type. The following buttons are available for this purpose: 

• Load data from the door controller 

• Transfer data to the door controller 

• Load data from a file 

• Save data to a file 

Door commands 
The door can be moved as required using the "Door commands" button. 

See Chapter Door commands (Page 26). 
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Additional parameters 
Some door controllers (e.g. for railway interior doors) support additional, controller-specific 
parameters. For these controllers, the "Additional parameters" button is displayed above the 
"Main menu" button. 

 

The following table shows which additional parameters are available and can be 
parameterized in the "Additional parameters" menu for the specific controller connected:  
 
Controller Parameter 
ATD400K Hold-open time standard 

Hold-open time cord-operated switch 
Opening width as a percentage 

ATD4xxW Limit energy close 
Limit energy open 
Limit energy (reduced) 
Partly open width 

ATD400T Hold-open time after OPEN command 
Hold-open time after motion detector 
Hold-open time after blockage 
Delay time in wait mode CLS 
Delay time in wait mode OPEN 
Number of blockages before wait mode CLS 
Number of blockages before wait mode OPEN 
Limited time motion detector 
Time delay before movement 
Reversal distance CLS 
X11 mode 
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The newly set parameters are transferred to the door controller by clicking the "Transfer data 
to the door controller" button. 

Click the "Main menu" button to exit the Driving parameters. 
 

 WARNING 

Danger of crushing and bruising! 

It is essential that a new learn run is made during ongoing operation after accepting another 
profile so that the closing and nudging speeds can be limited as a function of the door 
weight. 

 

5.6 Oscilloscope function 
The oscilloscope function enables the door speed and the distance traveled to be recorded in 
a 60 second window (single run) or continuously (roll). 

 

Door commands 
The door can be moved as required using the "Door commands" button. 

See Chapter Door commands (Page 26). 
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Settings 

 

You can set the scale for the distance and recorded speeds with the "Settings" button.  

Zoom 
The zoom function enables an area of the time axis to be shown magnified in the large 
diagram window. Either enter the area to be displayed in the "Zoom" field, or select the area 
to be magnified in the recording window with the mouse. 

Define the starting point of the zoom area with the left mouse button, and the end point with 
the right mouse button. The selected segment is indicated by a lighter background color, and 
shown magnified in the large window. 

Save zoom data 
The "Save zoom data" button saves the measured values in a file (CSV format).  

Exit oscilloscope 
Click the "Main menu" button to exit the oscilloscope. 
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5.7 Door commands 

 

The input signals of the door control system can be simulated in the "Door commands" 
window, and the door moved in accordance with the buttons clicked. 
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HCS12 Firmware Loader 6 
6.1 Introduction 

You can use the Siemens HCS Firmware Loader to update the operating software on the door 
controller, i.e. install new firmware. 

These instructions shows the steps required to update the firmware. 

6.2 Connect the door controller 

Connect the door controller 
Proceed as follows: 

1. Connect the USB adapter to the PC. 

2. Connect the door controller to the USB adapter. 

 
  Note 

The controller must not yet be supplied with power. 

The HCS12 Firmware Loader detects the controller as soon as the power is switched on, so 
therefore it must be started first.  

 



HCS12 Firmware Loader  
6.3 Operating the HCS12 Firmware Loader 

 SIDOOR SOFTWARE KIT 

28 Operating Instructions, 10/2021, A5E34340431A/RS-AD/004 

6.3 Operating the HCS12 Firmware Loader 

Start the Firmware Loader 
You start the program either with a double-click on the desktop icon "Siemens HCS12 
Firmware Loader V1.xx" or in the Start menu under  
"Start" > "Programs" > "SIDOOR SOFTWARE KIT" > "Siemens HCS12 Firmware Loader V1.xx". 

Select the language 
After the application has started, select the desired language by clicking either the USA/GB or 
German flag. 
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Select firmware file and serial port, switch on controller. 
1. Use the "Browse..." button to select the corresponding update file (*.sx file). 

2. In the "Serial connection" selection menu, select the entry "Siemens SIDOOR USB to UART 
Bridge Controller (COMn)" as the interface to the controller. 

3. Switch on the controller or the power supply to the controller. The status message 
"Connection established" then appears in the lower status window. 
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Start the update 
Click the "Start update" button to start the update process. The status bar indicates the 
progress of the update process. 

 
 

 Note 

The connections to the PC and the power supply must not be interrupted during the update 
process, otherwise the process must be repeated. The controller will not function again until 
the update process has been successfully completed.  
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After the new firmware file has been written successfully to the controller, the new version ID 
appears in the "Application version" status window. 

 

Start the new application 
Click the "Start application" button to start the new application on the controller. 

Alternatively, you can start the new application by switching the controller off and on again.  
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SIDOOR Manager 7 
7.1 Introduction 

The Siemens SIDOOR Manager can be used to update the operating software of the door 
control unit (basic module ATxx and/or the PROFINET module) via TCP/IP, i.e. to install a new 
firmware. A SIDOOR firmware file (*.sid file) is required for an update. The Siemens SIDOOR 
Manager can alternatively be started in batch mode to install a new firmware on multiple 
door control units in parallel. 

The sequences required for the firmware update are shown below. 

7.2 Connecting the door controller 
1. Connect the door controller to the PC via Ethernet. 

2. Make sure the network and/or TCP/IP settings have been configured appropriately for the 
device. 

The PC and the device must be in the same network segment, or it must be possible for 
them to connect via TCP/IP. 
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7.3 Operating the SIDOOR Manager 

Start the Service Tool 
1. Start the program in one of the following two ways: 

– Double-click on the "SIDOOR Manager V1.xx" desktop icon 

– Start menu: "Start" > "Programs" > "SIDOOR SOFTWARE KIT" > "SIDOOR Manager V1.xx" 

2. The following Welcome screen appears when the application is started. 
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Select the language 
After starting the application, select English or German from the menu bar "Edit" > 
"Language". 
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Set the IP address and establish the connection 
1. Enter the IP address of the door control unit (e.g. "192.168.0.9") in the "IP address" field. 

2. Establish the connection in one of the two following ways: 

– Click "Establish connection..." 

– Via the menu bar "Tools" > "Establish connection…" 

3. After a connection has been successfully established, the status bar displays, for example, 
"Connected to 192.168.0.3". 
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Upload new firmware 
1. Select "Tools" > "Upload new firmware…" from the menu bar. 

2. The current firmware versions (of the ATxx basic module and the PROFINET module) on the 
door control units are displayed in the "Information" field. 

3. Use the "Browse..." button to select the corresponding update file (*.sid file). 

4. Optional functionalities 

– You can read out the current firmware versions again via the "Read version" button. 

– You can lock or release the device again for PROFINET data communication using the 
"Lock module" or "Release module" buttons. When the 
update process starts, the device is automatically locked. 
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Start the update 
1. Click the "Start update..." button to start the update process. 

2. The status bar indicates the progress of the update process. 

 

 
 CAUTION 

Material damage resulting from interruption of the power supply during the update 
process 

The controller can be damaged if the power supply is interrupted during the update 
process. It can then only be restored via Siemens Support. 

For this reason, make sure that the power supply is not interrupted during the update 
process. 

 

 

3.  The door control unit is automatically restarted following a successful firmware update. 

4. The door control unit is fully ready for use again following the restart. 
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Accessing additional information 
The version identification of the SIDOOR Manager, for example, can be displayed via the 
menu bar "?" > "About". Keep this number to hand for support enquiries.  

You can close the window again by clicking "Close". 
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Displaying the log and log file 
You can show or hide the current log output of the SIDOOR Manager via the menu bar "View" 
> "Log".  

You can additionally display the current log file of the SIDOOR Manager via the menu bar 
"File" > "Open log file...". The file is displayed with the default Windows file viewer (e.g. 
Notepad). The log file can be useful for support enquiries. 

 

Parallel firmware update (batch mode) 
You can find the file "MultiFwUpdateExample.bat" in the program directory of the SIDOOR 
Manager. This file shows an example of the call of several instances of the SIDOOR Manager. 
The SIDOOR Manager can be called with the following arguments: 
• auto (the firmware update is executed automatically without user inputs) 
• host [hostname/ip-address] (host name or IP address of the door control unit) 
• file [filename] (file name with path to the firmware update file) 
• min (Starts SIDOOR Manager minimized) 

Sample file "MultiFwUpdateExample.bat": 
START SIDOORManager.exe -auto -min -host 192.168.0.1 -file 
D:\ATxxxxx.sid 
START SIDOORManager.exe -auto -min -host 192.168.0.2 -file 
D:\ATxxxxx.sid 
START SIDOORManager.exe -auto -min -host 192.168.0.3 -file 
D:\ATxxxxx.sid 
START SIDOORManager.exe -auto -min -host 192.168.0.4 -file 
D:\ATxxxxx.sid 
START SIDOORManager.exe -auto -min -host 192.168.0.5 -file 
D:\ATxxxxx.sid 
START SIDOORManager.exe -auto -min -host 192.168.0.6 -file 
D:\ATxxxxx.sid 
timeout /t 10 
pause 
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Set serial port and establish connection 
1. In the "Serial connection" selection menu, select the entry "Siemens SIDOOR USB to UART 

Bridge Controller (COMn)" as the interface to the controller. 

2. Click "Connect…", or use the menu command "Tools" -> "Connect…". 
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Door commands 
The input signals of the door control unit can be simulated and the door moved according to 
the buttons by using the menu command "Tools -> Door commands…". 
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Service Tool emulation: 
You can call the emulation of the service tool with the menu command "Tools -> Service Tool 
emulation…". 
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Read/write parameters 
All parameters of the respective door control unit can be read based on their parameter 
number and modified, if necessary, with the menu command "Tools -> Read/write 
parameters…". 
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Technical Assistance A 
 

Technical support for SIDOOR products 
• Information material and downloads for SIDOOR products: 

Information and Download Center (www.siemens.com/siplus/infomaterial) 
Here you can find, for example: 

– Catalogs 

– Brochures 

• Documentation on SIDOOR products: 
Industry online support 
(http://support.automation.siemens.com/WW/view/en/50247080/133300) 
Here you can find, for example: 

– Manuals and operating instructions 

– Current product information, FAQs and downloads 

– Characteristics and certificates 

Technical Support 
Expert advice on technical questions with a wide range of demand-driven services for all our 
products and systems. 

If you have any technical questions, contact Technical Support at: 

E-Mail Technical Support (mailto:support.automation@siemens.com) 

Support Request (https://www.siemens.com/automation/support-request) 

http://www.siemens.com/siplus/infomaterial
http://support.automation.siemens.com/WW/view/en/50247080/133300
mailto:support.automation@siemens.com
https://www.siemens.com/automation/support-request
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