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Legal information
Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage 
to property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices 
referring only to property damage have no safety alert symbol. These notices shown below are graded according to 
the degree of danger.

DANGER
indicates that death or severe personal injury will result if proper precautions are not taken.

WARNING
indicates that death or severe personal injury may result if proper precautions are not taken.

CAUTION
indicates that minor personal injury can result if proper precautions are not taken.

NOTICE
indicates that property damage can result if proper precautions are not taken.
If more than one degree of danger is present, the warning notice representing the highest degree of danger will be 
used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property 
damage.

Qualified Personnel
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems.

Proper use of Siemens products
Note the following:

WARNING
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended or 
approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and maintenance 
are required to ensure that the products operate safely and without any problems. The permissible ambient 
conditions must be complied with. The information in the relevant documentation must be observed.

Trademarks
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication may 
be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability
We have reviewed the contents of this publication to ensure consistency with the hardware and software described. 
Since variance cannot be precluded entirely, we cannot guarantee full consistency.  However, the information in this 
publication is reviewed regularly and any necessary corrections are included in subsequent editions.
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Security information 1
Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, systems, machines, and networks.
In order to protect plants, systems, machines and networks against cyber threats, it is necessary 
to implement – and continuously maintain – a holistic, state-of-the-art industrial security 
concept. Siemens’ products and solutions constitute one element of such a concept.
Customers are responsible for preventing unauthorized access to their plants, systems, 
machines and networks. Such systems, machines and components should only be connected to 
an enterprise network or the internet if and to the extent such a connection is necessary and only 
when appropriate security measures (e.g. firewalls and/or network segmentation) are in place.
For additional information on industrial security measures that may be implemented, please 
visit:
https://www.siemens.com/industrialsecurity
Siemens’ products and solutions undergo continuous development to make them more secure. 
Siemens strongly recommends that product updates are applied as soon as they are available 
and that the latest product versions are used. Use of product versions that are no longer 
supported, and failure to apply the latest updates may increase customer’s exposure to cyber 
threats.
To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed 
under
https://www.siemens.com/industrialsecurity.
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Preface 2
Purpose of this documentation

The Getting Started for Route Control provides an initial overview of the Route Control system 
and supports you in creating a simple project. The project can be configured on a SIMATIC PC 
station. This Getting Started addresses newcomers to Route Control who are active in the fields 
of
• Engineering
• Commissioning and service

Basic knowledge required
You should be accustomed to working in the following fields:
• Microsoft Windows 7 / Windows 2008 Server operating systems
• Microsoft Windows 10 / Windows 2012 Server operating systems
• Functions and configurations of SIMATIC S7 (S7-400, STEP 7)
• Functions and configurations of SIMATIC NET (network components, data transmission 

media)
• Functions and configurations of PCS 7 OS, PCS 7 ES and PCS 7 AS

Scope of this manual
This Getting Started is valid for "PCS 7 Engineering Toolset as of V9.0".
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SIMATIC Route Control Getting Started 3
3.1 Overview

General
SIMATIC Route Control is a program package for the automated material and product transport 
in plants. SIMATIC Route Control encompasses both the configuration and the runtime system, 
and provides many interfaces to the PCS 7 basic system and user programs.
Route Control can provide anything ranging from simple transport processes to a large number 
of complex route combinations, depending on the process cell design. The Route Control tool is 
predominantly used to simplify and standardize the configuration, processing and diagnostics 
of material transport (routes). The route control functions support the determination, 
verification, control, supervision and monitoring of route requests, starting at the material 
source, and ending at the destination via the corresponding routes.

Route Control features:
• Comfortable functions for configuring and interconnecting technological elements in CFC.
• Wizard-assisted configuration of parameters for coupling the Route Control automation 

systems and the Route Control Servers.
• Wizard-assisted configuration of the communication (cross-linking) between the AS relevant 

to Route Control.
• Transfer of elements from the S7 project (CFC) to the Route Control project.
• Installation of the elements in partial routes by means of drag-and-drop.
• Interface in the form of a file in CSV format for the configuration of partial routes by means 

of external tools such as MS EXCEL.

Runtime system
The runtime system is used for automatic route search, the grouping of all partial routes and 
their integrated Route Control elements, and for controlling, operating and monitoring material 
transport. It also supports the control of transport operations on multiple automation systems. 
The user interface for material transport is installed in an AS which is the master station. The 
Route Control elements can be distributed to several AS. The RC(Route Control) system supports 
operation with one master and up to 31 slave stations. The SW also provides comprehensive 
functions for the diagnostics of material transport and corresponding messages. RC supports 
the redundant configuration of the Route Control Server to obtain a fault-tolerant system.

Note
The terms route and material transport are used synonymously in this Getting Started.

SIMATIC Route Control Getting Started (V9.0)
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Note
The SIMATIC Route Control system is designed for the transport of products and materials; it is 
not designed for the automation of packaging units or package tracing.

SIMATIC Route Control Getting Started
3.1 Overview
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3.2 Route Control components

Route Control can be divided into three areas:
1. Engineering System (ES)
2. Runtime system (client-server system)
3. Automation system (AS)

SIMATIC Route Control Getting Started
3.2 Route Control components
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Engineering System 
The Engineering System is used to create the configuration data for Route Control. The 
Route Control Wizard is used to read data which is relevant to Route Control from other 
configuration tools and to edit this data, for example, the CFC charts. This data is then passed to 
Route Control Engineering for further processing. All information is saved to a database. This 
database forms the basis of route control.

Runtime system (Client-Server system)
The runtime system is usually configured as a client-server architecture which consists of the 
server of the Operator System (OS), the SIMATIC Route Control Server, the OS Client and of the 
SIMATIC Route Control Client. SIMATIC Route Control Server is based on the configuration 
database. This data is supplemented by route control relevant runtime information received 
from the automation system. The main task of the SIMATIC Route Control Server involves 
flexible route finding based on configuration and runtime data. Online data represent 
information pertaining, for example, to faults, manual mode, maintenance, and to routes and 
their elements. SIMATIC Route Control Server downloads the element lists of a route to the 
automation systems. Material transport is controlled after its start by the AS. The SIMATIC 
Route Control Client is used to operate and monitor material transports. The OS Client is used in 
the context of Route Control to operate and monitor the Route Control faceplates.

Automation system (AS)
The separation between the OS and AS is derived from the time-sensitive requirements of the 
process. The AS handles the actual control of the route and controls and monitors the route 
elements. Route search is not a time-sensitive function. As the SIMATIC Route Control Server also 
holds the central image of the route network, it also handles route search functions. This task 
splitting facilitates maximum flexibility in terms of route searches and the execution of time-
sensitive processes. The Route Control Server communicates with the AS of S7-DOS connection, 
whereas the OS Server communicates with the AS of STEP 7 standard communication.

SIMATIC Route Control Getting Started
3.2 Route Control components
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3.3 Route Control and PCS 7

Integration of Route Control in PCS 7 Engineering
PCS 7 software components used in SIMATIC Route Control:
• SIMATIC Logon for the administration of user rights
• SIMATIC CFC for creating Route Control elements and route blocks in the AS
• SIMATIC NetPro for managing S7 communication
• PCS 7 OS as operator control and monitoring system, including visualization of Route Control 

messages
• SIMATIC SFC for the creation of user programs for automated material transport
• SIMATIC NET provides the basis for runtime communication.

Integration of Route Control in the PCS 7 OS
Route Control provides a block icon, a faceplate and a Route Control Center (RCC) button for 
integration in the OS process control interface. The "RCC" button on the PCS 7 OS interface is 
used to open the Route Control Center. The faceplate is opened by clicking the block icon in the 
process picture. The faceplate visualizes route details and provides options of operating the 
material transport. The blocks of the Route Control library use the ALARM blocks and 
communication routes for reporting to a PCS 7 OS message server.

SIMATIC Route Control Getting Started
3.3 Route Control and PCS 7
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3.4 The Route Control Getting Started project

Introduction
The Route Control Getting Started project is based on the fermentation and storage cellar of a 
brewery. The plant consists of two fermenting tanks (FT) and two storage tanks (ST).

Description of the plant
Fermentation is a term used in bioreaction engineering to describe fermentation processes, for 
example, in a brewery. The storage tanks receive the finished fermentation products. The 
Getting Started is focused on the configuration of all objects relevant to Route Control within the 
PCS 7 system. The "Route Control Getting Started plant" shown in the picture forms the basis of 
the Getting Started project. All processes are simulated on CFC level as a real process is not 
available for the project. A "Reset" button is available in the WinCC process picture for resetting 
the fill levels in the fermenting tanks and storage tanks. The purpose of the project is to control 
the transport of products from the fermenting tanks to the storage tanks through different 
piping routes. The Route Control System controls the valves and pumps.

Double seat valve
The valves V4, V5, V8, V9, V16, V17, V20 and V21 are double seat valves. The image below 
shows the function of this double seat valve.

SIMATIC Route Control Getting Started
3.4 The Route Control Getting Started project
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3.5 System requirement for the Getting Started

System requirements for Route Control Getting Started
• PCS 7 single station with Route Control installation. The system requirements for PCS 7 is of 

V9.0. 
• A communication processor CP 1613 or another network adapter for the PCS 7 station
• Automation system AS 416-3 or higher
• CPU firmware V3.1.0 or higher
• Communication processor CP 443-1 for the AS
• Hard-wired network connection between the PCS 7 station and the AS

SIMATIC Route Control Getting Started
3.5 System requirement for the Getting Started
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Preparations 4
4.1 How to unpack the PCS 7 project from an archive file

Introduction
The PCS 7 project must be unpacked from the archive file so that you can open and edit it in 
SIMATIC Manager. The basic project is stored online as a zip file with this manual under 
"Appendix". Copy the file "rcgsmp_d.zip" to "C:\Programs Files\Siemens\STEP7\examples".

Prerequisite
SIMATIC Manager is open.

Procedure
1. Select the "File > Retrieve..." menu command.

The "Retrieving - Select an Archive" dialog box opens.
2. Go to the "Programs\Siemens\STEP7\examples" folder, select the file "rcgsmp_0_b.zip" and 

open it by clicking the "Open" button.
The "Select destination directory" dialog box opens.

3. Select the "Programs\Siemens\STEP7\S7Proj" folder and click "OK".
The "Retrieve" message window opens after the file has been successfully extracted.

4. Click "OK".
5. Open the PCS 7 project.

Sample solution
You will find a sample solution for this Getting Started in the same zip file "rcgsmp_0_b.zip" 
(English) or "rcgsmp_0_a.zip" (German) mentioned in the introduction. 
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4.2 How to adapt the station name

Introduction
Customize the name of the PC station in the PCS 7 project to suit your specific installation 
requirements.

Prerequisite
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

You can activate this under the menu item "View > Component view". 

Procedure
1. Select the "RCGSMP_0/RCGSOS_0/ES" object from the tree view.
2. Select the "Edit > Object Properties" menu command.
3. Enter the name of the local computer as defined on the network system.

Note
The name of your local computer is available in the Windows Control Panel under "System". 
The icon of the PC station is identified in the component view by a yellow arrow. Refresh by 
pressing the <F5> function key if the PC station is not marked with a yellow arrow.

Preparations
4.2 How to adapt the station name
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4. Select "Computer name identical to PC station name". 
The computer name is automatically entered in the "Computer name" input field.

5. Click "OK".

Preparations
4.2 How to adapt the station name
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4.3 How to adapt the hardware configuration of the AS

Introduction
The AS hardware configuration must be adapted to suit your automation system requirements.

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Procedure
1. Select the "RCGSMP_0/RCGSAS_0/AS" folder from the tree view.
2. Select the "Hardware" object from the detailed view and then select the "Edit > Open Object" 

menu command.
3. If you are using a different version of the CP 443-1 in your project, select the required CP from 

the hardware catalog and drag it to the position of the existing CP.
Confirm the first message dialog by clicking "Yes" and the second by clicking "OK".

4. Select "Edit > Go To > Ethernet Node".
The "Go To Ethernet Node" window opens.

5. Click "Go To".
6. Click "Close".
7. Select "Edit > Object Properties".
8. Click "Properties".

Preparations
4.3 How to adapt the hardware configuration of the AS

SIMATIC Route Control Getting Started (V9.0)
22 Getting Started, 06/2018, A5E43618934-AA



9. Click the "Parameters" tab. Enter the MAC address in the "Properties - Ethernet Interface" 
dialog box.

10.Deactivate the "IP protocol is being used" checkbox.
11.Select the "Plant bus" entry from the "Subnet" list.
12.Click "OK" in the "Properties - Ethernet interface" dialog box, and then click "OK" in the 

"Properties - CP 443-1" dialog box.
The CP is customized for the Route Control Getting Started project.

13.Close HW Config.
14.Click "Yes" in the "Save changes to AS?" message dialog box.

Note
You also have to adapt your hardware configuration in HW Config if you are operating with a 
different power supply module which occupies fewer or more slots in the rack. Example: 
PS 407 20 A = 3 slots, PS 407 10 A = 2 slots.

Preparations
4.3 How to adapt the hardware configuration of the AS
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4.4 How to adapt the OS configuration

Introduction
Customize the OS configuration in the PCS 7 project to suit your installation requirements.

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Procedure
1. Select the "RCGSMP_0/RCGSOS_0/[PC station name]" object from the tree view.
2. Select the "Configuration" entry from the detailed view and then select the "Edit > Open 

Object" menu command.
3. Select a network adapter from the hardware catalog and drag-and-drop it to slot 4.

The "Properties" dialog box opens.
4. Activate the "Set MAC Address" checkbox.
5. Select the "MAC Address" input box and enter the MAC address of the PC's network adapter.
6. Deactivate the "IP protocol is being used" check box.
7. Select the "Plant bus" entry from the "Subnet" list.
8. Click "OK" in the "Properties - Ethernet Interface CP 16**" dialog box.

Note
Using CP 16** is optional, IE General can also be used instead of a CP card.

9. Click "OK" in the "Properties - CP 16**" dialog box.
10.Insert the "RC application" object from the Route Control catalog to slot 2.
11.Insert the "RC application client" object from the Route Control catalog to slot 3.
12.Select the "Station > Save and Compile" menu command.
13.Close HW Config.

Preparations
4.4 How to adapt the OS configuration
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Result

Preparations
4.4 How to adapt the OS configuration
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4.5 How to edit the name of the Operator Station

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Procedure
1. Select the "OS" object from the "WinCC Application" area of the PC station.
2. Select the menu command "Edit > Open object".

A dialog box is displayed stating "The configured server is not available. Do you want to open 
the project using the local computer as the server?" 

3. Click "Yes".
WinCC Explorer opens.

4. Select "Computer" from the navigation window.
5. Double-click the computer icon in the detailed window.

The "Computer properties" dialog box opens.
6. Click "Use local computer name".
7. Click "OK".

The "Change computer name" message is output.
8. Click "OK" and close the WinCC Explorer.

Your changes are activated at the next start of WinCC Explorer.

Preparations
4.5 How to edit the name of the Operator Station
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4.6 How to set parameters in NetPro and configure the hardware

Introduction
Configure the PC station in NetPro in order to enable its communication with the AS.

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Procedure in NetPro
1. Select the "RCGSMP_0/ RCGSOS_0/[name of your local computer]/WinCC Application" object 

from the tree view.
2. Select the "Connections" entry from the detailed window and then select the "Edit > Open 

Object" command.
NetPro opens.

3. Select the "WinCC Application" object at the SIMATIC PC station.
4. Select "Insert > New Connection" in menu command.

5. Select the AS.

Preparations
4.6 How to set parameters in NetPro and configure the hardware
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6. Click "OK".
The "Properties - S7 connection" window opens.

7. Click "OK".
8. Select the "Network > Save and compile" menu command.

The "Save and compile" dialog box opens.
9. Activate the "Compile and check everything" check box and then click "OK".
10.The "Outputs for consistency check" window opens after compilation has been completed. 

Close this window.
11.Close NetPro.

Procedure in SIMATIC Manager for PC configuration
1. Change to SIMATIC Manager. 
2. Select the PC station and then select the "PLC > Configure" command.

The "Configure" dialog box opens.
3. Activate "Use configure computer name".
4. Click "Configure".

The "Configure: PC name" dialog box opens.
5. Click "OK".
6. Click "OK", if "Information" dialog box opens.
7. Click "Close", after configuration completion message is displayed.

Preparations
4.6 How to set parameters in NetPro and configure the hardware
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8. Select the PC station and then select the "PLC > Download" menu command.
The message dialog box "This action overwrites configuration data which are already... Do 
you want to continue loading?" opens.

9. Click "Yes".
The "Stop target modules" dialog box opens.

10.Click "OK".
The download is completed.

Procedure in SIMATIC Manager for hardware configuration
1. Select the AS.
2. Double click the "Hardware".

The "HW Config" window opens.
3. Click  to download the hardware.

Preparations
4.6 How to set parameters in NetPro and configure the hardware
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4.7 How to create the required users

Introduction
For Route Control and WinCC, you must create a user and include the user in the 
RC_MAINTENANCE user group when using SIMATIC Logon. 

Note
Define and memorize your own user name and password if the user name = rcuser and password 
= RC11**er entries do not conform to rules set up on your PC.

Procedure
1. Press the icon + R and insert "compmgmt.msc" in the run dialog.

Note
For Windows 7, Start > Control Panel > Administrative Tools > Computer Management.

2. Expand the "Local Users and Groups" tree.
3. Right-click the "User" folder.
4. Select the "New User..." in the menu.
5. Entries to be made in the "New User..." dialog box:

User name: rcuser
Full name: Route Control User
Password: RC11**er
Confirm the password: RC11**er
User must change the password at next logon: deactivate this check box
User cannot change password: activate
Password never expires: activate
Account is disabled: deactivate

Preparations
4.7 How to create the required users
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6. Click "Create".

7. Double-click the "Groups" folder.
8. Double-click the "RC_MAINTENANCE" group.
9. Click "Add".

A "Select users" window opens.
10.Type "PC name/Username" in "Enter the object names to select" area.
11.Select "Check Names".
12.Click "OK".

Result
You have successfully created a user named "rcuser" as a member of the "RC_MAINTENANCE" 
group.

Preparations
4.7 How to create the required users
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4.8 How to select the communication module in SIMATIC Shell

Introduction
You now select the communication module you are going to use to configure the PC stations.

Note
You can discard this configuration for a single-user PC station which is not networked with other 
PC stations.

Procedure
1. Select the PC station (workstation) from the tree view in Windows Explorer.
2. Select the "Simatic Shell" folder.
3. Click "Settings" in the shortcut menu.

The "Settings" dialog box opens.
4. Select the network adapter (communication module) you are going to use for 

communication with the Engineering Station.
5. Click "OK" to save your entries.

The communication module is now initialized.

Preparations
4.8 How to select the communication module in SIMATIC Shell
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Route Control Project Engineering in the 
automation system 5
5.1 Route Control blocks

5.1.1 Overview

General
Each process involves the operation of control elements such as valves or motors. The AS 
controls these elements using the CFC blocks of the PCS 7 library. An interface block of the Route 
Control library interconnects these PCS 7 blocks. This shows the RC Wizard that these control 
elements are to be used in the Route Control system. The Route Control Wizard "imports" these 
interface blocks by creating a corresponding data record in the Route Control database. This data 
record makes the element visible in the Route Control configuration and allows its use in partial 
routes.
Route Control is represented in the automation system by means of function blocks (FB), 
functions (FC), and data blocks (DB).

These blocks can be organized in four groups under the aspect of Route Control:
1. General configuration of Route Control: RC_IF_CFG
2. Control of material transport: RC_IF_ROUTE
3. Interface blocks for interfacing with the process: RC_IF_VALVE, for example
4. Tool blocks: "Subprograms" for route control, cross-coupling, and communication

You can also distribute the DBs to four groups:
1. Configuration: RC_CFG (DB 00)
2. Route lists: RC_ROUTnnn (DB 101 to DB 400)
3. Element lists: RC_xE_FIELD (DB 96 to DB 99)
4. Tool DBs: Communication, cross-coupling, …
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5.1.2 Blocks

Route Control interface blocks
The names of the Route Control interface blocks start with RC_IF....
These blocks form the interface for the Route Control system within the automation system.

Blocks for activating a route
RC_IF_ROUTE (FB 800), RC_IF_DECODER (FC 801), RC_IF_ENCODER (FC 800)

Blocks for interfacing the control elements (CE)
RC_IF_VAL_MOT (FB 825), RC_IF_VALVE (FB 826), RC_IF_MOTOR (FB 822), RC_IF_MOT_REV 
(FB 823), RC_IF_MOT_SPED (FB 824), RC_IF_USER_CE (FB 829)

Blocks for interfacing the sensor elements (SE)
RC_IF_CONDUCT (FB 846), RC_IF_SENSOR (FB 845), RC_IF_USER_SE (FB 848)

Blocks for interfacing the parameter elements (PE)
RC_IF_VOLUME (FC 808), RC_IF_TIMER (FC 809), RC_IF_USER_PE (FC 807)

Blocks for interfacing the link elements (LE)
RC_IF_LE (FB 828)

Note
Take all blocks to be installed in CFC charts in the course of exercises from the "Lib" master data 
library.

Note
You can use the RC_IF_USER_CE, RC_IF_USER_SE and RC_USER_PE blocks to develop user-
specific block types.
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5.2 The Route Control configuration block

5.2.1 Overview of the configuration block

The RC_IF_CFG configuration block
One instance of this block must be installed in a central CFC chart for each Route Control CPU 
(AS). This block is the central instance where you configure the AS. The block itself calls three 
system components:
1. Communication to the Route Control Server.

Sending message frames using the AS system block BSEND.
2. Communication with the partner AS within a Route Control project if a material transport 

uses elements in several AS (AS system block PUT).
3. Execution of the route list DBs, and corresponding activation / monitoring of all elements of 

this route. The block generates central messages of the AS Route Control system, for 
example, error in communication with RC Server.

Most important parameters of the RC_IF_CFG block:
Block contact Meaning
RC_AS_ID Unique identifier for this AS within the project.
OB_KOMM Defines the OB which handles server communication.
OB_SYS Defines the OB which is used to process the route lists.
OB_XC Defines the OB which is used to process the cross-coupling.
CE_SIMU Defines whether to simulate processing of the values returned by the control 

elements. 1 -> simulation, 0 -> no simulation.
SE_SIMU Defines whether to simulate processing of the values returned by the sensor 

elements. 1 -> simulation, 0 -> no simulation.
QERR Indicates error events.
NoRoutes Maximum number of routes used in this Route Control project.

Note
In addition to the organization block (OB) in which you have installed it, the RC_IF_CFG block is 
installed automatically in the following OBs:
Startup OBs (OB 100, OB 101 and OB 102), OB 1 and the error OBs (OB 121 and OB 80).
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Note
The system is limited to 300 simultaneous material transport operations. If your application only 
requires a small number of simultaneous material transport operations, you can reduce load on 
CPU memory by deleting the obsolete DBs from the SIMATIC project. The DBs for 
RC_ROUTE201...300 and DB 301 to DB 400 can be deleted if you are operating with a maximum 
of 200 routes. Reduce the maximum number of material transport operations in the same way 
at all automation systems of the RC project. Report the required number of routes to the RC 
system by way of the "NoRoutes" input at the RC_IF_CFG block. The value 200 must be set at this 
input in the example described above.

5.2.2 Exercise with RC_IF_CFG

Task
Configure the "RC_IF_CFG" block in the CFC chart "RC_System".

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Procedure
1. Open the "RC_System" CFC chart from the partial project "RCGSAS_0".
2. Copy the RC_IF_CFG (FB 850) block from the "Lib" master data library to the CFC chart.
3. Right-click "RC_IF_CFG" block and select "Object properties".
4. Enter the name "RC_System" in the "Name" input box and click "OK".
5. Open the "Common" CFC chart from the partial project "RCGSAS_0".
6. Interconnect output "Q" of the "CE_SIMU" block with input "CE_SIMU" of the "RC_System" 

block.
7. Interconnect output "Q" of the "SE_SIMU" block with input "SE_SIMU" of the "RC_System" 

block.
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Result
The AS is ready to use by Route Control. Configuration is completed after the Route Control 
Wizard session is closed.

Route Control Project Engineering in the automation system
5.2 The Route Control configuration block

SIMATIC Route Control Getting Started (V9.0)
Getting Started, 06/2018, A5E43618934-AA 37



5.3 Interface blocks for control elements

5.3.1 Overview of the interface blocks for control elements

"Control Element" (CE) interface block
Each material transport involves the operation of control elements such as valves or motors. The 
AS operates these actuating elements using the technological blocks of the PCS 7 library. In 
order to make these actuators available for use in Route Control you must interconnect each 
technological block with an interface block of the type "Control Element" (CE) of the 
Route Control library. These control elements are the active elements of a route control system, 
that is, they represent the actuating elements within the route control.

Control element types
Various types of suitable control elements are provided for Route Control in order to be able to 
control the technological blocks according to their type.
Other blocks, or blocks from other libraries can be implemented by means of a user-defined 
interface block.
The following interface blocks of the type "Control Element" are available:

Route Control block Control element type Technological block
RC_IF_MOTOR (FB 822) MOTOR MotL (FB 1850)

MotS (FB 1910)
RC_IF_MOT_REV (FB 823) MOT_REV MotRevL (FB 1851)
RC_IF_MOT_SPED (FB 824) MOT_SPED MotSpdCL (FB 1854)

MotSpdL (FB 1856)
RC_IF_VALVE (FB 826) VALVE VlvL (FB 1899)

VlvS (FB 1911)
RC_IF_VAL_MOT (FB 825) VAL_MOT VlvMotL (FB 1900)
RC_IF_USER_CE(FB 829) User type, template for user-specific 

interface blocks
Other block

Basic procedure for configuring the blocks
Step Handling

1 Installation of a technological block such as MOTOR in the CFC chart
2 Interconnection of the technological block with the I/O devices
3 Installation of the corresponding RC_IF_xxx, for example, RC_IF_MOTOR
4 Interconnection of both blocks
5 Starting the Route Control Wizard in order to automatically generate the element ID
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Important block contacts for all control elements
Block contact Meaning
ID Unique ID within the AS. Checked by the Route Control Wizard. A new ID is assigned 

if the value is zero.
FB_CLOSE Return value of the process valve.

Only with RC_IF_VALVE and RC_IF_VAL_MOT.
FB_OPEN Return value of the process valve.

Only with RC_IF_VALVE and RC_IF_VAL_MOT.
FB_ON Motor feedback.

Only with RC_IF_MOTOR, RC_IF_MOT_SPED and RC_IF_MOT_REV.
MONITOR Monitoring of the feedback signals. 1 -> activated, 0 -> deactivated.
MAN_AUT Operating mode (manual / auto) of the downstream block.
LOCK Defines whether a downstream block is interlocked.
ERROR Defines whether a downstream block is in error state.
DISABLED Defines whether an element is available.
QAUTO_OC Automatic control, 1 -> OPEN, 0 -> CLOSE. Only RC_IF_VALVE and RC_IF_VAL_MOT.
QAUTO_ON Automatic control, 1 -> ON, 0 -> OFF.

Only with RC_IF_MOTOR, RC_IF_MOT_SPED and RC_IF_MOT_REV.
QROUTE ID of the route which actively controls this element.
QMODE_NO Mode level of the route which actively controls this element. 
QMODE_ID Function ID of the route which actively controls this element.

Note
An example in the Online Help and a CFC example with textual interconnections in the 
Route Control library show which parameters must be / may be interconnected.

5.3.2 Exercise with RC_IF_VALVE

Task
Configure the "RC_IF_VALVE" block in the CFC chart "V1".

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Procedure
1. Open the "V1" CFC chart from the partial project "RCGSAS_0".
2. Copy the "RC_IF_VALVE" block from the "Lib" master data library to the CFC chart.
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3. Right-click "RC_IF_VALVE" block and select "Object properties".
4. Enter the name "CE_V1" in the "Name" input box.
5. Interconnect the following outputs of the "CE_V1" block with the "V1" block:

Output CE_V1 Input V1
QAUTO_OC AUTO_OC
QBA_EN BA_EN
QOCCUPIED OCCUPIED
QBA_ID BA_ID
QBA_NA BA_NA
QSTEP_NO STEP_NO

6. Interconnect the following outputs of the "V1" block with the inputs of the "CE_V1" block:

Output V1 Input CE_V1
QCONTROL FB_OPEN
QCONTROL FB_CLOSE
QGR_ERR ERROR
QMAN_AUT MAN_AUT

7. Right-click on the "FB_CLOSE" in "CE_V1" block and select "Invert" to negate the input.

Result
You have successfully configured a control element of the type "VALVE".
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5.3.3 Exercise with RC_IF_MOTOR

Task
Configure the "RC_IF_MOTOR" block in the CFC chart "P2".

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Procedure
1. Open the "P2" CFC chart from the partial project "RCGSAS_0".
2. Copy the "RC_IF_MOTOR" block from the "Lib" master data library to the CFC chart.
3. Right-click "RC_IF_MOTOR" block and select "Object properties".
4. Enter the name "CE_P2" in the "Name" input box.
5. Interconnect the following outputs of the "CE_P2" block with the inputs of the "P2" block:

Output CE_P2 Input P2
QAUTO_ON AUTO_ON
QBA_EN BA_EN
QOCCUPIED OCCUPIED
QBA_ID BA_ID
QBA_NA BA_NA
QSTEP_NO STEP_NO

6. Interconnect the following outputs of the "P2" block with the inputs of the "CE_P2" block:

Output P2 Input CE_P2
QGR_ERR ERROR
QSTART FB_ON
QMAN_AUT MAN_AUT

7. Interconnect output "QSTART" of the "P2" block with input "FB_ON" of the "P2" block.
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Result
You have successfully configured a Route Control interface block of the "MOTOR" type.
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5.4 Interface blocks for sensor elements

5.4.1 Overview of the interface blocks for sensor elements

"Sensor Element" (SE) interface block
Sensor elements are passive elements of the route control system. These elements are used to 
poll states without actively changing these. You assign the SEs to a specific type similar to the 
CEs. The system supports the use of SENSOR (binary sensor) and CONDUCT (analog sensor with 
4 levels) element types.

Sensor element types
The Route Control block library contains two interface blocks for sensor elements (SE) for 
interfacing with the process. The "SENSOR" type is suitable for acquiring binary signals, and the 
"CONDUCT" type can be used to acquire analog signals with four switching states.
Users can implement their own feedback function by means of a user-specific interface block.
The following interface blocks of the "Sensor Element" type are available:

Route Control block Sensor element type Technological block
RC_IF_SENSOR (FB 845) SENSOR CH_DI (FC 277) among others
RC_IF_CONDUCT (FB 846) CONDUCT CH_AI (FC 275) among others
RC_IF_USER_SE (FB 848) User type, template for 

user-specific interface 
blocks

Other block

Basic procedure for configuring the blocks
Step Handling

1 Installation of an RC_IF_xxx such as RC_IF_SENSOR in a CFC chart.
2 Interconnection of RC_IF_xxx with the signal to be monitored.
3 Starting the Route Control Wizard in order to automatically generate the element ID.

Important contacts of the RC_IF_SENSOR block
Block contact Meaning
ID Unique ID within the AS. Checked by the Route Control Wizard. A new ID is as‐

signed if the value is zero.
ERROR Defines whether an interconnected block is in error state.
DISABLED Defines whether an element is available.
FB_00 Actual value of a sensor returned by the process.

1 -> interconnected sensor returns TRUE
0 -> interconnected sensor returns FALSE

QRET_VAL Return value of the block 0 -> no error, 8xxx -> error.
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Block contact Meaning
QROUTE ID of the route which uses this element.
QFUNC_ID Function ID of the route which uses this element.

5.4.2 Exercise with RC_IF_SENSOR

Task
Configure the "RC_IF_SENSOR" block in the CFC chart "FT1".

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Procedure
1. Open the "FT1" CFC chart from the partial project "RCGSAS_0".
2. Copy the "RC_IF_SENSOR" block from the "Lib" master data library to the CFC chart.
3. Right-click "RC_IF_SENSOR" block and select "Object properties".
4. Enter the name "S1" in the "Name" input box.
5. Interconnect the "EMPTY" output of simulation block "FT1" with input "FB_00" of the "S1" 

block.

Result
You have successfully configured a control element of the type "SENSOR".
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5.5 Interface blocks for parameter elements

5.5.1 Overview of the interface blocks for parameter elements

"Parameter Element" (PE) interface block
Parameter elements represent setpoints in the route control system. They do not evaluate 
feedback signals.

Parameter element types
The Route Control block library contains three interface blocks for parameter elements for 
interfacing with the process.
Users can implement their own parameter elements by means of a user-specific interface block.
The following interface blocks of the "Parameter Element" type are available:

Route Control block Parameter Element type Technological block
RC_IF_VOLUME (FC 808) VOLUME OP_A_LIM (FB 46), for example
RC_IF_TIMER (FC 809) TIMER OP_A_LIM (FB 46), for example
RC_IF_USER_PE (FC 807) User type, template for user-specific 

interface blocks
Other block

Basic procedure for configuring the blocks
Step Handling

1 Installation of an RC_IF_xxx such as RC_IF_VOLUME in a CFC chart.
2 Interconnection of the RC_IF_xxx with the block which is to receive the parameter.
3 Interconnection of the feedback signal of the PE block.

Input ACT_VAL as real value.
4 Definition of the conversion factor used to calculate the integer outputs QVALUE_I and 

QVALUE_D.
QVALUE_I = QVALUE_D = QVALUE_R * FACTOR

5 Programming a substitute value DEF_VAL.
6 Setting up the response to deactivation of the element at input EN_DEF.
7 Starting the Route Control Wizard in order to automatically generate the element ID.

Important contacts of the RC_IF_VOLUME block
Block contact Meaning
ID Unique ID within the AS. Checked by the Route Control Wizard. A new ID is assigned 

if the value is zero.
FACTOR Scaling ratio for the output values QVALUE_I and QVALUE_D.
DIS_ACTV Internal activation of the actual value can be prevented. 
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Block contact Meaning
DEF_VAL Substitute value.
EN_DEF Reaction after deactivation of the element:

1: the substitute value is output
0: the last valid setpoint is output

ACT_VAL Feedback value received from the process.
Q_VALUE_I Setpoint as 16-bit integer.
QVALUE_D Setpoint as 32-bit integer.
QVALUE_R Setpoint as 32-bit floating point number.
QRET_VAL Return value of the block 0 -> no error, 8xxx -> error.
QROUTE ID of the route which actively controls this element.
QFUNC_ID Function ID of the route which actively controls this element.

5.5.2 Exercise with RC_IF_VOLUME

Task
Configure the "RC_IF_VOLUME" block in the CFC chart "P2".

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Procedure
1. Open the "P2" CFC chart from the partial project "RCGSAS_0".
2. Copy the "RC_IF_VOLUME" block from the "Lib" master data library to the CFC chart.
3. Right-click "RC_IF_VOLUME" block and select "Object properties".
4. Enter the name "PE_P2" in the "Name" input box.
5. Interconnect output "QVALUE_R" with input "ACT_VAL".
6. Program the value "1" in input "FACTOR".
7. Program the value "enable" in input "EN_DEF".
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Result
You have successfully configured a parameter element of the type "VOLUME".
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5.6 Interface block for link elements

5.6.1 Overview of the interface block for link elements

"Link Element" (LE) interface block
Link elements are used to store the current material within partial routes. The route request, or 
a separate trigger of the AS program, initiates a check of material compatibility based on these 
elements.
Prior to material transport you can only save the material information the connection elements 
contain by way of SET_MAT input at the route block of the AS program.

Connection element types
We do not distinguish between different subtypes of connection elements.

Basic procedure for configuring the block
Step Handling

1 Installation of RC_IF_LE in a CFC chart.
2 Starting the Route Control Wizard in order to automatically generate the element ID.

Important contacts of the RC_IF_LE block
Block contact Meaning
ID Unique ID within the AS. Checked by the Route Control Wizard. A new ID is assigned 

if the value is zero.
DEF_VAL Default value which can be activated in the connection element by setting input 

SET_DEF.
SET_DEF Activation of the default value at the positive edge.
QRET_VAL Return value of the block 0 -> no error, 8xxx -> error.
QERR Indicates whether an error is active at the block.
QMAT_I Material ID of the connection element as integer value (INT).
QMAT_DI Material ID of the connection element as Double Integer value (INT).
QBA_ID Element is occupied by a SIMATIC BATCH Charge with this ID.
QROUTE ID of the route which actively controls this element.
QFUNC_ID Function ID of the route which actively controls this element.

Note
The material can be visualized in the process picture by way of output QMAT_DI.
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5.6.2 Exercise with RC_IF_LE

Task
Configure the "RC_IF_LE" block in the CFC chart "Material".

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Procedure
1. Open the "Material" CFC chart from the partial project "RCGSAS_0".
2. Copy the "RC_IF_LE" block from the "Lib" master data library to the CFC chart.

Note
The CFC chart already contains blocks of the type RC_IF_LE.

3. Right-click "RC_IF_LE" block and select "Object properties".
4. Enter the name "LE_FT1" in the "Name" input box.

Result
You have successfully configured a link element.
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5.7 Interface block for material transport

5.7.1 Overview of the interface block for material transport

The RC_IF_ROUTE interface block of a route
This block represents the central route interface to the user program and the AS block for the 
Route Control faceplate in the process picture.
The block handles the following tasks:
1. Definition of route parameters (source, destination, via, mode level, and material, for 

example)
2. Starting, stopping, ending and resuming material transports
3. Definition of monitoring times (system monitoring time, fault tolerance time)
4. Definition of dynamic setpoints for external parameter elements
5. Transfer of the batch ID / batch name and of the step number from a BATCH system
The block controls exactly one route, that is, one material transport. It returns additional 
information about the status of the route and its elements to the user program by means of 
output parameters. Usually, one user-defined SFC derived from RC_IF_ROUTE_SFC, one 
RC_IF_ENCODER (FC800) is connected upstream and one RC_IF_DECODER (FC801) is connected 
downstream of RC_IF_ROUTE.

Dynamic or static route ID
A route can be operated with a static or a dynamic route ID. Up to 300 simultaneous material 
transports are supported. Operation with no more than 300 routes can be handled by means of 
static route ID. However, you can also handle more than 300 routes by assigning dynamic route 
IDs.  In this case system resources are allocated dynamically to the active routes. This dynamic 
ID concept also facilitates engineering as it prevents the Route Control system from assigning 
redundant IDs. Dynamic IDs can also be used to handle less than 300 routes. This could be a 
practical workaround in situations where the maximum number of simultaneous routes is 
limited by license, for example, you can combine licenses as desired for 10 or 50 material 
transports up to a maximum of 300 material transports. This Route Control Getting Started 
deploys static route IDs.
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Overview of interface blocks for material transport
Block Function
RC_IF_ROUTE Central interface block for controlling material transport.

The instances of this block can be interconnected with the Route Control face‐
plate.

RC_IF_ENCODER Auxiliary block which converts 32 binary signals into a 32-bit DWORD.
The block can be used, for example, to convert 32 bits for the control function of 
input MODE at RC_IF_ROUTE.

RC_IF_DECODER Auxiliary block which converts a 32-bit DWORD into 32 bits.
The block can be used to convert the mode feedback signals of RC_IF_ROUTE to 
single bits.

Most important parameters of the RC_IF_ROUTE block
Block contact Meaning
ROUTE_ID Route ID which is unique across all automation systems of an RC project. The 

Route Control Wizard checks this ID and assigns a new one if the value is zero.
FIXED_ID Defines whether a dynamic or a static route ID is assigned.

0 -> dynamic, 1 -> static
FUNC_ID Function ID of the route
MON_TM Substitute value of the process monitoring time
FLT_TM Substitute value of the fault tolerance time
MODE_TBL Mode table parameter for the route request
VIA_1 to VIA_10 Interim locations for transport of materials
MODE Modes to be activated
SOURCE Start position of a route
DEST Destination of a route
MATERIAL Material to be transported
REQ_AU Interconnectable input for activating the route request
ON_AU Interconnectable input for starting the route
ACK_AU Interconnectable input for acknowledging the route
HOLD_AU Interconnectable input for holding the route
STOP_AU Interconnectable input for stopping the route
QMODE_AC Returns the current mode IDs
QREQ_ERR Return value of the route request 1 -> error, 0 -> OK
QACTIVE Route status
QAUTO Automatic route control is active 
QMAN Manual route control is active 
QREQ Diagnostics information pertaining to the route request
QON Defines whether the route is in "busy" state.
QHOLD Defines whether the route was held.
QVALID Validation of static route data
QRESTPOS Defines whether all actively used control elements of a mode level are currently 

in idle position.
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5.7.2 Exercise with interface block RC_IF_ROUTE for manual mode

Task
Configure the "RC_IF_ROUTE" block in the CFC chart "ROUTE1".

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Note
The term manual mode denotes controlling of a route using the Route Control Center, without 
using any SFC blocks or an AS user program.

Procedure
1. Open the "Route1" CFC chart from the partial project "RCGSAS_0".
2. Copy the "RC_IF_ROUTE" block from the "Lib" master data library to the CFC chart.
3. Right-click "RC_IF_ROUTE" block and select "Object properties".
4. Enter the name "Route1" in the "Name" input box.
5. Program the value "1" at input "ROUTE_ID".
6. Program the value "1" at input "FIXED_ID".
7. Insert the "RC_IF_ENCODER" block in the CFC chart.
8. Select the "Object properties" command from the shortcut menu of the block.
9. Enter the name "Encoder1" in the "Name" input box.
10.Interconnect output "QMODE" of "Encoder1" with input "MODE" of the "ROUTE1" block.
11.Insert the "RC_IF_DECODER" block in the CFC chart.
12.Select the "Object properties" command from the shortcut menu of the block.
13.Enter the name "Decoder1" in the "Name" input box.
14.Interconnect output "QMODE_AC" of "Route1" with input "MODE_AC" of "Decoder1".

Result
You have successfully configured an interface block for manual material transport.

Note
If you want to run it in automatic mode, configure it with an SFC type as described in 6.2.
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Controlling a route using a SFC block 6
6.1 SFC Typical of the RC library

SFC Typical of the Route Control library
The Route Control library contains an SFC Typical which can be used as sample for user-specific 
blocks. This SFC block is prepared for controlling a route.
It handles the following tasks:
• Transfer of the static parameters for route requests to the "RC_IF_ROUTE" block ("Starting" 

sequencer).
• Starting and evaluating the route request ("Starting" sequencer).
• After having successfully completed the route request, the SFC changes to simple control 

mode ("Run" sequencer).

This SFC Typical can be customized to suit your requirements as follows:
• Customizing the functionality of the "Run" sequencer to suit the modes used in your Mode 

Table. (An overview of the modes used in SFC Typical is available in the "Run" sequencer)
• Customizing reactions to route errors, for example: Using the "QERR", "QMON_TOU" or 

"QMON_FLT" error outputs as start condition for the "Holding" sequencer and setting the SFC 
to "Stop" in case of errors.

• Expansion of parameters for material functions (input "I_MATERIAL", outputs "QMATERIAL" 
and "QSET_MATERIAL"). Activation and evaluation of the materials in "Run" sequencer in 
preparation of the transport operation.

SFC Typical and the "RC_IF_ROUTE", "RC_IF_ENCODER" and "RC_IF_DECODER" interface blocks 
are interconnected with an SFC block instance accordingly.

Note
The "ROUTE_SFC" chart in the Route Control library contains an example of the entire 
interconnection.
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6.2 Exercise with SFC Type

Task
Interconnect an SFC instance with an "RC_IF_ROUTE" block.

Note
Auto mode means that material transport is controlled by means of an SFC block.

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Procedure
1. Open the "Route2" CFC chart from the partial project "RCGSAS_0".
2. Copy the "RC_IF_ROUTE" block from the "Lib" master data library to sheet 1 of the "Route2" 

CFC chart.
3. Rename the copied "RC_IF_ROUTE" block as "Route2".
4. Program a 2 at ROUTE_ID.
5. Program a 1 at FIXED_ID.
6. Copy the "RC_IF_SFC" block from the "Lib" master data library to the "Route2" CFC chart. 
7. Rename the copied "RC_IF_SFC" block as "SFC_R2".
8. Interconnect output "RC_VIA_1" of the "SFC_R2" block with input "VIA_1" of the "Route2" 

block.
After this step, all I/O belonging to "SFC_R2" are automatically connected to their 
corresponding I/Os.
Note
The SFC Type features three kinds of block contacts that are a group of contacts: "RC_" of the 
type "RC_IF_ROUTE", "SP_" of the type "RC_IF_ENCODER", and "AC_" of the type 
"RC_IF_DECODER". All I/O belonging to a block contact which is connected to the 
corresponding block is automatically interconnected with the block.

9. Copy the "RC_IF_ENCODER" block into sheet 4 of the "Route2" CFC chart. 
10.Rename the copied "RC_IF_ENCODER" block as "Encoder2".
11.Copy the "RC_IF_DECODER" block into sheet 4 of the "Route2" CFC chart. 
12.Rename the copied "RC_IF_DECODER" block as "Decoder2".
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13.Interconnect output "SP_M_01" of the "SFC_R2" block with input "M_01" of the "Encoder2" 
block.
Note
Once "SP_M_01" of "SFC_R2" block is interconnected with "M_01" of "Encoder2", the outputs 
"SP_M_02" to "SP_M_32" are automatically connected to the corresponding inputs "M_02" to 
"M_32".

14.Interconnect output "QM_01" of the "Decoder2" block with input "AC_QM_01" of the 
"SFC_R2" block.
Note
Once "QM_01" of "Decoder2" block is interconnected with "AC_QM_01" of "SFC_R2", the 
outputs "QM_02" to "QM_32" are automatically connected to the corresponding inputs 
"AC_QM_02" to "AC_QM_32".

15.Interconnect output "QMODE_AC" of the "Route2" block with input "MODE_AC" of the 
"Decoder2" block.

16.Interconnect output "QMODE" of the "Encoder2" block with input "Mode" of the "Route2" 
block.

17.Open the "FT1" CFC chart from the partial project "RCGSAS_0".
18.Interconnect output "Empty" of the "FT1" block with input "FT1_Empt" of the "SFC_R2" block.
19.Open the "FT2" CFC chart from the partial project "RCGSAS_0".
20.Interconnect output "Empty" of the "FT2" block with input "FT2_Empt" of the "SFC_R2" block.
21.Open the "ST1" CFC chart from the partial project "RCGSAS_0".
22.Interconnect output "Full" of the "ST1" block with input "ST1_Full" of the "SFC_R2" block.
23.Open the "ST2" CFC chart from the partial project "RCGSAS_0".
24.Interconnect output "Full" of the "ST2" block with input "ST2_Full" of the "SFC_R2" block.
25.Interconnect the following outputs of the block "SFC_R2" with its inputs: 

Outputs Inputs
Source_QP IN_SOURCE
Destination_QP IN_DEST
Via1_QP IN_VIA_1

Note
CFC chart "Route3" contains an example of interconnections between the "Decoder", 
"Encoder" and the "RC_IF_ROUTE" block.
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Result
You have successfully configured a material transport at CFC level from the "Fermenting tank 1" 
source to "Storage tank 1" destination.
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6.3 Exercise for the compilation and download of CFC charts

Task
Compile and download the CFC charts.

Prerequisite
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 
• The hardware is downloaded to the AS.
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Procedure
1. Right-click the "Charts" folder.

2. Select the "Compile" menu command.
The "Compile program" dialog box opens.

3. Activate the "Entire program" check box.
4. Deactivate the "Generate module drivers" checkbox.
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5. Click "OK".
Note
Adapt local data on the AS accordingly, if the compiler reports errors in terms of local data 
requirements. You can calculate local data requirements using the chart reference data of the 
CFC editor.

6. Right-click the "Charts" folder.
7. Select the "PLC > Download" menu command.
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8. Activate the "Entire program" check box.

9. Click "OK".
The "Download" dialog box opens.

10.Click "Yes".

How to customize local data requirements 

Note
During compilation of AS, if the compiler reports errors in terms of local data requirements, 
follow the below mentioned steps.
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1. Open a CFC chart.
2. Open the chart reference data by selecting the "Options > Chart reference data" menu.
3. Calculate local data requirements using the "View > Local data" menu.
4. Customize local data accordingly in the "Properties" dialog box of the AS.

Note
Download the hardware again to AS.

Note
The priority classes relate to the following OBs:
Priority class 1 = OB 1 and OB 80; priority class 12 = OB 35; priority class 25 = OB 70, OB 73, 
OB 81-87, and OB 60 to 65; priority class 26 = OB 80; priority class 27 = OB 100 to 102; priority 
class 28 = OB 80 to 87; priority class 29 = OB 90.

Result
You have successfully compiled and downloaded the AS program.
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Route Control Wizard 7
7.1 Overview of the Route Control Wizard

Overview
Using the Route Control Wizard, you can export the data relevant for Route Control from the S7 
project and import it into the Route Control Engineering.

Tasks of the Route Control Wizard
The Route Control Wizard performs the following tasks:
• Export of AS names and IDs from the S7 project, including check and correction of the IDs of 

the automation systems.
• Export of the plant hierarchy from the S7 project, including the plants and units.

The export only includes process cells and units which are relevant to SIMATIC BATCH.
• Export of AS elements and routes (route = RC_IF_ROUTE), including check and correction of 

IDs.
• Establish and modify the communication links between the automation systems relevant to 

Route Control and Route Control servers.
• Export of AS-server connections.
• Selection of the PCS 7 OS Message Server.
• Generation of Route Control Server messages.
• Generation of operation messages of Route Control faceplates.
• Import of the data to the Route Control project.

Note
The Route Control Wizard assigns the IDs for Route Control elements and connections, and 
writes these IDs to the block inputs in the CFC chart.
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7.2 Exercise with the Route Control Wizard

Task
Use the Route Control Wizard to perform all possible actions.

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated. 

Procedure
1. Select the "Options > SIMATIC Route Control > Wizard" menu command.

The Route Control Wizard opens.
2. The "Route Control Configuration" dialog box is opened if the Route Control does not contain 

a configuration for this S7 project.
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3. Click "Yes".
A Route Control object and the database are created.
The data is read from the S7 project.
The step for selecting the actions opens.
Note
Login with RC maintenance group user credentials described in section 4.7.

4. Activate all check boxes.
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5. Click "Next".
The step for selecting the message server opens.

6. Activate the check box for the message server.
7. Click "Next".

The step for selecting the objects opens.

8. Activate all check boxes.
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9. Click "Next".
The list of objects found is listed in the dialog box.

10.Click "Next".
The step for displaying the selected options opens.
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11.Click "Finish".
The selected actions are executed.
The step for displaying your changes opens.

12.Click "Display logs".
The log file is opened in a text editor.
Note
RC Engineering will automatically start, if the checkbox "Automatically start RC Engineering 
when the wizard closes" is activated.

13.Check the log.
You can also find this log in SIMATIC Manager via the menu.
Note
You can also find this log in SIMATIC Manager via the menu
"Options > SIMATIC Route Control > Show Wizard Log…" menu command.

14.Close the log file.
15.Click "Close".

Result
The selected actions were executed.
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7.3 Configuring connections

Configuring the connection to the Route Control server
Communication between a Route Control AS and a Route Control server is implemented by 
means of S7-DOS functionality. The Route Control Wizard sets up all necessary connections in 
NetPro.

Conventions
• The AS to Server connection is created as S7-Connection.
• The Route Control Wizard sets all addressing parameters (partner address, connection 

resource) required for this S7-Connection.
• The Route Control Wizard activates the connection information in the Route Control 

configuration.
• The Route Control Wizard transfers the connection information to the "RC_IF_CFG" block.
• The Route Control server goes online to the AS during its startup.

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated.

Procedure
1. Select the "RCGSMP_0/ RCGSOS_0/[name of your local computer]/WinCC Application" object 

from the tree view.
2. Select the "Connections" entry from the detailed window and then select the "Edit > Open 

Object" command.
NetPro opens.

3. Select "View > Cross project network view" menu command.
4. Select the "Network > Save and compile" menu command.

The "Save and compile" dialog box opens.
5. Activate the "Compile and check everything" check box and then click "OK".
6. The "Outputs for consistency check" window opens after compilation has been completed. 

Close this window.
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7. Select the CPU and click  . 
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8. Select the PC Station and click .

9. Close NetPro.
10.Download the CFC charts by following the steps described in section 6.3.
11.Go to SIMATIC Manger.
12.Select "RCGSOS > WinCC > OS".
13.Right-click "OS" and select "Compile".

Note
Make sure that the Picture tree option is not checked and the SFC visualization is checked 
during OS compilation.
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Plant structure under the aspect of Route Control 8
8.1 Locations

Locations
Locations are virtual elements of the route control system which are used to break down the 
plant into partial routes. 
Starting with PCS7 V7.0, the locations are configured as equipment properties in the plant view 
of the S7 project and are then transferred to Route Control Engineering using the Route Control 
Wizard.

Locations in the Route Control Getting Started project
Locations required for the Route Control Getting Started project.

Location Meaning Actuators / sensors
FT1 Fermenting Tank1 S1, V3, V4, V5, V6
FT2 Fermenting Tank2 S2, V7, V8, V9, V10
ST1 Storage Tank1 S3, V15, V16, V17, V18
ST2 Storage Tank2 S4, V19, V20, V21, V22
L1 Line1 V1, V4, V8, V11, P2, V13, V16, V20, V23, V25
L2 Line2 V2, V5, V9, V12, P4, V14, V17, V21, V24, V26
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8.2 Partial routes

Partial routes
You do not configure any routes in SIMATIC Route Control. Instead, you configure partial routes 
as connections between two locations. The partial routes form the route network. Runtime route 
requests contain the definition of the source and destination location. You can define up to 10 
additional VIA locations. The Route Control server sets up the optimal route based on the 
available partial routes.
Each element to be used for material transport must be assigned to a partial route in your 
configuration.

Mode table
Each partial route is assigned to a Mode Table. A Mode Table contains 32 modes which you can 
name appropriately. Material transport is controlled in runtime by activating and deactivating 
modes. This functionality allows you to control and poll all elements of the partial routes of a 
route according to their configuration.

Priority
The partial routes are weighted by the priority class. Priority classes are defined as numbers 
ranging from 1 to 9999. Value 1 represents the highest weighting level. Routes and partial 
routes with high weighting are preferred for route searches.

Example:
The partial routes are assigned priorities as shown in the diagram below.

Partial routes are always unidirectional. You have two options of setting up a route from FT1 to 
ST1. The route via location L1 with overall priority class 1 and the route via location L2 with 
overall priority class 2. The system would select the route via L1 with overall priority class 2.
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Bidirectional
The "Bidirectional" parameter is not set when users create new partial routes. Unidirectional 
partial routes are always directed from the source to the destination. The direction of the partial 
route can be reversed by setting the Bidirectional parameter.

Source / destination
Always define different locations to the source and destination of partial routes.

Configure the following partial routes: 
No. Partial route 

name
Description

1 FT1_L1 Fermenting Tank1 to Line1
2 FT1_L2 Fermenting Tank1 to Line2
3 FT2_L1 Fermenting Tank2 to Line1
4 FT2_L2 Fermenting Tank2 to Line2
5 L1_ST1 Line1 to Storage Tank1
6 L1_ST2 Line1 to Storage Tank2
7 L2_ST1 Line2 to Storage Tank1
8 L2_ST2 Line2 to Storage Tank2

Route network with locations and partial routes:
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8.3 Mode table

The Mode Table
Each partial route is assigned to a Mode Table. A Mode Table contains 32 modes which you can 
name appropriately. Mode Tables are a means of structuring the partial routes in order to 
improve the overview. The Mode Table is a parameter which influences the route search. The 
route search includes all partial routes if input "MODE_TBL" = 0 at the "RC_IF_ROUTE" block. 
However, if a specfic ID is defined for route identification then only the partial routes of that mode 
table are included.

Each Mode Table contains 32 modes. The modes are represented by 32 control bits which can 
be activated separately. These modes are used to activate all elements which are assigned to this 
mode in the partial routes. The modes can be assigned meaningful names in the Mode Table 
which can be visualized in runtime. Modes represent the actual control functions of a route. 
Each mode corresponds with one bit of a 32-bit control word (input "MODE" at "RC_IF_ROUTE"). 
Each mode can be assigned partial route elements with specific runtime properties. Activation 
of the mode always includes its elements.
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8.4 Getting Started modes

Introduction
It is not useful to activate all control operations simultaneously when handling complex material 
transports which involve a large number of control elements. For this reason, the Mode Table 
contains 32 modes which can be activated and deactivated separately. Elements can be 
controlled in different ways in different modes.

Mode table
We shall define a Mode Table named "Transfer" in this Getting Started project.

Modes
As a rule you should always check the position of the valves before starting a material transport. 
This check is an actual fact prerequisite for the transfer.
This function is named "Basic position".
Verify that the corresponding valves are in open state before you start the pump. There should 
be a delay between the opening of the valves and activation of the pump. We shall now open all 
valves for the transport operation by calling the "Set route" function and activating the pump by 
calling the "Pump On" function.
The "Set route" function can always be used to activate the transport valves. Practical 
experience shows, however, that it is of advantage to activate the source and destination valves 
separately. For this reason we shall implement the "Open Source" and "Open Destination" 
functions.
The sensors for fill level evaluation are interconnected in separate functions:
"Source not empty" and "Dest not full".
These functions can be activated to suit application requirements and form the basis for the user 
program to be created.

Plant structure under the aspect of Route Control
8.4 Getting Started modes

SIMATIC Route Control Getting Started (V9.0)
Getting Started, 06/2018, A5E43618934-AA 79



8.5 Control tables

Control tables
The elements are to be activated in the corresponding modes as shown in the tables below. You 
need these tables for the exercise "Assigning Route Control elements to partial routes".
The activation key is defined as follows:

Symbol Meaning
a Activation
d Deactivation
? Check
a? Check for activated state
d? Check for deactivated state

You can change the symbols in Route Control Engineering using the "Options > Symbols" menu 
commands.

Activation table of partial route FT1_L1
Element Basic set‐

ting
Set route Pump On Open 

source
Open 
desti‐
nation

Source not 
empty

Dest not full

S1      d?  
CE_V3 d?   a    
CE_V4 d? a      
CE_V5 d?       
CE_V6 d?       
CE_V1 d?       
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Element Basic set‐
ting

Set route Pump On Open 
source

Open 
desti‐
nation

Source not 
empty

Dest not full

CE_V8 d?       
CE_V11 d? a      
CE_P2 d?  a     
CE_V13 d? a      
CE_V16 d?       
CE_V20 d?       
CE_V23 d?       
CE_V25 d?       

Activation table of partial route FT1_L2
Element Basic set‐

ting
Set route Pump On Open 

source
Open 
desti‐
nation

Source not 
empty

Dest not full

S1      d?  
CE_V3 d?   a    
CE_V4 d?       
CE_V5 d? a      
CE_V6 d?       
CE_V2 d?       
CE_V9 d?       
CE_V12 d? a      
CE_P4 d?  a     
CE_V14 d? a      
CE_V17 d?       
CE_V21 d?       
CE_V24 d?       
CE_V26 d?       

Activation table of partial route FT2_L1
Element Basic set‐

ting
Set route Pump On Open 

source
Open 
desti‐
nation

Source not 
empty

Dest not full

S2      d?  
CE_V7 d?   a    
CE_V8 d? a      
CE_V9 d?       
CE_V10 d?       
CE_V1 d?       
CE_V4 d?       
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Element Basic set‐
ting

Set route Pump On Open 
source

Open 
desti‐
nation

Source not 
empty

Dest not full

CE_V11 d? a      
CE_P2 d?  a     
CE_V13 d? a      
CE_V16 d?       
CE_V20 d?       
CE_V23 d?       
CE_V25 d?       

Activation table of partial route FT2_L2
Element Basic set‐

ting
Set route Pump On Open 

source
Open 
desti‐
nation

Source not 
empty

Dest not full

S2      d?  
CE_V7 d?   a    
CE_V8 d?       
CE_V9 d? a      
CE_V10 d?       
CE_V2 d?       
CE_V5 d?       
CE_V12 d? a      
CE_P4 d?  a     
CE_V14 d? a      
CE_V17 d?       
CE_V21 d?       
CE_V24 d?       
CE_V26 d?       

Activation table of partial route L1_ST1
Element Basic set‐

ting
Set route Pump On Open 

source
Open 
desti‐
nation

Source not 
empty

Dest not full

S3       d?
CE_V15 d?    a   
CE_V16 d? a      
CE_V17 d?       
CE_V18 d?       
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Activation table of partial route L1_ST2
Element Basic set‐

ting
Set route Pump On Open 

source
Open 
desti‐
nation

Source not 
empty

Dest not full

S4       d?
CE_V19 d?    a   
CE_V20 d? a      
CE_V21 d?       
CE_V22 d?       

Activation table of partial route L2_ST1
Element Basic set‐

ting
Set route Pump On Open 

source
Open 
desti‐
nation

Source not 
empty

Dest not full

S3       d?
CE_V15 d?    a   
CE_V16 d?       
CE_V17 d? a      
CE_V18 d?       

Activation table of partial route L2_ST2
Element Basic set‐

ting
Set route Pump On Open 

source
Open 
desti‐
nation

Source not 
empty

Dest not full

S4       d?
CE_V19 d?    a   
CE_V20 d?       
CE_V21 d? a      
CE_V22 d?       
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Route Control Engineering 9
9.1 Exercise for the configuration of locations

Introduction
The locations are created in SIMATIC Manager as equipment properties in the plant hierarchy of 
the S7 project. These locations are exported from the S7 project and imported to the 
Route Control Engineering database using the Route Control Wizard.

Task
Define the location types.

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• Plant view is activated. 

You can activate this under the menu item "View > Plant view".

Equipment properties
Start by defining the equipment property types in the shared declarations. A location represents 
an instance of one of these types in the equipment properties of the plant hierarchy. The 
following equipment property types, including their instances, must be created for the project.

Name Data type Source Destination Via
Destination LOCATION  x x
Line1 LOCATION x x x
Line2 LOCATION x x x
Source LOCATION x  x

Folder name S88 Type Definition Equipment properties
Fermenting tank 1 Unit Source
Fermenting tank 2 Unit Source
Line Unit Line1, Line2
Storage tank 1 Unit Destination
Storage tank 2 Unit Destination
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Procedure
How to define the location types 
1. Right-click the "Ferment Storage cellar" folder in the subproject "RCGSAS_0" and select 

"Object properties".
The "Properties - Hierarchy folder" dialog box opens.

2. Select the "S88 Type Definition" tab.
3. Select the "Process cell" entry from the "Object type" drop-down list box.

4. Click "OK".
5. Open the object properties of the "Fermenting_cellar > Fermenting tank 1" folder.
6. Set the "Unit" object type in the "S88 Type Definition" tab.
7. Click "OK".
8. Set the "Unit" object type at the "Fermenting cellar > Fermenting tank 2", "Line >Line", 

"Storage cellar > Storage tank 1" and "Storage cellar > Storage tank 2" folders.
9. Right-click "Shared Declarations" folder and select the "Insert new object > Equipment 

property".
A "Equipment properties" folder is created.

10.Repeat step 9 three times.
You have now created four "Equipment property" objects in the "Equipment properties" 
folders.

11.Right-click the new "Equipment Property1" object and select "Object properties".
The "Properties Equipment Property" dialog box opens.
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12.Enter the following data:
Name: "Source"
Data type: "LOCATION", Source: activated, Dest: deactivated, Via: activated.

13.Click "OK".
14.Enter the following data in the object properties of the new "Equipment properties2" object:

Name: "Destination"
Data type: "LOCATION", Source: deactivated, Destination: activated, Via: activated.
Click "OK".

15.Enter the following data in the object properties of the new "Equipment properties3" object:
Name: "Line1"
Data type: "LOCATION", Source: activated, Destination: activated, Via: activated.
Click "OK".

16.Enter the following data in the object properties of the new "Equipment properties4" object:
Name: "Line2"
Data type = "LOCATION", Source: activated, Destination: activated, Via: activated.
Click "OK".
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How to enter the locations
1. Right-click the "Fermenting tank 1" folder and select the "Insert new object > Equipment 

properties".
The "Equipment properties" folder is created.

2. Right-click the new "Equipment properties" folder and select the "Insert new object > 
Equipment property".
The new "Equipment property" object is created.
Note
In the case of "Line", the "Equipment property" has to be added twice.

3. Right-click the new "Equipment property" object and select "Object properties".
The "Properties Equipment Property" dialog box opens.

4. Select the "Source" entry from the "Type" field. 
Note
If "Source" entry is selected from "Type" field, the "Name" and "Display name" are selected as 
"Source" automatically.

5. Click "OK".
Your entries are applied.
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6. Repeat the steps from 1 to 5 to configure all other locations listed in the table.

Folder name S88 Type Definition Equipment properties
Fermenting tank 1 Unit Source
Fermenting tank 2 Unit Source
Line Unit Line1, Line2
Storage tank 1 Unit Destination
Storage tank 2 Unit Destination

7. Export and import the data using the Route Control Wizard described in section 7.2.

Result
You have successfully configured the following equipment properties:

Name Data type Source Destination Via
Source LOCATION x  x
Destination LOCATION  x x
Line1 LOCATION x x x
Line2 LOCATION x x x

Results in SIMATIC Manager:
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Result in Route Control Engineering:
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9.2 Exercise with the mode table

Task
Configure a Mode Table named "Transfer".

Prerequisite
Route Control Engineering is open.

Note
Follow the instructions described in 7.2 to open Route Control Engineering.

Modes of the "Transfer" Mode Table
The table below shows the modes which should be provided in the Mode Table:

No. Function
1 Basic setting
2 Set route
3 Pump on
4 Open source
5 Open destination
6 Source not empty
7 Dest not full

Procedure
1. Expand the Mode Tables folder on the upper left column in "SIMATIC Route Control 

Engineering" window.
2. Right-click the "Mode Table" folder and select "Rename".
3. Change the name to "Transfer".
4. Right-click the "Mode 1" in the "Transfer" table and select "Rename".
5. Change the name to "Basic setting".
6. Repeat the steps from 4 to 5 for "Mode 2" to "Mode 7" in accordance with the "Mode table 

functions" shown above.
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Result
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9.3 Exercise in configuring partial routes

Task
Configure the partial routes as required.

Prerequisite
Route Control Engineering is open.

The partial routes listed below are to be created for the Transfer Mode Table:
Partial route name Source Destination
FT1_L1 Fermenting tank 1/Source Line/Line1
FT1_L2 Fermenting tank 1/Source Line/Line2
FT2_L1 Fermenting tank2/Source Line/Line1
FT2_L2 Fermenting tank2/Source Line/Line2
L1_ST1 Line/Line1 Storage tank 1/Destination
L1_ST2 Line/Line1 Storage tank 2/Destination
L2_ST1 Line/Line2 Storage tank 1/Destination
L2_ST2 Line/Line2 Storage tank 2/Destination
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Procedure
1. Right-click "Transfer" folder in the lower half of Route Control Engineering and select "Add 

partial route".

2. Enter the name "FT1_L1" in the "Properties" dialog box.
3. Select the "Start point:" as "Fermenting tank 1/Source".
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4. Select the "End point:" as "Line/Line1".
Note
The values for "Start point:" and "End point:" are generated automatically and differ from 
system to system. 

5. Click "OK".
The program saves your entries.

6. Configure all partial routes according to the table shown below.

Partial route 
name

Source Destination

FT1_L1 Fermenting tank 1/Source Line/Line1
FT1_L2 Fermenting tank 1/Source Line/Line2
FT2_L1 Fermenting tank2/Source Line/Line1
FT2_L2 Fermenting tank2/Source Line/Line2
L1_ST1 Line/Line1 Storage tank 1/Destination
L1_ST2 Line/Line1 Storage tank 2/Destination
L2_ST1 Line/Line2 Storage tank 1/Destination
L2_ST2 Line/Line2 Storage tank 2/Destination
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Result

Note
If you start by programming the source and the destination in the properties of a partial route, 
the system proposes a name which is derived from the source and the destination.
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9.4 Exercise in assigning Route Control elements to the partial routes

Task
Assign the control elements, sensor elements, parameter elements and connection elements to 
the partial routes. Refer to the information in the "Activation tables" section.

Prerequisite
Route Control Engineering is open.

Procedure
1. Select the partial route "FT1_L1" in the bottom section of Route Control Engineering.
2. Select the "Elements" tab.
3. Expand the folders "RCGSMP_0 > RCGSAS_0 > AS" in upper left corner of the "SIMATIC Route 

Control Engineering" window.
4. Select "Control elements" in the tree view.
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5. Drag-and-drop valve "CE_V3" from the detailed view to the "Elements" table.

A "Properties" dialog box opens.
6. Select the "Type:" as "VALVE".
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7. Activate the "Passive usage:" checkbox.

8. Click "OK".
9. Configure the elements of all partial routes in accordance with the "Activation tables" 

described in section 8.5.
Note
These elements of partial routes can also be configured in the "Functions" tab. You can also 
copy and then edit partial routes and their assigned elements.
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9.5 Exercise in loading and updating the Route Control Server

Task
• Program your runtime parameters so that the Route Control Server starts up independent of 

WinCC.
• Starting, loading and updating the Route Control Server.

Prerequisite
Route Control Engineering is open.

Procedure
1. Select the "Windows icon > All apps > Siemens Automation > Serverdialog" menu command.

Note
For Windows 7, Select the "Start > All programs > Siemens Automation > SIMATIC > 
ROUTE CONTROL > Serverdialog" menu command.
For Windows 2012 server or higher, type "Serverdialog" in the search box of the Windows 
task bar.
The Route Control server dialog starts and is displayed as icon  in the task bar.

2. Select the "Options > Download to server" menu command in Route Control Engineering.
The "Download to server" dialog box opens.

3. Select the client configured in 4.4.
4. Click "Start".

The server is loaded along with the selected client.
5. Click "OK" in the summary dialog box.

Both dialog boxes are closed.
6. Activate the Route Control server: Open the server window and select "Activate".

Note
Before Activation of Server dailog, the CFC charts have to be downloaded. Follow the steps 
described in section 6.3.
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7. Select the "Windows icon > All apps > Siemens Automation > Center" menu command on 
client.
The Route Control Center opens for Windows 10.
Note
For Windows 7, select the "Start > All programs > Siemens Automation > SIMATIC > 
ROUTE CONTROL > Center" menu command on client.
For Windows 2012 server or higher, type "Center" in the search box of the Windows task bar.

8. Click the icon  in the Route Control Center.
The "SIMATIC RC Server" dialog box opens.

9. Click "Update".
The "Update SIMATIC RC Server" dialog box opens.

10.Click "OK".
The Route Control Server is updated.

11.Click "Close".
Note
During the first load operation or if no new data has been transferred, the "Update" button 
is grayed out. In these two cases, the server data is already up to date.

Result
The Route Control Server is updated and up.

Route Control Engineering
9.5 Exercise in loading and updating the Route Control Server

SIMATIC Route Control Getting Started (V9.0)
102 Getting Started, 06/2018, A5E43618934-AA



9.6 Exercise in checking routes in offline mode

Introduction
Use the "offline" route search functions in order to check routes configured offline in 
Route Control Engineering before you download these to the server. The search tool does not 
access the Route Control Server in offline mode.

Prerequisite
Route Control Engineering is open.

Procedure
1. Select the "Options > Verify route" menu command.

The "Route Control route search" window opens.
2. Select the "Route search" tab on the right side of the window. 

The route search settings are displayed.
3. Select the "Transfer" entry from the "Mode Table" drop-down list box.
4. Activate the "Find all routes between source and destination" radio button.
5. Select the "Fermenting tank 1" entry from the "Source" drop-down list box.
6. Select the "Storage tank 2" entry from the "Destination" drop-down list box.
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7. Click . 
The search tool finds two potential routes.

8. The details of the partial routes of a route are displayed in the lower windows.
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9.7 Materials and material sequences

Introduction
Route Control Engineering allows you to create materials and to configure the material 
sequence. Example: a piping system which was cleaned with a caustic solution must be 
neutralized with water. You can configure this rule in the Route Control Engineering. The 
materials can be allocated to groups.

Engineering
The following material groups and materials are to be used:

Material name Material group
Raw Material1 Raw materials
Raw Material2
Product1 Products
Product2
Cleaner1 Cleaners
Cleaner2
Water1 Water
Water2

Observe the following predecessor / successor relationships of the material groups:

Predecessor Successor 
Products Cleaners

Products
Raw materials Cleaners 

Raw materials
Cleaners Water
Water Cleaners

Products
Raw materials

Note
The runtime user program can transfer the requested new material prior to the route request. 
The new material is included in the route search and is checked whether or not it is a valid 
successor material.
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9.8 Exercise in the configuration of materials and material successions

Exercise in the configuration of materials and material sequences
Configure the materials, the material groups, and the material successors.

Prerequisite
Route Control Engineering is open.

Procedure
1. Select the "Options > Material..." menu command.

The "Material Configuration" dialog box opens.

2. Right-click in the Name column and select "New" to create a material in the "Material 
definition" tab.

3. Rename it as "Raw material 1".
4. Repeat step 2 to 3 to create all the other materials in the "Material definition" tab.
5. Right-click the "Material groups" and select "New" to create a material group in the "Material 

groups" tree. 
6. Rename it as "Raw materials".
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7. Repeat step 5 to 6 to create all the other material groups in the "Material groups" tree. 
Configure the material and material groups listed in the table by following the above steps.

Material name Material groups
Raw Material1 Raw materials
Raw Material2
Product1 Products
Product2
Cleaner1 Cleaners
Cleaner2
Water1 Water
Water2

8. Select the "Cleaners" group from the "Material groups" tree.
9. Assign the "Cleaner1" and "Cleaner2" materials to "Cleaners" group in the "Material groups" 

tree using drag-and-drop.
10.Assign all materials to their material groups in the same way.
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11.Open the "Material sequences" tab.

Note
The material sequence shown in the figure is a result of the above steps. The user can edit the 
material sequence as per their requirements.

12.Download and update the Route Control Server.
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Route Control Center 10
10.1 General

General
The Route Control Center is the user interface for operators of the Route Control system. 
Automatic material transports are visualized in the WinCC process picture by means of SFCs.
The Route Control Center can be used to control material transport in manual mode. The various 
material transport modes can be started manually if the route is in manual mode. The operator 
can view and trace all material transports and their states in online mode.
The Route Control Center can be started from a Route Control faceplate or by selecting "Windows 
icon > All apps > Siemens Automation > Center" for Windows 10. 

Note
For Windows 7, "Start > All programs > Siemens Automation > SIMATIC > Route Control > Center" 
from the Windows Start menu. 
For Windows 2012 server or higher, type "Center" in the search box of the Windows task bar.

If opened from a faceplate the RCC only displays information of the material transport and the 
route ID of the faceplate. If the Route Control project is opened using the Windows Start menu, 
all the configured routes are displayed.
The relevant route data and error information of a material transport are displayed in several 
views. The elements of a material transport and their corresponding activation functions can be 
visualized.
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10.2 Functions of the Route Control Center

Route Control Center
The figure below lists the defined areas of Route Control Center:

1. Menu bar
2. Tool bar
3. Route line of material transport
4. Functions
5. Elements
6. Partial routes
7. Status bar
8. Modes of material transport

The menu bar
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Menu item Submenu Meaning
Program Server Selection Opens a dialog box where you can select the Route Control Server 

to which you want to connect the Route Control Center.
Log On Opens a user log on dialog. This function is only available if no 

other user is logged on.
Log Off Opens a dialog where a user can log off and log on again. This 

function is only available if a user is logged on.
Exit Closes the Route Control Center application. 

Function Manual Operation Toggles between manual and auto mode.
Start Saved Route If a route has been saved for a combination of sources, destination 

and vias, it can be started using this button. 
Request Route This function triggers a route request.
Start Route Starts the route. There are no modes activated as yet.
Pause Route Holds the route
Resume Route Restarts a route from hold state. If the route was in error state the 

error is acknowledged.
Stop Route Stops the route
Save Current Route Saves the currently selected route with its route properties.
Apply Material Activates the material information at the Route Control Server.
Update Route Updates the list of elements and the route status, and requests the 

data from the Route Control Server once again.
Update Elements Updates the list of elements and requests the data from the 

Route Control Server once again.
Route Properties Opens the Route properties dialog box. This property can only be 

changed if the route is not active.
View Element List Changes to the "Elements" view in the lower section of the 

Route Control Center. The view displays the "Elements" and 
"Modes" tabs. 

 Request Details Changes to the view which shows the result of a route request in 
the lower section of the Route Control Center.

 Maintenance Hides/shows the maintenance view for the AS 
 Toolbar Hides or shows the toolbar
 Status Bar Hides or shows the status bar
 Always On Top The Route Control Center is always displayed in the foreground and 

cannot be moved to the background, irrespective of any change to 
another application or window.

 Server Status Opens a dialog box which displays the status of the Route Control 
Server.

 Update Fetches the data again from the Route Control Server and initializes 
the view.

Options Language Sets the user language
 Routes Log Opens the route log file
 Settings... Settings of the Route Control Center
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Menu item Submenu Meaning
Help Contents... Opens the Help system.

Context-sensitive 
Help 

Opens the Help system and jumps to the corresponding descrip‐
tion of the active dialog box.

Introduction Opens the Help system and jumps to the introduction
Getting started Opens the Help system and jumps to the description of the first 

steps.
Using Help Information on how to use the help.
About... Opens a dialog with information pertaining to the product name 

and version, to the Copyright, and to the manufacturer.

The toolbar

Symbol Description
Anchors the Route Control Center to its position. It is not moved to the background or closed 
after switching to another application.
Opens a selection dialog box for a Route Control Server. This dialog box can be used on a 
multiclient to address a different Route Control Server.
Opens the dialog box which displays the status of the Route Control Server. 

Updates the view. The data is fetched explicitly from the server again.

Changes to the inactive route operating mode, that is, to "Manual" or "Auto" mode. 

Requests the route. Only available in manual mode.

Starts the route. Modes will not be activated at this time. Only available in manual mode.

Starts a saved route.

Interrupts the route. Modes will be deactivated. The actual route remains in active state and 
the route lists remain loaded. Not enabling elements. Only available in manual mode.
Acknowledges errors and resumes route processing.

Saves the current route.

Stops the route. Modes will be disabled. Enables elements of the route list. Only available in 
manual mode.
Transfer of the material for transport. This icon can only be operated if at least one connection 
element of the route differs from the defined material of the route.
Switches to the maintenance view of the Route Control Center.

Route line of a material transport
This line returns the name of the route block, the route ID, the AS, the mode ID, the mode table, 
the material, the step number, the Batch name, the source and destination and a description of 
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the material transport.
The current state of material transport is visualized in color.

Note
The short info provides additional information relating to column entries, for example, the 
instance DB number of the route block. 

Modes of material transport
Route Control Engineering allows you to create up to 32 modes in each Mode Table.

Note
This part of the Route Control window is only visible after a route is requested. It is bound to the 
"Functions" tab.

"Functions" tab
Displays all elements of the selected route in one line.

"Elements" tab
Displays all modes of the elements of the selected route in one line.

Partial routes tab
Displays all partial routes of the selected route.

Status bar

Element Description
Total number of displayed routes

AS status

Status of the Route Control Server to which the Route Control Center is connected

Station name of the Route Control Server
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Element Description
Display of the route log. The small green triangle indicates the active state of the route log. 
The corresponding short info indicates the path of the log file and the number of days for 
a circular buffer. The route log is opened by double-clicking the icon.
The license is installed for 300 simultaneous routes. Only one other route was simultane‐
ously active since the last startup of the server.
Name of the logged on user

Note
The user is only logged off, if the Route Control Center was the last application connected to 
SIMATIC Logon.
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10.3 Exercise in requesting a route using the Route Control Center

Task
Request a route in the Route Control Center.

Prerequisite
• The Route Control Server is loaded and in ACTIVE state.
• The Route Control Center is open.
• If you are not yet logged on, log on by means of credentials described in 4.7.

Procedure
1. Select the route line Route1 in the top section of the Route Control Center.
2. Click the  toolbar icon.

Note
By default, the route is in "Manual" mode. If it is not in "Manual" mode, then use this icon.

3. Double-click route line Route1.
The "Route properties" dialog box opens.
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4. Select the following paths:
Mode table: Transfer
Source: Ferment Storage cellar/Fermenting tank 1/Source
Destination: Ferment Storage cellar/Storage tank 1/Destination
Via1: Ferment Storage cellar/Line/Line1.
Select the paths by clicking these in the drop-down list boxes.

5. Click "OK".
6. Click the "Request route" toolbar button .

A dialog box opens.

7. Click "Yes".
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8. The route line is displayed on a yellow background. The "Functions" tab displays all 
Route Control elements and associated modes which are active during material transport.

9. The route request was successfully completed.
10.Click the "Stop route" toolbar button .

A dialog box opens.

11.Click "Yes".
The route request is stopped.
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Route Control Project Engineering in the Operator 
Station 11
11.1 The Route Control block icon

The Route Control block icon
The block icon displays the main statuses of a route. The block icon is not yet interconnected with 
the process tag.

The title bar displays the route name. That is the instance name of the block in the CFC chart of 
the type "RC_IF_ROUTE" which is interconnected with this icon. 
The next row displays the route status.
The footer shows the route ID of the current material transport. Any active messages are 
visualized in the PCS 7 group display.
The block icon is available in the WinCC picture "@pcs7typicalsrc.pdl". You can copy this icon to 
your own picture. To interconnect this copy with the instance of RC_IF_ROUTE, see 11.4.

Description of the route states in the block icon
Icon Meaning

Route is deactivated and inactive (automatic mode)
Route is deactivated and inactive (manual mode)
Route request is active (automatic mode)
Route request is active (manual mode)
Route is active and running (automatic mode)
Route is active and running (manual mode)
Route is held (automatic mode)
Route is held (manual mode)
Route is in error state (automatic mode)
Route is in error state (manual mode)
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11.2 Route Control faceplate

Route Control faceplate
The Route Control faceplate is used to control routes in manual mode. Open the faceplate by 
clicking a block icon in the process picture. The faceplate cannot be used to modify source, 
destination and Via parameters. The modes cannot be controlled by means of the faceplate. 
These parameters must be entered for manual mode by means of the Route Control Center.
Route Control faceplate in active state:

Route Control faceplate in Automatic mode:
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Note
To change the mode from Manual to Automatic, Click "..." beside the "Operating mode" display 
and select "Automatic" in the Route Control Faceplate.

Route Control faceplate in Manual mode:
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The Route Control faceplate contains the following operator controls:

Icon Meaning
Runs the route in Automatic mode.

Runs the route in Manual mode.

Requests the route (in Manual mode)

Start route (in Manual mode)
Pauses the route (in Manual mode)

Resume route (in Manual mode)
Stops the route (in Manual mode)

Save the route (in Manual mode)
Run the saved route (in Manual mode)
Opens the BATCH Control Center if this is installed on your computer. It will be unavailable if the BATCH client 
is not installed.
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Icon Meaning
Opens the SFC dialog box with the SFC which controls this route.
The path to the corresponding SFC must have been configured at the RC faceplate. (For example: using the 
RC Wizard in the Graphics Designer.)
Opens the Route Control Center with additional details of this route, including all elements and their status.

The route status is visualized in the Route Control faceplate by the following icons:

Icon Meaning
Inactive state indicates that the route is in IDLE state.

Yellow indicates the active state of the route request, the ready state of the route, or the 
held state of the route.
Green indicates the busy state of the route and the activated state of the elements.

Red indicates that the route is in error state.
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11.3 Route Control messages in the Operator Station

Route Control messages on the Operator Station
SIMATIC Route Control outputs messages from the Route Control Server and from the AS blocks. 
Instead of listing the Route Control-Server messages based on a specific order, the next sections 
classify the Route Control-Server messages based on their tasks and meaning within the 
Route Control system. The listing is incomplete as it only covers the most important messages 
related to the handling of the Route Control system.
A large number of messages refer to configuration errors within the AS, such as missing DBs or 
FBs of Route Control. The messages are not covered in these sections as they are self-
explanatory. 
The Online Help contains additional comments relating to the message.

Route request messages
Reporting component Message text
RC Server Partial route is currently being used
RC Server Element is in manual mode
RC Server Element is faulty
RC Server Element in maintenance
RC Server Maintenance concerns elements
RC Server Element material error
RC Server Element disabled
RC Server Error downloading route list to AS
AS block RC_IF_ROUTE Error transferring route list to AS
AS block RC_IF_ROUTE Route request timeout
AS block RC_IF_ROUTE Unassigned / available route not found
AS block RC_IF_ROUTE Invalid locations
AS block RC_IF_ROUTE Element(s) with incorrect status
AS block RC_IF_ROUTE Material compatibility error

Runtime messages
Reporting component Message text
AS block RC_IF_ROUTE Route ID error
AS block RC_IF_ROUTE Cross-coupling time monitoring error
AS block RC_IF_ROUTE Status monitoring time error
AS block RC_IF_ROUTE Fault tolerance time error
AS block RC_IF_ROUTE Idle state error
AS block RC_IF_ROUTE No available route ID found
AS block RC_IF_ROUTE AS is not configured for this route ID
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11.4 Exercise in configuring the Route Control block icon in the process 
picture

Task
Configure the Route Control block icons.

Prerequisite
• The Getting Started project is open in SIMATIC Manager.
• The Component view is activated.

Procedure
1. Select the "RCGSOS_0 > PC STATION > WinCC Application > OS" object.
2. Select the "Edit > Open object" menu command.

WinCC Explorer opens.

3. Select the Graphics Designer object in the tree view on the left side. 
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4. Select the "Overview.pdl" object in the detailed view on the right side.
Graphics Designer opens with the "Overview" screen.

5. Select the "File > Open" menu command in Graphics Designer.
The "Open" dialog box opens.

6. Select the picture "@pcs7typicalsrc.pdl" and click "Open".
7. Select both block icons. 

8. Copy to the clipboard using the "CTRL+C" keystroke.
9. Switch to the "Overview.pdl" picture.
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10.Insert the blocks using the "CTRL+V" keystroke.
Note
The blocks have to be copied twice.

11.Arrange the block icons as shown below.

12.Select the block icon.
13.Select the "Dynamic Wizard > Standard Dynamics".

Note
The Dynamic Wizard is visible by default in Graphics Designer and can be found in "View > 
Toolbars > Dynamic Wizard".
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14.Double-click the "Link a prototype to a structure or rename an existing link".

Note
The available options shown in Dynamic Wizard differ for each selected object or if no object 
is selected in the "Overview.pdl" picture.

15.Click "Next" in the "Welcome to the Dynamic Wizard" dialog box.
16.Click the "..." button in the "Set options" dialog box.
17.Activate the "ES Variables" checkbox in the "Tags" window.
18.Select "ES Variables > RCGSAS_0 > AS/CPU 417-4/S7 Program(1)" from the tree view.

19.Select "Route1" from the detailed view.
20.Click "OK".
21.Select the network, if it is prompted.
22.Click "Next" in the "Set options" dialog box.
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23.Click "Finish" in the "Finished !" dialog box. The block icon is now interconnected with CFC 
block "Route1".

24.Repeat the steps 12 to 23 to link the other block icons as shown below.

Note
Interconnect the two upper block icons with CFC block "Route1" and the lower pair of block 
icons with CFC block "Route2". 

25.Save the "Overview.pdl" picture.

Route Control Project Engineering in the Operator Station
11.4 Exercise in configuring the Route Control block icon in the process picture

SIMATIC Route Control Getting Started (V9.0)
Getting Started, 06/2018, A5E43618934-AA 129



11.5 Exercise in configuring the SFC block icon in the process picture

Task
Configure the SFC faceplate in the process picture.

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• WinCC Explorer is open.
• The "Overview.pdl" picture is open in Graphics Designer.

Procedure
1. Open the "@TemplateAPLV8.PDL" picture in Graphics Designer.
2. Select the block icon.

3. Copy to the clipboard using the "CTRL+C" keystroke.
4. Switch to the "Overview.pdl" picture.
5. Insert the block using the "CTRL+V" keystroke.
6. Position the block icon below the "Route2/Route2" block icon as shown below.
7. Select the copied block icon in "Overview.pdl" picture.
8. Select "Object Properties > Properties".

Note
The "Object Properties" and "Dynamic Wizard" are visible by default in Graphics Designer and 
can be found in "View > Toolbars".

9. Select the "General" submenu in the "Properties" tab and then double-click "StructureType".
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10.Enter "RC_IF_SFC" as output value and then click "OK".

11.Select the copied block icon in "Overview.pdl" picture.
12.Select the "Dynamic Wizard > Standard Dynamics".
13.Double-click the "Link a prototype to a structure or rename an existing link".
14.Link the block icon with the SFC instance "Route2/SFC_R2" by following the steps 14 to 23 

described in 11.4.
15.Save the "Overview.pdl" picture.

16.Select "File > Exit" to close the Graphics Designer.
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Handling material transports using Route Control 12
12.1 Exercise in executing and monitoring material transport using the 

RCC

Task
Execute and monitor material transport using the Route Control Center

Prerequisites
• The Getting Started project is open in SIMATIC Manager.
• The Route Control Server is loaded and in "ACTIVE" state.
• The Route Control Center is open.
• The WinCC project "OS" is open in WinCC Explorer.
• If you are not yet logged on, log on by means of credentials described in 4.7.

Procedure
1. Select "File > Activate" in WinCC Explorer.

Note
The reset button for simulation tank levels should be set as shown .

2. Select the route line "Route1" in the top section of the Route Control Center.
3. Click the  toolbar icon.

Note
By default, the route is in "Manual" mode. If it is not in "Manual" mode, then use this icon.

4. Double-click route line "Route1".
The "Route properties" dialog box opens.
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5. Select the following paths:
Mode table: Transfer
Source: Ferment Storage cellar/Fermenting tank 1/Source
Destination: Ferment Storage cellar/Storage tank 1/Destination
Via1: Ferment Storage cellar/Line/Line1.
Select the paths by double-clicking these in the drop-down list boxes.
Note
Due to following the steps in 10.3, these paths are already selected. You need to just check 
them before running the route.

6. Click "OK".
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7. Click "Start route" in the toolbar.
A dialog box opens.

8. Click "Yes".
The route line is displayed on a green background. The "Functions" tab displays all 
Route Control elements and associated modes which are active during the material transport

9. Click the Basic settings column in the "Functions" tab in the lower section of the RCC. This 
opens a dialog box where you can activate the Basic settings mode.
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10.Click "Yes". The Basic settings are activated.

11.Activate the "Set Route" mode.
12.Change to the WinCC Runtime window to monitor the reaction of the valves.
13.Activate all modes.
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14.Change to the WinCC Runtime window to monitor the material transport.
Note
The route enters the error state at the end of material transport because the setpoint 
monitoring time at Sensor1 or Sensor2 is exceeded. 

15.Click "Stop route" in the RCC.
16.Acknowledge the error in WinCC using the "Acknowledge error" button in Route 1 faceplate.

17.Activate the Reset switch  in the "Overview" process picture.
18.Deactivate the Reset switch  in the "Overview" process picture.
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12.2 Exercise in executing and monitoring material transport by means 
of SFC

Task
Execute and monitor material transport by means of SFC

Prerequisites
• The Route Control Server is loaded and in "ACTIVE" state.
• WinCC Runtime is active.
• Route Control Center is open.
• If you are not yet logged on, log on by means of credentials described in 4.7.

Procedure
1. Click the "Route2" block icon in the "Overview" screen of WinCC Runtime.

The "Route2" block icon's faceplate opens.
2. Click "..." in "Route2" block icon faceplate.
3. Select "Automatic" in the "Route2" block icon faceplate, if necessary.
4. Click the "Route2_SFC" block icon in the "Overview" screen of WinCC Runtime.
5. Select the "Prepared values" view from the drop-down menu in the "Example-SFC to use with 

Route Control" window.
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6. Enter the following setpoints:
Source: "FT2"
Destination: "ST2"
Via1: "L2".

7. Click "Start" button in the "Example-SFC to use with Route Control" window.

Handling material transports using Route Control
12.2 Exercise in executing and monitoring material transport by means of SFC

SIMATIC Route Control Getting Started (V9.0)
Getting Started, 06/2018, A5E43618934-AA 139



8. Select "SFC section" from the drop-down menu in the "Example-SFC to use with Route 
Control" window.

9. Monitor the material transport.
10.Activate the Reset switch  in the "Overview" process picture.
11.Deactivate the Reset switch  in the "Overview" process picture.
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List of abbreviations A
A.1 Abbreviations

Abbreviations
Abbreviation Meaning
AS Automation system
CE Control Element
CFC Continuous Function Chart
CPU Central Processing Unit
CSV File format - Comma-Separated Values
DB Data Block
ES Engineering Station
FB Function Block
FC Function
FT Fermenting Tank
GS Getting Started
HW Hardware
IP Internet Protocol
ISA-88 Standard that describes the structure of a batch plant
LE Link Element
MAC address Media Access Control address
MP Multiproject
OB Organization Block
OS Operator Station
PCS 7 Process Control System 7
PE Parameter element
RC Route Control
RCC Route Control Center
SE Sensor element
SFC Sequential function chart
ST Storage Tank
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