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Legal information
Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage 
to property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices 
referring only to property damage have no safety alert symbol. These notices shown below are graded according to 
the degree of danger.

DANGER
indicates that death or severe personal injury will result if proper precautions are not taken.

WARNING
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Qualified Personnel
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems.

Proper use of Siemens products
Note the following:

WARNING
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended or 
approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and maintenance 
are required to ensure that the products operate safely and without any problems. The permissible ambient 
conditions must be complied with. The information in the relevant documentation must be observed.

Trademarks
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Introduction 1
1.1 Purpose of this manual

This documentation contains a detailed description of the SIRIUS engineering Safety ES 
software. The documentation provides you with the information you require for configuring, 
planning, parameterizing and diagnosing a 3SK2 safety relay or a 3RK3 Modular Safety System 
with the Safety ES software.

1.2 Required basic knowledge
A general knowledge of the following areas is needed in order to understand this manual:
• Low-voltage switchgear
• Digital circuit logic
• Automation systems
• Safety systems

1.3 Validity range
This manual is valid for the components listed below:

Component Article number   
Safety ES (parameterization software) 3ZS1316-*
  Safety ES V1.0 Basic
  

  3ZS1316-4CC10-0YA5

  Safety ES V1.0 Basic / License Download   3ZS1316-4CE10-0YB5  

  Safety ES V1.0 Standard   3ZS1316-5CC10-0YA5  

  Safety ES V1.0 Standard / License Download   3ZS1316-5CE10-0YB5  
  Safety ES V1.0 Premium
  

  3ZS1316-6CC10-0YA5
  

  Safety ES V1.0 Premium / License Download 
  3ZS1316-6CE10-0YB5
  

3SK2 safety relays
3SK2 safety relay 22.5 mm (basic unit) 3SK2112-xAA10
3SK2 safety relay 45 mm (basic unit) 3SK2122-xAA10
3RK3 Modular Safety System
3RK3 Basic (central unit) 3RK3111-xAA10
3RK3 Advanced (central unit) 3RK3131-xAC10

SIRIUS engineering Safety ES V1.0
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Component Article number   
3RK3 ASIsafe basic (central unit) 3RK3121-xAC00
3RK3 ASIsafe extended (central unit) 3RK3122-xAC00
4/8F‑DI (expansion module) 3RK3211-xAA10
2/4F‑DI 1/2F‑RO (expansion module) 3RK3221-xAA10
2/4F‑DI 2F‑DO (expansion module) 3RK3231-xAA10
4F‑DO (expansion module) 3RK3242-xAA10
4/8F‑RO (expansion module) 3RK3251-xAA10
8DI (expansion module) 3RK3321-xAA10
8DO (expansion module) 3RK3311-xAA10
Accessories
PROFINET interface 3SK25 (interface module) 3SK2511-xFA10
Diagnostics display 3RK3611-3AA00

3SK2611-3AA00
DP interface (interface module) 3RK3511-xBA10

x = 1: Version with screw-type terminals:
x = 2: Version with spring-loaded terminals:
SIEMENS reserves the right to include updated information about new components or new 
versions of components in a Product Information.

1.4 Additional documentation

List of references
You will find further manuals in the table that may be of interest for your project planning. They 
are available to download from the Internet free of charge. You can create your own individual 
system documentation in the Siemens Industry Online Support under "mySupport".

Title of the manual Document number
SIRIUS 3RK3 Modular Safety System 3ZX1012-0RK31-1AB1
SIRIUS 3SK2 Safety Relays 3ZX1012-0SK21-1AB1
SIRIUS 3SK1 Safety Relays 3ZX1012-0SK11-0AB0
SIRIUS 3RM1 motor starters 3ZX1012-0RM10-2AB1
SIRIUS Safety Integrated 3ZX1012-0SK11-1AB1
PROFIBUS Network Manual C79000-G8900-C124-03
AS-Interface 3RK2703-3AB02-1AA1
SIMATIC PROFINET System Description A5E00298287-06 

Introduction
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Interesting links
• Manuals in Siemens Industry Online Support (https://support.industry.siemens.com/cs/ww/

en/ps/man)
• FAQs about safety engineering (http://support.automation.siemens.com/WW/view/en/

60763768/133000)
• Safety Evaluation Tool (http://www.siemens.com/safety-evaluation-tool)
• Systematic industrial safety engineering: Safety Integrated (http://www.siemens.com/

safety-integrated)
• Further information on PROFINET (https://www.siemens.com/global/en/home/products/

automation/industrial-communication/profinet.html)
• The EMC Directive 2014/30/EU in Practice (https://www.siemens.com/global/en/home/

markets/panel-building/control-cabinet/emc-optimization.html)
• Industrial Control Panels and Electronic Equipment of Industrial Machinery for North 

America (https://www.siemens.com/global/en/home/markets/panel-building/control-
cabinet/north-america.html)

• Control Panels compliant with IEC Standards and European Directives (https://
www.siemens.com/global/en/home/markets/panel-building/control-cabinet/eu-
directives.html)

1.5 Siemens Industry Online Support

Information and service
At Siemens Industry Online Support you can obtain up-to-date information from our global 
support database:
• Product support
• Application examples
• Forum
• mySupport
Link: Siemens Industry Online Support  (https://support.industry.siemens.com/cs/de/en)

Product support
You can find information and comprehensive know-how covering all aspects of your product 
here:
• FAQs 

Answers to frequently asked questions
• Manuals/operating instructions

Read online or download, available as PDF or individually configurable.
• Certificates

Clearly sorted according to approving authority, type and country.
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• Characteristics
For support in planning and configuring your system.

• Product announcements 
The latest information and news concerning our products.

• Downloads 
Here you will find updates, service packs, HSPs and much more for your product.

• Application examples
Function blocks, background and system descriptions, performance statements, 
demonstration systems, and application examples, clearly explained and represented.

• Technical data
Technical product data for support in planning and implementing your project

Link: Product support (https://support.industry.siemens.com/cs/ww/en/ps)

mySupport
The following functions are available in your personal work area "mySupport":
• Support Request

Search for request number, product or subject
• My filters

With filters, you limit the content of the online support to different focal points.
• My favorites

With favorites you bookmark articles and products that you need frequently.
• My notifications

Your personal mailbox for exchanging information and managing your contacts. You can 
compile your own individual newsletter in the "Notifications" section.

• My products
With product lists you can virtually map your control cabinet, your system or your entire 
automation project.

• My documentation
Configure your individual documentation from different manuals.

• CAx data 
Easy access to CAx data, e.g. 3D models, 2D dimension drawings, EPLAN macros, device 
circuit diagrams

• My IBase registrations
Register your Siemens products, systems and software.

1.6 DataMatrix code and Siemens Industry app

DataMatrix code
A DataMatrix code is lasered onto the lower terminal cover of all 3SK2 safety relays.

Introduction
1.6 DataMatrix code and Siemens Industry app

SIRIUS engineering Safety ES V1.0
14 Operating Manual, 12/2021, A5E32640754002A/RS-AF/006

https://support.industry.siemens.com/cs/ww/en/ps


DataMatrix codes are standardized in ISO/IEC 16022. The DataMatrix codes on Siemens devices 
use ECC200 coding for powerful error correction.
The following device information is encoded in the DataMatrix codes as a bit stream:
• Article number
• Serial number
• If applicable, MAC address
This information is stored in the following format in the DataMatrix code:

1P Article number + S serial number 
(+ 23S MAC address)

Data identifier Net content Separator  

Note
The information content is displayed without spaces.

This machine-readable information simplifies and accelerates handling of the respective devices.
As well as fast access to the serial numbers of the respective devices for unique identification, the 
DataMatrix codes simplify communication with Siemens Technical Support.

SIEMENS Industry Support App
DataMatrix codes primarily enable extremely fast and convenient access to all the device-
specific information available on an article number in the SIEMENS Service & Support Portal, 
such as operating instructions, manuals, data sheets, FAQs, etc.
We offer the SIEMENS Industry Support App free for this purpose. It can be used on most 
commercially available smartphones and tablets.
The SIEMENS Industry Support App is available for iOS and Android-based devices and can be 
accessed via the following links:

Link for Android Link for iOS

1.7 Support Request
After you have registered, you can use the Support Request form in the online support to send 
your question directly to Technical Support:

Support Request: Internet (https://www.siemens.com/support-request)

Introduction
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1.8 Configurator for safety relays

Configurator   
Various configurators are available online to assist you during the engineering process. 
The configurator for safety relays with accessories is a selection and Engineering tool. You can 
select the individual components and plan your system in accordance with your specific 
requirements. You can save your selection, export it as a text file or you can order it directly. 
The configurator automatically compiles a document list of the information available in Service 
& Support for every component. You can use it as the basis for putting together your system 
documentation.
Link: Configurator (https://www.siemens.com/sirius/configurators)

1.9 Evaluation of safety functions

Safety Evaluation Tool
The Siemens Safety Evaluation Tool for the IEC 62061 and ISO 13849‑1 standards supports you 
in evaluating the safety functions of your machine. The TÜV-tested online tool guides you step 
by step, from specifying the structure of the safety system and selecting the components to 
determining the achieved safety integrity (SIL /PL). The final result is a report in conformance 
with the standards that you can integrate as proof of safety into the documentation.
Link: Safety Evaluation Tool (http://www.siemens.com/safety-evaluation-tool/)

Safety Integrated
Just like the safety relay, the Safety Evaluation Tool is part of Safety Integrated, the intelligent 
safety solution from Siemens that features a complete product portfolio. Our certified safety 
technology complies with all relevant standards and is already contained in the Safety 
Evaluation Tool.
Link: Safety Integrated (http://www.siemens.com/safety-integrated)

1.10 User responsibility for system design and function
The products described here were developed to perform safety-related functions as part of an 
overall installation or machine. 
A complete, safety-related system is generally equipped with sensors, evaluation units, and 
signaling units, and uses reliable shutdown concepts. 
It is the responsibility of the manufacturer to ensure that the system or machine is functioning 
properly as a whole.
Siemens AG, its regional offices, and associated companies (hereinafter referred to as "Siemens") 
cannot guarantee all the properties of a whole installation or machine that has not been 
designed by Siemens.

Introduction
1.10 User responsibility for system design and function

SIRIUS engineering Safety ES V1.0
16 Operating Manual, 12/2021, A5E32640754002A/RS-AF/006

https://www.siemens.com/sirius/configurators
http://www.siemens.com/safety-evaluation-tool/
http://www.siemens.com/safety-integrated


Nor can Siemens assume liability for recommendations that appear or are implied in the 
following description. No new guarantee, warranty, or liability claims beyond the scope of the 
Siemens general terms of supply are to be derived or inferred from the following description.

Introduction
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Safety information 2
2.1 General safety notes

Note
SIL 3 in accordance with EN 62061
PL e / Cat. 4 in accordance with EN ISO 13849-1
The safety relays are designed in such a way as to allow implementation of applications up to 
SILCL 3 in accordance with EN 62061, PL e / Cat. 4 in accordance with EN ISO 13849-1.

WARNING
Hazardous Voltage.
Can Cause Death, Serious Injury, or Property Damage.
Hazardous electrical voltages can cause electric shock, burns and damage.
• Turn off and lock out all power supplying the system and device before working on the 

device.
• To ensure protection against the hazard of electric shock from the 3SK2 safety relay when 

the terminal cover is open, screw in all terminal screws that are not needed to clamp 
conductors.

• Close the terminal covers on the 3SK2 safety relay and always keep them closed during 
operation.

WARNING
Risk from conductive contamination
Can Cause Death, Serious Injury, or Property Damage.
The devices must be protected against conductive contamination while taking account of the 
ambient conditions. One way you can do this is to install the devices in a control cabinet with 
the appropriate degree of protection.
You will find further information in the IEC 60529 standard "Degrees of protection provided by 
enclosures (IP Code)".

WARNING
Loss of the safety functions of the 3SK2 safety relay
Can Cause Death, Serious Injury, or Property Damage.
3SK1 output expansions and 3RM1 Failsafe motor starters that are connected to the 
3SK2 safety relay via 3ZY12 device connectors are supplied with voltage via the device 
connectors.
Do not directly connect any separate supply voltage to a 3SK1 output expansion (A1 / A2) or to 
a 3RM1 Failsafe motor starter (A1 / A2) as otherwise the safety function will be bypassed.

SIRIUS engineering Safety ES V1.0
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WARNING
Safe functional extra-low voltage of 3SK2 safety relay.
The 3SK2 safety relays with a supply voltage of 24 V DC must be operated by means of a fail-safe 
power supply with safe functional extra-low voltage (SELV, PELV). This means these modules 
may only be subjected to a voltage of Um even in the event of a fault. 
The following applies for 3SK2 safety relays: Around < 60.0 V.
You can find more detailed information about safety functional extra-low voltage in the data 
sheets of the power supplies to be used.

WARNING
Loss of the safety function when slide switch is moved on 3SK1 output expansions in the 
case of the 3SK2 safety relay
Can Cause Death, Serious Injury, or Property Damage.
Parameterization of the logic of the 3SK2 safety relay in Safety ES must correspond to the slide 
switch setting on the 3SK1 output expansion in order for the safety function not to be rendered 
inactive.
• Make sure that the setting of the slide switch on the 3SK1 output expansion corresponds to 

your logic parameterized in Safety ES. 
• Use a cover seal to protect the slide switch of the 3SK1 output expansion against 

unauthorized and unintentional adjustment. 

NOTICE
Electromagnetic interference
The following must be grounded in accordance with the regulations to ensure noise immunity 
of all system components:
• All system components
• PELV / SELV power supply units (please also note the documentation for the respective 

power supply unit in this regard).
PROFINET / PROFIBUS must be grounded according to the installation guidelines for PROFINET / 
PROFIBUS networks.

NOTICE
Damage caused by electrostatic charge
When handling and installing the system components, ensure that the components are 
protected from electrostatic charge. Changes to the system configuration and wiring are only 
permissible while the supply voltage is switched off.
Connection of safety relays is only permissible when the power supply is switched off.

Note
Operational faults and malfunctions in communication
If the EMC Directive 2004/108/EC is not complied with when plants and devices are installed, 
communication breaks may occur. 

Safety information
2.1 General safety notes
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Note
Simultaneity of signals
Depending on when a signal change takes place within the cycle, the signal change is detected 
either in the same cycle or not until the following cycle time. 
This means it is possible for supposedly simultaneous signal changes to be detected at two 
different inputs by the logic, but not simultaneously.
Take this behavior into account when creating your configuration.

Note
Cover all unused system interfaces.

2.2 Recycling and disposal
For environmentally friendly recycling and disposal of your old device, please contact a company 
certified for the disposal of old electrical and/or electronic devices and dispose of the device in 
accordance with the regulations in your country.

2.3 Intended use

WARNING
Incorrect use of hardware products.
Can Cause Death, Serious Injury, or Property Damage.
This equipment is only allowed to be used for the applications described in the catalog and in 
the technical description, and only in conjunction with non-Siemens equipment and 
components recommended by Siemens.
Correct transport, storage, installation and assembly, as well as careful operation and 
maintenance, are required to ensure that the product operates safely and without faults.
Before you run any sample programs or programs you have written yourself, make sure that 
running the plant cannot cause injury to anyone else or damage to the machine itself.
EU note regarding machine safety: Commissioning is absolutely prohibited until it has been 
ensured that the machine in which the component described here is to be installed complies 
with the stipulations of the Directive 2006/42/EC.

Safety information
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WARNING
Incorrect use of software products.
Can Cause Death, Serious Injury, or Property Damage.
The software may be used only for the applications described in the catalog or the technical 
description, and only in combination with the software products, components and devices of 
other manufacturers where recommended or permitted by Siemens.
Before you run any sample programs or programs you have written yourself, make sure that 
running the plant cannot cause injury to anyone else or damage to the machine itself. 

WARNING
Hazardous system state
Can Cause Death, Serious Injury, or Property Damage.
Safe state (safety concept)
The basis of the safety concept is that a safe state exists for all process variables. With the safety 
relay, this is the value "0". This applies to sensors and actuators.
Note that the use of inverting functions either in the logic diagram or in the wiring outside the 
system may prevent the safe state from being reached.

WARNING
Loss of the safety function through changes to the system.
Can Cause Death, Serious Injury, or Property Damage

To ensure the safety of the system, any changes to it or any replacement of defective 
components must be followed by a thorough and successfully completed function test of the 
system.
A complete function test consists of the following tests:
• Configuration test (test of the configuration)
• System test (wiring test of the connected sensors and actuators)

Safety information
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WARNING
Loss of the safety function due to missing function test.
Can Cause Death, Serious Injury, or Property Damage.
When using actuators such as 3SK1 output expansions, contactors or relays, a function test 
interval (shutdown test) ≤ 1 year for SILCL 2 or ≤ 1 month for SILCL 3 is required. Only then do 
the safety values apply. 
Exception: A function test interval ≤ 1 year is also permissible for SIL3 applications in the 
process industry (in accordance with IEC 61511), exclusively for low-demand use, due to a 
significantly lower failure rate/probability of the electromechanical components.  This does not 
apply to safety-related applications in accordance with the Machinery Directive 2006/42/EC.
Function test procedure for actuators with contacts:
• Actuate the connected sensors.
• Check their effect on the safety relay and the downstream actuators*.
• Activate the safety relay via the connected sensors.
• Check their effect on the safety relay and the downstream actuators*.
• Defective devices must be replaced.
*Since the read-back time of the delayable output functions is retriggerable, the actuation 
duration for switching on and off for the regular function test must be longer than the time set 
in the "Switching time" parameter. Only in this way can it be ensured that the expected 
switching state has also been set on the connected actuator.
For additional information on the parameters, please refer to chapter "F output delayed 
(Page 273)".

WARNING
Loss of the safety function.
Can Cause Death, Serious Injury, or Property Damage. 
Test interval for safe AS-i input slaves
The calculated failure probabilities for safe transmission of AS-i input slaves is based on an 
actuation interval of one year.
For this reason, all sensors that are recorded using safety-related AS-i input slaves must be 
actuated at least once every 12 months in order to test their function. 
If the mechanism of the safety-related AS-i input slaves is used for direct data exchange, a 
corresponding signal change must also take place here at least once every 12 months, same as 
for the safety-related AS-i input slaves.

Safety information
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2.4 Safety information for hazardous areas

WARNING
Explosion hazard in hazardous areas.
Can Cause Death, Serious Injury, or Property Damage. 
The components of the safety relay are not suitable for installation in hazardous areas.
Please contact your ATEX specialist.

2.5 Current information about operational safety

Important note for maintaining operational safety of your system

WARNING
Loss of safety functions due to obsolete information.
Can Cause Death, Serious Injury, or Property Damage.
Please take note of our latest information
Systems with safety-related characteristics are subject to special operational safety 
requirements on the part of the operator. The supplier is also obliged to comply with special 
product monitoring measures. For this reason, we publish a special newsletter containing 
information on product developments and features that are (or could be) relevant to operation 
of safety-related systems. By subscribing to the appropriate newsletter, you will ensure that you 
are always up-to-date and able to make changes to your system, when necessary:
For this purpose, go to the page: Safety Integrated for industrial safety technology (https://
www.siemens.com/safety-integrated)
Click "Subscribe to newsletter".

2.6 Security information
Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, systems, machines and networks.
In order to protect plants, systems, machines and networks against cyber threats, it is necessary 
to implement – and continuously maintain – a holistic, state-of-the-art industrial security 
concept. Siemens’ products and solutions constitute one element of such a concept.
Customers are responsible for preventing unauthorized access to their plants, systems, 
machines and networks. Such systems, machines and components should only be connected to 
an enterprise network or the internet if and to the extent such a connection is necessary and only 
when appropriate security measures (e.g. firewalls and/or network segmentation) are in place.

Safety information
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For additional information on industrial security measures that may be implemented, please 
visit 
https://www.siemens.com/industrialsecurity. 
Siemens’ products and solutions undergo continuous development to make them more secure. 
Siemens strongly recommends that product updates are applied as soon as they are available 
and that the latest product versions are used. Use of product versions that are no longer 
supported, and failure to apply the latest updates may increase customer’s exposure to cyber 
threats.
To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed 
under 
https://www.siemens.com/industrialsecurity. 

2.7 Information on data protection
Siemens observes standard data protection principles, in particular the principle of 
privacy by design.
For this Safety ES product, this means:
The product processes/saves the following personal data: "Name of project engineer", 
"Configuration engineer company name", "Responsible department", "Author", "Name of 
releasing party" and "Company name of releasing party".
The above-mentioned data is required for documentation of the application. Data is saved for a 
specific purpose and limited to that which is absolutely necessary to identify authorized 
operators.
SIEMENS AG does not use the stored information nor forward it to third parties.
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Software description 3
3.1 Application areas for safety systems

Safety systems
Safety systems are part of machines and plants. Their task is to minimize possible hazards for 
humans, machines and the environment. To this end, they monitor safety functions such as 
Emergency Stop and switch off the plant or system in a safety-related fashion. A safety system 
consists of sensors for sensing signals of the protective equipment (e.g. protective doors) from 
safety relays (e.g. 3SK2 safety relays) that evaluate these signals, and of actuators (e.g. 3RM1 
Failsafe motor starters; 3RT contactors) that are controlled by the safety system and respond 
accordingly.
In most countries in the world there are binding regulations on the safeguarding of machines 
and plants. For Europe, the European Machinery Directive (2006/42/EC) defines the basic 
requirements for machine safety. The technical details of these requirements are specified in 
"harmonized" standards such as EN 62061 or EN ISO 13849-1 with the highest classification 
SILCL 3 or PL e/Cat. 4 for production automation.

3SK2 safety relays
3SK2 safety relays are safety relays that can be parameterized with software and using which you 
can interconnect several safety applications with each other. In this way, you can set shutdown 
ranges, for example, and freely define other dependencies. 3SK2 safety relays are generally 
suitable for applications involving two or more safety-related functions. SIRIUS 3SK1 safety 
relays are available for applications with only one safety-related function.
3SK2 safety relays read sensor signals via inputs, interconnect these signals according to the 
parameterizable logic, and use the processed signals to control the outputs, and thus actuators, 
in a fail-safe manner. 
Depending on the version of the device and the external connection of sensors and actuators, 
applications can be implemented at up to SILCL 3 in accordance with EN 62061 and PL e/Cat. 4 
in accordance with EN ISO 13849-1. 
At least one 3SK2 basic unit and the Safety ES parameterization and diagnostics software are 
required for every system configuration. You can decide between two safety relay sizes with 
different functional scopes.

Safety ES parameterization and diagnostics software 
The safety functions are parameterized via the Safety ES software. The software represents the 
wiring of the individual functions using graphical parameterization. All safety or logic functions 
are available as blocks and can also be easily configured and then logically combined with one 
another. The software checks the interconnection for errors before the safety program can be 
loaded into the safety relay.
Forcing 
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Test operation of the software assists you during commissioning. Here, output signals of 
function elements can be forced in order to test the logic processing or already installed system 
sections. Forcing means that the output signals in the logic can be set to 1 or 0, irrespective of 
the real signal.
Deactivating safety functions 
Functions can be specifically deactivated in the software and assigned substitute values. This 
means that a complete safety program can be created and tested for the maximum 
configuration for a system. The system can then be commissioned with a partial configuration, 
while the parts that are not needed in the safety program remain deactivated. If the system is 
later expanded, these steps mean that you only need to reactivate the applicable parts of the 
safety program.
Diagnostics
The software allows you to monitor the safety system and, to this end, visualizes the status of 
the safety functions and the status of the devices. The status of each element and the 
configuration as a whole can be viewed online.
Documentation of the safety functions
Documentation is also created for the safety functions and, after printing, can be used for system 
documentation purposes in compliance with DIN EN ISO 7200.

Device connector interface
3SK2 safety relays can be connected to the following actuators using 3ZY12 device connectors:
• 3SK1 output expansions (24 V DC)
• 3RM1 Failsafe motor starters (24 V DC)
3SK1 output expansions and safety-related 3RM1 Failsafe motor starters can be controlled and 
monitored for correct function using these 3ZY12 device connectors. 
The device connectors quickly, easily and flawlessly take over the safety-related wiring. This 
reduces your wiring effort and costs and possible troubleshooting. 

Interface modules for communication via bus systems and integration in TIA
The 3SK2 safety relays communicate with higher-level controllers via an optional interface 
module. Thus, the basic unit can be interfaced to a PLC via PROFINET/PROFIBUS, for example, 
and therefore also be integrated in TIA. Fault diagnostics and status information can be passed 
on cyclically and acyclically. 
Via the interface module, the 3SK2 safety relays offer the option of exchanging process signals 
with a higher-level controller. This is possible in both directions. Up to 64 bits are available for 
this purpose in each direction. The individual signals are manually interconnected in the user 
program. This makes it possible to generate individual diagnostics messages, for example.  
Operational switching signals (such as unlocking commands for protective doors with tumblers) 
as well as fault acknowledgement and starting commands can be sent from the PLC to 3SK2 
safety relays.

Software description
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Diagnostics display
Pending messages with detailed information shown as text are displayed on the optional 
diagnostics display. The diagnostics display enables time-saving troubleshooting without 
connection to a PG / PC with Safety ES. The cause of a fault can be located quickly and easily and 
you can respond directly to it. The diagnostics display can be installed in the control cabinet door 
and is operable from the outside. You do not need any complex parameterization to be able to 
use the diagnostics display. It is sufficient to assign corresponding names or identifiers when 
creating the safety application. These names and identifiers are then read directly from the 
device by the diagnostics display and displayed.

Diagnostics
The 3SK2 safety relays possess multiple diagnostics options:
• Diagnostics via displays on the device/LEDs
• Diagnostics with Safety ES
• Diagnostics with diagnostics display (if a diagnostics display is available)
• Diagnostics via PROFINET (if PROFINET interface is available)
• Diagnostics via PROFIBUS (if DP interface is available)

3.2 Interfaces

Interfaces
The safety relay can be accessed by Safety ES via an RS232, USB or fieldbus interface. The 
communication via the fieldbus interface is implemented via an optional interface module.

WARNING
Unauthorized access to safety functions via fieldbus. 
Can Cause Death or Serious Injury.
Unauthorized access to the safety relay via fieldbus, such as PROFINET or PROFIBUS, can result 
in configuration changes and overriding of safety functions.
To prevent unauthorized access to the safety relay via the fieldbus, assign a password for 
accessing the device in Safety ES. If you operate several safety relays in one fieldbus network, 
you must assign a separate password for each safety relay to prevent confusion when accessing 
via the fieldbus. In other words, the passwords must not be identical.

Software description
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3.3 Safety ES

The engineering software (ES)   
The SIRIUS Safety ES engineering software is the software for configuring, parameterizing and 
diagnosing the safety relays.  
It provides the following functions:
• Simple configuration of the devices of a system configuration, including the graphical 

parameterization of the function elements, e.g. monitoring functions
• Test and commissioning functions, e.g. device diagnostics, monitoring of logic elements, 

forcing of logic elements
• Tool for creating the system documentation, e.g. documentation of the circuits, device 

comments, module names

Communication
Safety ES communicates with the safety relay via the device interface of the safety relay or via the 
fieldbus.

1

2

3

4

① PC/PG
② Diagnostics display
③ Safety relay
④ Interface module

Figure 3-1 Communication options of Safety ES
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WARNING
Unauthorized access to safety functions via fieldbus. 
Can Cause Death or Serious Injury.
To prevent unauthorized access to the safety relay via the fieldbus, e.g. PROFINET or PROFIBUS, 
assign a password for accessing the device in Safety ES.
If you operate several safety relays in one fieldbus network, you must assign a separate 
password for each safety relay to prevent mix-ups when accessing via the fieldbus. In other 
words, the passwords must not be identical.

Licenses
The Safety ES parameterization software is available in three different license versions with 
different functional scopes:   
• Basic license

– CD with a license on a USB stick
– License download

• Standard license
– CD with a license on a USB stick
– License download

• Premium license
– CD with a license on a USB stick
– License download

For the functional scope of each license version, see the chapter "License-dependant available 
menu commands (Page 32)".
The software package contains:

Software Application
Safety ES Configuring of the safety relay
Automation License Manager License management
.NET Framework Required for generating the printout or print preview
MSI Execution of the setup
Readme (Readme.rtf) Important information you require before installation.
7Zip Unzipping files

Note
The licenses are implemented exclusively as a floating license. You will find additional 
information in the chapter "Installing the Automation License Manager (Page 42)".
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3.4 License-dependant available menu commands
The Safety ES software is available in 3 different license variants:
• Basic license: This license contains a reduced functional scope and is suitable for basic and 

low-cost diagnostics.
• Standard license: This license contains a full range of functions for creating configurations. 
• Premium license: Compared with the standard license, this license enables Safety ES to also 

communicate with the safety relay via the fieldbus (PROFINET or PROFIBUS). This license 
version also features macro functionality. 

Not all functions are available with all licenses. If a function is not available with your license 
version, the associated menu option is always grayed out.

Overview: Availability of menu options   
The following table provides an overview of which commands are available with which license 
version:   

Menu option Basic license Standard license Premium license
Switching device New... ✓ ✓ ✓

Open... ✓ ✓ ✓
Import ... ‑ ✓ ✓
Open Online... ✓ ✓ ✓
Save ✓ ✓ ✓
Save as... ‑ ✓ ✓
Export... ‑ ✓ ✓
Close ✓ ✓ ✓
Page Setup... ‑ ✓ ✓
Print Preview... ‑ ✓ ✓
Print... ✓ ✓ ✓
Most recently used files ‑ ✓ ✓
Exit ✓ ✓ ✓
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Menu option Basic license Standard license Premium license
Edit Undo ‑ ✓ ✓

Restore ‑ ✓ ✓
Cut ‑ ✓ ✓
Copy ‑ ✓ ✓
Paste ‑ ✓ ✓
Delete ✓ ✓ ✓
Select all ‑ ✓ ✓
Go to... ‑ ✓ ✓
Insert comment ‑ ✓ ✓
Realign graphic ‑ ✓ ✓
Interrupt connection ‑ ✓ ✓
Redraw partial connection ‑ ✓ ✓
Add diagram ‑ ✓ ✓
Remove diagram ‑ ✓ ✓
Create macro... ‑ ‑ ✓
Edit terminal identifier... ‑ ✓ ✓
Object properties... ✓ ✓ ✓
Check consistency ✓ ✓ ✓
Password for project ac‐
cess...

✓ ✓ ✓

Reset password for project 
access...

✓ ✓ ✓

Password for device access... ✓ ✓ ✓
Password for test mode... ✓ ✓ ✓
Offline logbook viewer... ✓ ✓ ✓
Compare with file... ‑ ✓ ✓
Compare with switching de‐
vice ...

‑ ✓ ✓
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Menu option Basic license Standard license Premium license
Target system Load to switching device ... ✓ ✓ ✓

Load to PC ... ✓ ✓ ✓
Go Offline ✓ ✓ ✓
Undo the fixed assignment 
of the interface

✓ ✓ ✓

PROFINET IO line view... ‑ ‑ ✓
PROFIBUS DP line view... ‑ ‑ ✓
Learn ASIsafe code tables... ✓ ✓ ✓
Prepare configuration test ... ✓ ✓ ✓
Approve configuration ... ✓ ✓ ✓
Cancel configuration release ✓ ✓ ✓
Configuring mode ✓ ✓ ✓
Test mode ‑ ✓ ✓
Safety mode ✓ ✓ ✓
Commands... ‑ ✓ ✓
Diagnostics configuration ✓ ✓ ✓
Diagnostics logic ✓ ✓ ✓
Device logbooks ✓ ✓ ✓

View Toolbar ‑ ✓ ✓
Status bar ‑ ✓ ✓
Zoom in ✓ ✓ ✓
Zoom out ✓ ✓ ✓
Zoom dialog ‑ ✓ ✓
Overall view ‑ ✓ ✓
Display settings ✓ ✓ ✓
Grid properties ✓ ✓ ✓
Move diagram ✓ ✓ ✓
Highlight signal flow ‑ ✓ ✓
Delete highlighting ‑ ✓ ✓
Navigation window ✓ ✓ ✓
Output window ✓ ✓ ✓
Catalog window ✓ ✓ ✓
Minimize/restore online dia‐
logs

‑ ✓ ✓

Options Basic Settings... ✓ ✓ ✓
Settings of Safety ES... ✓ ✓ ✓
Cross references ‑ ✓ ✓
Symbol list ‑ ✓ ✓
Terminal list ‑ ✓ ✓
Export macros... ‑ ‑ ✓
Import macros... ‑ ‑ ✓
Release information... ✓ ✓ ✓
Set PC/PG interface... ‑ ‑ ✓
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Menu option Basic license Standard license Premium license
Help Help topics ✓ ✓ ✓

Info ✓ ✓ ✓

Which device is supported by which software version?   
Device Safety ES V1.0 Safety ES V1.0 SP3
3SK2 basic units  
3SK2 safety relay 22.5 mm ✓ ✓
3SK2 safety relay 45 mm ✓ ✓
3RK3 central units  
MSS 3RK3 Basic ✓ ✓
MSS 3RK3 Advanced ✓ ✓
MSS 3RK3 ASIsafe basic ✓ ✓
MSS 3RK3 ASIsafe extended ✓ ✓
3RK3 interface modules  
PROFINET interface - ✓
DP interface ✓ ✓
3RK3 expansion modules  
4/8 F‑DI ✓ ✓
2/4 F‑DI 2 F‑DO ✓ ✓
2/4 F‑DI 1/2 F‑RO ✓ ✓
8 DO ✓ ✓
4 F‑DO ✓ ✓
4/8 F‑RO ✓ ✓
8 DI ✓ ✓
3RK3 / 3SK2 HMI modules  
Diagnostics display ✓ ✓
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Software user interface 4
4.1 Design of the user interface

When you start the software of the safety relay (Safety ES) and create a new project using the 
menu command "Switching device" > "New", then the user interface opens in the 
"Configuration" > "Main system" setting. The central work space of this setting is the 
configuration table.

① Title line ⑥ Navigation window
② Menu bar ⑦ Status bar
③ Toolbar ⑧ Output window
④ Work space ⑨ Information window
⑤ Catalog window   
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Number Description Function
① Title line Contains general information:

• The type of license: Basic / Standard / Premium
• "Unnamed": Project not yet saved
• <File name>: Project already saved
• The connection status: [Online] / [Offline]
• Name of the displayed logic diagram

② Menu bar Providing all of the functions required for program control.
③ Toolbar Contains buttons for frequently used program commands.
④ Work space Depending on the selected view in the navigation window, 

this contains tables or diagrams for editing the project:
• Identification parameters
• Configuration table
• Logic diagram

⑤ Catalog window Depending on the selected view in the navigation window, 
this contains the components needed for the configuration:
• Configuration: Devices for hardware configuration
• Logic diagram: Function elements for the safety logic

⑥ Navigation window Allows the various views of the open project to be selected:
• Identification: Safety relay, marking, project
• Configuration: Main system
• Logic: Diagram 1 / diagram n

⑦ Status bar Contains information on the program status of Safety ES for 
selected menu commands and buttons.

⑧ Output window Contains information on the project which does not appear 
in dialog boxes, e.g. cross reference lists and symbol lists.

⑨ Information window Contains information on the components selected in the 
catalog window.

4.2 Toolbar
Menu option Basic license Standard license Premium license
View Toolbar ‑ ✓ ✓

Actions
To display or hide the toolbar at the top of the application screen, choose "View" > "Toolbar". 
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Properties of the toolbar   

Figure 4-1 Toolbar in Safety ES
• The toolbar has icons that make the most important menu functions directly accessible. If 

you allow the mouse pointer to rest on an icon for about one second, its function is briefly 
displayed as a tool tip and in the status bar in plain text.

• To print data, click on the printer icon. All other icons correspond to the function of the 
associated menu command.

• You cannot change the number or assignment of the icons for the individual menu 
commands.

4.3 Status bar
Menu option Basic license Standard license Premium license
View Status bar ‑ ✓ ✓

Actions   
To display or hide the status bar at the bottom of the application screen, choose "View" > "Status 
bar". 

Properties of the status bar
The status bar contains the standard information and additional information. 

Figure 4-2 Status bar in Safety ES

No. Meaning
① Displays the operating state of the safety relay and the status of the user program

STOP: Circuit is not being processed
RUN: Circuit is being processed

② Shows the current utilization of the user memory.
③ Display of the current utilization of the internal memory of the safety relay (depends on the type 

and number of function elements used).
④ Shows the current utilization of the parameterized program cycle time.
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No. Meaning
⑤ Connection status (online / offline).
⑥ Type of online connection (e.g. COM1 (= serial interface), DP 42 (= PROFIBUS connection to a 

switching device with address 42) IP 192.168.0.2 (= PROFINET connection to a switching device 
with IP address 192.168.0.2)
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Software installation 5
5.1 Requirements

To be able to work with Safety ES, you must meet the following requirements:

Software requirements
To configure the devices, you need a programming device or PC with the MS Windows 7 
Ultimate / Professional / Enterprise or MS Windows 10 Professional / Enterprise operating system. 
The readme file (Readme.rtf) contains the current software requirements.
• You need administrator rights to install Safety ES. To be able to work with Safety ES under 

MS Windows 7 Ultimate / Professional /Enterprise or MS Windows 10 Professional / Enterprise, 
at least the main user rights are required.

• When Safety ES is installed, the administrator must grant full access
 rights to the Safety ES setup directory to all users wishing to work 
with Safety ES on this computer. You can find information on assigning access rights in the 
documentation of your operating system.

Hardware requirements
• A programming device or PC is required for using Safety ES:

Refer to the readme file (Readme.rtf) in which the current hardware requirements are listed.

Required knowledge
Understanding of this documentation and software requires the following:
• General knowledge of the operating system used.
• Basic knowledge of parameterizing, configuring, and commissioning safety relays.

5.2 Usage authorizations via the Automation License Manager

Automation License Manager       
To use the programming software, you need a product-specific license key (usage 
authorization), which is installed using the Automation License Manager. 
The Automation License Manager is a software product developed by Siemens AG that is used 
to manage license keys (technical representation of licenses) on a system-wide basis.
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The Automation License Manager is available:
• On the product CDs of Safety ES
• On the Internet as a download (http://support.automation.siemens.com/WW/view/en/

114358)
The Automation License Manager features an online help function that you can use to call up 
context-specific information via the F1 key or by choosing "Help" > "Help for Automation License 
Manager". This help function contains detailed information about how to use the Automation 
License Manager and the functions it offers.

License keys
The license key acts as the technical representation of a license (electronic license stamp).
SIEMENS AG issues a license key for all license-protected software. The software can only be 
used in accordance with the license and usage conditions associated with the license key once 
the system has established that a valid license key has been installed on the computer when the 
software is launched.
License keys can be stored as follows and transferred from one storage medium to another:
• On license key data carriers
• On local hard disks
• On the hard disks of computers in the network
For more information about using license keys, please refer to the online help for the 
Automation License Manager. 

Note
• Safety ES cannot be used without a license key.
• To familiarize yourself with the operator interface and the range of functions, you can 

activate one trial license, allowing you to work with the system for 14 days. Following this 
period, you must acquire a valid license. Otherwise you cannot continue to work with 
Safety ES.

5.3 Installing the Automation License Manager

Installing Automation License Manager     
Automation License Manager is installed by a setup program. You will find the installation 
software for the Automation License Manager on the Safety ES product CDs. 
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You can install the Automation License Manager together with Safety ES or later.   

Note
• For detailed information on the setup procedure for the Automation License Manager, read 

the latest readme file (Readme.rtf).
• The online help for the Automation License Manager contains all the information you need 

about using license keys and the functions they offer.

Installing license keys at a later date
When you start the Safety ES software without installed license keys, the system displays a 
corresponding message. 
You can install license keys later in the following ways: 
• Install license keys from a USB stick
• Install license keys downloaded from the Internet (license keys must be ordered first)
• Using floating license keys available on the network.
Refer to the online help for the Automation License Manager for detailed information on 
installing license keys. To access this context-sensitive help function, press F1 or select the menu 
command "Help" > "Help on Automation License Manager". 

Note
• License keys will only be operational if they are installed on a hard disk on which write access 

is allowed.
• Floating licenses can also be used within a network ("remote" use). 

5.4 Rules for using license keys

Additional information    
You can open the context-sensitive online help for the Automation License Manager by pressing 
F1 or by selecting the menu command "Help" > "Help on Automation License Manager". 
This help contains all the information you need about the functions and handling of license keys. 

NOTICE
Read the information on handling license keys contained in the online help and readme file for 
the Automation License Manager. If you do not follow these instructions, the license keys may 
be irretrievably lost.
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5.5 Installation

Requirements

Note
You require administrator rights to install Safety ES.     

Before installing:

Note
Read the "readme.rtf" file on the CD ROM before installing Safety ES.

Installation of the software from CD ROM
The installation program starts automatically after you insert the CD ROM, if this function is 
activated on your computer. 
If the installation program does not start automatically, proceed as follows:
• Open the main directory on the CD ROM.
• Double click on the "setup.exe" file to start the setup program. The setup program guides you 

step by step through the entire process of installing Safety ES.

Installation of the software after download
Save the downloaded *.exe file and unzip it.
• Double click on the "setup.exe" file to start the setup program. The setup program guides you 

step by step through the entire process of installing Safety ES.

5.6 Starting the program

Starting the Safety ES program on the PC
After terminating the installation program, and after restarting your computer (if prompted to 
do so during setup), you can start Safety ES as follows:   
• By double-clicking on the "Safety ES" icon on the desktop.
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Start wizard  
After the program has been started, a deactivatable Start wizard appears with which you can 
execute the following actions:
• Create a new configuration ("New")
• Open an existing configuration file ("Open")
• Read out a configuration online from a safety relay ("Open online")
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Operation (software) 6
6.1 Description of the menu commands

6.1.1 Switching device menu

6.1.1.1 New...

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

New... ✓ ✓ ✓

Actions
To create a new project, choose "Switching device" > "New."   
A list containing the short codes for the available switching devices is displayed. You can select 
one of these switching devices for processing or you can search for a specific switching device 
for further processing.
In the display window underneath a short description of the selected switching device is 
displayed. If you install SIRIUS engineering for other switching devices, the new switching 
devices are added to the hardware catalog.   

Searching for a switching device
To search for a specific switching device, proceed as follows:
1. Enter the name or article number of the switching device in the search dialog box either in 

full or in part.
2. Click on the up and down search buttons to look for the switching device.
If the switching device could not be found the following error message appears:
"The device being searched does not exist in the catalog."
As a remedy, change the search text and click on the search buttons again.

Selecting a switching device
To choose the switching device, select it and then click "OK" or simply double-click the required 
device name.
To open or close the sub-directories of the switching device tree displayed, click [+] or [-].
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6.1.1.2 Open...

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

Open... ✓ ✓ ✓

Actions
To open parameter files that were generated with Safety ES and that have the file extension *.sdp 
(switching device parameters), choose the "Switching device" > "Open..." menu command. 
When a file is selected, the directory that was last used is always displayed from which you can 
navigate to the required file. 

6.1.1.3 Import...

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

Import... ‑ ‑ ✓ ✓

Actions  
To overwrite the diagrams currently in use with the values from the file, choose "Switching 
Device" > "Import...." The current focus of the program does not change (that is, if you make 
changes, for example, these will not be saved in the imported file but in the originally opened 
file).

Error message when parameters are overwritten
The current parameters are overwritten with those from the file.
If the content of the file is not compatible with the current safety relay, an error message is 
displayed (Example: You are processing the parameters of Safety ES and have opened the 
parameter file for a motor starter.)

Note
Overwriting parameters
When you choose the "Import" menu command, the parameters in the main memory are 
overwritten without you being prompted to confirm this.

Storage directory display
When a file is selected, the directory that was last used is always displayed from which you can 
navigate to the required file.
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6.1.1.4 Open online...

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

Open online... ✓ ✓ ✓

Actions   
The "Switching device > Open online..." switching command establishes a data connection 
between the PC and a switching device via the local device interface or the fieldbus and 
downloads the data from a switching device once to the work memory of the PC. The data 
connection remains in place,

Local device interface   
The "Local interface" tab is only present when a RS232 interface is available, or a USB-PC cable 
or a USB-to-serial adapter is connected to the PC / PG. To load the data from a switching device 
into the working memory of the PC through the local device interface, proceed as follows:
• Specify the COMx interface.
• Confirm the dialog with "OK".
• The program establishes a connection with the specified safety relay, checks whether the 

parameters that are currently displayed are compatible with this safety relay, and then reads 
all the parameters from the device.
– If no configuration is open when the "Open online..." action is performed, a graphical 

diagram will be created in which the function elements are arranged automatically.
– If a configuration is open when the "Open online..." action is performed, the offline 

configuration will be compared with the online data. The graphical arrangement of the 
function elements of the offline parameters is retained as far as possible.

PROFIBUS DP   

WARNING
Unauthorized access to safety functions via PROFIBUS. 
Can Cause Death or Serious Injury.
As a result of unauthorized access to the safety relay via PROFIBUS, the configuration can be 
changed and safety functions stopped.
To prevent unauthorized access to the safety relay via the PROFIBUS network, assign a password 
for accessing the device in Safety ES.
If you operate several safety relays in one PROFIBUS network, you must assign a separate 
password for each safety relay to prevent mix-ups when accessing via the fieldbus. In other 
words, the passwords must not be identical.

Operation (software)
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The preconditions for access over PROFIBUS are the use of the DP interface module, a PROFIBUS 
interface in the PC / PG and a Premium license.
Perform the following steps:
1. Connect the DP interface to the PC / PG using a PROFIBUS cable.
2. Start Safety ES. 
3. Open the "Switching device" > "Open online..." menu.
4. Select the access point under "Options" > "Set PG/PC interface...".
5. Enter the DP address under "Preferred address," or select the corresponding address under 

"Available stations."  
6. Click OK to confirm.

Note
Without configuration or with the factory settings, the safety relay logs on to the PROFIBUS with 
address 126.

PROFINET IO

WARNING
Unauthorized access to safety functions via PROFINET. 
Can Cause Death or Serious Injury.
As a result of unauthorized access to the safety relay via PROFINET, the configuration can be 
changed and safety functions stopped. To prevent unauthorized access to the safety relay via 
the PROFINET network, assign a password for accessing the device in Safety ES.
If you operate several safety relays in one PROFINET network, you must assign a separate 
password for each safety relay to prevent mix-ups when accessing via PROFINET. In other 
words, the passwords must not be identical.

The preconditions for access over PROFINET are the use of the PROFINET interface module, an 
Ethernet interface in the PC/PG and a Premium license. Perform the following steps:
1. Connect the PROFINET interface to the PC/PG using a connecting cable.
2. Start Safety ES.
3. Open the "Switching device" > "Open online..." menu.
4. Select the access point under "Options" > "Set PG/PC interface...".

Operation (software)
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5. Enter the DP address under "IP address," or select the corresponding IP address under 
"Accessible nodes". With this IP address you can communicate with the PC/PG with the 
PROFINET interface. 
Note that you can change the IP address in Safety ES. During download to the switching 
device, this new IP address is stored in the PROFINET interface. You can prevent a change by 
setting the "Station address - Change authorizations" parameter accordingly. To ensure 
communication with the controller, the assigned IP addresses in the automation software 
must match the IP address set in the PROFINET interface.

6. Click OK to confirm.

6.1.1.5 Save

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

Save ✓ ✓ ✓

Actions  
With the "Switching device > Save" menu command, you save existing parameters in the 
standard format (*.sdp) on a data medium.
If no file is open at this point (e.g. because you have selected "Switching device" > "New" to select 
a new safety relay for processing), the "Save as..." dialog box will open instead.

6.1.1.6 Save as...

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

Save as... ‑ ‑ ✓ ✓

Actions  
With the menu command "Switching device" > "Save as...", you save the current data under a 
new name.

6.1.1.7 Export ...

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

Export... ‑ ‑ ✓ ✓
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Actions  
With the "Switching device" > "Export..." menu command, you can copy the currently displayed 
parameters to a parameter file.

6.1.1.8 Close

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

Close ‑ ✓ ✓ ✓

Actions  
With the menu command "Switching device" > "Close", you exit the function for processing the 
current parameters. The menu command has the following effect:
• An opened parameter file is closed.
• An existing online connection to a safety relay is terminated.
• If you have changed any parameters, you are asked if you want to save the changes before 

you exit the program.

6.1.1.9 Information about the print options

Required settings
A default printer must be set up on the target system.

Print on DIN A3  
To print on DIN A3, a DIN A3-capable printer must be installed and defined as the default printer. 
To select the DIN A3 format, choose "Switching device" > "Page setup...".

6.1.1.10 Page Setup...

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

Page Setup... ‑ ‑ ✓ ✓

Actions  
To call up a dialog in which you can set the print options, select "Switching device" > "Page 
setup...". These settings are copied for a specific project (*.sdp file) or device.

Operation (software)
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Setting options
The Wizard contains the following four pages: 
• Page 1 - General settings: choosing the page format
• Page 2 - Header: maintaining the header fields
• Page 3 - Footer: maintaining the footer fields
• Page 4 - Contents: selecting the data to be printed, paper orientation, margins

Page 1 - General settings

Settings on the 1st page  
On page 1 of the "Page setup" dialog, you can define the general settings. These functions 
include:   
• The paper format for the entire report (default: A4)
• What happens when you close a dialog (print preview is displayed, printout is triggered)
• Display of initial page

Note
Further format settings
You can define further format settings (e.g. page margins and document alignment) on page 4 
of the "Page setup" dialog.

Page 2 - Header

Maintaining the header
On page 2 of the "Page setup" dialog (header), you can maintain the header fields.      

Inserting elements in the header
You can insert the following elements left justified, centrally, or right justified via the context 
menu (can be selected using the "+" pushbuttons):

Element Note
Date short Date in short format as defined in the control panel under "Regional and 

Language Options".
Date Date in long format as defined in the control panel under "Regional and 

Language Options".
System time Time as defined in the control panel under "Regional and Language Op‐

tions".
Time 24h Time 24 hour clock format.

Operation (software)
6.1 Description of the menu commands

SIRIUS engineering Safety ES V1.0
Operating Manual, 12/2021, A5E32640754002A/RS-AF/006 53



Element Note
Path Path of the *.sdp file that is currently open.
Document name Name of the current *.sdp file / DP address / COM port
Page (curr.) Current number of pages.
Pages (tot.) Total number of pages.
My text When you select "My text", the system displays a field in which you can 

enter your own text.
My image You can add a picture or logo here.

To remove any elements, choose "-".

Page 3 - Footer

Maintaining the footer     
On page 3 of the "Page setup" dialog (footer), you can maintain most of the fields in the (tabular) 
footer.   

Standard DIN EN ISO 7200   
The tabular footer is structured in accordance with DIN EN ISO 7200.
Overview of all the fields in the footer:

Footer field Meaning Maintaining
Specific section of the footer of Safety ES
Diagram Number of the logic diagram Automatic
Diagram name Configured name of the logic diagram Automatic
Diagram sheet Page and pages, including the logic diagram Automatic
Last change Date and time of last change saved Automatic
Configuration CRC Cyclic Redundancy Check which saves all safety-relevant configura‐

tion data (4 bytes).
Automatic

Standard-compliant part of the footer
Department respon‐
sible

Name of the department which, at the time the document is re‐
leased, is responsible for the technical content and updating the 
document.

In the "Page setup" dialog

Technical reference Company contact for technical queries regarding the content of the 
document.

In the "Page setup" dialog

Document type Indicates the content and format of the document (intended specif‐
ically for searching for documents).

In the "Page setup" dialog

Document status Status of the document within the lifecycle (e.g. "Being processed", 
"Released", "Withdrawn").

In the "Page setup" dialog

Owner Name of the company that is the legal owner of the document (an 
abbreviated trade name or logo can also be entered) 
With Safety ES: Configuration engineer's company name

in the "Identification" > "Project" 
output window

Created by Name of the person who created or revised the document. 
With Safety ES: Name of configuration engineer

in the "Identification" > "Project" 
output window
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Footer field Meaning Maintaining
Approved by For approvals/releases with signature (e.g. releases required for ac‐

ceptance inspections performed by certification centers).
handwritten on the printout

Title Unique name for the parameters or project
With Safety ES: Project name

in the "Identification" > "Project" 
output window

Item number Establishes a unique reference to the document. In the "Page setup" dialog
Modification Indicates the different versions with combinations of letters and/or 

numbers.
In the "Page setup" dialog

Release date Date on which the document was approved/released. handwritten on the printout
Language Indicates the document language (in max. 4 characters). In the "Page setup" dialog
Sheet Current page / total number of pages Automatic

Page 4 - Contents

Selecting the configuration data to be printed.    
On page 4 of the "Page setup" dialog, you can select which configuration data is to be printed. 
In the selection tree, select the checkbox in front of the data you want to print out. You can either 
select individual elements or higher-level elements with all the associated sub-elements. You 
must select at least one element before you can close the dialog. 

Separate page layout for level 2 elements
In the various tab dialog boxes on the right, you can define a separate page layout for level 2 
elements (e.g. parameters). This layout is valid for all levels below this. You can also select the 
paper orientation (portrait/landscape) and the margins. You have already set the paper format 
(e.g. A4) on page 1 of the "Page setup" dialog. This setting applies to the entire report.

Applying the settings
Once you have made all the required settings, you can exit the dialog and apply all your settings 
by choosing "Finish".

6.1.1.11 Print preview...

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

Print Preview... ‑ ‑ ✓ ✓

Actions   
To call up a print preview that displays the document with the current settings, choose 
"Switching device" > "Print preview...". On page 1 of the "Page setup" dialog, you can specify that 
the print preview is displayed automatically when you close the dialog.
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Export from print preview
You have the option of saving the contents of the print preview as a PDF. To do so, click on the 
diskette icon in the toolbar in the Print Preview window.

6.1.1.12 Print...

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

Print... ✓ ✓ ✓

Actions   
To open the standard Windows "Print" dialog, choose the "Switching Device" > "Print..." menu 
command. You can make the following settings in this dialog, for example:
• Printer selection
• Select the pages to be printed (e.g., pages 1 to 11)
• Number of copies
• Printer driver settings

Further print options
You can also print a document by selecting the "Printer" icon in the toolbar. The document is then 
printed with the current print settings. You can also print documents from page 1 of the "Page 
setup" dialog box (General settings) by closing the dialog box.

6.1.1.13 List of the files last used

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

Most recently 
used files

‑ ‑ ✓ ✓

Actions  
Under the menu command "Switching device" the last nine files used are listed.
When you click one of the files, it is displayed.

Operation (software)
6.1 Description of the menu commands

SIRIUS engineering Safety ES V1.0
56 Operating Manual, 12/2021, A5E32640754002A/RS-AF/006



6.1.1.14 Exit

Menu option Button Basic license Standard li‐
cense

Premium li‐
cense

Switching de‐
vice

Exit ‑ ✓ ✓ ✓

Actions  
To exit the program, select "Switching device" > "Exit". If you have changed any parameters, you 
are asked if you want to save the changes before you exit the program.

6.1.2 Edit menu

6.1.2.1 Undo

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Undo ‑ ✓ ✓

Actions  
The menu command "Edit" > "Undo" performs the following actions:
• You can undo changes to parameters and changes in the logic diagram (moving blocks, 

changing connections, etc.).
Position changes (e.g. dialog selection, scroll, select) cannot be undone.

• Once you have executed this menu command, the system displays the view that was active 
before the action you have just undone.

• File functions (e.g. "Save," "Load," "Download," "Open Online") delete the entire undo history 
("Undo" can no longer be used).

6.1.2.2 Redo

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Restore ‑ ✓ ✓

Actions  
The menu command "Edit" > "Redo" cancels one (or more) previous undo actions.
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6.1.2.3 Cut

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Cut ‑ ✓ ✓

Actions  
The menu command "Edit" > "Cut" transfers selected objects to the clipboard which can then be 
pasted using the "Edit" > "Paste" menu command. The selected objects are deleted at the source 
location.

6.1.2.4 Copy

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Copy ‑ ✓ ✓

Actions  
The menu command "Edit" > "Copy" transfers selected objects to the clipboard which can then 
be pasted using the "Edit" > "Paste" menu command.

6.1.2.5 Paste

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Paste ‑ ✓ ✓

Actions  
The menu command "Edit" > "Paste" pastes objects that were copied to the clipboard by the 
menu command "Edit" > "Copy".

6.1.2.6 Delete

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Delete ✓ ✓ ✓
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Actions  
The menu command "Edit" > "Delete" removes selected objects.

6.1.2.7 Select all

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Select all ‑ ‑ ✓ ✓

Requirements
This menu command can only be selected if the logic diagram is active.

Actions  
The "Edit" > "Select all" menu command selects all of the graphical objects (circuit elements, 
connections, comments and reference points).

6.1.2.8 Go to...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Go to... ‑ ‑ ✓ ✓

Requirements
This menu command can only be selected if the logic diagram is active.

Actions  
The "Edit" > "Go to..." menu command opens a dialog box in which you can select and enter the 
search criteria:

Action Result
Searching by "Element number" The chosen function element is selected.
Searching by "Name" The function element to which the specified element iden‐

tifier is assigned is selected.
Searching by "Page" The page with the page number selected by you in the cur‐

rent diagram is displayed.
The page number is structured as follows: <Diagram 
name:H1V1>.
This page number is indicated in the logic diagram view and 
on every printout at the bottom right.
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6.1.2.9 Insert comment

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Insert com‐
ment

‑ ✓ ✓

Requirements
This menu command can only be selected if you are in the offline mode and the logic diagram 
is active.

Actions  
Using the "Edit" > "Insert comment" menu command, you can insert a comment anywhere in the 
logic diagram.

6.1.2.10 Realign graphic

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Realign graphic ‑ ✓ ✓

Requirements
This menu command can only be selected if you are in the offline mode and the logic diagram 
is active.

Actions  
Using the "Edit" > "Realign graphic" menu command, you can optimize the arrangement of the 
safety circuit in the graphical view (in the logic diagram):
• Overlaps are removed.
• Function elements that overlap connections, each other, or page limits are moved.
• Connections that overlap each other are moved.
• The function elements are arranged according to the signal flow.

6.1.2.11 Interrupt connection

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Interrupt con‐
nection

‑ ✓ ✓
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Requirements
This menu command can only be selected if the logic diagram is active and an interrupted 
connection is selected.

Actions  
The "Edit" > "Interrupt connection" menu command replaces the connecting line between two 
function elements with arrows to keep the configuration in the logic diagram clear. The 
connection is retained.

6.1.2.12 Redraw partial connection

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Redraw partial 
connection

‑ ✓ ✓

Requirements
This menu command can only be selected if the logic diagram is active and an interrupted 
connection is selected.

Actions  
The "Edit" > "Redraw partial connection" menu command undoes the "Interrupt connection" 
command. The connecting line reappears.

6.1.2.13 Add diagram

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Add diagram ‑ ✓ ✓

Requirements
This menu command can only be selected if you are in the offline mode and the logic diagram 
is active. 

Actions  
Using the "Edit" > "Add diagram" menu command, you can insert another diagram for your safety 
logic.
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Naming / renaming a diagram
You can modify the diagram name by double-clicking on "Diagram 1" in the navigation window. 
Enter the desired name in the "Properties - Diagram" dialog box.

6.1.2.14 Remove diagram

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Remove dia‐
gram

‑ ✓ ✓

Requirements
This menu command can only be selected if the logic diagram is active.

Actions   
The "Edit" > "Remove diagram" menu command deletes the current diagram from the navigation 
window.

Note
It is only possible to split up the safety logic in connection with an offline project.

Note
Remove diagram
If you delete a diagram, all of the connections, function elements, and comments will also be 
deleted with it.

6.1.2.15 Create macro...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Create macro ‑ ‑ ‑ ✓

Requirements
This menu command can only be selected if the logic diagram is active and at least one function 
element is selected.

Actions  
With the "Edit" > "Create macro" menu command, you create a macro from the selected function 
elements that you can reuse as a block in other projects.
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6.1.2.16 Edit terminal identifier...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Edit terminal 
identifier...

‑ ‑ ✓ ✓

Requirements
This menu command can only be selected if a device or a real AS-i slave has been selected in the 
main system or subsystem. Terminal identifiers can only be assigned for terminals if the 
terminals can also be interconnected in the logic diagram.

Actions   
The "Edit" > "Edit terminal identifier..." menu command opens a dialog box for entering the 
identifiers for the terminals. 
The result only appears in the logic diagram when the relevant checkbox on the "Logic" tab under 
"Options" > "Settings of Safety ES..." is selected.

6.1.2.17 Object properties...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Object proper‐
ties

‑ ✓ ✓ ✓

Requirements
This menu command can only be selected if a device, a real AS-i slave, or a function element in 
the logic diagram has been selected in the main system or subsystem. 

Actions  
Using the "Edit" > "Object properties" menu command, you can call up the parameter 
assignment dialogs for the circuit elements of the safety circuit or for the devices.

6.1.2.18 Check consistency

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Check consis‐
tency

‑ ✓ ✓ ✓
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Actions  
The "Edit" > "Check consistency" menu command is used to check the configuration for 
consistency.

Note
A consistency check is carried out every time the configuration is saved.

The errors found during this check appear in the output window "Consistency check results" 
below the work space.

6.1.2.19 Password for project access...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Password for 
project ac‐
cess...

‑ ✓ ✓ ✓

Requirements
This menu command can only be selected if an offline configuration is open in Safety ES.

Actions 
Using the "Edit" > "Password for project access..." menu command, you can perform the 
following actions: 
• Assigning the password for project access for the first time.

Note
Password length
The password must consist of a maximum of 8 characters.

• To modify the password for project access: enter the old password and then enter the new 
password twice.

• To reset the password protection for project access: enter the old password and then leave the 
new password empty (do not enter any content) and confirm with "OK."

• If the password for project access is lost: create a code for release with the "Forgotten 
password" button.

Password prompt
This password prompt appears in the "Enter password" dialog box when you open an offline 
configuration.
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6.1.2.20 Forgot password

Actions
With the "Edit" > "Password for project access..." menu command, you can request a file for 
releasing the password from the Siemens hotline if the password is lost.   

Activate password
If lost, activate the password as follows:
• Under the "Password for project access..." menu command, click on the "Forgot password..." 

button.
In the dialog box, enter "Forgot password":
– Your name
– Company name
– The name of the file in which your password is encoded and saved

• Submit a Support Request (Page 15).
• The Siemens hotline will send you a file with an activation code.
• Import the file with the activation code using the "Edit" > "Password for project access..." 

menu command. This menu command can only be selected if you have previously created 
the activation data.

• Assign a new password (max. 8 characters) for project access.

Note
The activation code is only valid once.

6.1.2.21 Reset password for project access...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Reset password 
for project ac‐
cess

‑ ✓ ✓ ✓

Requirements
This menu command can only be selected if you have previously created the file for resetting 
forgotten passwords in the "Forgot password" dialog box using the "Password for project access" 
menu command.   
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Actions
Reset the password as follows:
• In the "Reset password for project access" dialog box, click on the "Import" button.
• In the "Open" window that follows, open the file containing the data saved for resetting the 

passwords, which you received from the Siemens hotline.
• When prompted, assign a new password (max. 8 characters) for project access.
• After the password has been correctly assigned, you will receive confirmation that the access 

password has been successfully reset.

6.1.2.22 Password for device access...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Password for 
device access

‑ ✓ ✓ ✓

Requirements
This menu command can only be selected if there is a connection with the safety relay.

WARNING
Unauthorized access to safety functions via fieldbus. 
Can Cause Death or Serious Injury.
To prevent unauthorized access to the safety relay via the fieldbus, e.g. PROFINET or PROFIBUS, 
assign a password for accessing the device in Safety ES.
If you operate several safety relays in one fieldbus network, you must assign a separate 
password for each safety relay to prevent mix-ups when accessing via the fieldbus. In other 
words, the passwords must not be identical.

WARNING
Unauthorized access to the safety relay 
Can Cause Death or Serious Injury.
To prevent unauthorized access to the safety relay, assign a password in Safety ES for device 
access.
In the case of several safety relays, you must assign a separate password to each device for 
device access.
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Actions  
Using the "Edit" > "Password for device access..." menu command, you can carry out the 
following actions: 
• Assign/change/reset the password for device access

Note
The password must consist of a maximum of 8 characters.
The password must not be identical to the "Password for test mode". If you have assigned an 
identical password for both, a change to test mode does not take place.

• Set the protection level

Password prompt
This password prompt appears in the "Enter password" dialog box when you open a password-
protected device access or when you open an online configuration.

Note
If you have forgotten the password for device access, you must restore the factory settings of the 
safety relay. You must do this on the safety relay because commands in Safety ES are password-
protected. You must then load the required configuration into the safety relay again.

6.1.2.23 Password for test mode...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Password for 
test mode...

‑ ✓ ✓ ✓

Requirements
This menu command can only be selected if there is a connection with the safety relay.

Actions   
With the "Edit" > "Password for test mode..." menu command, you can assign and change a 
password for switching to test mode.

Note
The password must consist of a maximum of 8 characters.
The password must not be identical to the "Password for device access". If you have assigned an 
identical password for both, a change to test mode does not take place.
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Password prompt
This password is prompted when you switch to test mode using the "Target system" > "Test 
mode" menu command.

Note
If you have forgotten the password for changing to test mode, you must restore the factory 
settings of the safety relay. You can do this on the safety relay or by means of a command 
(Page 79) in Safety ES. You must then load the required configuration into the safety relay 
again.
You can find out how to restore the factory settings on the device in the manual of the safety 
relay used, see chapter "Additional documentation (Page 12)".

6.1.2.24 Offline logbook viewer...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Offline logbook 
viewer...

‑ ✓ ✓ ✓

Requirements
This menu command can only be selected if an offline configuration is open in Safety ES.

Actions
Use the "Edit" > "Offline logbook viewer..." command to open the dialog window "Offline logbook 
viewer...". With the "Import" button, you can open and view a saved logbook (*.csv file).
You can learn how to save a logbook (*.csv file) in chapter "Device logbooks (Page 83)".

Logbooks 
The logbooks saved in the file are displayed in the dialog window. You can sort the logbooks by 
clicking on the column title. 
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The following information on the entries is displayed:

Column Description
Type The following logbooks are displayed, see also the legend:

• Error
• Operating Error
• Warning
• Prewarning
• Event
By activating the checkboxes , you specify which logbooks are displayed in the 
dialog window.

Index Consecutive number of the entries of all logbooks that indicates how many entries 
are available in the logbook; the index is not sorted.

Source Message source:
• 1 = device
• 2 = Function element 
• 3 = Communication

Operating hours Operating hours count at which the message occurred
Element No. Number of the affected element function, not relevant for messages from the 

sources "Device" or "Communication"
Element function Type of element function for which the message occurred
Message Pending message, incoming messages are marked "+", outgoing (acknowledged) 

messages are marked "-"; the messages are not sorted.

6.1.2.25 Compare with file...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Compare with 
file...

‑ ‑ ✓ ✓

Actions   
The "Edit" > "Compare with file..." menu command compares the parameters in the current 
configuration with the parameters of a selected file.

Result
the system lists any differences.
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6.1.2.26 Compare with switching device...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Edit Compare with 
switching de‐
vice...

‑ ‑ ✓ ✓

Actions  
The "Edit" > "Compare with switching device..." menu command compares the parameters in the 
current configuration with the parameters of a safety relay that has been opened online.

Result
the system lists any differences.

6.1.3 Target system menu

6.1.3.1 Load to switching device...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Load to switch‐
ing device...

✓ ✓ ✓

Actions   
The "Target system" > "Load to switching device..." menu command saves the parameters of the 
current configuration to a safety relay over an online connection.

Note
Overwriting the parameters
When you choose this menu command, the parameters in the safety relay are overwritten 
without you being prompted to confirm this.
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Transferring the parameters
Transfer the parameters as follows:
• Open an online connection to a safety relay via the connection dialog box.
• Click "OK" to close the dialog box.
• The program establishes a connection with the specified safety relay, checks whether the 

parameters that are currently displayed are compatible with this safety relay, and then loads 
all the parameters to the safety relay.

6.1.3.2 Load to PC...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Load to PC... ✓ ✓ ✓

Actions  
The "Target system" > "Load to PC..." menu command downloads the parameters currently 
stored in the safety relay to the PC over an online connection.

Note
Overwriting the parameters
When you choose this menu command, the parameters in the main memory are immediately 
overwritten.

Transferring the data
Transfer the data as follows:
• Open an online connection to a safety relay via the connection dialog box.
• Click "OK" to close the dialog box.
• The program establishes a connection with the specified switching device and reads all 

parameters from the device to the PC.

6.1.3.3 Go offline

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Go Offline ✓ ✓ ✓
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Actions   
The menu command "Target system" > "Go offline" terminates an existing online connection to 
a switching device. 
The application remembers the status it was in prior to setting up the online connection. It does 
this by taking a snapshot of all important information in the background. (Which SIRIUS 
engineering product was launched? Is a file open? What values do the individual parameters 
have? …)
After the online connection has been terminated, you are asked whether you want to keep the 
parameters that are currently displayed now that you are offline.
• If you answer "No", the snapshot is restored.
• If you answer "Yes", nothing happens (except that the online connection has been 

terminated).

Exception:
If the parameter values stored in the snapshot are identical to the parameter values that are 
currently displayed, the above question is skipped because both answers would have the same 
effect.

6.1.3.4 Undo the fixed assignment of the interface

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Undo the fixed 
assignment of 
the interface

✓ ✓ ✓

Actions  
The "Target system" > "Undo the fixed assignment of the interface" menu command undoes the 
assignment set in the "Load to switching device" dialog box. By clicking the menu option or the 
corresponding icon in the toolbar, you reopen the connection dialog the next time the software 
attempts to establish an online connection.

6.1.3.5 PROFIBUS DP line view...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system PROFIBUS DP line 
view...

‑ ✓ ✓ ✓

Actions
To display all the devices in the PROFIBUS segment, choose "Target system" > "PROFIBUS DP Line 
view".       
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Reference
You can find more information in the online help in the section Line view.

6.1.3.6 PROFINET IO line view

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system PROFINET IO line 
view...

‑ ‑ ‑ ‑

Requirements
This menu option is only active if the PROFINET IO driver is installed.

Actions
To display all the devices in the network segment, choose "Target System" > "PROFINET IO line 
view".

6.1.3.7 Learn ASIsafe code tables...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Learn ASIsafe 
code tables...

-- ✓ ✓ ✓

Requirements
This menu command can only be selected if the 3RK3 Advanced, 3RK3 ASIsafe basic or 
3RK3 ASIsafe extended central unit is configured and an online connection exists with a device.

Actions   
With the "Target system" > "Learn ASIsafe code tables..." menu command, you can open the 
dialog box for teaching and diagnosing the code tables of the safety-related AS-i input slaves.
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Slave status 0..15 / slave status 16..31   
Status Color Meaning
Addr. 0 ... 31 -- Address of F slave
Slave red One configured AS‑i slave is missing.

yellow An AS-i slave that does not correspond to the target configuration has been detected.
green A new AS-i slave has been detected. The AS-i slave has not been configured in Safety ES.
Green with check 
mark

The configured AS-i slave has been detected. The structure corresponds to the set 
configuration.

gray No AS-i slave exists at this address and no AS-i slave has been configured.
Code table red The code table is missing or is unknown.

yellow At least 2 AS-i slaves have the same code table.
green A new code table has been detected; the code tables can be learned. The code tables 

can be applied using the "Apply code tables" button.
Green with check 
mark

The configured code table has been detected. The structure corresponds to the set 
configuration.

gray No slave exists at this address and no slave has been configured.
F-IN1 / 2
F-OUT 1 ... 4

red The signal is erroneous.
yellow A safety-related AS-i slave has been detected, but no code sequence transmitted.
green The signal is 1.
White The signal is 0.
gray This terminal does not exist.

Teach
• Start teaching 

If the MSS 3RK3 detects missing code sequence tables during startup or after changes to the 
AS-i bus, an automatic attempt is made to teach these.
Note
Each slave only transmits the code sequence if the inputs are closed. For that reason, you 
must set and reset all input contacts of the safety-related input slaves during the teaching 
phase and control the safety-related outputs, so that all code sequences can be determined.   

• Progress bar "Teaching in progress":
The active teaching operation is displayed with a continuous progress bar.

• Slaves after teaching:
The slaves whose code sequence has been acquired by teaching and the total number of 
safety-related slaves with a code sequence are displayed. The progress is additionally 
displayed as a percentage.

• "Apply code table" button:
To apply the determined code tables and store them as targets, click the "Apply code tables" 
button.

The code sequences are stored in the memory module. No reteaching of code sequences is 
therefore necessary when devices are replaced.
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6.1.3.8 Prepare configuration test...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Prepare config‐
uration test...

‑ ✓ ✓ ✓

The prerequisite for approving a configuration is a successfully carried out configuration test.   

Requirements
This menu command can only be selected if offline configuration is opened.

Actions   
Using the "Target system" > "Prepare configuration test..." menu command, you can create the 
printouts that you can use to support the configuration test.   

Create configuration data
• Call up the "Target system" > "Prepare configuration test..." menu command.
• In the dialog box that now opens, define the access path (local device interface, PROFINET or 

PROFIBUS).
• Confirm with "OK". A connection to the safety relay is established.
• Then the following actions are carried out:

– Comparison to see whether the opened configuration agrees with the online 
configuration in the safety relay. If the comparison reveals differences, it is aborted and an 
error message is displayed.

– Consistency check (also of the logic diagram)
– If an error is detected, the process is aborted.
– The online configuration is opened.
– Print preview in which you can decide whether the configuration data should be printed 

out or saved as a PDF file.

More information
You can find more information on this topic in the chapter "Configuration test".

6.1.3.9 Approve configuration...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Approve config‐
uration...

‑ ✓ ✓ ✓
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Requirements
This menu command can only be selected under the following conditions:
• An offline configuration is open.
• A connection to the safety relay exists.
• Safety relay is in configuring mode.

WARNING
Loss of the safety function.
Can Cause Death, Serious Injury, or Property Damage.
A configuration may only be released if a complete function test of the configuration has been 
successfully completed.

Actions   
Using the "Target system" > "Approve configuration..." menu command, you create a file with the 
release data for a configuration.   

Approve configuration
To create a printout with the required configuration release specifications, proceed as follows:   
• Call up the "Target system" > "Approve configuration..." menu command.
• In the dialog box that now opens, define the access path (local device interface, PROFINET or 

PROFIBUS).
• Confirm with "OK". A connection to the safety relay is established. Acknowledge the dialog 

with OK.
• Then the following actions are carried out:

– Comparison to see whether the opened configuration agrees with the online 
configuration in the safety relay. If not, an error message is displayed.

– Displaying the dialog box
The CRC is displayed. Check whether this matches the CRC of the system documentation.
Then enter the following data:
◆ Your name
◆ Your company name

– Password prompt for device access, if assigned.
– Print preview in which you can decide whether the release data should be printed out or 

saved as a PDF file.  

Result
After the configuration is released, you can switch the safety relay to safety mode.

Operation (software)
6.1 Description of the menu commands

SIRIUS engineering Safety ES V1.0
76 Operating Manual, 12/2021, A5E32640754002A/RS-AF/006



6.1.3.10 Cancel configuration release

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Cancel configu‐
ration release

‑ ✓ ✓ ✓

Requirements   
This menu command can only be selected under the following conditions:
• A safety relay is opened online
• The safety relay is in "configuring mode."

Actions  
The "Target system" > "Cancel configuration release" menu command cancels the release of the 
configuration on the safety relay.

6.1.3.11 Configuring mode

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Configuring 
mode

‑ ✓ ✓ ✓

Actions
Using the "Target system" > "Configuring mode" menu command, you switch the operating 
mode of the safety relay to configuring mode.

Result
In configuring mode, the safety relay will be in the following state:   
• The safety relay is ready to accept new configuration data.
• No logic processing is performed.

6.1.3.12 Test mode

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Test mode ‑ ‑ ✓ ✓
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Requirements
This menu command can only be selected under the following conditions:
• A safety relay is opened online
• The safety relay is in "configuring mode."
• The configuration must be error-free. However, the configuration does not have to be 

released.
• To switch to test mode, you must enter the password for "Switching to test mode".

WARNING
Automatic system starting in the test mode
Can Cause Death, Serious Injury, or Property Damage.
In the test mode, the safety program is executed and the outputs are controlled according to 
the safety program. 
Take appropriate organizational measures, such as deactivating the main circuit or cordoning 
off parts of the system, to ensure safety for persons and the system.

Actions
Using the "Target system" > "Test mode" menu command, you switch the operating mode of the 
target system to test mode.

Application   
You can use this operating mode for support when conducting the prescribed function test of 
the safety circuit. For example, you can force the outputs of function elements in test mode.

6.1.3.13 Safety mode

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Safety mode ‑ ✓ ✓ ✓

Requirements
This menu command can only be selected under the following conditions:
• A safety relay is opened online.
• The safety relay is in "configuring mode."
• The configuration must be fault-free and released.
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Actions
Using the "Target system" > "Safety mode" menu command, you switch the operating mode of 
the target system to safety mode.

Result
In the safety mode, the safety relay will be in the following state:   
• The configured safety circuit is active.
• The outputs are controlled according to the "Circuit parameter assignment" (= circuit 

diagram).

6.1.3.14 Commands...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Commands... ‑ ‑ ✓ ✓

Requirements
This menu command can only be selected under the following conditions:
• A safety relay is opened online.
• The available commands also depend on the mode; see the table below.

Actions
Using the "Target system" > "Commands" menu command, you can activate device commands 
as additional functions on the safety relay.
The procedure is as follows:
• Select the "Target system" > "Commands" menu command. The "Commands" dialog box 

opens.
• Select a command from the drop down list.
• Send the command to the safety relay using the "Send" button.
You can start another command once the previous command is executed and the "Send" button 
is active again.

Monitoring command processing   
A list in the "Commands" dialog box shows the current status of the command processing and 
the feedback messages from the diagnostics data memory determined by Safety ES. The list is 
expanded with each sent command. It is deleted when the dialog box is closed.
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Device commands   
The following device commands are available:

Device com‐
mands

Description Can be activated in Feedback

Factory settings   All of the parameter values are reset to 
their default values.
After the factory settings have been re‐
stored, the device executes a restart au‐
tonomously, the connection to the safety 
relay is interrupted, and the configuration 
is closed.

• Configuring 
mode

• Factory settings restored
• The restart is executed.

Reset   Tripping, i.e. a shutdown due to a protec‐
tion violation, can be acknowledged using 
this command. All of the errors whose cau‐
ses have been eliminated are acknowl‐
edged together

• Configuring 
mode

• Test mode
• Safety mode

• Reset implemented.
• Reset not possible.

Restart   Causes a "hardware reset" of the safety re‐
lay. 

• Configuring 
mode

• Test mode
• Safety mode

• Transmission ok

Delete memory 
module   

Deletes the data on the memory module 
of the connected safety relay.
Note:
With this command, the connection to the 
safety relay is interrupted and the configu‐
ration is closed.
After the memory module has been de‐
leted, a reset (using the RESET button) or a 
complete restart of the safety relay has to 
be performed as otherwise an online con‐
nection to the safety relay is not possible.
Note:
The command is not available on the 
3SK2 safety relay 22.5 mm.

• Configuring 
mode

• Memory module not plugged in
• Memory module defective
• Programming active
• Programming successful
• Programming error

Cancel access 
rights

Cancels all passwords, i.e. all access rights 
are revoked.

• Configuring 
mode

• Safety mode

• Access authorization exists: No

Apply code ta‐
bles

The determined code tables are applied 
and stored as the target setting.

• Configuring 
mode

• Test mode
• Safety mode

• Code tables missing
• 8x4-bit code sequence errors
• Multiple code tables
• New codes tables
• Code tables known
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Device com‐
mands

Description Can be activated in Feedback

Open access path The required access path is opened by the 
safety relay (if no other access path is al‐
ready open): Write/controlling access

• Configuring 
mode

• Safety mode

• Access path to fieldbus control is 
open

• Access path to fieldbus Safety ES is 
open

• Access path to device interface is 
open

Close access path The open access path is closed • Configuring 
mode

• Safety mode

• Access path is closed

6.1.3.15 Diagnostics configuration

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Diagnostics 
configuration

‑ ✓ ✓ ✓

Actions  
Using the "Target system" > "Diagnostics configuration" menu command, activate the following 
submenu options:

Module status
• Module status: You activate the module status display which is displayed in color in the 

configuration table. 
• This menu command can only be selected if the following conditions are met:

– A safety relay is opened online.
– The main system / subsystem is activated in the navigation window.

Device messages  
• Device messages: You activate the "Device messages" dialog box.
• This menu command can only be selected if the following conditions are met:

– A safety relay is opened online.
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6.1.3.16 Diagnostics logic

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Diagnostics 
logic

‑ ✓ ✓ ✓

Actions
Using the "Target system" > "Diagnostics logic" menu command, activate the following submenu 
options:

Monitoring    
• The "Target system" > "Diagnostics logic" > "Monitor" menu command shows the statuses of 

the inputs and outputs, of the function elements and of the connections between the 
function elements according to their status.

• This menu command can only be selected if the following conditions are met:
– A safety relay is opened online.
– The device is in safety or test mode.
– The logic diagram with the safety circuit is activated.

Element messages...   
• The "Target system" > "Diagnostics logic" > "Element messages" menu command shows the 

status messages for a function element that is selected in the logic diagram. You can monitor 
status messages of several function elements simultaneously.

• This menu command can only be selected if the following conditions are met:
– The safety relay is opened online.
– The device is in safety or test mode.
– The logic diagram with the safety circuit is active.
– At least one function element must be selected.

Element reset   
• The "Target system" > "Diagnostics logic" > "Element reset" menu command acknowledges 

the errors of one or several selected function elements.
• This menu command can only be selected if the following conditions are met:

– A safety relay is opened online.
– The device is in safety or test mode.
– The logic diagram with the safety circuit is activated.
– One or more function elements are selected.
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Forcing   

WARNING
Automatic system starting in the test mode
Can Cause Death, Serious Injury, or Property Damage.
In the test mode, the safety program is executed and the outputs are controlled according to 
the safety program. 
Take appropriate organizational measures, such as deactivating the main circuit or cordoning 
off parts of the system, to ensure safety for persons and the system.

• The "Target system" > "Diagnostics logic" > "Force" menu command preassigns fixed values to 
the outputs of function elements (= forcing). You can select the following assignments:
– Force to "0"
– Force to "1"
– Cancel forcing
– Cancel forcing (all)

• This menu command can only be selected if the following conditions are met:
– The "test mode" is activated.
– The logic diagram with the safety circuit is activated.
– An online connection is available.
– At least one connection of a function element is selected.

6.1.3.17 Device logbooks

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Target system Device log‐
books...

- ✓ ✓ ✓

Requirements
This menu command can only be selected if there is a connection to a 3SK2 safety relay.

Actions
With the "Target system" > "Logbooks..." menu command, the logbooks of the safety relay are 
displayed in a dialog window.

Logbooks 
In the logbooks of the safety relay, all messages are saved with a time stamp and a log is thus 
created. The log is stored in the device. This makes it possible to evaluate the events later. 
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The safety relay saves the following logbooks in separate memories. Above a certain number, 
the oldest entries are overwritten with the new messages.

Num‐
ber

Message source Message type

1 Device Error (device fault)
2 Operating Error
3 Warning
4 Prewarning
5 Event
6 Elements Error (wiring error)
7 Operating Error (logic error)
8 Warning
9 Prewarning
10 Event
11 Communication Error
12 Operating Error
13 Warning
14 Prewarning
15 Event

Logbook update
There are two ways of updating the logbook display:
• Automatic update

To activate the automatic update of the logbook, set the check mark for “Cyclically update 
logbook data”. This setting enables the relevant data to be read out at regular intervals. This 
can affect the speed of Safety ES.

• Manual update
If the automatic update feature is deactivated, you can display the latest logbook entries by 
pressing the “Update” button. This does not affect the speed of Safety ES.

Display
You can sort the logbooks by clicking on the column title. The following information on the 
entries is saved:

Note
Grayed-out logbook entries or red logbook entry "Configuration changed"
If a new, changed configuration is loaded into the safety relay, this is indicated with a red logbook 
entry "Configuration changed". All older logbook entries of the elements are grayed out.
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Column Description
Type The following logbooks are displayed, see also the legend:

• Error
• Operating Error
• Warning
• Prewarning
• Event
By activating the checkboxes , you specify which logbooks are displayed in the 
dialog window.

Index Consecutive number of the entries of all logbooks that indicates how many entries 
are available in the logbook; the index is not sorted

Source Message source:
• 1 = device
• 2 = Function element 
• 3 = Communication

Operating hours Operating hours count at which the message occurred
Element No. Number of the affected element function, not relevant for messages from the 

sources "Device" or "Communication"
Element function Type of element function for which the message occurred
Message Pending message, incoming messages are marked "+", outgoing (acknowledged) 

messages are marked "-".

Delete logbook entries
You can delete the entries of a logbook in the device using the "Delete" button. While the dialog 
box is open, the logbooks remain saved in Safety ES. You can recognize deleted logbooks by the 
green symbol.

Note
Exception
Device errors are not deleted

Note
Factory settings
In the factory settings, the logbooks are not deleted.
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Save logbooks as *.csv file
Using the "Save as..." button, you can save logbooks or selected logbook entries in a *.csv file:
• Selected logbook entries

Select individual entries for this purpose by clicking on the corresponding entry in the Type 
column.
You can select several entries by pressing the CTRL key at the same time, and you can select 
a consecutive list by pressing the shift key at the same time. 

• Displayed logbooks
Using the checkbox at top left, you determine which logbooks are displayed and saved.

• All logbooks
This also saves the logbooks that are not displayed.

• Support information
With this selection, the logbooks are prepared for Technical Support and stored in a *.csv file.

6.1.4 View menu

6.1.4.1 Toolbar

Menu option Basic license Standard license Premium license
View Toolbar ‑ ✓ ✓

Actions
To display or hide the toolbar at the top of the application screen, choose "View" > "Toolbar". 

Properties of the toolbar   

Figure 6-1 Toolbar in Safety ES
• The toolbar has icons that make the most important menu functions directly accessible. If 

you allow the mouse pointer to rest on an icon for about one second, its function is briefly 
displayed as a tool tip and in the status bar in plain text.

• To print data, click on the printer icon. All other icons correspond to the function of the 
associated menu command.

• You cannot change the number or assignment of the icons for the individual menu 
commands.
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6.1.4.2 Status bar

Menu option Basic license Standard license Premium license
View Status bar ‑ ✓ ✓

Actions   
To display or hide the status bar at the bottom of the application screen, choose "View" > "Status 
bar". 

Properties of the status bar
The status bar contains the standard information and additional information. 

Figure 6-2 Status bar in Safety ES

No. Meaning
① Displays the operating state of the safety relay and the status of the user program

STOP: Circuit is not being processed
RUN: Circuit is being processed

② Shows the current utilization of the user memory.
③ Display of the current utilization of the internal memory of the safety relay (depends on the type 

and number of function elements used).
④ Shows the current utilization of the parameterized program cycle time.
⑤ Connection status (online / offline).
⑥ Type of online connection (e.g. COM1 (= serial interface), DP 42 (= PROFIBUS connection to a 

switching device with address 42) IP 192.168.0.2 (= PROFINET connection to a switching device 
with IP address 192.168.0.2)

6.1.4.3 Zoom in

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Zoom in ✓ ✓ ✓

Requirements
This menu command can only be selected if the logic diagram is active.
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Actions  
The "View" > "Zoom in" command enlarges the current view by one zoom level.

6.1.4.4 Zoom out

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Zoom out ✓ ✓ ✓

Requirements
This menu command can only be selected if the logic diagram is active.

Actions  
The "View" > "Zoom out" command reduces the current view by one zoom level.

6.1.4.5 Zoom dialog

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Zoom dialog ‑ ✓ ✓

Requirements
This menu command can only be selected if the logic diagram is active.

Actions  
The "View" > "Zoom dialog" menu command opens the zoom dialog box of the logic diagram. A 
zoom level can be selected there.

6.1.4.6 Overall view

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Overall view ‑ ✓ ✓

Requirements
This menu command can only be selected if the logic diagram is active.
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Actions  
Using the "View" > "Overall view" menu command, you can set the zoom level in such a way that 
the entire diagram is visible on the screen.

6.1.4.7 Display settings

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Display settings ‑ ✓ ✓

Requirements
This menu command can only be selected if the logic diagram is active.

Actions  
With the "View" > "Display properties" menu command, you open the "Display properties" dialog 
box. You can set the display properties there.

6.1.4.8 Grid settings

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Grid setting ‑ ✓ ✓

Requirements
This menu command can only be selected if the logic diagram is active.

Actions  
With the "View" > "Grid settings" menu command, you open the "Screen grid" dialog box. You can 
set the grid there.

6.1.4.9 Move diagram

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Move diagram ‑ ✓ ✓
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Requirements
This menu command can only be selected if the logic diagram is active.

Actions  
With the "View" > "Move diagram" menu command, you switch to move mode. The diagram can 
only be moved with the mouse.

6.1.4.10 Highlight signal flow

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Highlight sig‐
nal flow

‑ ✓ ✓

Requirements
This menu command can only be selected if the logic diagram is active and an element (e.g. a 
function element or connection) is selected.

Actions  
The "View" > "Highlight signal flow" menu command visually highlights all of the elements 
located in the signal flow to the left (input side) and right (output side) of the selected element.

6.1.4.11 Delete highlighting

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Delete high‐
lighting

‑ ✓ ✓

Requirements
This menu command can only be selected if the logic diagram is active and a signal flow is 
highlighted.

Actions  
The "View" > "Delete highlighting" menu command deletes all markings that resulted from the 
"Highlight signal flow" menu command.
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6.1.4.12 Navigation window

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Navigation win‐
dow

✓ ✓ ✓

Actions  
The "View" > "Navigation window" menu command shows/hides the navigation window.

6.1.4.13 Output window

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Output window ✓ ✓ ✓

Actions   
The "View" > "Output window" menu command shows/hides the output window.

6.1.4.14 Catalog window

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Catalog win‐
dow

✓ ✓ ✓

Actions  
The "View" > "Catalog window" menu command shows/hides the catalog window.

6.1.4.15 Minimize / restore online dialogs

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

View Minimize / re‐
store online di‐
alogs

‑ ✓ ✓
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Requirements
A safety relay is open online and at least one online dialog is open, e.g. the "Device messages" 
dialog.

Actions   
Use the "View" > "Minimize/restore online dialogs" menu command to collectively minimize or 
restore the display of all open online dialog boxes.

Which commands are executed?
• If an online dialog box is open, the menu command executes the function: "Minimize all open 

online dialog boxes".
• If all open online dialog boxes are minimized, the menu command executes the function: 

"Restore all minimized online dialog boxes".

6.1.5 Options menu

6.1.5.1 Basic settings...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Basic Settings... ‑ ✓ ✓ ✓

Changing the basic settings  
The menu command "Options" > "Basic settings..." starts a dialog box in which you can change 
the basic behavior and appearance of SIRIUS engineering. Any changes you make do not 
become effective until you choose "OK" or "Apply". 

Change options
You can make the following settings in this dialog box:
• "Language"  

All available languages are shown in the selection list. When you change the language, this 
affects all the displayed texts in Safety ES (menu texts, dialog texts, parameter names, etc.). 
Other installed SIRIUS engineering products are not affected. Switching to a different 
language does not in any way affect how SIRIUS engineering functions.

• "Show picture at startup of SIRIUS engineering"
If you activate this checkbox, SIRIUS engineering displays a picture for a few seconds in the 
middle of the screen when the program starts.
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• In "Offline" state: Automatic "Online" after “Load to switching device”
This setting is only effective if you choose "Target system" > "Load to switching device" before 
an online connection to a safety relay has been established. In this case, the program 
establishes a new connection, transfers the parameters to the device, and then terminates 
the connection immediately afterwards.
The behavior at this point depends on whether you have activated the checkbox: In "Offline" 
state: Automatic "Online" after "Load to switching device":
– Activated: the program reestablishes a connection with the same device, loads its 

parameters to the PC, and maintains the online connection. You can check the parameters 
and determine how they affect the behavior of the device.

– Deactivated: no further automatic actions are carried out. The program has the same 
status as it did before the action "Load to switching device".

• "Show startup wizard"  
If you activate this checkbox, a startup wizard opens when you start Safety ES. With the help 
of this startup wizard, you can:
– Create a new project
– Open an existing project
– Open a project online with an existing connection to the safety relay

6.1.5.2 Settings of Safety ES - "General settings" tab

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Settings of 
Safety ES

‑ ✓ ✓ ✓

Requirements
This menu command can only be selected if a configuration is opened in SIRIUS Safety ES.

Actions  
Using the "Options" > "Settings of Safety ES..." menu command, you can set the desired response 
of the Safety ES.
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"General settings" tab
The "General settings" tab contains the following settings:
• "Display object properties automatically on insert":

If you select "Display object properties automatically on insert," a dialog box for the 
properties of the respective object (in which you can set the parameters) will immediately 
appear after a device is inserted in the hardware configuration tables or after a function 
element is inserted in the logic diagram.

• "Show consistency check messages when saving"
• "Cyclic data updates in online dialogs every ... seconds":

The data sets required for open online dialog boxes are read from the safety relay in this time 
interval.

6.1.5.3 Settings of Safety ES - "Download options" tab

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Settings of 
Safety ES...

‑ ✓ ✓ ✓

Requirements
This menu command can only be selected if a configuration is open in Safety ES.

Actions  
Using the "Options" > "Settings of Safety ES..." menu command, you can set the desired response 
of the Safety ES.

"Download settings" tab
In the "Download settings" tab, you can define which parts of the system documentation are to 
be loaded to the safety relay when the configuration is downloaded:
• Equipment identifier (BMK) 
• Element name 
• Element comment 
• Terminal identifier 
• Element positions
• Module list of the device connector

Operation (software)
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Save memory space 
You do not have to load the system documentation to the safety relay because the system 
documentation is not evaluated by the safety relay and is therefore not needed for the safety 
relay to function.

6.1.5.4 Settings of Safety ES - "Logic" tab

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Settings of 
Safety ES...

‑ ✓ ✓ ✓

Requirements
This menu command can only be selected if a configuration is open in Safety ES.

Actions   
Using the "Options" > "Settings of Safety ES..." menu command, you can set the desired response 
of the Safety ES.

"Logic" tab
The "Logic" tab contains the following settings for the display options:
• "Label page transitions of connections also on screen":

Defines whether the labels of the connections on the page transitions will be visible on the 
screen.

• "Displaying element comments"  
The comments of the function elements are visible in the logic diagram.

• "Display terminal identifiers":  
Here you can set whether the terminal identifiers are to be displayed.

• "Retain element numbers in macros if possible"  
If the element number is not yet used in the current diagram, the element number that the 
function element had when the macro was created (and that is stored in it) will be assigned 
to the function element again when it is reused.
If this setting is deactivated, the next free element number will be assigned to the function 
element, starting at 1.
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• "Display settings" button: 
– Select a display element.
– The current color of the selected element is specified.
– You can change the color of the selected element.
– You can restore the basic settings.
– Confirm with "OK," to apply your changes.
– You will find additional information in chapter "Display settings (Page 131)."

• "Realign graphic" button:
– Here, you can define the layout strategy by selecting whether and how to "Avoid 

connections crossing function elements."
◆ Interrupt connections if possible
◆ Move function elements down

– You can also apply a "Standard column grid across all subnetworks of a function diagram" 
if you select the corresponding checkbox.

– You can position the output cells in a separate column on the far right (for each 
subnetwork) if you select the lowermost checkbox.

– Confirm with "OK," to apply your changes.
• "Screen grid" button: 

– The graphical grid influences the moving of graphical elements. You can choose whether 
objects are to be aligned to the grid and / or whether objects are to be aligned to other 
objects. Select the appropriate checkboxes for this.

– You can set the grid size (mm) in "Distance."
– You can define how the grid will be displayed by setting which grid points will be shown.
– You can activate or deactivate display of the grid by selecting the relevant checkboxes.
– Confirm with "OK," to apply your changes.
– You will find additional information in chapter "Grids and lines (Page 132)."

6.1.5.5 Cross references

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Cross referen‐
ces

‑ ‑ ✓ ✓

Requirements
This menu command can only be selected if a configuration is open in Safety ES.

Operation (software)
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Actions  
The "Options" > "Cross references" menu command shows the cross references in tabular form 
in the output window.

Structure of the cross reference list
Operand Kind Type Usage loca‐

tion
Diagram Page

Device
Channel
Terminal identifier
Device status function

Access:
WR = write
RO = read

Type of 
operand

Element type 
and element 
number of the 
function ele‐
ment.

Name of the dia‐
gram in which the 
function element is 
located.

Page on which the function 
block that is connected to 
the function element is lo‐
cated.

Note
The cross reference list only displays the operands used in the safety circuit.

Edit cross references
With the context menu (right mouse button) or by double-clicking on the item, you can go to the 
position where the cross reference is used in order to edit it.

6.1.5.6 Symbol list

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Symbol list ‑ ‑ ✓ ✓

Requirements
This menu command can only be selected if a configuration is open in Safety ES.

Actions
The "Options" > "Symbol list" menu command shows the plant identifier you assigned in the form 
of a table in the output window.   
To improve the legibility of the configuration, you can assign identifiers for parts of your 
configuration data within the context of the system documentation. The symbol list gives an 
overview of the identifiers assigned by you, their assignments, and the type.

Operation (software)
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Example of a symbol list
Identifier Assignment Type
Switching device 1 SLOT5 Equipment identifier (BMK)
Terminal_1 SLOT3_F-IN1 Terminal identifier
Terminal_2 SLOT4_Q6 Terminal identifier
Press - Plant identifier
Hall 1 - Location identifier
EMERGENCY STOP_1 EMERGENCY STOP [35] Name

Editing entries in the symbol list
You can perform the following actions in the context menu (right mouse button):
• Delete: The selected identifier is deleted.
• Editing: The selected identifier can be changed (can also be activated if the identifier is 

selected and you click on it again or press F2).
If you change or delete identifiers, then the display in the respective view is immediately 
updated.

• Go to: You jump to the corresponding icon, which is then selected (can also be activated by 
double-clicking).

Sorting:
• If you click on the column header in the columns "Identifier" and "Assignment," the items will 

be sorted alphabetically by this column.
• Clicking on the "Type" column header sorts the column as follows: Equipment identifier, 

Name, Comment, Terminal identifier, Location identifier, Plant identifier.

Note
Editing rules
You cannot assign the same identifier twice.

6.1.5.7 Terminal list

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Terminal list ‑ ‑ ✓ ✓

Requirements
This menu command can only be selected if a configuration is open in Safety ES.
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Actions  
The "Options" > "Terminal list" menu command lists all available terminals of the slot and subslot 
(AS-i) modules, as well as bit memories, in the output window with the relevant terminal 
identifier (right-hand column) and the interconnection status in the logic diagram (left-hand 
column).   
The terminals are also shown for which no identifier has been assigned and also those terminals 
that are not yet interconnected.

Example of a terminal list
Terminal Terminal marking
ASi#02_IN1 Pushbutton_1
SLOT3_F-IN1 Terminal_1
SLOT3_F-M1 Bit_memory_1

Editing entries in the terminal list
You can perform the following actions in the context menu (right mouse button):
• Delete: The selected terminal identifier is deleted.
• Editing: The selected terminal identifier can be changed (can even be activated if the 

identifier is selected and you click on it again or press F2).
If you change or delete identifiers, then the display in the respective view is immediately 
updated.

• Go to: Interconnecting terminal is in the logic will take you to the corresponding function 
element and select it (can also be activated by double-clicking).

Sorting: 
• Clicking on the column header of the first column sorts the items of this column by their 

interconnection status.
• Clicking on the relevant column header sorts the items of the "Terminal" and "Terminal 

identifier" columns alphabetically.
Note
Editing rules
You cannot assign the same terminal identifier twice.

6.1.5.8 Export macros...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Export mac‐
ros...

‑ ‑ ‑ ✓
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Requirements
This menu command can only be selected if a configuration is open in Safety ES.

Actions  
With the "Options" > "Export macros..." menu command, you can save the existing macros on 
any data medium to make them available to other users.
See also chapter "Macro functionality (Page 134)."

6.1.5.9 Import macros...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Import mac‐
ros...

‑ ‑ ‑ ✓

Requirements
This menu command can only be selected if a configuration is open in Safety ES.

Actions  
With the "Options" > "Import macros..." menu command, you can import exported macros from 
other users to use them in your project.
See also chapter "Macro functionality (Page 134)"

6.1.5.10 Release information...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Release infor‐
mation...

‑ ✓ ✓ ✓

Requirements
This menu command can only be activated if the configuration has been released.

Actions  
The "Options" > "Release information..." menu command displays the following release data in 
the "Display release information" dialog box for the configuration currently in Safety ES:   
• Name of the person releasing
• Name of the company of the person releasing

Operation (software)
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• Release status
• Configuration CRC
• Release time stamp

The release information can be printed out via the "Print" button.   

6.1.5.11 Set PG/PC interface...

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Set the PG/PC 
interface...

- - - ✓

Actions
The "Options" > "Set the PG/PC interface..." menu command opens a dialog box in which you can 
set the PG/PC interface.

More detailed information in the help file   
You will find detailed information in the S7DOS help file s7epatda.chm in the Windows system 
directory. Depending on the configuration of your operating system, you will find the help file 
either in C:\Windows\system32\s7epatda.chm or in C:\Winnt\system32\s7epatda.chm.
This can only be set if communication with SIRIUS engineering is supported via PROFIBUS DP, 
PROFINET IO or the SIMATIC network.

6.1.6 Help Menu

6.1.6.1 Help topics

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Help Help topics ✓ ✓ ✓

Actions  
The menu command "Help" > "Help Topics" starts the online help for Safety ES.
The online help is structured as follows:
• The left window contains the table of contents, index, and find function of the online help.
• The main window contains the individual help topics.
• You can find topics of relevance to all SIRIUS engineering products in the higher-level online 

help.
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6.1.6.2 Info

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Help Info ‑ ✓ ✓ ✓

Actions  
The "Help" > "Info" menu command provides information about the following:
• All the SIRIUS engineering products that have been installed
• Copyright
• Technical Support

6.2 Identification

6.2.1 Basic unit

"Basic unit" view 
The "Identification" > "Basic unit" view contains an overview of the device-specific information. 
You can read from the file using the "Switching device" > "Open" menu command, or from the 
safety relay using the "Switching device" > "Open online" command.

Note
When you create a new safety relay, the content will be empty. 
If no safety relay is configured, all the fields are gray in offline mode.
If a safety relay is configured, the contents are partially available in the offline mode. They are all 
available in online mode.

Information in the "Basic unit" dialog     
The "Identification" > "Basic unit" view contains the following information: 

Information Meaning
Article No. Article number of the safety relay.
Short designation Short designation of the safety relay, e.g. 3RK3 Basic.
System Designation of the line of products, e.g. "Safety relay".
Manufacturer Name of manufacturer, e.g. "Siemens AG"
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Information Meaning
PI profile Gives information about the PROFIBUS profile supported by the safety relay 

and the line of products belonging to the safety relay.
This field is gray in offline mode.

Device family Designation of the overall device family, e.g. safety-related switching device.
Device subfamily Designation of the subfamily that is subordinate to the device family, switch‐

ing devices with the same process view and data sets of identical content, e.g. 
safety relays.

Device class Designation of the device class that is subordinate to the subfamily, e.g. 
modular.

Function group Describes the device-specific, identical characteristics within a device sub‐
family, e.g. use of the same parameters from the parameter data set.

Fieldbus interface Information on the fieldbus interface, e.g. "PROFINET IO", supported by the 
safety relay.
This field is gray in offline mode.

System interface Information on the internal system interface supported by the safety relay.
This field is gray in offline mode.

Device interface Information on the local interface supported by the safety relay.
This field is gray in offline mode.

ID no. Specifies the communication ID number of the safety relay.
This field is gray in offline mode.

HW revision level Product version which is entered prior to delivery.
This field is gray in offline mode.

FW revision level Information on the version of the device firmware.
This field is gray in offline mode.

Revision counter Labels changes of HW-related parameters and cannot be edited.
This field is gray in offline mode.

I&M version Version of the I&M (Identification & Maintenance) function in the safety relay.
This field is gray in offline mode.

Supported I&M data Specify which I&M blocks are supported by the safety relay.
This field is gray in offline mode.

Serial number Contains a production label with production information.
This field is gray in offline mode.

Time stamp The time stamp is written to the safety relay when the safety relay is named 
in the factory and specifies the date and time of production.
This field is gray in offline mode.
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6.2.2 Marking

"Identification" view    
In the "Identification" > "Marking" view, you can enter descriptions about the safety relay or 
system. 
The descriptions are part of the plant documentation. You can read from the file using the 
"Switching device" > "Open" menu command or from the safety relay using the "Switching 
device" > "Open online" menu command.   

Information Meaning
Plant identifier The plant identifier specifies in which part of the plant a safety relay will be 

installed and operated. Max length: 32 characters.
Location identifier The location identifier specifies at which location in the plant a safety relay 

will be installed and operated. Max length: 22 characters.
Installation date Enter the date the safety relay was installed in the plant here. Max. length: 

16 characters.
Description You can enter additional information here. Max length: 54 characters
Author You can enter the name of the author of the entries here.
Comment Here you can store additional information in the system or in the safety relay.

Max. length for the Author and Comment input fields, taken together: 187 
characters.

Note
This view cannot be edited in the online view.
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6.2.3 Project

"Project" view     
In the "Identification" > "Project" view, you can enter the following descriptions: 
• Project name
• Name of configuration engineer
• Configuration engineer's company name

Information Meaning
Project name Enter at least one character
Name of configuration engineer Enter at least one character
Configuration engineer's compa‐
ny name

Enter at least one character

Configuration CRC   Cyclic Redundancy Check which saves all safety-relevant configura‐
tion data (4 bytes).
The transfer of safety-relevant configuration data through insecure 
communication channels must be secured for the safety relay.

Configuration time stamp The Safety ES enters the current time stamp when a configuration is 
saved.

Configuration released Release status of the configuration. Details can be determined via 
"Options" > "Release information".

Configuring tool Specifies the software with which the opened configuration was 
created, e.g. Safety ES

Version of the configuring tool Specifies the version of the software with which the opened config‐
uration was created, e.g. K1.0.2.0

Number of slot modules Number of slot modules in the device configuration
Number of subslot modules Number of subslot modules (AS-i slaves) in the device configuration
Number of function elements Number of function elements in the device parameter assignment.
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6.3 Configuration

6.3.1 Main system

Configuration   
You configure the hardware of the safety relay in the "Main system" configuration table. The rows 
represent the slots of the safety relay: The fixed slots 1 to 3 and the maximum number of 
expansion modules supported by the selectable safety relay. 

Note
Procedures for configuring
The procedure for configuring in Safety ES has an effect on various functions. 
There are two ways of configuring in Safety ES:
1. You start with configuring the hardware configuration and then configure the logic. Once you 

have configured a safety relay, all non-supported function elements will no longer be 
available in the catalog window of the logic diagram.

2. You start with configuring the logic and then configure the hardware configuration. If you use 
function elements in the logic diagram that are not supported by every safety relay, the non-
supported devices are then no longer available in the hardware catalog of the configuration.

Slot assignment     
Slots are assigned to the following devices:
• System slot 1: HMI modules (optional)
• System slot 2: Interface module (optional)
• System slot 3: 3RK3 central units / 3SK2 basic units
• From system slot 4: 3RK3 expansion modules (optional, number depends on the 3RK3 safety 

relay used)
You can assign devices to the slots as follows:
• Drag the device out of the catalog window and drop it into the table.

When a device is selected in the catalog window, the rows in the table where the device can 
be positioned are highlighted in color.

Changing and editing entries in the configuration table
You can edit positioned devices directly in the configuration table:
• You can delete devices unless their inputs / outputs are already connected in the safety 

circuit. In this case, all interconnections must first be removed. If you confirm the message 
with "Yes", this occurs automatically.

• You can drag and drop devices from one row to another.

Operation (software)
6.3 Configuration

SIRIUS engineering Safety ES V1.0
106 Operating Manual, 12/2021, A5E32640754002A/RS-AF/006



• When you switch or move devices, the assignment of the affected inputs/outputs in the 
safety circuit is adapted accordingly.

• You can copy and paste expansion modules including their parameters or swap their slots 
using the command "Swap slot".
Note
An equipment identifier must not exist twice. Therefore a number is added to the equipment 
identifier when copying. If the maximum number of characters is exceeded by adding the 
number, the equipment identifier is shortened.   

Editing the configuration table using the context menu
By pressing the right mouse button and selecting a device in the configuration table, a context 
menu pops up with which you can edit the entries in the table.

"Swap slot" command
You can swap slots of devices.

"Delete blank rows automatically" command
With this command you can correct an erroneous configuration in the main system. There will 
be no more blank rows between devices in the table.
The assignment of the affected inputs/outputs in the safety circuit is adapted accordingly, just as 
it is when modules are moved.

"Edit terminal identifier" command   
The dialog box shows you the existing terminals in the "Terminal" column and you can edit the 
following:
• "Terminal identifer" column: A terminal designation can be entered (max. 32 characters).
• "Supplement identifiers" button: Inserts the terminal identifiers in the unassigned fields.
• "Delete identifiers" button: Deletes the terminal identifiers in the selected fields.

"Object properties" command
Information on the selected module is displayed in this properties window, and you can define 
parameters in it.

"Optimize column width" command
Adapts the column width optimally to the column contents.
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Further editing options in the configuration view
In the configuration view, you have the following editing options:
• Determine online  

When a safety relay is connected, you can adopt the actual configuration, i.e. the hardware 
configuration of the safety relay, by clicking the "Determine online" button. The user is asked 
if the current configuration is to be replaced.
Note
Diagnostics display
The connected diagnostic display is not recognized by "Determine online."

• Show hardware configuration  
When the checkbox "Show hardware configuration" is selected, an image with the devices 
and their required arrangement is shown in the area below the checkbox.

• Consistency check  
The user can execute a consistency check by means of the menu command "Edit" > "Check 
consistency" to determine whether the configuration is possible.

6.3.2 Swap slots
If, for example, all the slots are assigned and you want to reorganize your configuration, you can 
swap the position of two expansion modules by means of the dialog "Swap slots":    
• Select the slot in the configuration table where one of the two expansion modules is 

positioned.
• Click the right mouse button.
• Select "Swap slot" from the context menu.
• The "Swap slot" dialog is opened.
• Select the slot in the drop-down list where the other expansion module is positioned.

Result
The slots of the two devices are swapped.
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6.3.3 Properties of the HMI module

Description       
You can open the "Properties of HMI module" dialog box as follows:
• Double-click on the module in the configuration table.
• Choose the "Object properties" menu option from the context menu (right mouse button).
• In the menu "Options" > "Settings of Safety ES..." under the tab "General settings", activate 

the checkbox "Display object properties automatically on insert". The properties dialog box 
will then pop up automatically when you drag the device from the catalog window into the 
configuration table of the project window.

Parameters
The parameters are described in the following table:

Parameter name Parameter value
Configuration
Module The designation of the selected module is displayed here. The field has a gray background and 

cannot be changed by the user.
Article No. The article number of the selected module is shown here. The field has a gray background and 

cannot be changed by the user.
Firmware The firmware of the selected module is shown here. The field has a gray background and cannot 

be changed by the user.
Equipment identifier Here you can specify a user-defined equipment identifier (max. 32 characters) for the selected 

module and assign it to inputs and outputs.
Inputs The number of inputs of the selected module is shown here.
Outputs The number of outputs of the selected module is shown here.

6.3.4 Properties of interface module

Description
You can open the "Properties of interface module" dialog box as follows:
• Double-click on a module in the configuration table.
• Choose the "Object properties" menu option from the context menu (right mouse button).
• In the menu "Options" > "Settings of Safety ES..." under the tab "General settings", activate 

the checkbox "Display object properties automatically on insert". The properties dialog box 
will then pop up automatically when you drag a module from the catalog window into the 
configuration table of the project window.
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Parameters for PROFINET interface
The parameters are described in the following table:

Parameter name Parameter value
Configuration
Module The designation of the selected module is displayed here. The field has a 

gray background and cannot be changed by the user.
Article number The article number of the selected module is shown here. The field has a 

gray background and cannot be changed by the user.
Firmware The firmware of the selected module is shown here. The field has a gray 

background and cannot be changed by the user.
Equipment identifier Here you can specify a user-defined equipment identifier (max. 32 char‐

acters) for the selected module and assign it to inputs and outputs.
Inputs The number of inputs of the selected module is shown here.
Outputs The number of outputs of the selected module is shown here.
Parameter assignment  
Baud rate   The baud rate is automatically detected by the safety relay. The field has a 

gray background and cannot be changed by the user.
MAC address After opening online, the MAC address of the PROFINET interface is dis‐

played here.
Ethernet addresses
IP address Enter the desired IP address here.  On "Load to switching device...", "Open 

online...", the valid IP address up to then is overwritten in the PROFINET 
interface and the new IP address is stored in the PROFINET interface. To 
enable communication with the controller, the known IP addresses in the 
automation software must match the IP address set in the PROFINET in‐
terface. You can set the IP address in the PROFINET interface and via the 
automation software. To do so, the change authorizations (see above) 
must be set accordingly.

Subnet mask Enter the subnet here. 
Router address Enter the address of the router here. 
Device name You assign the device name here. 
Ethernet addresses - Change authorizations Here you can define the following change authorizations at the station 

address:
• Changes possible without restrictions (e.g. by means of PROFINET 

mechanisms in STEP 7 or DS 160).
• Can only be changed by means of data set (DS 160).

Diagnostics
Group diagnostics   Here you select whether the group diagnostics is blocked or released.

If this parameter is set to "block," the "Group error diagnostics," "Group 
warning diagnostics," and "Group prewarning diagnostics" parameters are 
not significant, i.e. they are ignored by the safety relay.

Group error diagnostics Here you select whether the group error diagnostics are blocked or re‐
leased.

Group warning diagnostics Here you select whether the group warning diagnostics are blocked or 
released.

Group prewarning diagnostics Here you select whether the group prewarning diagnostics are blocked or 
released.
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Parameters for DP interface
The parameters are described in the following table:

Parameter name Parameter value
Configuration
Module The designation of the selected module is displayed here. The field has a 

gray background and cannot be changed by the user.
Article number The article number of the selected module is shown here. The field has a 

gray background and cannot be changed by the user.
Firmware The firmware of the selected module is shown here. The field has a gray 

background and cannot be changed by the user.
Equipment identifier Here you can specify a user-defined equipment identifier (max. 32 char‐

acters) for the selected module and assign it to inputs and outputs.
Inputs The number of inputs of the selected module is shown here.
Outputs The number of outputs of the selected module is shown here.
Parameter assignment  
Baud rate   The baud rate is automatically detected by the safety relay. The field has a 

gray background and cannot be changed by the user.
Station address This is where you define the station address.
Station address - Change authorizations Here you can define the following change authorizations at the station 

address:
• Changes possible without restrictions (e.g. by means of the fieldbus 

command "SET_SLAVE_ADD," DS 160, or setting element).
• Can only be changed by means of data set (DS 160), which can be sent 

from the controller or from Safety ES, or by means of the setting ele‐
ment (on the DP interface).

• Can only be changed by means of data set (DS 160).
Diagnostics
Group diagnostics   Here you select whether the group diagnostics is blocked or released.

If this parameter is set to "block," the "Group error diagnostics," "Group 
warning diagnostics," and "Group prewarning diagnostics" parameters are 
not significant, i.e. they are ignored by the safety relay.

Group error diagnostics Here you select whether the group error diagnostics are blocked or re‐
leased.

Group warning diagnostics Here you select whether the group warning diagnostics are blocked or 
released.

Group prewarning diagnostics Here you select whether the group prewarning diagnostics are blocked or 
released.
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6.3.5 Basic unit properties

Description     
You can open the dialog window "Basic unit properties" as follows:
• Double-click on a module in the configuration table.
• Choose the "Object properties" menu option from the context menu (right mouse button).
• In the menu "Options" > "Settings of Safety ES..." under the tab "General settings", activate 

the checkbox "Display object properties automatically on insert". The properties dialog box 
will then pop up automatically when you drag a module from the catalog window into the 
configuration table of the project window.

Parameters
The parameters are described in the following table:

Parameter name Parameter value
Configuration
Module The designation of the selected module is displayed here. The field has a gray background and 

cannot be changed by the user.
Article No. The article number of the selected module is shown here. The field has a gray background and 

cannot be changed by the user.
Firmware The firmware of the selected module is shown here. The field has a gray background and 

cannot be changed by the user.
Equipment identifier Here you can specify a user-defined equipment identifier (max. 32 characters) for the selected 

module and assign it to inputs and outputs.
Inputs The maximum number of available inputs is indicated here.
Outputs The maximum number of available outputs is indicated here.
Parameter assignment - Device response
Program cycle time [ms]   Here you define the program cycle time within a range of 10 to 60 ms in steps of 5 ms.

On the 3RK3 central units with AS-i interface1), a program cycle time of 15 ... 60 ms is possible 
when the AS-Interface is used.
When the 3SK2 safety relay is operated with a DP interface, set a program cycle time of 15 ms.

Process data structure Here you specify the process data width that is processed by the safety relay. The following 
values are available:
• 32DI/32DO
• 64DI / 64DO (not possible for MSS 3RK3 Basic)
Note:
Note that a valid GSD or GSDML file must be installed in the engineering software of the PLC. 
You can find more information on this in the manual of the safety relay used.

Parameter assignment - AS-Interface1)   
AS-i interface Activate the AS-i interface in order to be able to use standard and safety-related AS-i slaves in 

your configuration. If AS-i slaves are already used in the logic diagram, the AS-i interface can 
no longer be deactivated.

Parameter assignment - AS-Interface - Simulated slaves1)   
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Parameter name Parameter value
Slave profile to address Here you can specify whether the MSS 3RK3 is to simulate AS-i slaves on the AS-i bus. The 

3RK3 central unit supports various profiles, which can be selected. The simulated slaves 
determined here are entered in the subsystem and can no longer be processed there. If you 
have allocated an address to a slave, the MSS 3RK3 will assign the corresponding selected 
profile to this address on the AS-Interface.   
Addresses at which a slave is already configured in the subsystem can no longer be assigned 
and are therefore displayed grayed out.

Documentation2)

Device connector For the plant documentation, you can supplement the expansions connected via 3ZY device 
connectors in the properties of the 3SK2 safety relays. All the expansions known and sup‐
ported at the time of publication of the Online Help are available to you in a selection menu. 
You can assign an equipment identifier for each expansion.
You can see the configured expansions in the print preview. The expansions are not shown in 
the hardware configuration.
Note:
You can edit the entries of the selection menu and change them at will.
Note:
You can save the configured expansions on the device, see chapter "Settings of Safety ES - 
"Download options" tab (Page 94)".

1) 3RK3 central units with AS-i interface: MSS 3RK3 Advanced, MSS 3RK3 ASIsafe basic and MSS 3RK3 ASIsafe extended
2) 3SK2 safety relays

6.3.6 Properties of expansion module

Description     
You can open the "Properties of expansion module" dialog box as follows:
• Double-click on a module in the configuration table.
• Choose the "Object properties" menu option from the context menu (right mouse button).
• In the menu "Options" > "Settings of Safety ES..." under the tab "General settings", activate 

the checkbox "Display object properties automatically on insert". The properties dialog box 
will then pop up automatically when you drag a module from the catalog window into the 
configuration table of the project window.

Parameters
The parameters are described in the following table:

Parameter name Parameter value
Configuration
Module The designation of the selected module is displayed here. The field has a gray background and 

cannot be changed by the user.
Article No. The article number of the selected module is shown here. The field has a gray background and 

cannot be changed by the user.
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Parameter name Parameter value
Firmware The firmware of the selected module is shown here. The field has a gray background and cannot 

be changed by the user.
Equipment identifier Here you can specify a user-defined equipment identifier (max. 32 characters) for the selected 

module and assign it to inputs and outputs.
Inputs The number of inputs of the selected module is shown here.
Outputs The number of outputs of the selected module is shown here.

6.3.7 AS-i subsystem

Configuration
You configure the AS-Interface hardware of the system configuration in the "Subsystem AS-i" 
configuration table.     

Determining the AS-i subslot configuration online
If a 3RK3 Advanced, 3RK3 ASIsafe basic or 3RK3 ASIsafe extended central unit with an AS-i 
connection is used in a system configuration, you can apply the actual configuration, i.e. the 
hardware configuration of the AS-i subslot configuration, by clicking on the "Determine online" 
button. 
The result will depend on the master and slaves used. Slave profile values that cannot be 
determined or calculated are shown as "?" and have to be adjusted manually.

Note
Determine online   
If the AS-i master is running and the safety relay is connected, only the ID codes of the slaves on 
the AS‑i bus can be determined.
If the safety relay is running and the AS‑i master is connected, all available information 
concerning the slave profiles can be determined.

The user is asked if the current configuration is to be replaced.

Determining an existing subslot configuration online
• If the ID code at an address determined online is identical tp the configured code, the 

parameter assignment entered will remain unchanged, even if the other values of the slave 
profile differ.

• If the ID code is different, the value determined online will be applied.
• If an entered AS-i slave cannot be determined online, the configured value will be retained.
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AS-i slaves   
The catalog window contains slaves that you can use in your configuring:
• Safety-related slaves:

Slaves that read the safety-related "On" or "Off" status of the connected sensor or the control 
device and transfer it to the master or safety monitor. The latter then switches outputs off if 
applicable (e.g. EMERGENCY STOP).

• AS‑i standard slaves
• AS-i A/B slaves

Simulated slaves       
No more than four non-safety-related AS-i slaves can be simulated, including one as a CTT2 
slave. This enables diagnostics using the CTT2 protocol. In so doing, the CTT2 protocol data are 
interconnected via the "Slot3_ASi#xx_Sx.y" and "Slot3_ASi#xx_Qy.z" terminals in the logic 
diagram. Up to 12 safety-related AS-i slaves can additionally be simulated. The number of safety-
related AS-i slaves depends on the central unit used:

 MSS 3RK3 
ASIsafe basic

MSS 3RK3
ASIsafe extended

MSS 3RK3 Advanced

Maximum number of simulated 
safety-related AS‑i slaves

8 10 12 

A simulated slave is provided by the 3RK3 central unit on the AS-i bus. With this function, signals 
from the logic diagram can be exchange with other stations on the AS-i bus.
You assign parameters to the simulated slaves in the "Basic unit properties ‑ System slot 3" dialog 
box. They will then be shown (in italics) in the "Subsystem AS-i" table. 

Rules for slot allocation
• The table for the AS-i subsystem contains 62 rows. According to AS-i Spec as from Version 

2.11, you can configure no more than the following:
– 31 standard slaves or safety-related input slaves
– 62 A/B slaves
– a mixture of the above

• Standard or safety-related slaves can only be inserted at A addresses. If an A address is 
allocated, the corresponding B address is no longer available.

• Simulated slaves are determined in the Properties dialog box of the corresponding 
3RK3 Advanced, 3RK3 ASIsafe basic or 3RK3 ASIsafe extended central unit and inserted at A/
B addresses (addressing of the simulated AS-i slaves). Simulated slaves are shown in italics 
and provided with the icon of the 3RK3 central unit. They cannot be edited.  

• Entries can be inserted, deleted, or cut out in any way, i.e. gaps between addresses are 
permitted.
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Module catalog for subsystem AS-i
This catalog contains all AS-i slaves marketed by Siemens AG that were known at the time of 
publication of this version of Safety ES. A universal slave must be used to incorporate more 
recent slaves from Siemens AG or to incorporate slaves from other manufacturers.

6.3.8 Properties of AS-i slaves

Description   
You can open the "Slave properties" dialog box as follows: 
• Double-click on a module in the configuration table.
• Choose the "Object properties" menu option from the context menu (right mouse button).
• In the "Options > Settings of Safety ES..." menu under the "General settings" tab, select the 

"Display object properties automatically on insert" checkbox. The properties dialog box will 
then pop up automatically when you drag a module from the selection window into the 
configuration table of the project window.

Parameters
The parameters are described in the following table:

Parameter name Parameter value
Configuration
Slave type The designation of the selected module is displayed here. The field has a gray background and 

cannot be changed by the user.
Article No. The article number of the selected module is shown here. The field has a gray background and 

cannot be changed by the user.
Equipment identifier Here you can specify a user-defined equipment identifier (max. 16 characters) for the selected 

module and assign it to inputs and outputs.
IO code If you use a universal slave, set the profile for this slave here.
ID code If you use a universal slave, set the profile for this slave here.
ID1 code If you use a universal slave, set the profile for this slave here.
ID2 code If you use a universal slave, set the profile for this slave here.
Monitor non-safety-related I/Os Select the checkbox for monitoring non-safety-related slaves or the non-safety-related infor‐

mation items of a safety-related AS-i slave. You can then interconnect the terminals in the 
logic diagram. The "Monitor non safe I/O" option can be set up to 14 times in one configura‐
tion.
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6.4 Logic diagram

6.4.1 Overview
You can switch to the logic diagram view by selecting a diagram in the navigation window. 
The logic diagram has the following features:   
• Graphical connection of the function elements used and representation as a function 

diagram:
– Representation of the switching elements as function elements with input connections 

and output connections
– Representation of physical and logic addresses in the form of address elements
– Representation of interconnections as connecting lines between function elements
– Display of relevant function element parameters

• Documentation management: 
– The pages are divided automatically.
– The individual pages are displayed on the screen as they are printed.

• Current states (e.g. digital outputs of function elements) of the safety relay can be monitored 
in the diagnostics mode.

• Working with the logic diagram:
– The user can switch between languages during operation.
– Optimization functions (e.g. arranging the function elements according to the signal 

flow).
– Placing and connecting the function elements by drag & drop.
– Function elements and connections can be moved as required.
– Comments can be placed in the screen and printout as required.
– Structuring of the logic by generating partial diagrams (e.g. one output circuit per 

diagram).
– The clarity of a diagram can be enhanced by interrupting connections and replacing them 

by freely movable reference points.
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Note
Procedures for configuring
The procedure for configuring in Safety ES has an effect on various functions. 
There are two ways of configuring in Safety ES:
1. You start with configuring the hardware configuration and then configure the logic. Once you 

have configured a safety relay, all non-supported function elements will no longer be 
available in the catalog window of the logic diagram.

2. You start with configuring the logic and then configure the hardware configuration. If you use 
function elements in the logic diagram that are not supported by every safety relay, these 
safety relays are then no longer available in the hardware catalog of the configuration.

6.4.2 Working with the logic diagram

6.4.2.1 Inserting, printing and deleting logic diagrams

Insert logic diagram
You can insert a new logic diagram in different ways:
• using the menu command "Edit" > "Insert diagram"
• Right-click on "Logic" or on an existing logic diagram. Select "Insert diagram" in the selection 

menu.

Print logic diagram
You can print individual logic diagrams. Right-click on the logic diagram you want to print. Select 
the relevant printer in the dialog window.

Delete logic diagram
You can delete a new logic diagram in different ways:
• using the menu command "Edit" > "Delete diagram"
• Right-click on the logic diagram you want to delete. Select "Delete diagram" in the selection 

menu.
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6.4.2.2 Selecting function elements and using them in the diagram

Inserting function elements  
Insert the function elements by selecting them in the catalog window and then drag and drop 
them into the work space.

Defining parameters
When you drag a function element into the work space, a dialog box pops up where you can 
define the function element parameters. For this you must activate the checkbox "Display object 
properties automatically on insert" in the menu "Options" > "Settings of Safety ES..." under the 
tab "General settings".
You can also open the dialog box subsequently by double-clicking the function element on the 
work space, or by choosing "Object properties" from the context menu (right mouse button).
You will find more information about the parameters in chapter "Function elements (Page 171)."

Finding function elements in the diagram
To display a function element already inserted in the diagram, double-click the entry of this 
function element in the catalog window. The first function element that is found in the diagram 
will be displayed. By double-clicking on this function element in the catalog window again, the 
next function element of this type is selected in the diagram.

6.4.2.3 Connecting function elements

Rules for drawing connections   
• Several connections can originate from an output of a function element.
• Only one connection can be connected to an input of a function element.

Drawing a connection between functions
To interconnect connections of function elements, perform the following steps:
• Move the mouse pointer over an unconnected input. It is then highlighted in blue.
• Press the left mouse button and keep it pressed.
• Keep the mouse button pressed and draw a connection to an output until it is highlighted in 

blue.
• Release the mouse button.

Result: A connection is established between the two terminals.

Note
You can also draw the connection from the output to the input.
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Connections between function elements in different diagrams
To connect function elements in different diagrams, proceed as follows:
• Select the connection point of the function element in the first diagram.
• In the context menu (right mouse button), select the command "Begin drawing connection".
• Switch to the second diagram.
• Select the connection point of the second function element.
• In the context menu (right mouse button), select the command "Finish drawing connection".

Crossover points of connections
• Crossover points of connections are not specifically marked. The route of the lines is usually 

apparent.
• If due to the high number of connections the route of the lines is not immediately apparent, 

then select the connection and its exact route will be highlighted.

Branches
• Branches are identified by a point.
• The system automatically sets the branch points. They cannot be selected and moved directly.
• You can move branch points indirectly by moving connections.

Figure 6-3 Branches

Rerouting of connections
If you want to reroute the end (or beginning) of an existing connection to a different terminal, 
then draw a new connection as follows:
• Select the relevant connection (line) by left-clicking.
• Select one of the two end points by left-clicking and holding the button pressed.
• Keep the mouse button pressed and drag the end point to another terminal.
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Alternatively, you can reroute several connections to a terminal simultaneously:
• Move the mouse pointer to the end point of a connection line until the blue rectangle is 

displayed.
• Left-click in the blue rectangle.
• Keep the mouse button pressed and reroute the connections to the respective terminal.

Moving a function element/connection
• Keep the left mouse button pressed to move function elements and connections.
• When function elements are moved, the start and end points of connections are fixed, since 

they are linked to the terminals of function elements.

6.4.2.4 Selecting

Select all   
Use the "Edit" > "Select all" menu command to select all function elements, connections, and 
comments.

Lasso function
Use the lasso function to select all objects within a specific area:
Keep the left mouse button pressed and drag open a rectangle.
All objects that are completely within the rectangle are automatically marked.

Multiple selection
• You can select more than one element at once by pressing the "<Ctrl>" key and selecting 

individual elements successively.

6.4.2.5 Delete
Use the menu command "Edit" > "Delete" to delete one or several selected objects and 
connections.  
You can also delete objects/connections via the context menu (right mouse button) and the 
"Delete" command or by pressing the "<Del>" key.
Call:

Button Command
"Edit" > "Delete"
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Note
Deleting an object
When you delete an object, you also delete all connections or interrupted connections that are 
linked to this function element.

6.4.2.6 Display of graphical conflicts
Graphical conflicts (part of a connection line/block is on top of another, connection lines that 
cross over blocks, blocks on top of page margins) are automatically highlighted in red.   
Use the "Edit" > "Realign graphic" menu command to arrange the objects in succession according 
to the signal flow.

Note
After the "Realign graphic" command, existing comments are positioned below the 
interconnections on the logic diagram.

Types of conflict
The following types of conflict are shown in the figure below:
• Part of a connection line is on top of another connection line
• Part of a block is on top of another block
• Connection lines cross over blocks
• Blocks on top of page margins

Figure 6-4 Graphical conflicts in the logic diagram

Operation (software)
6.4 Logic diagram

SIRIUS engineering Safety ES V1.0
122 Operating Manual, 12/2021, A5E32640754002A/RS-AF/006



Note
Please note the following:
• Graphical conflicts can also occur at reference points.
• During graphical configuration, it is continuously checked whether graphical conflicts occur.
• During the consistency check, graphical conflicts are listed as warning messages in the 

output window.
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6.4.2.7 Realign graphic
Use the "Edit" > "Realign graphic" menu command to arrange the function elements and 
connections according to the signal flow.   
Call:

Button Command
"Edit" > "Realign graphic"

Defining options
• In the menu "Options" > "Settings of Safety ES..." > "Logic", click on the button "Realign 

graphic".
The window "Options - Realign graphic" is opened.
– Select the "Avoid connections crossing functions" checkbox if you want to prevent 

connections from crossing function elements.
– If the checkbox is selected, you can choose whether connections will be interrupted or 

whether the affected function elements will be moved down until there is no longer a 
conflict with connections.

– You can also apply a "Standard column grid across all subnetworks of a function diagram" 
if you select the corresponding checkbox.

– You can position the output cells in a separate column on the far right (for each 
subnetwork) if you select the lowermost checkbox.

Realignment principles
• Only a graphical realignment of the objects is implemented. The configuration remains 

unchanged.
• Graphical conflicts are automatically eliminated.
• Automatic arrangement is also possible when the configuration is read from the safety relay 

(open online).
• After automatic arrangement, function elements and connections can be moved and 

adjusted.
• Use the menu command "Edit" > "Undo" to undo the new arrangement.

Note
After the "Realign graphic" command, existing comments are positioned below the 
interconnections on the logic diagram.
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6.4.2.8 Move diagram

Activating and deactivating the move mode  
With the "View" > "Move diagram" menu command, you can switch to move mode. In the move 
mode, you can move the diagram using the mouse if it is larger than the current window.
Call:

Button Command
"View" > "Move diagram"

Click the button again or choose "View" > "Move diagram" to deactivate move mode.

Note
Special features in the move mode  
• When the move mode is activated, you cannot select and move objects or draw connections.
• The mouse pointer is represented by a hand symbol when the move mode is activated.

Alternately, the diagram can also be moved with the cursor keys even while move mode is not 
active.
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6.4.2.9 Zooming
You can zoom in or zoom out in a diagram step by step using the menu command "View" > "Zoom 
in" or "View" > "Zoom out". The zoom factor is increased or decreased by a fixed value.     
Zooming in and out can also be executed as follows:
• Mouse click on the graphical work space > Keep the key "<Ctrl>" pressed > Use the mouse 

wheel.
• Mouse click on the graphical work space > Click on the "+" or "-" key on the keyboard.
Call:

Button Command
"View" > "Zoom in"

"View" > "Zoom out"

"View" > "Zoom dialog"

Zoom dialog   
With the menu command "View" > "Zoom dialog", you can open a zoom dialog where you can 
directly set a zoom factor:

Zoom center point
If no object is selected in the diagram, the center point of the screen is selected for zooming.
If one or several objects are selected in the diagram, the center point of the selected object/area 
is selected for zooming.
If the zoom function is carried out repeatedly this zoom center point is moved step by step to the 
center of the screen.

6.4.2.10 Overall view

Network overview  
Use the menu command "View" > "Overall view" to obtain an overview of the network.
Call:

Button Command
"View" > "Overall view"

6.4.2.11 Insert comment
Use the menu command "Edit" > "Insert comment" to insert comments in the diagram wherever 
required.  
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Call:

Button Command
"Edit" > "Insert comment"

Procedure
• Select "Insert comment" at the current mouse position in the context menu. The mouse 

pointer then becomes a symbol that represents a comment.
• Or click on the "Insert comment" button.
• Left-click on the required position in the diagram.
• A dialog box opens in which you can enter the comment.

Editing a comment element
You can edit a comment element:
• Edit the comment text:

– "Edit comment" context menu (double-click on the comment)
– A dialog field for entering the text pops up.

• Move by means of drag and drop
• Change the size. Line breaks are automatically inserted to adapt the text to the size.
• Delete

6.4.2.12 Interrupt connection

Clear representation of large diagrams   
With the "Edit" > "Interrupt connection" menu command, you can interrupt connections to 
achieve clearer representation of large diagrams with many function elements and connections.
Call:

Button Command
"Edit > "Interrupt connection"
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Procedure
• 1. Select the connection:

• 2. Click the button or choose "Interrupt connection" from the context menu (right mouse 
button).

• 3. The connection is interrupted. Reference points are generated that indicate to which 
function element each connection is routed.

Reference points   
A reference point indicates to which function element and terminal of the function element the 
connection is routed (with any relevant diagram name).
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You cam select, move, and delete a reference point:
• Selecting a reference point

– Single mouse click (on the tip of the arrow):
The reference point and the corresponding reference point are selected: 

– Double mouse click (on the tip of the arrow):
The corresponding reference point is selected (if necessary, the window is scrolled down 
so that the corresponding reference point becomes visible):

• Deleting a reference point
– Select the reference point.
– Delete the reference point and thus the entire connection between the respective 

function elements with the "Edit" > "Delete" menu command.
– You can also "Delete" using the context menu (right mouse button), "Delete" command or 

by selecting the reference point and pressing the "<Del>" key.

Note
When a reference point or an individual partial connection is deleted, the entire connection 
(including the second partial connection) is deleted.

6.4.2.13 Redraw partial connection

Restoring an interrupted connection  
Use the menu command "Edit" > "Redraw partial connection" to restore an interrupted 
connection.
Call:

Button Command
"Edit" > "Redraw partial connection" 
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Procedure
• Select the partial connection.

Alternatively, you can also select the reference point.
• Select the menu command "Edit" > "Redraw partial connection" or click on the button 

"Redraw partial connection". Alternately, you can connect the partial connection using the 
context menu (right mouse button).

6.4.2.14 Highlight signal flow

Highlight objects in color   
With the menu command "View" > "Highlight signal flow", you highlight the following objects in 
the logic diagram in color:
• All function elements and connections that indirectly send signals to an input of the selected 

block (signal flow on the input side).
• All function elements and connections to which the signals of all outputs of the selected 

function element are sent directly or indirectly (signal flow on the output side).
Call:

Button Command
"View" > "Highlight signal flow"

Highlighted elements

Figure 6-5 Highlight signal flow
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Delete highlighting   
The highlighting is independent of the selection of the objects and is retained until one of the 
following events occurs:
• Another element is graphically highlighted.
• The structure of the diagram is changed, for example, by deleting an element or inserting a 

connection.
• A reference point is selected (in the case of an interrupted connection).
• The menu command "View" > "Delete highlighting" is executed.

6.4.2.15 Delete highlighting
The menu command "View" > "Delete highlighting" cancels the graphical highlighting of the 
selected objects.  
Call:

Button Command
"View" > "Delete highlighting"

6.4.2.16 Display settings

Selection of the display category   
In the "View" > "Display settings" dialog box, you can set how function elements will be displayed.
You can also call up this dialog with the menu command "Options" > "Settings of Safety ES..." 
under the tab "Logic" by clicking on the "Display settings" button.
Call:

Button Command
"View" > "Display settings"

Selecting a display element
All changeable display elements are entered in the "Display element" list.
When you select an element, its current color is shown in the box "Current color" below it:

Operation (software)
6.4 Logic diagram

SIRIUS engineering Safety ES V1.0
Operating Manual, 12/2021, A5E32640754002A/RS-AF/006 131



Figure 6-6 Display settings

Change color
• Click on the "Change color" button.
• The standard Windows color dialog is opened.
• Select a predefined basic color.
• Define user-specific colors:

– Expand the window with the button "Define colors".
– In the expanded window, use the mouse to either select a color from the colors offered or 

define a corresponding color using the keyboard (tone, saturation, brightness, red, green, 
blue color components).

– Click the "Add colors" button and your self-defined color will be added to the range of user-
defined colors.

– The color settings are stored and are available for further sessions. They apply for all 
projects.

Reset settings
Use the button "Reset all" to restore the state after installation.

6.4.2.17 Grids and lines

Screen grid button     
With the "View" > "Grid settings" command or the "Change grid settings" button, you can 
manually optimize the graphical display in the "Screen grid" dialog box.
You can also call up this dialog with the menu command "Options" > "Settings of Safety ES..." 
under the tab "Logic" by clicking on the "Screen grid" button.
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Call:

Button Command
"View" > "Change grid settings" 

"Screen grid" dialog box
• Align objects

You can align objects with the grid and / or with other objects. To do so, select the 
corresponding checkboxes.

• Grid settings
The distance between the individual grid points can be set from 5 to 50 mm in steps of 5 mm. 
(Default: 30 mm)
You can choose whether every first, second, third, fourth, fifth, or sixth grid point is to be 
shown. (Default:Display 1st grid point)
Activate the option "Display grid on the screen" to display a screen grid.
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6.4.2.18 Errors and system callbacks
If you execute impermissible actions when working with the logic diagram, error messages are 
displayed.

Meaning of the error messages and system callbacks   
Error message Meaning
It is not permitted to connect inputs to 
each other.

You have tried to interconnect two inputs. This is not permitted.

Connection of two outputs not possible. You have tried to interconnect two outputs. This is not permitted. 
This connection is prohibited. You have tried to create a connection that is not possible.

Inputs and outputs cannot be interconnected at will.
Inputs can only be used once. You have tried to connect to an input that is already assigned. An input can only be 

the output point of one connection.
Feedbacks are not permissible. You have tried to establish a connection between outputs and inputs with the same 

function element. Note that this does not have to be a direct connection, the feed‐
back can be established across multiple function elements. Check the signal flow.

6.4.2.19 Macro functionality
You can use the macrofunction as follows:   
• To put together a library of function units that you use particularly.
• To combine blocks (= macros) from function elements and interposed connections, partial 

diagrams, or whole diagrams.
• To export and import macros out of your project or into other projects.
• To reuse the macros in other projects.

Properties of macrofunctionality
• All macros are stored in a file in a user-specific area on the hard disk.
• Each user sees his or her own macros. Macros can be made available to other users using the 

export function (e.g. through a central storage location on a server).
• The number of elements in a macro is not limited.
• A macro can only be created from the elements of a single diagram.
• Freely positioned comments can be included in a macro.
• Interrupted connections are stored as such in the macro and will be interrupted when the 

macro is used.
• When a macro is created, connections are only included if they have a defined start and end 

point.
• Macros can be deleted using the context menu (right mouse button).
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• Name and description of the macros can be modified subsequently using the context menu 
(right mouse button).

• The following actions cannot be undone:
– Importing and exporting macros
– Creation and deletion of macros
– Modifying the properties of a macro

Creation of a macro
To create a macro perform the following steps:
• In the diagram, select the function elements from which you want to assemble the macro, 

being sure to select the required connection lines, too.
• Choose "Create macro..." from the context menu using the right mouse button.
• The properties dialog box of the newly create macro will be shown. Enter the following 

details:
– Name: Name of the macro, with which the macro will be stored in the "Macros" folder in 

the catalog window.
– Description: You can enter a description of the macro here.

Using macros
If you want to use an existing macro in your diagram, please proceed as follows:
• Define the type of element number assignment in the "Options" > "Settings" menu:

– Assign a new element number: Starting at 1, the next free element number is assigned to 
the function element.

– Retain old element numbers if possible: If the element number is not yet used in the 
current diagram, the element number that the function element had when the macro 
was created (and that is stored in it) will be assigned to the function element again when 
it is reused.

• Drag the macro out of the "Macros" folder in the function catalog into the diagram. This 
breaks down the macro into individual connections and function elements. You can modify 
the individual components.
The following rules apply when inserting function elements:
– Interconnections to input/output terminals are reset (to avoid duplicate assignments).
– The elements of the macro are inserted at the current mouse position.
– All elements of the macro are selected after insertion (for example, to be able to move 

them afterward).
– The element parameters of each individual element are retained. (They are stored in the 

macro.)
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Storing macros
The macros you created and imported are stored in the "Macros" folder in the function catalog 
with the name you assigned to them.

Export macros   
• To export macros, choose the "Export macros..." menu command from the "Options" menu. 

The "Export macros" dialog box opens.
• Choose the macros from the "Existing macros" list (identical with the list of the macros in the 

function catalog) that you wish to export.
• Insert the selected macros into the "Macros to be exported" list using the "Add" button.
• Click the "Export" button.
• In the "Save macro file as" dialog box, enter the path and filename of the macro file to be 

created.

Import macros   
• To import macros, choose the "Import macros..." menu command from the "Options" menu. 

The "Import macros" dialog box opens.
• Choose the macros you want to import from the "Importable macros" list.
• Insert the selected macros into the "Macros to be imported" list using the "Add" button.
• Click the "Import" button.

6.5 Passwords

6.5.1 Passwords
The configuration and the access to the safety relay are subject to special password protection 
based on safety technology. You can assign three passwords:   
• Password for device access (optional)
• Password for project access (optional)
• Password for changing to test mode (mandatory)

Operation (software)
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WARNING
Unauthorized access to safety functions via fieldbus. 
Can Cause Death or Serious Injury.
To prevent unauthorized access to the safety relay via the fieldbus, e.g. PROFINET or PROFIBUS, 
assign a password for accessing the device in Safety ES.
If you operate several safety relays in one fieldbus network, you must assign a separate 
password for each safety relay to prevent mix-ups when accessing via the fieldbus. In other 
words, the passwords must not be identical.

Note
Secure password
A password must consist of a maximum of 8 characters. A secure password can only be used for 
a single application, is 8 characters long, and contains uppercase and lowercase letters, special 
characters and numerals. It should not contain any common numeric sequences from the 
computer keyboard or words from the dictionary. Change your password at regular intervals. 

Passwords - Overview
 Password for device access Password for project access Password for changing to test 

mode
Description • This password prevents unau‐

thorized access to the safety re‐
lay. The password is assigned 
when the protection level is set.

• You can control access to the 
safety relay by setting a protec‐
tion level. For the safety relay, 
the following protection levels 
can be set:
– Write protection
– Project write/read protection

• This password protects an off‐
line configuration from unau‐
thorized access.

• If you do not enter a password, 
the configuration is opened as 
"read only", i.e. you cannot 
change the configuration

• This password prevents an un‐
authorized change to "test 
mode".

• It is only possible to change to 
"test mode" if a valid password 
has been entered. If no pass‐
word has yet been assigned for 
test mode, you have to assign 
one when changing to test 
mode.

• The default password is 
"0000".

Assigning / 
Changing

In Safety ES, via the "Edit" > "Pass‐
word for device access" menu com‐
mand.
Requirement: You are now in config‐
uring mode and are online.

In Safety ES, via the "Edit" > "Pass‐
word for project access" menu 
command.
Requirement: You are offline.

In Safety ES, via the "Edit" > "Pass‐
word for test mode" menu com‐
mand.
Requirement: You are now in con‐
figuring mode and are online.
Note:
This password must not be identi‐
cal to the password for device ac‐
cess. In this case, switchover to 
test mode is denied. 
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 Password for device access Password for project access Password for changing to test 
mode

Prompt • Independently of the set protec‐
tion level:
– When changing the device 

access password.
• "Write protection" protection lev‐

el:
– For write access to a safety 

relay (e.g. when loading), if 
no access rights exist.

• Protection level "Project write 
protection/read protection":
– Just as for the "Write protec‐

tion" protection level
– When opening an online con‐

figuration

• When opening an offline con‐
figuration

• When changing the project ac‐
cess password.

• When switching to test mode 
via the "Target system" > "Test 
mode" menu command.

Validity As long as an access authorization 
for the safety relay exists.

As long as the offline configuration 
is open.

The password must be re-entered 
for each change to test mode.

Note
If you change the passwords, this has no effect on the release status of a configuration.

Deactivate password protection (only password for project access and password for device access)
You can deactivate the password protection again by entering a tick in the box "Deactivate 
password" in the dialog window. To do this, you must first enter the old password.

Forgot password
• The password for project access can be reset.
• Both the password for device access and the password for switching to test mode can only be 

reset by restoring the factory settings.

Dialog box "Edit" > "Password for project access"
• This password prompt appears in the "Enter password" dialog box when you open an offline 

configuration.
• If you have still not assigned a password for project access, enter a new password at the 

prompt "New password" and enter it again to "Confirm password".
• Change the project access password by entering the old password and then entering the new 

password twice
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• Deactivate the password protection for the project by first entering the old password and then 
entering a blank password twice.

• Use the "Forgot password" button to create a file with the encrypted password if you lose the 
project access password. Send this file with the activation information to the Siemens 
hotline. The Siemens hotline will send you a file with an activation code. You can find more 
information in Chapter "Forgot password (Page 65)".

Dialog box "Edit" > "Password for device access"
• This password is requested in the case of password-protected write device access (e.g. 

loading new configuration) or when going online (only in the case of protection level "Project 
write/read protection").

• You can assign/change/reset the password for device access.
• You can set the protection level with this menu command.

Note
If you have forgotten the password for device access, you must restore the factory settings of the 
safety relay. You must do this on the safety relay because commands in Safety ES are password-
protected.

Dialog box "Edit" > "Password for test mode"
• This password is requested every time you switch to test mode via the "Target system" > "Test 

mode" menu command.
• You can assign/change the password for changing to test mode.

Note
If you have forgotten the password for changing to test mode, you must restore the factory 
settings of the safety relay. You can do this on the safety relay or by means of a command in 
Safety ES.

Prompt for passwords
• Enter password

– The "Enter password" dialog appears if you open a password-protected configuration, for 
example.

– Enter the password and confirm with "OK".
• Password forgotten:

– If you have forgotten the project access password, you can open the configuration write-
protected. To do this, click on the "Cancel" button. An online configuration can only be 
opened if the protection level has been set to "Write protection".
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6.5.2 Enter password

Enter password
The "Enter password" dialog appears when you open a password-protected configuration.
Enter the password and confirm with "OK".

Password lost
If you have lost the password, you can open the configuration write-protected by clicking on the 
"Cancel" button.

Forgot password
Using the "Create project access password" menu command, you can reactivate access to the 
configuration via the "Forgot password" button.
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Configuring 7
7.1 General information

Safety information

Note
Since commissioning is an important, safety-related step, it must be carried out by qualified 
personnel.

WARNING
Loss of the safety function.
Can Cause Death, Serious Injury, or Property Damage.
To ensure the safety of the system, a full function test of the system must be conducted and 
successfully completed.
A complete function test consists of the following tests:
• Configuration test (test of the configuration)
• System test (wiring test of the connected sensors and actuators)

7.2 Modes
The safety relay always differentiates between three operating modes: 
• Configuring mode
• Test mode
• Safety mode

Configuring mode (DEVICE LED: yellow)   
The monitoring functions are not active in configuring mode. No signals are output at the 
terminals. In configuring mode, you can modify existing parameters. This is done by creating a 
configuration in the PC / PG with Safety ES and downloading it to the safety relay. It is also 
possible to upload and edit a configuration available in the safety relay.

The safety relay enters configuring mode after switch-on if LED display
DEVICE SF

There is no configuration in the device. yellow off
The configuration in the device has not been released. yellow off
The configuration in the device is incorrect. yellow red
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The safety relay enters configuring mode after switch-on if LED display
DEVICE SF

A configuration error was identified in test mode. yellow red
The connection is interrupted in test mode. yellow red
A Category 1 error occurs in safety or test mode.
Only diagnosis and reset possible.

Flashing 
red

red

Test mode (DEVICE LED: flickering green)   
Test mode can only be accessed online from configuring mode using a password-protected 
command. You can switch to test mode even if the configuration has not been released.
The user program is processed in test mode. All monitoring functions are active in accordance 
with the set parameterization. Logical outputs of function elements can be set, see Chapter 
"Forcing (Page 158)". This makes it easier to carry out troubleshooting in the application and 
check the wiring.

WARNING
Automatic system starting in the test mode
Can Cause Death, Serious Injury, or Property Damage.
In the test mode, the safety program is executed and the outputs are controlled according to 
the safety program. 
Take appropriate organizational measures, such as deactivating the main circuit or cordoning 
off parts of the system, to ensure safety for persons and the system.

Safety mode (DEVICE LED: green)   
In safety mode, all monitoring functions are active in accordance with the set parameterization. 
Safety mode can only be exited by means of a command.

The safety relay changes to safety mode Display
DEVICE SF

Once the system has been switched on and if the configuration has been 
released and the test results of the device startup are OK.

green off

From configuring mode by means of the relevant command. green off
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7.3 Creating a configuration in Safety ES

Requirement
Before you start configuring in Safety ES, you require the following information:   
• Structure/wiring of the system
• Required safety functions
• Configuration/wiring of the hardware

Procedures for configuring in Safety ES
The procedure for configuring in Safety ES has an effect on various functions.
There are basically two ways of configuring:
1. You start with configuring the expanded hardware configuration and then configure the 

logic. If you have configured a device that does not support all function elements, these 
elements are then no longer available in the catalog window of the logic diagram.

2. You start with configuring the logic and then configure the expanded hardware 
configuration. If you use function elements in the logic diagram that are not supported by all 
devices, these devices are then no longer available in the hardware catalog of the 
configuration.

Configuration
Main system   
In Safety ES, the various devices from the hardware catalog are assigned to their relevant slot. 
Drag each device into the central work space and onto the slot that they really occupy in the 
expanded configuration.
The minimum configuration consists of a safety relay in slot 3. 
An interface module for connection to a higher-level bus system can be optionally configured in 
slot 2.
An HMI module can be configured in slot 1.

Note
3SK1 output expansions and 3RM1 Failsafe motor starters
You can configure 3SK1 output expansions and 3RM1 Failsafe motor starters for the 
documentation in the properties of the 3SK2 safety relays.

Sub-system   
In the subsystem, the real AS-i slaves and AS‑i components are configured at their respective AS‑i 
addresses. The hardware catalog contains all supported AS‑i components from SIEMENS. Just 
like in the main system, they can be dragged into the work space and have their AS‑i address 
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assigned. Using the universal modules, the profiles of standard and A/B slaves can be defined 
independently of manufacturer.

Note
Configuration of simulated slaves   
Simulated slaves are allocated their AS-i addresses and the profile is selected in the properties of 
the safety relay. The simulated slaves are displayed in italics in the subsystem.

You can find more information in Chapter "Configuration (Page 106)".

Logic   
The safety logic is created in the logic diagram. The inputs and outputs of the devices of the main 
system and of the AS-i slaves of the subsystem, as well as signals via the fieldbus (PROFINET or 
PROFIBUS) are linked with function elements. Drag the required function elements onto the 
work space. Parameterize the individual elements in the relevant element properties that you 
can open by double-clicking the element. Here, you can set the various parameters and connect 
the inputs and outputs of the function elements with the inputs and outputs of the devices. 
You will find additional information in Chapters "Logic diagram (Page 117)" and "Function 
elements (Page 171)."

7.4 Interconnecting the signals (terminals)

Signals
There are various types of signals you can interconnect in Safety ES:
• Signals from the inputs and outputs of the terminals
• Signals via the fieldbus (PROFINET or PROFIBUS, MSS Basic only PROFIBUS)
• Signals via AS-Interface (MSS 3RK3 with AS-i interface)
• Flags from the program (3SK2 safety relay)
• Signals from the inputs and outputs of the device connector interface (3SK2 safety relay)

Interconnecting inputs and outputs of the terminals
You interconnect the input and output terminals of the devices with the function elements in the 
logic diagram. To do so, open the properties dialog box by double-clicking on the relevant 
function element in the logic diagram. 
Clicking the  button opens a selection menu in which all interconnectable signals (terminals) 
of the devices are displayed and can be selected:
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Interconnecting PROFIBUS signals
A precondition for the interconnecting of PROFIBUS signals is the configuration of an interface 
module. 
You interconnect the PROFIBUS signals with the input and output cells in the logic diagram. To 
do so, open the properties dialog box by double-clicking on the relevant function element in the 
logic diagram.
Clicking the  button opens a selection menu in which all interconnectable PROFIBUS inputs 
and outputs are displayed and can be selected:

Interconnecting of PROFINET signals
A precondition for the interconnecting of PROFINET signals is the configuration of a PROFINET 
interface module. You interconnect the PROFINET signals with the input and output cells in the 
logic diagram. To do so, open the properties dialog box by double-clicking on the relevant 
function element in the logic diagram. Clicking the  button opens a selection menu in which 
all interconnectable PROFINET inputs and outputs are displayed and can be selected:
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Interconnecting AS-Interface signals (MSS 3RK3 with AS-i interface)
You interconnect the AS-Interface signals with the input and output cells in the logic diagram. 
To do so, open the properties dialog box by double-clicking on the relevant function element in 
the logic diagram.
Clicking the  button opens a selection menu in which all interconnectable AS-Interface signals 
are displayed and can be selected:

Interconnecting flags (3SK2 safety relay)

WARNING
Increasing of fault reaction time when using flags
Can Cause Death, Serious Injury, or Property Damage.
Flags are written at the end of a program cycle and can be read in again at the input by functions 
in the next program cycle.
Each flag that is contained in a signal path increases the fault response time. 
Please note this when calculating the overall response time. You can find out how to calculate 
the response times in the manual of the safety relay, see Chapter "Additional documentation 
(Page 12)".

You interconnect the flags with the input and output cells, as well as the output functions, in the 
logic diagram. To do so, open the properties dialog box by double-clicking on the relevant 
function element in the logic diagram.
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Clicking the  button opens a selection menu in which all interconnectable flags of the device 
are displayed and can be selected:

Interconnecting the inputs and outputs of the device connectors (3SK2 safety relay)
You interconnect the inputs and outputs of the device connector interface with the function 
elements in the logic diagram. To do so, open the properties dialog box by double-clicking on the 
relevant function element in the logic diagram. The inputs and outputs of the device connectors 
are indicated with "-C" in the list.
Clicking the  button opens a selection menu in which all interconnectable terminals and 
signals of the device are displayed and can be selected: 

7.5 Connection rules
Because of the hardware properties or safety regulations, there are connection rules that must 
be checked or monitored when function elements are edited.           

General
• Signals must not be connected recursively, i.e. "backward."
• Non-fail-safe input signals (= standard inputs) can only be added to a safety circuit if they are 

ANDed with a safe signal.
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• Input terminals (fail-safe/non-fail-safe) can only be used once as an input (input cell or 
monitoring functions).  

• Output terminals (fail-safe/non-fail-safe) can only be used once as an output (output cell / 
switching output), However, each output terminal can also be used once as an input terminal 
with an input cell.  
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Monitoring functions
• Only fail-safe signals must be connected to a signal input (INx) of a monitoring function.  
• "Mixed connection" of signals is not possible, i.e. for multi-channel function elements 

capable of cross-circuit detection, only channels of the same devices can be connected. 
(Exception: mode selector switch).
Note
For cross-circuit detection, channels of individual devices are combined into "channel 
groups"; the number of channel groups depends on the device.
Channel group 1: IN1 / IN2
Channel group 2: IN3 / IN4
Channel group 3: IN5 / IN6
...
Channel group 10: IN19 / IN20

• The following rules apply for interconnecting channels to multi-channel monitoring 
functions with the exception of the mode selector switch:  
– If an input in a channel group is used with one channel, the assigned second input must 

no longer be used with two channels. It can still be used with one channel.
– If an input of a channel group is used with two channels, the second associated input is 

automatically configured to the still unused input of the element (e.g. emergency stop: 
IN1 is configured to SLOT3_F-IN1, IN2 is automatically assigned to SLOT3_F-IN2).
Note
An acknowledgment button must be connected to one test output. 
Cross-circuit monitoring is always implemented in the case of a single-channel enabling 
button. This is why a single-channel acknowledgment button must also be connected via 
a test output. 
Non-floating wiring is not possible.   

Note
If a safety shutdown mat (cross-circuit principle) is connected to a slot (safety relay or 
expansion module), cross-circuit detection must be deactivated for the remaining inputs 
on this slot because otherwise the monitoring functions configured for these inputs will 
also signal a cross-circuit when somebody steps on the safety shutdown mat.   
Exception:
On the 3SK2 safety relay (45 mm), there are two independent test cycle pairs. You can use 
one test cycle pair for the safety shutdown mat (cross-circuit principle), and the other test 
cycle pair independently of this with monitoring functions for cross-circuit detection. 
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Cell functions can be placed by the user
• Fail-safe and non-fail-safe input signals as well as fail-safe and non-fail-safe output signals 

can be connected once to an input cell function.
• Only fail-safe and non-fail-safe output signals or bit memories can be connected to an output 

cell function.

Interconnecting bit memories
With the help of bit memories, you can save output signals intermediately, and read them in 
again and further process them at the input of one or more functions.
A bit memory cell function can be read and written via fail-safe and non-fail-safe signals. 

Note
A bit memory cell function cannot serve as a signal input for a monitoring function.
A bit memory function can always be considered fail-safe irrespective of its use.

WARNING
Increasing of fault reaction time when using flags
Can Cause Death, Serious Injury, or Property Damage.
Flags are written at the end of a program cycle and can be read in again at the input by functions 
in the next program cycle.
Each flag that is contained in a signal path increases the fault response time. 
Please note this when calculating the overall response time. You can find out how to calculate 
the response times in the manual of the safety relay, see Chapter "Additional documentation 
(Page 12)".

Interconnecting of PROFINET / PROFIBUS signals
• Non-safety-related signals can be connected optionally via PROFINET / PROFIBUS using an 

interface module. 
• Take account of the response times of the devices plus the communication runtimes in your 

calculation. Updating of the process image between the safety relay and the interface 
module interface takes place dependent on the configured program cycle time (min. 10 ms).
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Interconnection of AS-i slaves
• Safety-related AS‑i input slaves

When safety-related AS-i input slaves are used, only the "two-channel" and "2xsingle-
channel" input type parameters are permissible for monitoring functions. It is not permitted 
to use a safety-related AS-i input slave with one channel. 
AS-i terminals may only be used together with the "NC/NC" input type parameter for the 
following monitoring functions: "Monitoring Universal", "EMERGENCY STOP", "Protective 
door", "Protective door with tumbler", and "Safety shutdown mat (NC principle)". 
For enabling-type input functions (two-hand operation and enabling button), AS-i terminals 
may only be used together with the "NO/NO" input type parameter.
The "NC/NO" input type parameter must not be used.
– Two-hand operation

When safety-related AS-i input slaves are used with two-hand operation, only the 
"2x2xsingle-channel (NO/NO/NO/NO)" and "four-channel (NO/NO/NO/NO)" input type 
parameters are permissible. 
The "four-channel (NO/NC/NO/NC)" input type parameter is not permitted for AS-i since 
the transferred value 0 is not safe.

• The two safety-related input signals of a monitoring function (F‑IN1 and F‑IN2) must 
originate from the same safety-related AS-i input slave.

• Discrepancy monitoring and sequence monitoring
If the input signal is present at an AS-i slave and the "2xsingle-channel" input type parameter 
is assigned, the discrepancy and sequence monitoring parameters are automatically 
deactivated.
This applies to the following function elements:
– Monitoring Universal
– EMERGENCY STOP
– Safety shutdown mat with NC principle
– Protective door
– Protective door with tumbler
– Enabling button
– Two-hand operation

• Safety shutdown mat with cross-circuit principle
There must not be any AS-i terminals connected to the "Safety shutdown mat with cross-
circuit principle" function element.

• Setting/resetting of safety-related AS‑i outputs using "AS-i 1..4F-DO"
Only the terminals of one safety-related AS-i output may be connected to the outputs of the 
"AS‑i 1..4F‑DO" output function. 
Connection of other terminals and the distribution among several safety-related AS-i outputs 
are not permitted.
An output cell sets/resets only the first channel Q1 of a safety-related AS-i output. Outputs 
Q2 ... Q4 and AUX1 and AUX2 are set/reset only using the "AS-i 1..4F-DO" output function.

• Representation of safety-related AS-i outputs
The received Q1 ... Q4, AUX1, and AUX2 signals of another MSS 3RK3 Advanced, MSS 3RK3 
ASIsafe basic or MSS 3RK3 ASIsafe extended may only be wired to input cells.
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• Monitoring of safety-related input slaves
The IN1 and IN2 receive signals may only be interconnected to input elements. 
Interconnecting to input cells is not permitted. Only the safety-related F-IN1&2 receive signal 
may be interconnected to an input cell.
The monitoring function "AS-i 2F-DI" is used instead of an input cell if you want to diagnose 
both of the input terminal signals of the ASIsafe input slave.

• Representation of safety-related input slaves
The send signals for a safety-related AS-i input slave may be interconnected only via an 
output cell.

Interconnecting expansions via device connectors on the 3SK2 safety relay
• "3SK1 output expansions" and "3RM1 motor starter" actuators can be connected to the 

3SK2 safety relay with little wiring using 3ZY12 device connectors via the device connector 
interface. 

• This interface provides two further safety-related outputs for control of the actuators and one 
feedback circuit for monitoring the two outputs. The signals of the interface can be wired in 
the logic diagram.

• The 3SK1 output expansion is assigned to a logical output of the 3SK2 safety relay by means 
of the slide switch on the front of the 3SK1 output expansion.

Slide switch Labeling The 3SK1 output expansion switches with out‐
put ...

3SK2 (22.5 mm de‐
vice)

3SK2 (45 mm device)

 Top "DELAYED" switch position F-Q4-C F-Q6-C
Bottom "UNDELAYED" switch posi‐

tion
 F-Q3-C F-Q5-C

WARNING
Loss of the safety function in the event of adjustment of the slide switch on 3SK1 
output expansions
Can Cause Death, Serious Injury, or Property Damage.
Parameterization of the logic of the 3SK2 safety relay in Safety ES must correspond to the 
slide switch setting on the 3SK1 output expansion in order for the safety function not to be 
rendered inactive.
• Make sure that the setting of the slide switch on the 3SK1 output expansion corresponds 

to your logic parameterized in Safety ES. 
• Use a cover seal to protect the slide switch of the 3SK1 output expansion against 

unauthorized and unintentional adjustment. 

• When used with 3ZY12 device connectors, the 3RM1 Failsafe motor starters are permanently 
assigned to one of the two safety-related outputs. It is not possible to change over to the 
other output:

22.5 mm device 45 mm device
 F-Q3-C F-Q5-C
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7.6 Commissioning

Safety information

Note
Since commissioning of the safety relay is an important, safety-related step, it must be carried 
out by qualified personnel.

WARNING
Loss of the safety function.
Can Cause Death, Serious Injury, or Property Damage.
To ensure the safety of the system, a full function test of the system must be conducted and 
successfully completed.
A complete function test consists of the following tests:
• Configuration test (test of the configuration)
• System test (wiring test of the connected sensors and actuators)

Methods of accessing the safety relay  
The following graphic shows the various ways of accessing the safety relay.

1

2

3

4

① PG/PC
② Diagnostics display
③ Safety relay
④ Interface module

Figure 7-1 Methods of accessing the safety relay
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Requirements
The following requirements must be met for commissioning:   
• The device is mounted.

Check all the latches to ensure that they are properly engaged.
• The device is correctly wired.
• The Safety ES software is installed on your PC/PG with the correct license.
• The configuration is available in a consistent form and saved.
• The utilization of the memory module, of the internal memory, and the program cycle time 

were monitored.  
You will find additional information in the following chapters:
– "Status bar (Page 39)"
– "Settings of Safety ES - "Download options" tab (Page 94)"

Note
Number of function elements
The number of function elements that can be processed by one safety relay depends on the 
type of function elements. A typical value is 250.

• The power supply unit for the safety relay is connected.
• PG/PC and safety relay are connected.

WARNING
Unauthorized access to safety functions via the fieldbus
Can Cause Death or Serious Injury.
To prevent unauthorized access to the safety relay via the fieldbus, e.g. PROFINET or 
PROFIBUS, assign a password for accessing the device in Safety ES.
If you operate several safety relays in one fieldbus network, you must assign a separate 
password for each safety relay to prevent mix-ups when accessing via the fieldbus. In other 
words, the passwords must not be identical.

• The consistency check must not output any messages.
– Warnings must be checked.
– Faults must be corrected.

Load to switching device...   

Note
If there is already a released configuration on the safety relay, cancel this configuration release 
with the "Target system" > "Cancel configuration release" menu command.
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START

Safety mode /

test mode?

Test modeSafety mode

Check consistency

Ctrl + Alt  + K

Load to switching device

Consistent configuration

Online

Go offline

Preparing the

configuration test

Online

Go offline

Enable the

configuration

Test mode

Test mode

Go online

Safety mode

Safety mode

Figure 7-2 Procedure for commissioning the safety relay with factory settings

Perform the following steps to load a configuration into the safety relay:
Step Action Result

1 Switch on the power supply. The safety relay executes a self-test.
2 Open the project in Safety ES. ‑
3 Choose the "Target system" > "Load to switching de‐

vice" menu command and confirm the memory dia‐
log box with "Yes" if you have changed the configu‐
ration.

The "Load to switching device" dialog box opens.

4 Set the interface and confirm with "OK". The configuration data is now downloaded. A message is dis‐
played on completion of the download.

5 Confirm with "OK". You are now online in configuring mode.
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7.7 Testing the configuration
Before you can switch the safety relay to safety mode, you must conduct a full function test and 
then release the configuration.

WARNING
Loss of the safety function.
Can Cause Death, Serious Injury, or Property Damage.
A configuration can only be released if a complete function test of the configuration has been 
successfully completed
A complete function test consists of the following tests:
• Check of the hardware configuration: 
• Check of the parameterization of safety functions

Project printouts for the test       
Use the printouts of the project to support the test.

Step Action Result
1 Open the parameter file containing the configuration that 

you have downloaded to the safety relay.
The configuration is displayed. You are offline.

2 Activate "Target system" > "Prepare configuration test". The "Prepare configuration test" dialog box opens.
3 Set the interface via which you have access to the device (e.g. 

COM1) and confirm with "OK".
The project printouts are generated as PDFs. The 
project switches to online mode.

• The printout contains all the configuration data stored in the safety relay.
• The configuration CRC is given on each page of the printout in the tabular footer. The printout 

is thus always uniquely assigned to one configuration and can later be used for the plant 
documentation. 

• If deviations or errors occur in these checks, test the configuration and wiring and start 
commissioning again.

WARNING
Loss of the safety function.
Can Cause Death, Serious Injury, or Property Damage.
Test the configuration on the safety relay.
It is not enough just to check the printout; the configuration must also be tested on the safety 
relay in the system.

Configuring
7.7 Testing the configuration

SIRIUS engineering Safety ES V1.0
156 Operating Manual, 12/2021, A5E32640754002A/RS-AF/006



Switching to test mode   
The safety relay can be switched to "Test mode" for the purpose of carrying out the full function 
test. Outputs of function elements can be forced in this operating mode.

WARNING
Automatic system starting in the test mode
Can Cause Death, Serious Injury, or Property Damage.
In the test mode, the safety program is executed and the outputs are controlled according to 
the safety program. 
Take appropriate organizational measures, such as deactivating the main circuit or cordoning 
off parts of the system, to ensure safety for persons and the system.

Note
A consistent configuration is the requirement for switching to test mode.

Note
If you have not yet assigned a password, you must assign one now. The password for test mode 
must not be identical to the password for device access.
The default password is: 0000   

Execute the following steps to switch to test mode:
Step Action Result

1 Go online with the menu command "Switching de‐
vice" > "Open online".

 

2 Choose "Target system" > "Test mode" and confirm 
the message "Activate test mode" with "Yes".

The "Change password for test mode" dialog box opens.

3 Enter the password for test mode or assign a pass‐
word.

The safety relay changes from configuring mode to test mode.
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7.8 Forcing
Forcing means that an output of a function element can be preset to a certain value ("0" or "1"), 
for example, to make it easier to perform troubleshooting.

Requirements
The following requirements must be met to activate the icons in the toolbar:
• The online view is activated.
• Test mode is activated on the safety relay.
• The logic diagram with the safety circuit is active.
• At least one connection of a function element is selected.

Forcing   

WARNING
Automatic system starting in the test mode
Can Cause Death, Serious Injury, or Property Damage.
In the test mode, the safety program is executed and the outputs are controlled according to 
the safety program. 
Take appropriate organizational measures, such as deactivating the main circuit or cordoning 
off parts of the system, to ensure safety for persons and the system.

With the "Target system" >Diagnostics logic" > "Force" > "Force to 0" and "Target system" > 
"Diagnostics logic" > "Force" > "Force to 1" menu commands or the corresponding icons in the 
toolbar, you can set the values "0"  or "1"  for selected outputs of function elements. 
If a connection is forced, an icon above the connection shows the value "0" (blue symbol) or "1" 
(green symbol) in the logic diagram.

Cancel forcing
You can cancel forcing for an individual forced output as follows:
• Using the "Target system" > "Diagnostics logic" > "Force" > "Cancel forcing" menu command.
• By clicking on the icon  in the toolbar.

Cancel forcing (all)
You can cancel forcing for all forced outputs as follows:
• Using the "Target system" > "Diagnostics logic" > "Force" > "Cancel forcing (all)" menu 

command.
• By clicking on the icon  in the toolbar.
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Interruption of the online connection 
If the online connection is interrupted in test mode, e.g. by removing the PC cable, it can take up 
to 10 s before forcing of an output to "1" is canceled.

7.9 Configuration release

Follow these instructions:     

WARNING
Loss of the safety function.
Can Cause Death, Serious Injury, or Property Damage.
Before the safety equipment is released for safety mode, you must ensure that all function 
elements are working correctly in accordance with the safety regulations. This encompasses 
the I/O connected to the safety relay (sensors and actuators) as well as the entire configuration 
of the safety relay.
When the configuration is released, you can (as an "authorized person") confirm that the 
system is correctly installed and that all the safety-relevant regulations and standards for the 
application are observed.

Note
The release procedure described below refers only to the configuration of the safety relay and 
not to the system test. The system test must be documented separately and is not an integral 
part of this documentation.

Once the function test has been successfully carried out, you can release the configuration.
To do so, proceed as follows:

Step Action Response
1 Select the menu command "Target system" > "Go off‐

line".1)
The offline configuration is opened.

2 Choose "Target system" > "Approve configuration". The "Approve configuration" dialog box is opened, thereby 
confirming that the system has been configured properly.

3 Set the interface via which you have access to the 
device (e.g., COM1) and confirm with "OK".

The "Approve configuration" dialog box opens.

4 Acknowledge the message text. The "Approve configuration" dialog box opens.
5 Enter the name and approving company and confirm 

with "OK".
The "Approve configuration" dialog box opens. The configu‐
ration has been successfully approved.

6 Acknowledge the message with "OK". The printout of the release information is created.
1) From SP2, configuration approval is also possible online. The step "Go offline" is automatically carried out by the software.
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Note
If the report could not be printed when the project was released, e.g., because no printer was 
available, the printout must be created at the latest by the time of acceptance by selecting 
"Options" > "Release information."     

Printout of the release information   
The printout of the release information contains the following information.   
• Name of the person releasing
• Name of the company of the person releasing
• Release status
• Release timestamp
• Configuration CRC

This must match the configuration CRC in the footer on the printout of the configuration. The 
release printout is thus always uniquely assigned to one configuration and can later be used 
for the plant documentation. 

Result of the release
Once the safety relay has been released, the device is in configuring mode and can be switched 
to safety mode.

7.10 Safety mode

Requirements
If the safety relay contains a valid, released configuration, you can switch the safety relay from 
configuring mode to safety mode.   

Note
Before switching the system to safety mode, ensure that the printout containing the release 
information is available.   

WARNING
Automatic system startup
Can Cause Death, Serious Injury, or Property Damage
When the system is switched on it switches to safety mode and the safety program is executed 
as soon as a valid, released configuration is available.
Take appropriate measures (e.g. start button) to guarantee a defined start of the system.
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Switching to safety mode
Step Action Response

1 Establish an online connection with the safety relay using 
the "Switching device" > "Open online" menu command.

The Set interface dialog box appears.

2 Set the interface and confirm with "OK". The project opens online.
3 Activate the menu command "Target system" > "Safety 

mode".
If a password has been assigned for device access, the 
"Enter password" dialog box appears. If a password for 
accessing the device has not yet been assigned, a mes‐
sage is displayed indicating that the switching device 
is not protected against unauthorized access.

4 Enter the password for device access and confirm this with 
"OK," or acknowledge the message with "Yes" if you have not 
assigned a password for device access.

The safety relay changes to safety mode.

"Safety mode"
• When the system is switched on, it switches automatically to safety mode if a valid, released 

configuration already exists in the safety relay.
• After starting safety mode, the status bar in Safety ES informs you of the change to the new 

operating mode. The operating mode is only displayed when a project is open online.
• In safety mode, the created safety circuit is processed. Safety mode does not allow you to 

force function outputs.  

7.11 Tips and Tricks

7.11.1 Comparison function

Menu option Basic license Standard license Premium license
Edit Compare with 

switching device
‑ ✓ ✓

Edit Compare with file ‑ ✓ ✓

Safety ES provides a function for comparing two configurations. The configuration that is 
currently open in Safety ES (source configuration) is compared to a configuration to be defined 
by you. This can either be online in the safety relay or offline in an *.sdp file.  
You can call up the comparison function with the following menu commands:
• "Edit" > "Compare with switching device"
• "Edit" > "Compare with file"
The "Comparison of configurations" dialog box displays the results.
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Compare with switching device  
Requirement: The configuration to be compared must be available in the switching device.
Carry out the comparison as follows:
1. Open the source configuration.
2. Select the "Edit" > "Compare with switching device" menu command. The "Compare with 

switching device" dialog box appears.
3. Select the safety relay that you would like to compare with the open configuration.
4. Click on the "OK" button.
Result: The source configuration is compared with the configuration in the safety relay. 

Compare with file 
Carry out the comparison as follows:
1. Open the source configuration.
2. Select the "Edit" > "Compare with file" menu command. The "Compare with file" dialog box 

appears.
3. Select the file that you would like to compare with the open configuration.
4. Click on the "Open" button.
Result: The source configuration is compared with the configuration in the *.sdp file. 

"Comparison of configurations" dialog box  
The "Comparison of configurations" dialog box contains any deviating results from the 
comparison in tabular form:
• "Parameter name" column: Contains the names of the parameters with deviations, these are 

displayed in a tree structure:
Configuration > Data structure > Element > Individual parameter

• "Source configuration" column: Contains the parameter value belonging to the parameter 
name in the open configuration.

• "Comparison configuration" column: Contains the parameter value belonging to the 
parameter name in the comparison configuration.

"Go to" button  
If you click on the "Go to" button in the "Comparison of configurations" dialog box, the respective 
view opens in the work space in which the object belonging to the selected parameter can be 
edited.
The prerequisite is that an element be selected in the tree structure in the table of differences.
Example: A function element is selected in the "Comparison of configurations" dialog box. "Go 
to" takes you to the relevant function element in the logic diagram.
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"Print" button:   
Using the "Print" button in the "Comparison of configurations" dialog box, open a print preview 
of the results of the comparison. Define whether you want to print out the results of the 
comparison or to save them in PDF format.

7.11.2 Cross references

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Cross referen‐
ces

‑ ‑ ✓ ✓

Requirements
This menu command can only be selected if a configuration is open in Safety ES.

Actions  
The "Options" > "Cross references" menu command shows the cross references in tabular form 
in the output window.

Structure of the cross reference list
Operand Kind Type Usage loca‐

tion
Diagram Page

Device
Channel
Terminal identifier
Device status function

Access:
WR = write
RO = read

Type of 
operand

Element type 
and element 
number of the 
function ele‐
ment.

Name of the dia‐
gram in which the 
function element is 
located.

Page on which the function 
block that is connected to 
the function element is lo‐
cated.

Note
The cross reference list only displays the operands used in the safety circuit.

Edit cross references
With the context menu (right mouse button) or by double-clicking on the item, you can go to the 
position where the cross reference is used in order to edit it.
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7.11.3 Symbol list

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Symbol list ‑ ‑ ✓ ✓

Requirements
This menu command can only be selected if a configuration is open in Safety ES.

Actions
The "Options" > "Symbol list" menu command shows the plant identifier you assigned in the form 
of a table in the output window.   
To improve the legibility of the configuration, you can assign identifiers for parts of your 
configuration data within the context of the system documentation. The symbol list gives an 
overview of the identifiers assigned by you, their assignments, and the type.

Example of a symbol list
Identifier Assignment Type
Switching device 1 SLOT5 Equipment identifier (BMK)
Terminal_1 SLOT3_F-IN1 Terminal identifier
Terminal_2 SLOT4_Q6 Terminal identifier
Press - Plant identifier
Hall 1 - Location identifier
EMERGENCY STOP_1 EMERGENCY STOP [35] Name

Editing entries in the symbol list
You can perform the following actions in the context menu (right mouse button):
• Delete: The selected identifier is deleted.
• Editing: The selected identifier can be changed (can also be activated if the identifier is 

selected and you click on it again or press F2).
If you change or delete identifiers, then the display in the respective view is immediately 
updated.

• Go to: You jump to the corresponding icon, which is then selected (can also be activated by 
double-clicking).

Sorting:
• If you click on the column header in the columns "Identifier" and "Assignment," the items will 

be sorted alphabetically by this column.
• Clicking on the "Type" column header sorts the column as follows: Equipment identifier, 

Name, Comment, Terminal identifier, Location identifier, Plant identifier.

Configuring
7.11 Tips and Tricks

SIRIUS engineering Safety ES V1.0
164 Operating Manual, 12/2021, A5E32640754002A/RS-AF/006



Note
Editing rules
You cannot assign the same identifier twice.

7.11.4 Terminal list

Menu option Symbol Basic license Standard li‐
cense

Premium li‐
cense

Options Terminal list ‑ ‑ ✓ ✓

Requirements
This menu command can only be selected if a configuration is open in Safety ES.

Actions  
The "Options" > "Terminal list" menu command lists all available terminals of the slot and subslot 
(AS-i) modules, as well as bit memories, in the output window with the relevant terminal 
identifier (right-hand column) and the interconnection status in the logic diagram (left-hand 
column).   
The terminals are also shown for which no identifier has been assigned and also those terminals 
that are not yet interconnected.

Example of a terminal list
Terminal Terminal marking
ASi#02_IN1 Pushbutton_1
SLOT3_F-IN1 Terminal_1
SLOT3_F-M1 Bit_memory_1

Editing entries in the terminal list
You can perform the following actions in the context menu (right mouse button):
• Delete: The selected terminal identifier is deleted.
• Editing: The selected terminal identifier can be changed (can even be activated if the 

identifier is selected and you click on it again or press F2).
If you change or delete identifiers, then the display in the respective view is immediately 
updated.

• Go to: Interconnecting terminal is in the logic will take you to the corresponding function 
element and select it (can also be activated by double-clicking).
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Sorting: 
• Clicking on the column header of the first column sorts the items of this column by their 

interconnection status.
• Clicking on the relevant column header sorts the items of the "Terminal" and "Terminal 

identifier" columns alphabetically.
Note
Editing rules
You cannot assign the same terminal identifier twice.

7.11.5 Flags (3SK2 safety relay)

Function
As well as logic inputs and outputs implemented in the hardware, the 3SK2 safety relay also has 
a certain number of "virtual" safety-related outputs called "flags". 
With the help of these flags, you can buffer output signals and read them in again and further 
process them via an input cell. If the signal of several functions is to be processed, this signal can 
be linked with the relevant functions via multiple connection of the output of the input cell.
If, for example, a fault occurs at an output element, you can read in the output signal of the 
"FAULT output" in the user program again, and further process it.

WARNING
Increasing fault response time when using flags
Can Cause Death, Serious Injury, or Property Damage.
Flags are written at the end of a program cycle and can be read in again at the input by functions 
in the next program cycle.
Each flag that is contained in a signal path increases the fault response time. 
Please note this when calculating the overall response time.

The flags are interconnected in the properties of the function elements in the same way as all 
other inputs and outputs. You can assign a terminal name in the terminal list ("Options" > 
"Terminal list").
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7.11.6 Creation, modification, and release of the configuration without the actual 
system

A configuration can created, modified, and released without the actual system. Transfer of the 
configuration into the memory module and release of the configuration do not have to be 
performed on the actual system. All that is required is a safety relay of the same type, and a link 
to the PC / PG with Safety ES. For example, configurations for series machines can be duplicated 
preliminarily.

Note
The procedure does not apply to 3SK2 safety relays with width 22.5 mm since these have no 
memory module. Here it is possible to duplicate the configurations with the 3SK26 diagnostics 
display. See the manual for 3SK2 safety relays for information about this.

Creation, modification, and release of the configuration without the actual system  
With the following steps, you can modify the configuration remotely away from the system:
• Open the current configuration with "Load to PC" or by opening the configuring file or 

creating a new configuration.
• Modification of the configuration
• Save

– Confirm cancellation of the configuration release
– Consistency is checked

• "Target system" > "Load to switching device"
– Choose an access path and confirm
– Confirm cancellation of the configuration release
– Confirm the message "Loading successfully completed"

• "Target system" > "Go offline" (may not be necessary depending on settings in Safety ES)
• "Target system" > "Prepare configuration test"

– Choose an access path and confirm
– Save and print out the PDF file

• "Target system" > "Go offline"
• "Target system" > "Approve configuration"

– Choose an access path and confirm
– Confirm release
– Enter the name and name of the company of the person releasing and confirm
– Confirm configuring released message
– Save and print the release information
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• Switch off safety relay
• Remove the memory module

Apply the configuration to the actual system
The following steps must be performed on the system:
• Switch off safety relay on the system
• Replace / insert the memory module
• Switching on

WARNING
Automatic system startup
Can Cause Death, Serious Injury, or Property Damage
After switching on, the safety relay changes to safety mode if all requirements are met.
In safety mode, the safety program is executed and the outputs are controlled according to 
the safety program. 
Take appropriate organizational measures, such as deactivating the main circuit or 
cordoning off parts of the system, to ensure safety for persons and the system.

– The safety relay performs a target / actual comparison of the hardware configuration.
– The safety relay checks whether there is a released project on the memory module.
– If this is the case, the safety relay will load the project into its main memory and switch to 

safety mode.
• A function test must be conducted.

WARNING
Loss of the safety function.
Can Cause Death, Serious Injury, or Property Damage.
To ensure the safety of the system, a full function test of the system must be conducted and 
successfully completed. A complete function test consists of the following tests: 
• Configuration test (test of the configuration) 
• System test (wiring test of the connected sensors and actuators)

• Normal operation of the system is now possible.

7.11.7 Converting projects from MSS 3RK3 to 3SK2

How can I use MSS 3RK3 projects for 3SK2 safety relays?
With the help of macros, you can buffer logic diagrams created with an MSS 3RK3. You can re-use 
these macros when creating a configuration with a 3SK2 safety relay. 
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You will find additional information in Chapters "Export macros... (Page 99)" and "Import 
macros... (Page 100)."
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Function elements 8
8.1 Notes on parameter assignment

8.1.1 Compatibility lists

Which safety relay is compatible with which accessories?
Safety relay
 

Diagnostics display Interface modules
3RK3 V1.0 3RK3 V1.1 3SK2 V1.0 3RK3 PRO‐

FIBUS DP
3SK2 PRO‐
FINET

3RK3 Basic Yes Yes Yes Yes No
MSS 3RK3 Advanced /
MSS 3RK3 ASIsafe

No Yes Yes Yes Yes

3SK2 safety relay No No Yes Yes Yes

Which function element is compatible with which safety relay?
Function element Safety relay

3RK3 Basic MSS 3RK3 Ad‐
vanced /
MSS 3RK3 ASIsafe

3SK2 safety relay
 

Cell functions Input cell Yes Yes Yes
Output cell Yes Yes Yes
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Function element Safety relay
3RK3 Basic MSS 3RK3 Ad‐

vanced /
MSS 3RK3 ASIsafe

3SK2 safety relay
 

Monitoring func‐
tions

Monitoring 
Universal

No Yes Yes

EMERGENCY 
STOP

Yes Yes Yes

ESPE (electro-
sensitive pro‐
tective equip‐
ment)

Yes Yes Yes

Safety shut‐
down mat (NC 
principle)

Yes Yes Yes

Safety shut‐
down mat 
(cross-circuit 
principle)

Yes Yes Yes

Protective door Yes Yes Yes
Protective door 
with tumbler

No Yes Yes

Enabling but‐
ton

Yes Yes Yes

Two-hand op‐
eration

Yes Yes Yes

Mode selector 
switch

Yes Yes Yes

AS-i 2F-DI No Yes No
Muting functions Muting (2-sen‐

sor-parallel)
No Yes Yes

Muting (4-sen‐
sor-parallel)

No Yes Yes

Muting (4-sen‐
sor-sequential)

No Yes Yes

Status functions Device status Yes Yes Yes
Element status No Yes Yes

Control functions Device com‐
mand

Yes Yes Yes

Logic functions AND Yes Yes Yes
OR Yes Yes Yes
XOR Yes Yes Yes
NAND Yes Yes Yes
NOR Yes Yes Yes
NEGATION 
(NEG)

Yes Yes Yes

Flip-flop FF-SR Yes Yes Yes
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Function element Safety relay
3RK3 Basic MSS 3RK3 Ad‐

vanced /
MSS 3RK3 ASIsafe

3SK2 safety relay
 

Counter functions Counter (0 -> 1) Yes Yes Yes
Counter (1 -> 0) Yes Yes Yes
Counter (0 -> 
1 / 1 -> 0)

Yes Yes Yes

Timer functions With ON delay Yes Yes Yes
With ON delay 
(trigger)

Yes Yes Yes

Passing make 
contact

Yes Yes Yes

Passing make 
contact (trig‐
ger)

Yes Yes Yes

With OFF delay Yes Yes Yes
With OFF delay 
(trigger)

Yes Yes Yes

Clocking Yes Yes Yes
Start functions Monitored start Yes Yes Yes

Manual start Yes Yes Yes
Output functions Standard out‐

put
Yes Yes Yes

F output Yes Yes Yes
Standard out‐
put delayed

No No Yes

F output de‐
layed

No No Yes

AS-i 1..4F-DO No Yes No

8.1.2 Parameterization of times

WARNING
Loss of the safety function.
Can Cause Death, Serious Injury, or Property Damage.
The value of each time setting must always be selected at the lowest possible value that the 
application requires (permits). The selection of the times must comply with the requirements 
resulting from the risk evaluation for the respective hazardous situation. Otherwise additional 
measures have to be taken to avoid circumventing the safety application.
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Input delay
The input delay is required for bouncing contacts (protective door) to stabilize the signals before 
they can be processed further by the function elements.
The input delay can be set to anywhere between 0 to 150 ms for all function elements.
When the inputs of the fieldbus process image are used, no input delay times can be set.
If safety-related AS-Interface inputs are used, the input delay time can be deactivated (= 0 s) or 
set to a value between 50 ...150 ms.
For master calls on the AS-i bus, an input delay time cannot be set.
For logic-driven signals that are read back, it is also not possible to set an input delay time; this 
pertains to all terminal types.

WARNING
Increase of fault response time
Can Cause Death, Serious Injury, or Property Damage
If the input delay increases, the overall response time of the safety program increases.     

8.1.3 Parameterization of start conditions

Start conditions
The following start conditions must be fulfilled before the output of a function element is set:
• When the startup test is active, the sensor that is being monitored must be actuated once. 

Faults must not occur here.  
• If any faults do occur, they must be rectified and acknowledged.

Monitored / manual start
During a monitored start, the start pulse of the safety equipment must be between 150 and 
2000 ms.
A monitored start can be carried out with the following function elements:
• Monitoring Universal
• EMERGENCY STOP
• ESPE (electro-sensitive protective equipment)
• Safety shutdown mat (NC principle)
• Safety shutdown mat (cross-circuit principle)
• Protective door
• Protective door with tumbler
• Standard output
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• Start functions
• Output functions
In the case of a manual start, a rising edge 0->1 is required as the start condition at the START 
input.

8.1.4 Discrepancy monitoring
The discrepancy monitoring tolerates, within a defined time window, that associated signals are 
not available at the same time. If this time is exceeded, an enable signal is not output. The 
discrepancy monitoring can be set in the properties of the monitoring function. The following 
table provides an overview of discrepancy monitoring for the monitoring functions when they 
are connected to two-channel sensors:

Monitoring function Discrepancy monitoring Discrepancy time   Can be set in function 
element

Monitoring Universal can be set to on / off ∞ or
can be set from/to: 
0 ... 60000 ms,

Yes, with parameter - 
Input > Type "two-chan‐
nel". 

EMERGENCY STOP on 5000 ms No
ESPE (electro-sensitive protective 
equipment)

on ∞ No

Safety shutdown mat (NC principle) on 5000 ms No
Safety shutdown mat (cross-circuit 
principle)

off - No

Protective door can be set to on / off ∞ or
can be set from/to: 
0 ... 60000 ms,

Yes, with parameter - 
Input > Type "two-chan‐
nel". 

Protective door with tumbler can be set to on / off ∞ or
can be set from/to: 
0 ... 60000 ms,

Yes, with parameter - 
Input > Type "two-chan‐
nel". 

Enabling button on ∞ No
Two-hand operation on 5000 ms Yes
Mode selector switch off ‑ Yes
AS‑i 2F‑DI off ‑ Yes

Note
The configured discrepancy time of the "protective door" and "Protective door with tumbler" 
monitoring functions must be greater than the configured input delay because otherwise a 
discrepancy time violation may occur with bouncing contacts, e.g. when the protective door is 
closed.

Note
The combination of "Discrepancy time monitoring on" and "Discrepancy time ∞" means that no 
discrepancy time violation exists and, as such, no fault is triggered. The system cannot be 
switched on, however, until after the discrepancy condition violation has been rectified.
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8.1.5 Cross-circuit detection
A cross-circuit, which is a short-circuit between channels, can only occur with redundant device 
controllers. Cross-circuit detection is only possible when the sensor is operated on T1 / T2 of the 
relevant device, see also "Connection rules (Page 147)". The cross-section detection can be 
activated in the properties of the monitoring function.
Since a cross-circuit is an error requiring acknowledgment, a cross-circuit that has been rectified 
must be acknowledged by means of a reset.

Note
AS-i slaves
If AS-i slaves are used, activation of cross-circuit detection is not possible. 
If a cross-circuit occurs at the sensor inputs of a safety-related AS-i input slave, this slave 
generates a code sequence error that results in shutdown of the associated function element. 
For further information, please refer to the documentation of the respective AS‑i slave.

The following table provides an overview of cross-circuit detection for the monitoring functions:

Monitoring function Cross-circuit detec‐
tion

Instructions Can be set in function 
element

Monitoring Universal can be set to on / off ‑ Yes
EMERGENCY STOP can be set to on / off ‑ Yes
ESPE (electro-sensitive protec‐
tive equipment)

can be set to on / off • If the ESPE is equipped with solid-state 
outputs, cross-circuit detection must 
be deactivated.

• If the ESPE has floating contacts, only 
the sensor line between the safety re‐
lay and the ESPE is tested when cross-
circuit detection is activated. The light 
array is not tested.

Yes

Safety shutdown mat (NC prin‐
ciple)

can be set to on / off ‑ Yes

Safety shutdown mat (cross-cir‐
cuit principle)

on In the case of this monitoring function, a 
cross-circuit is not a fault, but corre‐
sponds to the safety requirement. There‐
fore, a cross-circuit is not evaluated as a 
fault and need not be acknowledged.
To be able to ensure absence of interac‐
tion of the safety shutdown mat with the 
cross-circuit detection of other sensors, 
only the safety shutdown mat is connec‐
ted to the test outputs T1 / T2.

No

Protective door can be set to on / off ‑ Yes
Protective door with tumbler can be set to on / off ‑ Yes
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Monitoring function Cross-circuit detec‐
tion

Instructions Can be set in function 
element

Enabling button on Cross-circuit monitoring is always imple‐
mented in the case of a single-channel 
enabling button. This is why a single-
channel enabling button must also be 
connected via a test output. Non-floating 
wiring is not possible.

No

Two-hand operation can be set to on / off A two-hand control of type III C (Cat. 4) 
can only be implemented if cross-circuit 
detection is activated.

Yes

Mode selector switch off ‑ No
AS‑i 2F‑DI off ‑ No

8.1.6 Parameter - input type
The "2xsingle-channel (NC/NC)" and "2x2xsingle-channel (NO/NO/NO/NO)" types of the "Input" 
parameter are only available for AS-i terminals.

Note
Parameter "Type" 2xsingle-channel
With this input circuit type, the discrepancy monitoring, sequence monitoring, and cross-circuit 
detection are deactivated.

8.1.7 Fault signaling output (FAULT)
The fault signaling output (FAULT) is activated for all monitoring and output functions and does 
not need to be wired. The fault signaling output indicates wiring and logic errors.

8.2 Cell function

8.2.1 Input cell

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced
MSS 3RK3 ASIsafe

3SK2 safety relay 

Cell functions Input cell ✓ ✓ ✓
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Description     
The input cell provides signal states for further processing in the safety logic. The signal states 
can be read in, for example, from the terminals of the input modules or also through a bus 
system.
The signal of an input cell can be used multiple times in the safety logic. 

Parameters
Parameter name Description/parameter value 
General Element number Consecutive number that is automatically assigned. You can change the number.

Element activated When this parameter is active, the function element is processed in the safety logic. 
When this parameter is deactivated, the set substitute value is made available at 
output Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters Terminal - Input Select the input to be processed by the function element.
Input delay [ms] Select here when the function elements further process the signals: 

• Input delay = "0"
The input signals are further processed by the function element without time 
delay when there is a signal change.

• Input delay not "0"
This parameter can be used to suppress signal interference. The signal state that 
was pending for most of the duration of the input delay is further processed.

Please note that the delay time specified by you is a multiple of the program cycle 
time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response times in 
the manual of the safety relay.

8.2.2 Output cell

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay 

Cell functions Output cell ✓ ✓ ✓
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Description     
The output cell forwards the signal states from the safety logic to an output. The signal states can 
be output, for example, at the terminal of an output module or also through a bus system.

Note
Setting/resetting of a safety-related AS-i output
For interconnection of multiple outputs of a safety-related AS-i output or auxiliary signals (AUX), 
you can use the output function "AS-i 1..4F-DO."

Parameters
Parameter name Description/parameter value
General Element number Consecutive number that is automatically assigned. You can change the number.

Element activated When this parameter is active, the function element is processed in the safety logic. 
When this parameter is deactivated, the set substitute value is made available at 
output Q.

Function output substi‐
tute value 

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameter Terminal - Output Select the output to be processed by the function element.

8.3 Monitoring functions

8.3.1 Monitoring Universal

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay 

Monitoring functions Monitoring Universal ‑ ✓ ✓

Description     
With the "Monitoring Universal" function element, you evaluate signals of any sensors using 
contacts with a positive opening operation, normally-open contacts, or a normally-closed/
normally-open combination.
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When the sensor is actuated, function output Q is deactivated, i.e., set to "0."

WARNING
Automatic system startup following transmission error at fieldbus inputs.
Can Cause Death, Serious Injury or Property Damage
Transmission errors at the fieldbus inputs can result in an erroneous start in which the system 
starts accidentally. To prevent this, the start type must be parameterized as "monitored." This 
is necessary to achieve SILCL 3 as per EN 61508 and PL e/ Cat. 4 as per EN ISO 13849‑1.

Parameters
Parameter name Description parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, 
for example, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change 
the number.
This number ensures a unique reference to the function element during 
diagnostics.

Element activated When this parameter is active, the function element is processed in the 
safety logic. 
When this parameter is deactivated, the set substitute value is made 
available at output Q.

Function output substitute 
value

"0" or "1" can be assigned to the substitute value when the element is 
deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameter Discrepancy monitoring This parameter is only available with parameter - Input > Type "two-
channel." 
You can choose whether this function will be deactivated or whether 
the discrepancy time between the inputs will be monitored.

Discrepancy time infinite You can select the discrepancy time infinite setting.
Discrepancy time [ms] You can select the discrepancy time between 0 and 60000 ms.

Please note that the discrepancy time specified by you is a multiple of 
the program cycle time specified by you in the properties of the safety 
relay.
You can find more information on the program cycle time and the re‐
sponse times in the manual of the safety relay.

Sequence monitoring You can deactivate the sequence monitoring of the inputs or define 
whether they will be monitored in ascending (IN1 > IN2) or descending 
(IN2 > IN1) order.
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Parameter name Description parameter value
Parameter - Input Type Use these parameters to determine the input type of the function ele‐

ment:
• single-channel (NC)

IN1 is monitored for "1", i.e. function output Q is deactivated when 
there is a "0" signal. 

• single-channel (NO)
IN1 is monitored for "0," i.e., function output Q is deactivated when 
there is a "1" signal.

• two-channel (NC/NC)
IN1 and IN2 are monitored for "1", i.e. function output Q is deacti‐
vated when there is at least one "0" signal.

• two-channel (NO/NO)
IN1 and IN2 are monitored for "0," i.e., function output Q is deacti‐
vated when there is at least one "1" signal.

• two-channel (NC/NO)
IN1 (NC) is monitored for "1" and IN2 (NO) is monitored for "0" 
(antivalent), i.e., function output Q is deactivated when there is a 
signal change at IN1 or IN2.

• 2xsingle-channel (NC/NC)
IN1 and IN2 are monitored for "1," i.e., function output Q is deacti‐
vated when there is at least one "0" signal. There are no further 
dependencies between the two signals.

IN1 Select the input to be processed by the function element. 
IN2 This parameter is only available if the following selection is made under 

parameter - Input > Type:
• two-channel
• 2xsingle-channel
IN2 is automatically assigned depending on the selected input IN1.

Input delay [ms] Select here when the function elements further process the signals:
• Input delay = "0"

The input signals are further processed by the function element 
without time delay when there is a signal change.

• Input delay not "0"
This parameter can be used to suppress signal interference. The 
signal state that was pending for most of the duration of the input 
delay is further processed.

Please note that the delay time specified by you is a multiple of the 
program cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the re‐
sponse times in the manual of the safety relay.

Cross-circuit detection When this parameter is activated, cross-circuits are detected with the 
aid of test outputs at the inputs.
If AS‑i slaves are used, cross-circuit detection is not possible.
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Parameter name Description parameter value
Parameter - Start Startup test • Activated:

After the switch from substitute value to real value or after the 
switch to safety or test mode, a start test must be conducted.
For this purpose, the sensor to be monitored must be actuated 
once. Only then can function output Q be activated depending on 
the type of start.

• Deactivated:
A start test is generally not required.

Start type • Automatic:
The function output Q is set as soon as all start conditions are ful‐
filled.

• Monitored:
Function output Q is set as soon as all start conditions are fulfilled 
and the start signal has changed from "0 → 1 → 0."

• Manual:
Function output Q is set as soon as all start conditions are fulfilled 
and the start signal is changed from "0 → 1".

8.3.2 EMERGENCY STOP

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay 

Monitoring functions EMERGENCY STOP ✓ ✓ ✓

Description     
With the "EMERGENCY STOP" function element, signals from the EMERGENCY STOP control 
devices with forcibly guided contacts are evaluated.
After the EMERGENCY STOP control device has been operated, function output Q is deactivated, 
i.e., set to "0."

WARNING
Automatic system startup following transmission error at fieldbus inputs.
Can Cause Death, Serious Injury or Property Damage
Transmission errors at the fieldbus inputs can result in an erroneous start in which the system 
starts accidentally. To prevent this, the start type must be parameterized as "monitored." This 
is necessary to achieve SILCL 3 as per EN 61508 and PL e/ Cat. 4 as per EN ISO 13849‑1.
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for 
example, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the 
number.

Element activated When this parameter is active, the function element is processed in the 
safety logic. 
When this parameter is deactivated, the set substitute value is made 
available at output Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is 
deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameter - Input Type This parameter defines the input type of the function element.
• single-channel (NC):

IN1 is monitored for "1", i.e. function output Q is deactivated when 
there is a "0" signal. 

• two-channel (NC/NC):
IN1 and IN2 are monitored for "1", i.e. function output Q is deactivated 
when there is at least one "0" signal.

• 2xsingle-channel (NC/NC)
IN1 and IN2 are monitored for "1," i.e., function output Q is deactiva‐
ted when there is at least one "0" signal. There are no further depend‐
encies between the two signals.

IN1 Select the input to be processed by the function element. 
IN2 Only available with the parameter - Input > Type two-channel (NC/NC) 

and 2xsingle-channel (NC/NC).
IN2 is automatically assigned depending on the selected input IN1.

Input delay [ms] Select here when the function elements further process the signals: 
• Input delay = "0":

The input signals are further processed by the function element with‐
out time delay when there is a signal change.

• Input delay not "0":
This parameter can be used to suppress signal interference. The signal 
state that was pending for most of the duration of the input delay is 
further processed.

Please note that the delay time specified by you is a multiple of the pro‐
gram cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the re‐
sponse times in the manual of the safety relay.

Cross-circuit detection When this parameter is activated, cross-circuits are detected with the aid 
of test outputs at the inputs.
If AS-i slaves are used, cross-circuit detection is not possible.
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Parameter name Description/parameter value
Parameter - Start Startup test • Activated:

After the switch from substitute value to real value or after the switch 
to safety or test mode, a start test must be conducted.
For this purpose, the sensor to be monitored must be actuated once. 
Only then can function output Q be activated depending on the type 
of start.

• Deactivated:
A start test is generally not required.

Start type • Automatic:
The function output Q is set as soon as all start conditions are fulfilled.

• Monitored:
Function output Q is set as soon as all start conditions are fulfilled and 
the start signal has changed from "0 → 1 → 0."

• Manual:
Function output Q is set as soon as all start conditions are fulfilled and 
the start signal is changed from "0 → 1".

8.3.3 ESPE (electro-sensitive protective equipment)

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced
MSS 3RK3 ASIsafe

3SK2 safety relay

Monitoring functions ESPE ✓ ✓ ✓

Description     
With the function element "ESPE" (electro-sensitive protective equipment) signals from, for 
example, light curtains and laser scanners are evaluated. 
The following ESPE types are supported by the safety relay:
• ESPE type 4 (self-monitoring) for applications up to SILCL 3 as per EN 62061
• ESPE type 2 with integrated automatic testing for applications up to SILCL 1 and SILCL 2 as 

per EN 62061 
(ESPE type 2 with manual or parameterizable testing are not supported.)

When something enters the protective field of the ESPE, the function output Q is deactivated, 
i.e., set to "0".

WARNING
Automatic system startup following transmission error at fieldbus inputs.
Can Cause Death, Serious Injury or Property Damage
Transmission errors at the fieldbus inputs can result in an erroneous start in which the system 
starts accidentally. To prevent this, the start type must be parameterized as "monitored." This 
is necessary to achieve SILCL 3 as per EN 61508 and PL e/ Cat. 4 as per EN ISO 13849‑1.
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for 
example, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the 
number.

Element activated When this parameter is active, the function element is processed in the 
safety logic. 
When this parameter is deactivated, the set substitute value is made 
available at output Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is 
deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameter - Input Type Use these parameters to determine the input type of the function ele‐
ment.
• single-channel (NC):

IN1 is monitored for "1", i.e. function output Q is deactivated when 
there is a "0" signal. 

• two-channel (NC/NC):
IN1 and IN2 are monitored for "1", i.e. function output Q is deactivated 
when there is at least one "0" signal.

• 2xsingle-channel (NC/NC)
IN1 and IN2 are monitored for "1," i.e., function output Q is deactiva‐
ted when there is at least one "0" signal. On restart, the other channel 
must not have passed through zero.

IN1 Select the input to be processed by the function element. 
IN2 This parameter is available with parameter - Input > Type two-channel 

(NC/NC) and with 2xsingle-channel (NC/NC). 
IN2 is automatically assigned depending on the selected input IN1.

Input delay [ms] Select here when the function elements further process the signals: 
• Input delay = "0":

The input signals are further processed by the function element with‐
out time delay when there is a signal change.

• Input delay not "0":
This parameter can be used to suppress signal interference. The signal 
state that was pending for most of the duration of the input delay is 
further processed.

Please note that the delay time specified by you is a multiple of the pro‐
gram cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the re‐
sponse times in the manual of the safety relay.

Cross-circuit detection When this parameter is activated, cross-circuits are detected with the aid 
of test outputs at the inputs.
If you use ESPE with electronic outputs you must deactivate cross-circuit 
detection.
If AS-i slaves are used, cross-circuit detection is not possible.
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Parameter name Description/parameter value
Parameter - Start Startup test • Activated:

After the switch from substitute value to real value or after the switch 
to safety or test mode, a start test must be conducted.
For this purpose, the sensor to be monitored must be actuated once. 
Only then can function output Q be activated depending on the type 
of start.

• Deactivated:
A start test is generally not required.

Start type • Automatic:
The function output Q is set as soon as all start conditions are fulfilled.

• Monitored:
Function output Q is set as soon as all start conditions are fulfilled and 
the start signal has changed from "0 → 1 → 0."

• Manual:
Function output Q is set as soon as all start conditions are fulfilled and 
the start signal is changed from "0 → 1".

8.3.4 Safety shutdown mat (NC principle)

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Monitoring functions Safety shutdown mat 
(NC principle)

✓ ✓ ✓

Description     
With the "Safety shutdown mat (NC principle)" function element, the signals from the safety 
shutdown mats with NC contacts are evaluated. 
When the safety shutdown mat is actuated, function output Q is deactivated, i.e., set to "0."

WARNING
Automatic system startup following transmission error at fieldbus inputs.
Can Cause Death, Serious Injury or Property Damage
Transmission errors at the fieldbus inputs can result in an erroneous start in which the system 
starts accidentally. To prevent this, the start type must be parameterized as "monitored." This 
is necessary to achieve SILCL 3 as per EN 61508 and PL e/ Cat. 4 as per EN ISO 13849‑1.

Function elements
8.3 Monitoring functions

SIRIUS engineering Safety ES V1.0
186 Operating Manual, 12/2021, A5E32640754002A/RS-AF/006



Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for 
example, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the 
number.

Element activated When this parameter is active, the function element is processed in the 
safety logic. 
When this parameter is deactivated, the set substitute value is made 
available at output Q.

Function output substi‐
tute value 

"0" or "1" can be assigned to the substitute value when the element is 
deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameter - Input Type Use these parameters to determine the input type of the function ele‐
ment:
• single-channel (NC):

IN1 is monitored for "1", i.e. function output Q is deactivated when 
there is a "0" signal. 

• two-channel (NC/NC):
IN1 and IN2 are monitored for "1", i.e. function output Q is deactivated 
when there is at least one "0" signal.

• 2xsingle-channel (NC/NC)
IN1 and IN2 are monitored for "1," i.e., function output Q is deactiva‐
ted when there is at least one "0" signal. There are no further depend‐
encies between the two signals.

IN1 Select the input to be processed by the function element. 
IN2 This parameter is available with parameter - Input > Type two-channel 

(NC/NC) and with 2xsingle-channel (NC/NC). 
IN2 is automatically assigned depending on the selected input IN1.

Input delay [ms] Select here when the function elements further process the signals: 
• Input delay = "0":

The input signals are further processed by the function element with‐
out time delay when there is a signal change.

• Input delay not "0":
This parameter can be used to suppress signal interference. The signal 
state that was pending for most of the duration of the input delay is 
further processed.

Please note that the delay time specified by you is a multiple of the pro‐
gram cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the re‐
sponse times in the manual of the safety relay.

Cross-circuit detection When this parameter is activated, cross-circuits are detected with the aid 
of test outputs at the inputs.
If AS-i slaves are used, cross-circuit detection is not possible.
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Parameter name Description/parameter value
Parameter - Start Startup test • Activated:

After the switch from substitute value to real value or after the switch 
to safety or test mode, a start test must be conducted.
For this purpose, the sensor to be monitored must be actuated once. 
Only then can function output Q be activated depending on the type 
of start.

• Deactivated:
A start test is generally not required.

Start type • Automatic:
The function output Q is set as soon as all start conditions are fulfilled.

• Monitored:
Function output Q is set as soon as all start conditions are fulfilled and 
the start signal has changed from "0 → 1 → 0."

• Manual:
Function output Q is set as soon as all start conditions are fulfilled and 
the start signal is changed from "0 → 1".

8.3.5 Safety shutdown mat (cross-circuit principle)

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay 

Monitoring functions Safety shutdown mat 
(cross-circuit principle)

✓ ✓ ✓

Description     
With the "Safety shutdown mat (cross-circuit principle)" function element, the signals from the 
safety shutdown mats with cross-circuit detection are evaluated.
When the safety shutdown mat is actuated, function output Q is deactivated, i.e., set to "0."

WARNING
Automatic system startup following transmission error at fieldbus inputs.
Can Cause Death, Serious Injury or Property Damage
Transmission errors at the fieldbus inputs can result in an erroneous start in which the system 
starts accidentally. To prevent this, the start type must be parameterized as "monitored." This 
is necessary to achieve SILCL 3 as per EN 61508 and PL e/ Cat. 4 as per EN ISO 13849‑1.
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Note
If a safety shutdown mat (cross-circuit principle) is connected to a slot (safety relay or expansion 
module), cross-circuit detection must be deactivated for the remaining inputs on this slot 
because otherwise the monitoring functions configured for these inputs will also signal a cross-
circuit when somebody steps on the safety shutdown mat.   
Exception:
On the 3SK2 safety relay (45 mm), there are two independent test cycle pairs. You can use one 
test cycle pair for the safety shutdown mat (cross-circuit principle), and the other test cycle pair 
independently of this with monitoring functions for cross-circuit detection. 

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for 
example, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the 
number.

Element activated When this parameter is active, the function element is processed in the 
safety logic. 
When this parameter is deactivated, the set substitute value is made 
available at output Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is 
deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameter - Input Type The input type of the function element is defined:
• two-channel (NC/NC):

IN1 and IN2 are monitored for "1", i.e. shutdown on operation of the 
safety shutdown mat.

IN1 Select the input to be processed by the function element.
IN2 IN2 is automatically assigned depending on the selected input IN1.
Input delay [ms] Select here when the function elements further process the signals: 

• Input delay = "0":
The input signals are further processed by the function element with‐
out time delay when there is a signal change.

• Input delay not "0":
This parameter can be used to suppress signal interference. The signal 
state that was pending for most of the duration of the input delay is 
further processed.

Please note that the delay time specified by you is a multiple of the pro‐
gram cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the re‐
sponse times in the manual of the safety relay.
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Parameter name Description/parameter value
Parameter - Start Startup test • Activated:

After the switch from substitute value to real value or after the switch 
to safety or test mode, a start test must be conducted.
For this purpose, the sensor to be monitored must be actuated once. 
Only then can function output Q be activated depending on the type 
of start.

• Deactivated:
A start test is generally not required.

Start type • Automatic:
The function output Q is set as soon as all start conditions are fulfilled.

• Monitored:
Function output Q is set as soon as all start conditions are fulfilled and 
the start signal has changed from "0 → 1 → 0."

• Manual:
Function output Q is set as soon as all start conditions are fulfilled and 
the start signal is changed from "0 → 1". 

8.3.6 Protective door

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Monitoring functions Protective door ✓ ✓ ✓

Description     
With the "Protective door" function element, the signals from the protective doors or safety 
flaps are evaluated by means of positive opening contacts or an NC/NO combination.
When the protective door is actuated, function output Q is deactivated, i.e., set to "0."

WARNING
Automatic system startup following transmission error at fieldbus inputs.
Can Cause Death, Serious Injury or Property Damage
Transmission errors at the fieldbus inputs can result in an erroneous start in which the system 
starts accidentally. To prevent this, the start type must be parameterized as "monitored." This 
is necessary to achieve SILCL 3 as per EN 61508 and PL e/ Cat. 4 as per EN ISO 13849‑1.
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Parameters
Parameter name Description parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, 
for example, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change 
the number.

Element activated When this parameter is active, the function element is processed in the 
safety logic. 
When this parameter is deactivated, the set substitute value is made 
available at output Q.

Function output substitute 
value

"0" or "1" can be assigned to the substitute value when the element is 
deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameter Discrepancy monitoring This parameter is only available with parameter - Input > Type "two-
channel." 
You can choose whether this function will be deactivated or whether 
the discrepancy time between the inputs will be monitored.

Discrepancy time infinite You can set the discrepancy time to infinite.
Discrepancy time [ms] You can set the discrepancy time between 0 and 60000 ms.

Please note that the discrepancy time specified by you is a multiple of 
the program cycle time specified by you in the properties of the safety 
relay.
You can find more information on the program cycle time and the re‐
sponse times in the manual of the safety relay.

Sequence monitoring You can deactivate the sequence monitoring of the inputs or define 
whether they will be monitored in ascending (IN1 > IN2) or descending 
(IN2 > IN1) order.
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Parameter name Description parameter value
Parameter - Input Type Use these parameters to determine the input type of the function ele‐

ment:
• single-channel (NC)

IN1 is monitored for "1", i.e. function output Q is deactivated when 
there is a "0" signal. 

• two-channel (NC/NC)
IN1 and IN2 are monitored for "1", i.e. function output Q is deacti‐
vated when there is at least one "0" signal.

• two-channel (NC/NO)
IN1 (NC) is monitored for "1" and IN2 (NO) is monitored for "0" 
(antivalent), i.e., function output Q is deactivated when there is a 
signal change at IN1 or IN2.

• 2xsingle-channel (NC/NC)
IN1 and IN2 are monitored for "1", i.e. function output Q is deacti‐
vated when there is at least one "0" signal. There are no further 
dependencies between the two signals.

IN1 Select the input to be processed by the function element. 
IN2 This parameter is only available if the following selection is made under 

parameter - Input > Type:
• two-channel
• 2xsingle-channel
IN2 is automatically assigned depending on the selected input IN1.

Input delay [ms] Select here when the function elements further process the signals:
• Input delay = "0"

The input signals are further processed by the function element 
without time delay when there is a signal change.

• Input delay not "0"
This parameter can be used to suppress signal interference. The 
signal state that was pending for most of the duration of the input 
delay is further processed.

Please note that the delay time specified by you is a multiple of the 
program cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the re‐
sponse times in the manual of the safety relay.

Cross-circuit detection When this parameter is activated, cross-circuits are detected with the 
aid of test outputs at the inputs.
If AS-i slaves are used, cross-circuit detection is not possible.
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Parameter name Description parameter value
Parameter - Start Startup test • Activated:

After the switch from substitute value to real value or after the 
switch to safety or test mode, a start test must be conducted.
For this purpose, the sensor to be monitored must be actuated 
once. Only then can function output Q be activated depending on 
the type of start.

• Deactivated:
A start test is generally not required.

Start type • Automatic:
The function output Q is set as soon as all start conditions are ful‐
filled.

• Monitored:
Function output Q is set as soon as all start conditions are fulfilled 
and the start signal has changed from "0 → 1 → 0."

• Manual:
Function output Q is set as soon as all start conditions are fulfilled 
and the start signal is changed from "0 → 1".

Note
The configured discrepancy time of the "protective door" monitoring function must be greater 
than the configured input delay because otherwise a discrepancy time violation may occur with 
bouncing contacts, e.g., when the protective door is closed.

8.3.7 Protective door with tumbler

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Monitoring functions Protective door with 
tumbler

‑ ✓ ✓

Note
The function element is not available in Safety ES for all devices. If a device that does not support 
this function element is configured in the configuration, the function element is hidden in the 
catalog window.

Description     
With the "Protective door with tumbler" function element, you evaluate signals from protective 
doors. You can control the door lock and monitor its status.
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For this purpose, the element has the following inputs:
• two function inputs IN1 and IN2 for position detection of the protective door.
• a "FEEDBACK_LOCK" function input for acquiring the locking status of the lock.
• an "IN_LOCK" function input for controlling the lock.
The element provides the following signals as the result:
• The switch-off signal for the system is output through function output "Q."
• The control signal for the lock is output through function output "LOCK."
• Error messages are output through function output "FAULT."

Functional principle
Function output Q of this element is only set to the value "1" if the protective door is closed and 
locked. 
When an unlocking command (= value "1") is applied to function input "IN_LOCK," function 
output Q is immediately set to "0" and the tumber is unlocked after a settable unlocking time 
through function output LOCK. 
If the unlocking command is applied to function input "IN_LOCK" before the unlocking time has 
elapsed, the tumbler will remain closed and the system can restart.
To lock a disengaged lock again, it is not necessary for the protective door to have been opened 
in the meantime. It can remain closed and be relocked immediately.
Time values are not saved. At the start of safety or test mode, all time values begin with their 
initial values. 

Start override
The start override enables function output Q to be set to the value "1" although an unlocking 
command is pending. This function can be used if the locking or unlocking command comes 
from a standstill monitor. (The standstill monitor only transmits the locking command when 
standstill is no longer detected.)
You can define the length of the start time in the "Start time" parameter if the start type "manual" 
or "monitored" has been selected.
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This setting has the following properties:
• When the START command is applied to function input START, the tumbler of the element is 

automatically engaged if the unlocking command is pending at function input IN_LOCK and 
the protective door is closed. Function output Q is set to "1." Concurrently with this, the start 
time is started and the "Start override active" message is set.
If the protective door is open, locking is only performed if this is permitted in the "Tumbler 
with open protective door" parameter.

• You can adapt the length of the start time to the application using the "Start time" parameter. 
At the latest after the start time has elapsed, the "Start override active" message will be reset. 
The locking command must then be pending at function input IN_LOCK. If no locking 
command is pending, function output Q will be set to value "0" again and the lock will be 
disengaged after the unlocking time has elapsed. If the locking command is detected before 
the start time has elapsed, the start time will be interrupted. The tumbler remains locked and 
the function output retains the value "1."

• If another starting command is detected at function input "START" while the startup time is 
running, the startup time is started from the beginning without the signal state of function 
outputs Q and LOCK being changed.

• This function is deactivated if the "start time" parameter is parameterized to value "0." A value 
not equal to "0" activates the function.

Interlock types
The "Protective door with tumbler" function element can be used for spring-locked or solenoid-
locked position switches.
• Spring-locked according to closed-circuit current principle

The tumbler is locked passively and unlocked actively, i.e., spring tension keeps the tumbler 
engaged. On a power failure, the tumbler remains engaged.

• Solenoid-locked according to open-circuit current principle
The tumbler has to be locked actively, i.e., magnetic force (solenoid energized) keeps the 
tumbler engaged. On a power failure, the tumbler is automatically unlocked and thus allows 
the service personnel to enter the system while it is de-energized.

WARNING
Protective door unlocking following power failure. 
Can Cause Death, Serious Injury, or Property Damage.
Note that this variant of the locking on power failure takes no account of possible run-down 
times of the system. If this can result in a hazard for persons, the tumbler must not be 
implemented in this way.
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WARNING
Unlocked safety door after switching on with unlock command pending.
Can cause death, serious injury, or property damage.
After the supply voltage is applied, the safety door is unlocked immediately if an unlock 
command is pending, without the unlock time continuing or running again.
Plan appropriate actions to avoid any danger.

WARNING
Automatic system startup following transmission error at fieldbus inputs.
Can Cause Death, Serious Injury or Property Damage
Transmission errors at the fieldbus inputs can result in an erroneous start in which the system 
starts accidentally. To prevent this, the start type must be parameterized as "monitored." This 
is necessary to achieve SILCL 3 as per EN 61508 and PL e/ Cat. 4 as per EN ISO 13849‑1.

Note
The configured discrepancy time of the "Protective door with tumbler" monitoring function must 
be greater than the configured input delay because otherwise a discrepancy time violation may 
occur with bouncing contacts, e.g., when the protective door is closed.

Note
On a signal change at the FEEDBACK_LOCK function input, an error is generated immediately, if 
the signal at function output LOCK has not changed.

Parameters
Parameter name Description parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This 
may, for example, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change 
the number.

Element activated When this parameter is active, the function element is processed in 
the safety logic. 
If this parameter is deactivated, the set substitute value is made 
available at outputs Q and LOCK.

Function output substitute 
value

"0" or "1" can be assigned to the substitute value when the element 
is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Substitute value LOCK "0" or "1" can be assigned to the substitute value when the element 
is deactivated.
Substitute value "0" means output LOCK = 0
substitute value "1" means output LOCK = 1
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Parameter name Description parameter value
Parameter Discrepancy monitoring This parameter is only available with parameter - Input > Type "two-

channel." 
You can choose whether this function will be deactivated or wheth‐
er the discrepancy time between the inputs will be monitored.

Discrepancy time infinite You can set the discrepancy time to infinite.
Discrepancy time [ms] You can set the discrepancy time between 0 and 60000 ms.

Please note that the discrepancy time specified by you is a multiple 
of the program cycle time specified by you in the properties of the 
safety relay.
You can find more information on the program cycle time and the 
response times in the manual of the safety relay.

Sequence monitoring You can deactivate the sequence monitoring of the inputs or define 
whether they will monitored in ascending (IN1 > IN2) or descending 
(IN2 > IN1) order.
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Parameter name Description parameter value
Parameter - Input Type Use these parameters to determine the input type of the function 

element:
• single-channel (NC)

IN1 is monitored for "1", i.e. function output Q is deactivated 
when there is a "0" signal. 

• two-channel (NC/NC)
IN1 and IN2 are monitored for "1", i.e. function output Q is de‐
activated when there is at least one "0" signal.

• two-channel (NC/NO)
IN1 (NC) is monitored for "1" and IN2 (NO) is monitored for "0" 
(antivalent), i.e., function output Q is deactivated when there is 
a signal change at IN1 or IN2.

• 2xsingle-channel (NC/NC)
IN1 and IN2 are monitored for "1", i.e. function output Q is de‐
activated when there is at least one "0" signal. There are no 
further dependencies between the two signals.

IN1 Select the input to be processed by the function element. 
IN2 This parameter is only available if the following selection is made 

under parameter - Input > Type:
• two-channel
• 2xsingle-channel
IN2 is automatically assigned depending on the selected input IN1.

Input delay [ms] Select here when the function elements further process the signals:
• Input delay = "0"

The input signals are further processed by the function element 
without time delay when there is a signal change.

• Input delay not "0"
This parameter can be used to suppress signal interference. The 
signal state that was pending for most of the duration of the 
input delay is further processed.

Please note that the delay time specified by you is a multiple of the 
program cycle time specified by you in the properties of the safety 
relay.
You can find more information on the program cycle time and the 
response times in the manual of the safety relay.

Cross-circuit detection When this parameter is activated, cross-circuits are detected with 
the aid of test outputs at the inputs.
If AS-i slaves are used, cross-circuit detection is not possible.

Tumbler with the open pro‐
tective door

The tumbler can only be engaged while the protective door is closed 
or open, depending on the "tumbler with open protective door" 
parameter. 
You can set the following parameters:
• not lockable

The tumbler cannot be engaged while the protective door is 
open.

• lockable
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Parameter name Description parameter value
The tumbler can be locked or unlocked irrespective of the posi‐
tion of the protective door.

Note:
When position switches whose door and lock contacts act on the 
same slave are used with AS-Interface, "lockable" must always be 
chosen in order to enable proper operation.

Interlock type Define the type of lock here:
• Spring locking
• Solenoid locking

Unlocking time [s] Here, you can define the unlocking time from 0 to 655 seconds.
This parameter permits time-delayed unlocking of the protective 
door after the system has been shut down.

Parameters - Feedback 
circuit

Feedback circuit monitoring The feedback circuit permits monitoring of the lock connected to 
the LOCK function output for correct locking. You can set the fol‐
lowing parameters:
• Deactivated
• Enabled
While the feedback circuit monitoring is activated, the following 
values are expected at the feedback input FEEDBACK_LOCK:
• Protective door unlocked: expected feedback circuit signal = "1"
• Protective door locked: expected feedback circuit signal = "0"

Feedback circuit switching 
time [s]

Parameter only available if parameter - Feedback circuit - Monitoring 
is active.
If the feedback circuit signal FEEDBACK_LOCK does not match the 
output signal LOCK no later than after the switching time has 
elapsed, function output "Q" will be switched off.
Please note that the entered feedback circuit switching time is a 
multiple of the program cycle time specified by you in the properties 
of the safety relay.
You can find more information on the program cycle time and the 
response times in the manual of the safety relay.
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Parameter name Description parameter value
Parameter - Start Startup test You can set the following parameters:

• Activated:
After the switch from substitute value to real value or after the 
switch to safety or test mode, a start test must be conducted.
For this purpose, the sensor to be monitored must be actuated 
once. Only then can function output Q be activated depending 
on the type of start.

• Deactivated:
A start test is generally not required.

Startup time [s] Here you can define a time between 0 and 60000 ms, during which 
the "IN_LOCK" locking command is to be overridden.

Start type • Automatic:
The function output Q is set as soon as all start conditions are 
fulfilled.

• Monitored:
Function output Q is set as soon as all start conditions are fulfil‐
led and the start signal has changed from "0 → 1 → 0."

• Manual:
Function output Q is set as soon as all start conditions are fulfil‐
led and the start signal is changed from "0 → 1".

8.3.8 Enabling button

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Monitoring functions Enabling button ✓ ✓ ✓

Description     
With the "Enabling button" function element, the signals from the enabling buttons are 
evaluated by means of an NO contact.

Note
Wiring of enabling button
An enabling button is always monitored for cross-circuit. This is achieved using test cycle outputs 
T1 and T2.
Cross-circuit monitoring is always implemented in the case of a single-channel enabling button 
too. This is why a single-channel enabling button must also be connected via a test output. Non-
floating wiring is not possible.

When the enabling button is actuated, function output Q is activated, i.e. set to "1."
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for 
example, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the 
number.

Element activated When this parameter is active, the function element is processed in the 
safety logic.
When the parameter is deactivated, the set substitute value is made avail‐
able at output Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is 
deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameter - Input Type Use these parameters to determine the input type of the function element:
• single-channel (NO)

IN1 is monitored for "1," i.e. function output Q is activated when there 
is a "1" signal.

• two-channel (NO/NO)
IN1 and IN2 are monitored for "1," i.e. function output Q is activated 
when there are two "1" signals.

• 2xsingle-channel (NO/NO)
IN1 and IN2 are monitored for "1," i.e. function output Q is activated 
when there are two "1" signals. There are no further dependencies 
between the two signals.

IN1 Select the input to be processed by the function element. 
IN2 Only available with the parameter - Input > Type two-channel (NO/NO) or 

2xsingle-channel (NO/NO).
IN2 is automatically assigned depending on the selected input IN1.

Input delay [ms] Select here when the function elements further process the signals:
• Input delay = "0"

The input signals are further processed by the function element with‐
out time delay when there is a signal change.

• Input delay not "0"
This parameter can be used to suppress signal interference. The signal 
state that was pending for most of the duration of the input delay is 
further processed.

Please note that the delay time specified by you is a multiple of the program 
cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response 
times in the manual of the safety relay.
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8.3.9 Two-hand operation

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Monitoring functions Two-hand operation ✓ ✓ ✓

Description     
With the "Two-hand operation" function element, the signals from the two-hand control unit are 
evaluated. 
When both buttons of the two-hand operated panel are operated within 500 ms (synchronous 
operation time), the function output Q is activated, i.e. set to "1". 
The following table shows the type as defined by EN 574 or EN ISO 13851 that is achieved for the 
various requirements.

Input type Input Cross-cir‐
cuit

Achievable type
according to EN 574 or EN ISO 13851
MSS 3RK3 3SK2 safety relay

NO/NO Fail-safe input terminal X III a III c
NO/NO Fail-safe AS‑i input slave - III a - 
NO/NC/NO/N
C 

Fail-safe input terminal X III c III c

NO/NC/NO/N
C 

Fail-safe input terminal - III c III c

NO/NO/NO/N
O

Fail-safe input terminal X III c III c

NO/NO/NO/N
O

Fail-safe input terminal - III a III a

NO/NO/NO/N
O

Fail-safe AS‑i input slave - III c -

X: enabled

Note
Two-hand control of type III C (Cat. 4)
A two-hand control of type III C (Cat. 4) can only be implemented if cross-circuit detection is 
activated.
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WARNING
Loss of safety function with two-hand operation type IIIc with 3SK2 safety relay
Can cause death, serious injury, or property damage.
With cycle times of > 30 ms, the synchronous actuation time can increase to up to 0.6 s for two-
hand operation type IIIc.
Set the cycle time to a maximum of 30 ms for two-hand operation type IIIc. This is the only way 
to guarantee the synchronous actuation time of 0.5 s required by the standard.

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for 
example, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the 
number.

Element activated When this parameter is active, the function element is processed in the 
safety logic. 
When this parameter is deactivated, the set substitute value is made 
available at output Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is 
deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Function elements
8.3 Monitoring functions

SIRIUS engineering Safety ES V1.0
Operating Manual, 12/2021, A5E32640754002A/RS-AF/006 203



Parameter name Description/parameter value
Parameter - Input Type Use these parameters to determine the input type of the function ele‐

ment:
• two-channel (NO/NO)

IN1 and IN2 are monitored for "1," i.e. function output Q is activated 
when there are two "1" signals.

• four-channel (NO/NO/NO/NO)
IN1 / IN2 and IN3 / IN4 are monitored for "1," i.e. function output Q is 
activated when there are four "1" signals.

• four-channel (NO/NC/NO/NC)
IN1 / IN3 (NC) are monitored for "1", and IN2 / IN4 (NO) are monitored 
for "0" (antivalent), i.e. function output Q is activated when there is a 
signal change at IN1 / IN2 and IN3 / IN4.

• 2xsingle-channel (NO/NO/NO/NO)
IN1 / IN2 and IN3 / IN4 are monitored for "1," i.e. function output Q is 
activated when all four signals are "1." There are no further depend‐
encies between the two signals.

IN1 Select the input to be processed by the function element. 
IN2 IN2 is automatically assigned depending on the selected input IN1.
IN3 This parameter is only available if the following selection is made under 

parameter - Input > Type:
• four-channel
• 2x2xsingle-channel
Select the input to be processed by the function element. 

IN4 This parameter is only available if the following selection is made under 
parameter - Input > Type:
• four-channel
• 2x2xsingle-channel
IN4 is automatically assigned depending on the selected input IN3.

Cross-circuit detection When this parameter is activated, cross-circuits are detected with the aid 
of test outputs at the inputs.
A two-hand control of type III C (Cat. 4) can only be implemented if cross-
circuit detection is activated.
If AS-i slaves are used, cross-circuit detection is not possible.

Input delay [ms] Select here when the function elements further process the signals:
• Input delay = "0"

The input signals are further processed by the function element with‐
out time delay when there is a signal change.

• Input delay not "0"
This parameter can be used to suppress signal interference. The signal 
state that was pending for most of the duration of the input delay is 
further processed.

Please note that the delay time specified by you is a multiple of the pro‐
gram cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the re‐
sponse times in the manual of the safety relay.

Function elements
8.3 Monitoring functions

SIRIUS engineering Safety ES V1.0
204 Operating Manual, 12/2021, A5E32640754002A/RS-AF/006



8.3.10 Mode selector switch

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Monitoring functions Mode selector switch ✓ ✓ ✓

Description     
With the "Mode selector switch" function element, the signals from the mode selector switch are 
evaluated by means of NO contacts. Up to 5 operating modes can be defined. In the downstream 
logic, you can parameterize the operating mode to be implemented as required.
The outputs Q1 to Q5 are assigned to the inputs IN1 to IN5. When the input IN1 is activated, the 
function output Q1 is activated, i.e. set to "1." Further input and output pairs respond 
analogously.
If a start function is required for releasing an operating mode, this can be implemented with the 
"Start functions".
The contact switchover time is 1000 ms, that is, a switch must be made between the operating 
modes within this time.

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for 
example, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the 
number.

Element activated When this parameter is active, the function element is processed in the 
safety logic. 
When this parameter is deactivated, the set substitute value is made 
available at output Q.

Function output substi‐
tute value

The substitute value "1" can only be assigned to one output at a time. "0" 
is automatically assigned to all others.

Parameter Type of switch Select the required step switch:
1 out of 2, 1 out of 3, 1 out of 4, 1 out of 5
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Parameter name Description/parameter value
Parameter - Input Type The input type of the function element is defined:

• single-channel (NO)
INx is monitored for "1," i.e. the function output Qx is deactivated 
when there is a "0" signal. 

IN1 Select the input to be processed by the function element.
IN2 Select the input to be processed by the function element.
IN3 This parameter is available for switch type 1 out of 3; 1 out of 4, or 1 out 

of 5.
Select the input that is to be processed by the function element.

IN4 This parameter is available for switch type 1 of 4 or 1 of 5. 
Select the input to be processed by the function element.

IN5 This parameter is available for switch type 1 of 5. 
Select the input to be processed by the function element.

Input delay [ms] Select here when the function elements further process the signals: 
• Input delay = "0"

The input signals are further processed by the function element with‐
out time delay when there is a signal change.

• Input delay not "0"
This parameter can be used to suppress signal interference. The signal 
state that was pending for most of the duration of the input delay is 
further processed.

Please note that the delay time specified by you is a multiple of the pro‐
gram cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the re‐
sponse times in the manual of the safety relay.

8.3.11 AS-i 2F-DI

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Monitoring functions AS-i 2F-DI ‑ ✓ -

Note
The function element is not available in Safety ES for all devices. If a device that does not support 
this function element is configured in the configuration, the function element is hidden in the 
catalog window.

Description     
The monitoring function "AS-i 2F-DI" is used instead of an input cell if you want to diagnose both 
of the input terminal signals of the ASIsafe input slave.
The ANDed signal from both input terminal signals is provided at function output Q, which can 
be further connected in the user program.
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Output Q = "1", when all inputs have the status "1".

Background 
The ASIsafe transmission protocol specifies that both the safety-related inputs of an AS‑i slave 
must have the status "1" (valid code sequence) for the transmitted signal to be considered safe. 
In this way, the two inputs of the slave cannot be used individually for safety-related purposes. 
Any deviation from the valid code sequence, either through an error or a signal change to "0" on 
at least one input, must result in shutdown.

Parameters
Parameter name Description/parameter value
General Name Enter a name for the element.

Comment This text appears above the function element in the diagram. This may, for 
example, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the 
number.

Element activated When this parameter is active, the function element is processed in the 
safety logic. 
When this parameter is deactivated, the substitute value is used.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is 
deactivated.

Parameter - Input IN1 IN1 and IN2 are monitored for "1," i.e. function output Q is deactivated 
when there is at least one "0" signal.

IN2 IN2 is automatically assigned depending on the selected input IN1.
Input delay [ms] Select here when the function element will further process the signals: 

• Input delay = "0":
The input signals are further processed by the function element with‐
out time delay when there is a signal change.

• Input delay not "0":
This parameter can be used to suppress signal interference. The signal 
state that was pending for most of the duration of the input delay is 
further processed.

Please note that the delay time specified by you is a multiple of the pro‐
gram cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the re‐
sponse times in the manual of the safety relay.
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8.4 Muting functions

8.4.1 Muting safety circuit

Application     
If materials have to be conveyed into or out of a hazardous zone for further processing, the 
openings of the access paths can be large enough to enable a person to reach into or enter the 
hazardous zone. The requirement is to protect persons who may attempt to enter the hazardous 
zone from harm while allowing the materials to pass automatically unhindered. This is achieved 
with a special safety circuit that monitors the opening to the hazardous zone with electro-
sensitive protective equipment (ESPE) and deactivates or "overrides" the protective equipment 
briefly when the material is conveyed. This safety circuit is known as "muting" and is described 
in the standard EN 61496‑1‑A.7.   

Properties
The function element has the following inputs:
• Function input "FREE" for acquiring the signal of the protection equipment (e.g. ESPE)
• 2 or 4 function inputs "MS1" ... "MS4" for acquiring the signals of the muting sensors
• a "STOP" function input for acquiring the system status
• a function input "RESTART" for clearing the muting section
The function element provides the following signals as the result:
• The switch-on/off signal for the system is output through function output "Q."
• The "Muting active" or "Muting restart possible" status (0.5-Hz flashing) is output through 

function output "MUT."
• Error messages are output through function output "FAULT"

Note
The sensors for starting and ending muting operation must be mutually independent and 
permanently wired.

Description
The "Muting" function element permits temporary suppression (muting) of a protective field 
safety function for a specific purpose, e.g. for conveying materials through the protective field.
This muting mode has the following properties:
• Muting cannot be disabled from the application.
• Muting is time-monitored and is possible for no longer than the parameterized "max. muting 

time."
• The signal of the protective field safety function is read in by the function element at function 

input FREE.
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• If the value "1" is applied to function input FREE (protective field free), function output Q is 
set to the value "1" (system running), provided that the "Muting" function element has not 
detected an error.

• If muting operation has been started, the value at function input FREE will be suppressed, i.e. 
the value "1" is still output at function output Q despite the protective field violation. The 
safety function is suppressed and the system continues to run.

• After muting has ended, the value at function input FREE is evaluated again. The overridden 
safety function is activated again.

Muting operation
The following figure shows a typical muting arrangement

① Muting indicator light
② Light array
③ Muting sensors

Figure 8-1 Typical muting equipment
Muting can be divided into five "muting phases":
• Phase 1 (= muting off)

– The muting section is free
– The material is in front of the opening or still in front of the muting sensors.
– The protective equipment is still active and the muting indicator light is off.

• Phase 2 (= start muting)
– The material is moving into the muting section and the material triggers the muting 

sensors for starting muting.
– The protective equipment is now overridden and the muting indicator light is on.
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• Phase 3 (= in muting)
– The material moves from the input to the output area of the muting section and the 

material triggers both the muting sensors for starting muting and the muting sensors for 
ending muting.

– The protective equipment is overridden and the muting indicator light is on.
• Phase 4 (= stop muting)

– The material moves out of the muting section.
– The material has passed the muting sensor for starting muting. Now only the muting 

sensors for stopping muting are triggered.
– The protective equipment is still overridden and the muting indicator light is still on.

• Phase 5 (= end muting)
– The material exits the muting section.
– The material has passed the muting sensors for ending muting.
– The protective equipment is active again and the muting indicator light is off.
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Muting modes   
Two mode groups are used for the "muting" function element with up to four muting sensors (= 
two pairs of sensors) at function inputs MS1 to 4:
• Parallel muting

– 2-sensor parallel muting is possible if the dimensions of the conveyed material are not 
constant or too little space is available. This muting type must be operated with two 
muting sensors whose beams cross behind the protective field in the hazardous zone. To 
prevent tampering, the point where the muting sensor light barriers cross must be far 
enough inside the hazardous zone. No direction monitoring is possible because it is not 
possible to detect from which side the conveyed material is coming.

!

– 4-sensor parallel muting is used for very small conveyed materials. This type of muting is 
the functional equivalent to 2-sensor parallel muting but the activation and deactivation 
signal is obtained from two pairs of sensors each. Material conveying is possible in both 
directions.

!

• Sequential (= serial) muting
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– 4-sensor sequential muting is used, above all, if the material to be conveyed into the 
hazardous zone always has the same dimensions and there is no lack of space. Material 
conveying is possible in both directions.

!

8.4.2 Description of the "muting" function
The signals of the muting sensors are monitored for signal discrepancy and signal sequence, 
depending on the muting mode.

Discrepancy monitoring     
Signal discrepancy
For the duration of the discrepancy time, different signal states are accepted at the two muting 
sensors forming a sensor pair without an error being signaled. On a signal discrepancy, only the 
signals of the muting sensor belonging to a muting sensor pair are monitored. In the case of 
muting sensor pair 1, these are the muting sensors MS1 and MS2; for muting sensor pair 2, 
muting sensor MS3 and MS4. For a definable max. time (= "Discrepancy time" parameter), the 
signal states of the associated muting sensors must be different. On violation of the signal 
discrepancy condition, muting is ended and a discrepancy error (= logic error) is signaled. This 
error is automatically acknowledged as soon as the corresponding muting sensors have the 
value "0," i.e. they are no longer being triggered. While a discrepancy error is pending, the 
muting section can be cleared using the RESTART function. This is indicated, e.g. by the flashing 
muting indicator light. 
Discrepancy monitoring is not performed in "4-sensor sequential" muting mode.

Signal dropout
The discrepancy time also allows signal dropouts of muting sensors, e.g. due to "gaps in 
conveyed materials", to be overridden for a period of time. Signal dropouts that are shorter than 
the assigned discrepancy time do not terminate muting.
The signal dropout suppression action of the "Discrepancy time" parameter affects all muting 
sensors, even in "4-sensor sequential" muting mode.
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Sequence monitoring   
Signal sequence monitoring is only possible in muting modes with more than 2 muting sensors. 
In the case of 4-sensor sequential muting, the signals of all four muting sensors and, in the case 
of 4-sensor parallel muting, the signals of the muting sensor pairs are monitored for their 
sequence. On violation of the sequence condition, muting is ended and a sequence error (= logic 
error) is signaled. This error is automatically acknowledged as soon as all muting sensors have 
the value "0," i.e. they are no longer being triggered. While a sequence error is pending, the 
muting section can be cleared using the RESTART function. This is indicated, e.g. by the flashing 
muting indicator light.

Muting time limit   
Correctly started muting is only possible for a defined maximum duration. Muting is ended no 
later than when the max. muting time has elapsed. Muting can only be restarted after a valid 
muting sensor sequence has been detected or, if the muting section is still occupied, after the 
RESTART command has been detected.
The muting time limit has no effect in the following cases:
• During clearance of the muting section with the RESTART command.
• If function input STOP is providing the information "System stopped."

Note
If it is possible that the conveyed material may remain in the muting section for a long time, 
for example, because the conveyor belt has been stopped, the answer is not to set the muting 
time limit to a very large value or to deactivate it. Instead, function input STOP should be 
linked with the "belt drive signal."

• If the time limit has been deactivated by parameter assignment.
WARNING

Unsecured hazardous locations.
Can Cause Death, Serious Injury, or Property Damage.
The muting time limit must only be shut down in justified cases, e.g. if the flow of materials 
is not normally interrupted in the muting section and if this does not pose a hazard to any 
person. If the muting time limit is deactivated, access to the hazardous locations must be 
prevented by suitable means.

System status "STOP"
If the system is operationally shut down while muting is active, this results in a (muting) error, 
e.g. because of a discrepancy error of the muting sensor signals or because the max. muting 
time has elapsed. To avoid this (muting) error, the system status must be acquired and evaluated.
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The "muting" element acquires the state of the system using function input STOP:
• STOP = 0: System running. All monitoring functions of the "muting" element are processed 

according to their parameter assignment.
• STOP = 1: System stopped. While muting operation is active, the time monitoring functions 

"muting time limit" and "discrepancy time monitoring of the muting sensors" are deactivated 
automatically. This prevents muting error messages due to elapsed times resulting from 
system shutdown.
The signal sequence and signal discrepancy evaluation (but without discrepancy time 
monitoring) of the muting sensor signals remains active. The value of function output Q is 
not changed. When the system is started again, the timers of the time monitoring function 
are reset or restarted. The signal sequence and signal discrepancy monitoring of the muting 
sensors is continued normally.

If the STOP function input is not connected, the system status will not be evaluated, i.e. the time 
monitoring functions are not affected.

Muting - RESTART function
A valid muting sequence can be interrupted operationally, e.g. on a power failure, while 
materials are being conveyed through the muting section. On power recovery, muting is not 
automatically resumed because the expected muting sensor sequence is not provided by the 
muting sensors already triggered. It may also be necessary to clear the muting section, for 
example, if the load of a pallet is unfavorably distributed so that only one muting sensor was 
triggered. To be able to remove conveyed material from the muting section without danger, the 
"muting" element provides the RESTART function for clearing the muting section.

Function input FEEDBACK_MUT
See "Muting indicator light" section

Function output MUT
The "muting active" state is output via a dedicated function output MUT to which, for example, 
a muting indicator light or a logical output terminal (e.g. PROFINET) can be connected.
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Muting indicator light
• The muting indicator light signals the following states:

– Steady light: muting has been correctly started and the protective equipment for 
monitoring the protective field is overridden.

– Flashing: clearance of the muting section is possible.
• Properties:

– To be able to control a muting indicator light, the "muting" element sets function output 
MUT to the value "1" if muting is active. This function output can be interconnected to a 
hardware or logical output terminal (e.g. PROFINET).

– It is optionally possible to monitor a muting indicator light connected to function output 
MUT using function input FEEDBACK_MUT. Depending on the available information 
about the status of the indicator light, e.g. directly from the indicator light itself or from 
a higher-level PLC, the evaluation logic of the signal can be selected at function input 
FEEDBACK_MUT using parameter "Monitoring - Muting indicator light". This parameter 
also enables deactivation of the monitoring function.

• Parameter "Monitoring - Muting indicator light"
– Deactivated: The muting indicator light is not monitored.
– statically for "1" = OK:

With this parameter assignment, for example, the feedback signals of a "self-monitoring 
muting indicator light" can be monitored.
FEEDBACK_MUT value "0": => Muting indicator light defective
FEEDBACK_MUT value "1": => Muting indicator light OK

– dynamically for MUT:
Signal evaluation at the FEEDBACK_MUT function input is performed by comparison with 
the output signal of function output MUT. On a signal change at function output MUT, the 
inverted signal from function output MUT is expected no later than after the 
parameterized "switching time muting indicator light" has elapsed.
When the 0.5-Hz flashing signal is output, the feedback signal is not monitored, i.e. the 
signal at function input FEEDBACK_MUT, can have any value. On deactivation of the 
flashing signal, however, the feedback signal corresponds to the inverted value of 
function output MUT no later than after the "switching time" has elapsed. Otherwise, an 
error will be generated.

• If a indicator light is defective, function output Q is set to the value "0" and the "muting 
indicator light defective" error message is set. This error message must be acknowledged 
with reset after the error has been corrected.
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8.4.3 Clearing the muting section

Requirements   
Clearance of the muting section can only be started if all the following conditions have been 
fulfilled: 
• At least one muting sensor is being triggered.
• Function input RESTART is connected.

If function input RESTART is not connected, the protective equipment cannot be cleared. 
• The "muting restart possible" message is set.
• A 0.5-Hz flashing signal is output at function output MUT. The muting indicator light flashes.

Starting clearance

WARNING
Unsecured hazardous location.
Can Cause Death, Serious Injury, or Property Damage.
The clearance operation must be observed. It must be possible to respond to a hazardous 
situation by releasing the RESTART button at any time. The button must be installed in a 
location from which the entire hazardous area can be seen.

To start clearance of the muting section, the following steps (1 to 3) must be completed within 
4 s.
• Press the RESTART button connected to the function input for at least 0.15 s.
• Then release the RESTART button for at least 0.15 s.
• Press the RESTART button again and hold it down.
• The following messages will then appear:

– The "muting restart possible" message is reset.
– The "muting active" message is set.
– Function output MUT outputs a 1 signal.

Duration of muting with the RESTART button
Muting remains active if one of the following conditions applies:
• As long as the button remains pressed with an invalid muting sensor signal combination.
• Until the muting sensors end muting while the button is pressed.
• If a valid muting sensor signal combination is detected when the button is released the 

second time, assuming there are no other errors such as a signal discrepancy.
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8.4.4 Muting (2-sensor-parallel)

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Muting functions Muting (2-sensor-paral‐
lel)

‑ ✓ ✓

Note
The function element is not available in Safety ES for all devices. If a device that does not support 
this function element is configured in the configuration, the function element is hidden in the 
catalog window.

Description   

!

Figure 8-2 Muting 2-sensor parallel scheme
With the "Muting (2 sensor-parallel)" function element, you monitor an override circuit (= 
muting) with the following properties using signals from a pair of sensors:
• Muting can be performed at very short intervals without incurring a muting error.
• When a gap is detected between two conveyed items, muting is ended correctly and started 

again immediately when the next conveyed item is detected.
• If no gap is detected, muting is not ended. Only the maximum permissible muting time ends 

muting.
• The muting sensors are monitored for signal discrepancy.
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WARNING
Danger from tampering.
Can Cause Death, Serious Injury, or Property Damage.
To prevent tampering, the beams of the two muting sensors must cross far enough behind 
protective field. If possible, the beams should point downward at different heights.

Note
On a signal change at the FEEDBACK_MUT function input, an error is generated immediately, if 
the signal at function output MUT has not changed.

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for ex‐
ample, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated If this parameter is active, the function element is processed in the safety logic.

If the parameter is deactivated, the set substitute values are made available at 
outputs Q and MUT.

Function output substitute 
value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Substitute value for func‐
tion output MUT

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output MUT = 0
substitute value "1" means output MUT = 1
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Parameter name Description/parameter value
Parameters Muting time infinite You can set the muting time to infinite.

Please note the safety instructions (Page 212).
Max. muting time [s] Enter the time after which operational muting will have ended at the latest.

You can set the max. muting time between 1 and 10800 s [3 h] in steps of 1 ms.
The muting time is started when muting is correctly started by the muting sen‐
sors.

Discrepancy time [ms] You can set the discrepancy time between 0 and 60000 ms. 
• For the duration of the discrepancy time, different signal states are accepted 

at the two muting sensors forming a sensor pair without an error being sig‐
naled.

• During active muting, signal dropouts of muting sensors are accepted for the 
duration of the discrepancy time without ending muting.

Please note that the discrepancy time specified by you is a multiple of the program 
cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response times 
in the manual of the safety relay.
While a discrepancy error is pending, you can clear the muting section using the 
RESTART function. This is indicated (e.g. flashing muting indicator light).

Monitoring of the muting 
indicator light

You can activate the monitoring function for the muting indicator light and 
choose the desired evaluation logic of the feedback signal at function input 
FEEDBACK_MUT:
• Deactivated
• statically for "1" = OK
• dynamically for MUT

switching time muting indi‐
cator light [s]

You can adapt the monitoring function for the indicator light to the switching 
time depending on the indicator light.
You can set the switching time between 0.01 and 30 s. in steps of 1 ms.
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8.4.5 Muting (4-sensor-parallel)

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Muting functions Muting (4-sensor-paral‐
lel)

‑ ✓ ✓

Note
The function element is not available in Safety ES for all devices. If a device that does not support 
this function element is configured in the configuration, the function element is hidden in the 
catalog window.

Description   

!

Figure 8-3 4-sensor-parallel scheme
With the "Muting (4 sensor-parallel)" function element, you monitor a override circuit (= muting) 
with the following properties using signals from two pairs of sensors (MS1 & MS2 and MS3 & 
MS4):
• This muting mode is used where there is little space.
• The muting sensors are time-monitored in pairs for signal discrepancy.
• The muting is triggered if either sensors MS1 and MS2 (= sensor pair 1) or MS3 and MS4 (= 

sensor pair 2) are activated within a certain discrepancy time.
• The muting sensors are monitored for sequence. The following are possible as a sequence:

– activation of "MS1 & MS2 → MS3 & MS4" and then deactivation of 
"MS1 & MS2 → MS3 & MS4"

– activation of "MS3 & MS4 → MS1 & MS2" and then deactivation of 
"MS3 & MS4 → MS1 & MS2"

• For the sequence conditions to be fulfilled, the conveyed material must be as long as the 
distance between MS1 & MS2 and MS3 & S4.
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• On deviation from the permissible sequence, muting is ended and a sequence error is output.
• Muting is not specific to a direction.

Note
On a signal change at the FEEDBACK_MUT function input, an error is generated immediately, if 
the signal at function output MUT has not changed.

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for exam‐
ple, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated If this parameter is active, the function element is processed in the safety logic.

If the parameter is deactivated, the set substitute values are made available at 
outputs Q and MUT.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Substitute value for func‐
tion output MUT

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output MUT = 0
substitute value "1" means output MUT = 1
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Parameter name Description/parameter value
Parameters Muting time infinite You can set the muting time to infinite.

Please note the safety instructions (Page 212).
Max. muting time [s] Specify the time after which operational muting will have ended at the latest.

You can set the max. muting time between 1 and 10800 s [3 h] in steps of 1 ms.
The muting time is started when muting is correctly started by the muting sensors.

Discrepancy time [ms] You can set the discrepancy time between 0 and 60000 ms.
• For the duration of the discrepancy time, different signal states are accepted at 

the two muting sensors forming a sensor pair without an error being signaled.
• During active muting, muting sensor signal dropouts are accepted for the du‐

ration of the discrepancy time without ending muting. 
Please note that the discrepancy time specified by you is a multiple of the program 
cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response times 
in the manual of the safety relay.
While a discrepancy error is pending, you can clear the muting section using the 
RESTART function. This is indicated (e.g. flashing muting indicator light).

Monitoring of the muting 
indicator light

You can activate the monitoring function for the muting indicator light and choose 
the desired evaluation logic of the feedback signal at function input FEED‐
BACK_MUT:
• Deactivated
• statically for "1" = OK
• dynamically for MUT

switching time muting in‐
dicator light [s]

You can adapt the monitoring function for the indicator light to the switching time 
depending on the indicator light.
You can set the switching time between 0.01 and 30 s. in steps of 1 ms.
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8.4.6 Muting (4-sensor-sequential)

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Muting functions Muting (4-sensor-se‐
quential)

‑ ✓ ✓

Note
The function element is not available in Safety ES for all devices. If a device that does not support 
this function element is configured in the configuration, the function element is hidden in the 
catalog window.

Description   

!

Figure 8-4 Muting 4-sensor-sequential scheme
With the "Muting (4 sensor-sequential)" function element, you monitor an override circuit (= 
muting) with the following properties using signals from four independent sensors (MS1 to 
MS4):
• This muting mode is used if there is sufficient space for entry into and exit from the hazardous 

zone and the conveyed material always has the same dimensions.
• The muting sensors are only monitored for sequence of triggering and non-triggering.

The following are possible as a sequence:
– triggering of "MS1 -> MS2 -> MS3 -> MS4" and ending triggering of "MS1 -> MS2 -> MS3 

-> MS4"
– triggering of "MS4 -> MS3 -> MS2 -> MS1" and ending triggering of "MS4 -> MS3 -> MS2 

-> MS1"
• For the sequence conditions to be fulfilled, the conveyed material must be as long as the 

distance between MS1 and MS4. On deviation from the permissible sequence, muting is 
ended and a sequence error is output.

• The time interval between the sensor signals is not relevant.
• Muting is not specific to a direction.
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Note
STOP function
When STOP is activated, the interference suppression is deactivated automatically. This results 
in limited usability of the STOP function for conveyed material with gaps. In this case, 4-sensor 
parallel muting must be used.

WARNING
Danger from temporary deactivation of muting.
Can cause Death, Serious Injury, or Property Damage
If the conveyed material feed is stopped in muting phase 2 (see chapter "Muting safety circuit 
(Page 208)") and the conveyed material is moved again in the opposite direction, muting 
remains active initially. After ending triggering of the last muting sensor and expiration of the 
assigned discrepancy time in which signal dropouts are accepted, muting is deactivated. 
Monitoring of the protective field is resumed only afterwards. For this reason, the shortest 
possible discrepancy time must be chosen.

Note
On a signal change at the FEEDBACK_MUT function input, an error is generated immediately, if 
the signal at function output MUT has not changed.

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for ex‐
ample, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated If this parameter is active, the function element is processed in the safety logic.

If the parameter is deactivated, the set substitute values are made available at 
outputs Q and MUT.

Function output substitute 
value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Substitute value for func‐
tion output MUT

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output MUT = 0
substitute value "1" means output MUT = 1
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Parameter name Description/parameter value
Parameters Muting time infinite You can set the muting time to infinite.

Please note the safety instructions (Page 212).
Max. muting time [s] Enter the time after which operational muting will have ended at the latest.

You can set the max. muting time between 1 and 10800 s [3 h] in steps of 1 ms.
The muting time is started when muting is correctly started by the muting sen‐
sors.

Discrepancy time [ms] You can set the discrepancy time between 0 and 60000 ms.
• During active muting, signal dropouts of muting sensors are accepted for the 

duration of the discrepancy time without ending muting.
Please note that the discrepancy time specified by you is a multiple of the program 
cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response times 
in the manual of the safety relay.

Monitoring of the muting 
indicator light

You can activate the monitoring function for the muting indicator light and 
choose the desired evaluation logic of the feedback signal at function input 
FEEDBACK_MUT:
• Deactivated
• statically for "1" = OK
• dynamically for MUT

switching time muting indi‐
cator light [s]

You can adapt the monitoring function for the indicator light to the switching 
time depending on the indicator light.
You can set the switching time between 0.01 and 30 s. in steps of 1 ms.

8.5 Status functions

8.5.1 Device status

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Status functions Device status ✓ ✓ ✓

Description     
The "Device status" function element provides status information about the safety relay. When 
the status activated in the parameter "Status type" exists, the function output Q is set to "1".
With the "Device status" function element, defined responses can be implemented in the 
downstream logic by connecting the function output Q in the logic diagram.
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Parameters
Parameter name Description/parameter value 
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic.

When the parameter is deactivated, the set substitute value is made available at 
output Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameter Status type Select the status message to be displayed at the function output Q. Your options are:
• No status information
• Group error
• Group warning (not in the case of MSS 3RK3 Basic)
• Group prewarning (not in the case of MSS 3RK3 Basic)
• Logic error
• Test mode active
• Safety mode active
You can find further information on the status message in the manual of the safety 
relay under "Data set 92".

8.5.2 Element status

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay
 

Status functions Element status ‑ ✓ ✓

Note
The function element is not available in Safety ES for all devices. If a device that does not support 
this function element is configured in the configuration, the function element is hidden in the 
catalog window.

Description     
The "Element status" function element allows you to connect certain messages of a function 
element in the safety circuit. For example, a specific error can be displayed on the system by 
means of a signal lamp.
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic.

When the parameter is deactivated, the set substitute value is made available at 
output Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters Status element no. The parameter specifies the function element from which the element status will be 
provided. Only numbers that exist in the configuration may be entered.

Status type You can select a status information item for a particular function element, which will 
then be output at the function output:
• No status information

This parameter setting enables, for example, use of this element as a space 
holder. The function output outputs the value "0."

• Timer is active
• Function waiting for startup test
• Logic error
• Wiring error
• Substitute input value active

8.6 Control functions

8.6.1 Device command

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Control functions Device command ✓ ✓ ✓

Description     
With the "Device command" function element, commands can be integrated into the safety relay 
and connected device-specifically. For example, a reset can be triggered using an external 
pushbutton or via the fieldbus (e.g. PROFINET).
When there is a positive edge "0 → 1" at the input IN, the command is executed.
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated If this parameter is active, the function element is processed in the safety logic.

If the parameter is deactivated, the command is not executed.
Parameter Command type • Execute no command

• Reset
• Apply code tables (MSS 3RK3 Advanced, MSS 3RK3 ASIsafe basic and MSS 3RK3 ASI‐

safe extended)

8.7 Logic functions

8.7.1 AND

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Logic functions AND ✓ ✓ ✓

Description     
The logic function "AND" has 1 to 5 function inputs IN and one function output Q.
Function output Q = "1", when all function inputs IN have the status "1".

Parameters 
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for ex‐
ample, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety 

logic.
When the parameter is deactivated, the set substitute value is made available at 
output Q.

Function output substitute 
value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters Number of logic inputs 1 to 5 elements can be parameterized for the element.
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8.7.2 OR

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Logic functions OR ✓ ✓ ✓

Description     
The logic function "OR" has 1 to 5 function inputs IN and one function output Q.
Function output Q = "1", when at least one function input has the status "1".

Parameters 
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for ex‐
ample, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety 

logic.
When the parameter is deactivated, the set substitute value is made available at 
output Q.

Function output substitute 
value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters Number of logic inputs 1 to 5 elements can be parameterized for the element.

8.7.3 XOR

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Logic functions XOR ✓ ✓ ✓

Description     
The logic function "XOR" has 1 to 5 function inputs IN and one function output Q.
Function output Q = "1", when only one logic input has the status "1" at the same time.
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Parameters 
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for ex‐
ample, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety 

logic.
When the parameter is deactivated, the set substitute value is made available at 
output Q.

Function output substitute 
value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters Number of logic inputs 1 to 5 elements can be parameterized for the element.

8.7.4 NAND

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Logic functions NAND ✓ ✓ ✓

Description     
The logic function "NAND" has 1 to 5 function inputs IN and one function output Q.
Function output Q = "0", when all function inputs have the status "1".

Parameters 
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for ex‐
ample, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety 

logic.
When the parameter is deactivated, the set substitute value is made available at 
output Q.

Function output substitute 
value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters Number of logic inputs 1 to 5 elements can be parameterized for the element.
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8.7.5 NOR

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Logic functions NOR ✓ ✓ ✓

Description     
The logic function "NOR" has 1 to 5 function inputs and one function output Q.
Function output Q = "0", when at least one function input has the status "1".

Parameters 
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for ex‐
ample, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety 

logic.
When the parameter is deactivated, the set substitute value is made available at 
output Q.

Function output substitute 
value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters Number of logic inputs 1 to 5 elements can be parameterized for the element.

8.7.6 NEGATION (NEG)

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Logic functions NEGATION ✓ ✓ ✓

Description     
The logic function "NEGATION" has one function input IN and one function output Q.
The input signal IN is output inverted at the function output Q. 
Function output Q = "1", when the input IN has the status "0".
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic. 

When this parameter is deactivated, the set substitute value is made available at 
output Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

8.8 Flip-flop

8.8.1 FF-SR

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Flip-flop FF-SR ✓ ✓ ✓

Description   
The safety relay supports the reset-dominant function "FF-SR". 
"Reset-dominant" means the function output Q cannot be set to "1" when the reset input R is "1".
The function element has:
• 2 inputs: Input for setting S, input for resetting R
• One function output Q 
The function output Q is formed in accordance with the following truth table:

Input for setting S Input for resetting R Function output Q
0 0 ‑
0 1 0
1 0 1
1 1 0

0 = low level
1 = high level 
- no change in the output status
Q = 1, when the input for setting S = "1" and the input for resetting R = "0".
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Q = 0, when the input for resetting R = "1".

Note
Simultaneity of signals
The inputs are detected once during each cycle time. Depending on when in the cycle the signal 
change takes place, the signal change will be detected in the same cycle time or not until the 
subsequent cycle time. It is thus possible that apparently simultaneous signal changes at two 
different inputs are not detected simultaneously by the logic.
To be able to detect a reset signal with certainty, the reset signal must be active longer than the 
set signal.
Take account of this behavior when creating your configuration.

Parameters 
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic. 

When this parameter is deactivated, the set substitute value is made available at 
output Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

8.9 Counter functions

8.9.1 Counter (0 -> 1)

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Counter functions Counter (0 → 1) ✓ ✓ ✓

Description   

Note
The count value is not stored. At the start of safety or test mode, all counters begin with their 
initial values.
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The safety relay supports the counter function "Counter (0 → 1)". The counter value is only 
changed when there is a positive edge at the counter inputs. The current counter value can be 
counted up or down via one proprietary counter input each. When a parameterizable counter 
limit value is achieved or overshot, the function output Q is set. 
The counter function has: 
• 3 inputs: CU - Counter input up, CD - Counter input down, R - Reset (parameterizable)
• One function output Q

Functional principle
• The counter value is increased by 1 with every positive edge at the "Counter input up", except 

when the counter value reaches the maximum value 65535.
• The count value is decreased by 1 with every positive edge at the "Count input down", except 

when the count value reaches the value 0.
• The counter value remains unchanged when there is a positive edge simultaneously at both 

counter inputs.

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic. 

When this parameter is deactivated, the set substitute value is made available at 
output Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters Counter limit value (CV) Set a counter limit value which is to be monitored (between 0 and 65535):
• Function output Q = "1" when the current counter value reaches this limit value.
• Function output Q = "0" when the current counter value falls below this limit 

value.
Reset You can select whether the counter value is set to "0" automatically or manually:

• Automatic
When the function output Q = "1", the counter value and function output Q are 
set to "0" after one program cycle of the safety relay.

• Manual
The counter value is set to "0", irrespective of the state of the function output Q.
If the counter value is not deleted after the limit value is exceeded, counting will 
continue.

• Automatic with manual reset
When the function output Q = "1", the counter value and function output Q are 
set to "0" after one program cycle of the safety relay.
The counter value can be reset to "0" when the function output Q = "0".
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8.9.2 Counter (1 -> 0)

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Counter functions Counter (1 → 0) ✓ ✓ ✓

Description   

Note
The count value is not stored. At the start of safety or test mode, all counters begin with their 
initial values.

The safety relay supports the counter function "Counter (1 → 0)". The counter value is only 
changed when there is a negative edge. The current counter value can be counted up or down 
via one proprietary counter input each. When a parameterizable counter limit value is achieved 
or overshot, the function output Q is set. 
The counter function has: 
• 3 inputs: CU - Counter input up, CD - Counter input down, R - Reset (parameterizable)
• One function output Q

Functional principle
• The counter value is increased by 1 with every negative edge at the "Counter input up", 

except when the counter value reaches the maximum value 65535.
• The counter value is decreased by 1 with every negative edge at the "Counter input down", 

except when the counter value reaches the value 0.
• The counter value remains unchanged when there is a positive edge simultaneously at both 

counter inputs.

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, be 
information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic. 

When this parameter is deactivated, the set substitute value is made available at output 
Q.

Function output sub‐
stitute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1
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Parameter name Description/parameter value
Parameters Counter limit value 

(CV)
Set a counter limit value which is to be monitored (between 0 and 65535):
• Function output Q = "1" when the current counter value reaches this limit value.
• Function output Q = "0" when the current counter value falls below this limit value.

Reset You can select whether the counter value is set to "0" automatically or manually:
• Automatic

When the function output Q = "1", the counter value and function output Q are set 
to "0" after one program cycle of the safety relay.

• Manual
The counter value is set to "0," irrespective of the state of function output Q.
If the counter value is not deleted after the limit value is exceeded, counting will 
continue.

• Automatic with manual reset
When the function output Q = "1", the counter value and function output Q are set 
to "0" after one program cycle of the safety relay.
The counter value can be reset to "0" when the function output Q = "0".

8.9.3 Counter (0 -> 1 / 1 -> 0)

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Counter functions Counter (0 → 1 / 1 → 0) ✓ ✓ ✓

Description   

Note
The count value is not stored. At the start of safety or test mode, all counters begin with their 
initial values.

The safety relay supports the counter function "Counter (0 → 1 / 1 → 0)". The counter value is 
only changed when there is a positive and negative edge. The current counter value can be 
counted up or down via one proprietary counter input each. When a parameterizable counter 
limit value is achieved or overshot, the function output Q is set. 
The counter function has: 
• 3 inputs: CU - Counter input up, CD - Counter input down, R - Reset (parameterizable)
• One function output Q
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Functional principle
• The counter value is increased by 1 with every positive and negative edge at the "Counter 

input up", except when the counter value reaches the maximum value 65535.
• The counter value is decreased by 1 with every positive and negative edge at the "Counter 

input down", except when the counter value reaches the value 0.
• The counter value remains unchanged when there is a positive edge simultaneously at both 

counter inputs.

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic. 

When this parameter is deactivated, the set substitute value is made available at out‐
put Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters Counter limit value 
(CV) 

Set a counter limit value which is to be monitored (between 0 and 65535):
• Function output Q = "1" when the current counter value reaches this limit value.
• Function output Q = "0" when the current counter value falls below this limit value.

Reset You can select whether the counter value is set to "0" automatically or manually:
• Automatic

When the function output Q = "1", the counter value and output Q are set to "0" 
after one program cycle of the safety relay.

• Manual
The counter value is set to "0", irrespective of the state of the function output Q.
If the counter value is not deleted after the limit value is exceeded, counting will 
continue.

• Automatic with manual reset
When the function output Q = "1", the counter value and function output Q are set 
to "0" after one program cycle of the safety relay.
The counter value can be reset to "0" when the function output Q = "0".
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8.10 Timer functions

8.10.1 With ON delay

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Timer functions With ON delay ✓ ✓ ✓

Description     

Note
The time value is not stored. At the start of safety or test mode, all time values begin with their 
initial values.

The safety relay supports the timer function "With ON delay". The function output Q is activated 
after the input (with a parameterizable delay time).
The timer function has:
• 2 inputs: IN, R ‑ Reset
• One function output Q

Note
MSS 3RK3 Basic limitation
MSS 3RK3 Basic does not support a reset input for this function element. 
The MSS 3RK3 Basic responds as if the "Reset" parameter has "deactivated" the value.

Functional principle
• If a "1" is detected at input IN and no reset is active, the delay time "t1" starts.
• After the delay time, function output Q is activated, i.e. set to "1", as long as there is a "1" at 

input IN.
• When there is an edge change at input IN before the the end of delay time "t1", the delay time 

continues. The function output Q remains deactivated, i.e. "0", if there is a "0" at input IN after 
the end of the delay time.
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"Reset" = "deactivated" and "Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = 
"deactivated". It also applies for "Reset" = "with positive edge" or "with negative edge", if there is 
no edge change at input R.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Delay time
① Either "1" or "0" is present.

Figure 8-5 Timer function "With ON delay" when "Reset" = "deactivated", "with negative edge", or "with 
positive edge".

"Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = "with positive 
edge".

Note
"Reset" = "with negative edge"
The behavior of the function element when "Reset" = "with negative edge" is exactly the same 
as when "Reset" = "with positive edge", except that the signal from R is inverted. Negative edge 
"1" > "0" is evaluated here.
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PWR Power supply
IN Function input
Q Function output
R Reset
t1 Delay time
tC Program cycle time

Figure 8-6 Timer function "With ON delay" when "Reset" = "with positive edge"

"Reset" = "with level 1"
The following diagram shows the behavior of the function element when "Reset" = "with level 1".

Note
Value "0" is present at function input R
If the value "0" is present at function input R, the behavior of the function element is the same 
as for the edge evaluation shown in the first diagram.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Delay time

Figure 8-7 Timer function "With ON delay" when "Reset" = "with level 1"
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic. 

When this parameter is deactivated, the set substitute value is made available at out‐
put Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters t1[s] • You enter the delay time here.
• The maximum value is 655 s, increment: 5 ms
Please note that the delay time specified by you is a multiple of the program cycle time 
specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response times in 
the manual of the safety relay.

Reset
(not in the case of MSS 
3RK3 Basic)

• deactivated
The timer cannot be reset selectively to the "initial position". 
The output Q is set/reset according to the input signal and the timer function. 

• with positive edge
When a positive edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored in 
this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a positive edge is detected again. 

• with negative edge
When a negative edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored in 
this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a negative edge is detected again. 

• with level 1
When the value "1" is detected at the reset input, all timers and the output Q are 
reset to the value "0" as long as the value "1" is present. The signal status at the 
timer trigger input is ignored in this process. The output Q assumes the value "0" 
for at least one program cycle.
The element starts over with its functionality only when the value "0" is detected 
again at the reset input. 1)

1) "Starts over" applies to timer functions that are started by level 1 at the timer trigger input: The timers are started if the value 
"1" is present at the timer trigger input.
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8.10.2 With ON delay (trigger)

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Timer functions With ON delay (trigger) ✓ ✓ ✓

Description     

Note
The time value is not stored. At the start of safety or test mode, all time values begin with their 
initial values.

The safety relay supports the timer function "With ON delay (trigger)". The function output Q is 
activated after the input (with a parameterizable delay time).
The timer function has: 
• 2 inputs: IN, R ‑ Reset
• One function output Q

Note
MSS 3RK3 Basic limitation
MSS 3RK3 Basic does not support a reset input for this function element. 
The MSS 3RK3 Basic responds as if the "Reset" parameter has "deactivated" the value.

Functional principle
• If a "1" is detected at input IN and no reset is active, the delay time "t1" starts.
• After the delay time, function output Q is activated, i.e. set to "1", as long as there is a "1" at 

input IN.
• The delay time is stopped on a 1 → 0 edge change at input IN On another 0 → 1 edge change, 

the delay time will restart. The function output Q remains deactivated, i.e. "0", if there is a "0" 
at input IN after the end of the delay time.
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"Reset" = "deactivated" and "Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = 
"deactivated". It also applies for "Reset" = "with positive edge" or "with negative edge", if there is 
no edge change at input R.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Delay time
① Either "1" or "0" is present.

Figure 8-8 Timer function "With ON delay (trigger)" when "Reset" = "deactivated", "with negative edge", 
or "with positive edge".

"Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = "with positive 
edge".

Note
"Reset" = "with negative edge"
The behavior of the function element when "Reset" = "with negative edge" is exactly the same 
as when "Reset" = "with positive edge", except that the signal from R is inverted. Negative edge 
"1" > "0" is evaluated here.
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PWR Power supply
IN Function input
Q Function output
R Reset
t1 Delay time
tC Program cycle time

Figure 8-9 Timer function "With ON delay (trigger)" when "Reset" = "with positive edge"

"Reset" = "with level 1"
The following diagram shows the behavior of the function element when "Reset" = "with level 1".

Note
Value "0" is present at function input R
If the value "0" is present at function input "R", the behavior of the function element is the same 
as for the edge evaluation shown in the first diagram.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Delay time

Figure 8-10 Timer function "With ON delay (trigger)" when "Reset" = "with level 1"
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic.

When the parameter is deactivated, the set substitute value is made available at output 
Q.

Substitute value "0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters t1[s] • You enter the delay time here.
• The maximum value is 655 s, increment: 5 ms
Please note that the delay time specified by you is a multiple of the program cycle time 
specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response times in 
the manual of the safety relay.

Reset
(not in the case of MSS 
3RK3 Basic)

• deactivated
The timer cannot be reset selectively to the "initial position". 
The output Q is set/reset according to the input signal and the timer function. 

• with positive edge
When a positive edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored in 
this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a positive edge is detected again. 

• with negative edge
When a negative edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored in 
this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a negative edge is detected again. 

• with level 1
When the value "1" is detected at the reset input, all timers and the output Q are 
reset to the value "0" as long as the value "1" is present. The signal status at the 
timer trigger input is ignored in this process. The output Q assumes the value "0" 
for at least one program cycle.
The element starts over with its functionality only when the value "0" is detected 
again at the reset input. 1)

1) "Starts over" applies to timer functions that are started by level 1 at the timer trigger input: The timers are started if the value 
"1" is present at the timer trigger input.
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8.10.3 Passing make contact

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Timer functions Passing make contact ✓ ✓ ✓

Description     

Note
The time value is not stored. At the start of safety or test mode, all time values begin with their 
initial values.

The safety relay supports the timer function "Passing make contact". An input signal generates 
a signal with parameterizable duration at function output Q.
The timer function has:
• 2 inputs: IN, R ‑ Reset
• One function output Q

Note
MSS 3RK3 Basic limitation
MSS 3RK3 Basic does not support a reset input for this function element. 
The MSS 3RK3 Basic responds as if the "Reset" parameter has "deactivated" the value.

Functional principle
• If a "1" is detected at input IN and no reset is active, the make time "t1" starts and function 

output Q is switched to "1".
• When there is a negative edge "1 → 0" at input IN before the the end of the time "t1", the time 

is reset. Function output Q is deactivated, i.e. set to "0".
• After the time period "t1", function output Q is deactivated, i.e. set to "0".
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"Reset" = "deactivated" and "Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = 
"deactivated". It also applies for "Reset" = "with positive edge" or "with negative edge", if there is 
no edge change at input R.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Make time
① Either "1" or "0" is present.

Figure 8-11 Timer function "Passing make contact" when "Reset" = "deactivated", "with negative edge", 
or "with positive edge".

"Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = "with positive 
edge".

Note
"Reset" = "with negative edge"
The behavior of the function element when "Reset" = "with negative edge" is exactly the same 
as when "Reset" = "with positive edge", except that the signal from R is inverted. Negative edge 
"1" > "0" is evaluated here.
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PWR Power supply
IN Function input
Q Function output
R Reset
t1 Make time
tC Program cycle time

Figure 8-12 Timer function "Passing make contact" when "Reset" = "with positive edge"

"Reset" = "with level 1"
The following diagram shows the behavior of the function element when "Reset" = "with level 1".

Note
Value "0" is present at function input R
If the value "0" is present at function input R, the behavior of the function element is the same 
as for the edge evaluation shown in the first diagram.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Make time

Figure 8-13 Timer function "Passing make contact" when "Reset" = "with level 1"
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic. 

When this parameter is deactivated, the set substitute value is made available at out‐
put Q.

Substitute value "0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameter t1[s] • You enter the make time here.
• The maximum value is 655 s, increment: 5 ms
Please note that the delay time specified by you can be a multiple of the program cycle 
time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response times in 
the manual of the safety relay.

Reset
(not in the case of MSS 
3RK3 Basic)

• deactivated
The timer cannot be reset selectively to the "initial position". 
The output Q is set/reset according to the input signal and the timer function. 

• with positive edge
When a positive edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored in 
this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a positive edge is detected again. 

• with negative edge
When a negative edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored in 
this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a negative edge is detected again. 

• with level 1
When the value "1" is detected at the reset input, all timers and the output Q are 
reset to the value "0" as long as the value "1" is present. The signal status at the 
timer trigger input is ignored in this process. The output Q assumes the value "0" 
for at least one program cycle.
The element starts over with its functionality only when the value "0" is detected 
again at the reset input. 1)

1) "Starts over" applies to timer functions that are started by level 1 at the timer trigger input: The timers are started if the value 
"1" is present at the timer trigger input.
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8.10.4 Passing make contact (trigger)

Function element Icons MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Timer functions Passing make contact 
(trigger)

✓ ✓ ✓

Description     

Note
The time value is not stored. At the start of safety or test mode, all time values begin with their 
initial values.

The safety relay supports the timer function "Passing make contact (trigger)". An input signal 
generates a signal with parameterizable delay time at function output Q. 
The timer function has:
• 2 inputs: IN, R ‑ Reset
• One function output Q

Note
MSS 3RK3 Basic limitation
MSS 3RK3 Basic does not support a reset input for this function element.
The MSS 3RK3 Basic responds as if the "Reset" parameter has "deactivated" the value.

Functional principle
• If a "1" is detected at input IN and no reset is active, the make time "t1" starts and function 

output Q is switched to "1".
• When there is a negative edge "1 → 0" at input IN before the the end of the time "t1", the time 

continues to elapse. Function output Q remains active, i.e. set to "1", during the time period 
"t1". When there is another positive edge "0 → 1" at input IN, time "t1" begins again.

• After the time period, function output Q is deactivated, i.e. set to "0".
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"Reset" = "deactivated" and "Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = 
"deactivated". It also applies for "Reset" = "with positive edge" or "with negative edge", if there is 
no edge change at input R.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Make time
① Either "1" or "0" is present.

Figure 8-14 Timer function "Passing make contact (trigger)" when "Reset" = "deactivated", "with 
negative edge", or "with positive edge".

"Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = "with positive 
edge".

Note
"Reset" = "with negative edge"
The behavior of the function element when "Reset" = "with negative edge" is exactly the same 
as when "Reset" = "with positive edge", except that the signal from R is inverted. Negative edge 
"1" > "0" is evaluated here.
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PWR Power supply
IN Function input
Q Function output
R Reset
t1 Make time
tC Program cycle time

Figure 8-15 Timer function "Passing make contact (trigger)" when "Reset" = "with positive edge"

"Reset" = "with level 1"
The following diagram shows the behavior of the function element when "Reset" = "with level 1".

Note
Value "0" is present at function input R
If the value "0" is present at function input R, the behavior of the function element is the same 
as for the edge evaluation shown in the first diagram.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Make time

Figure 8-16 Timer function "Passing make contact (trigger)" when "Reset" = "with level 1"
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, be 
information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic.

When the parameter is deactivated, the set substitute value is made available at output 
Q.

Substitute value "0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameter t1[s] • You enter the make time here.
• The maximum value is 655 s, increment: 5 ms
Please note that the delay time specified by you is a multiple of the program cycle time 
specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response times in the 
manual of the safety relay.

Reset
(not in the case of 
MSS 3RK3 Basic)

• deactivated
The timer cannot be reset selectively to the "initial position". 
The output Q is set/reset according to the input signal and the timer function. 

• with positive edge
When a positive edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored in 
this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a positive edge is detected again. 

• with negative edge
When a negative edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored in 
this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a negative edge is detected again. 

• with level 1
When the value "1" is detected at the reset input, all timers and the output Q are reset 
to the value "0" as long as the value "1" is present. The signal status at the timer trigger 
input is ignored in this process. The output Q assumes the value "0" for at least one 
program cycle.
The element starts over with its functionality only when the value "0" is detected 
again at the reset input. 1)

1) "Starts over" applies to timer functions that are started by level 1 at the timer trigger input: The timers are started if the value 
"1" is present at the timer trigger input.
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8.10.5 With OFF delay

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Timer functions With OFF delay ✓ ✓ ✓

Description     

Note
The time value is not stored. At the start of safety or test mode, all time values begin with their 
initial values.

The safety relay supports the timer function "With OFF delay". The function output Q is 
deactivated after the input (with a parameterizable delay time). 
The timer function has:
• 2 inputs: IN, R ‑ Reset
• One function output Q

Note
MSS 3RK3 Basic limitation
MSS 3RK3 Basic does not support a reset input for this function element.
The MSS 3RK3 Basic responds as if the "Reset" parameter has "deactivated" the value.

Functional principle
• If a "1" is detected at input IN and no reset is active, function output Q is set to "1".
• When there is a negative edge "1 → 0" at input IN, delay time "t1" begins.
• After the delay time, function output Q is deactivated, i.e. set to "0".
• When there is a positive edge "0 → 1" at input IN before the the end of the delay time "t1", the 

delay time continues. Function output Q remains active, i.e. set to "1".
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"Reset" = "deactivated" and "Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = 
"deactivated". It also applies for "Reset" = "with positive edge" or "with negative edge", if there is 
no edge change at input R.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Delay time
① Either "1" or "0" is present.

Figure 8-17 Timer function "With OFF delay" when "Reset" = "deactivated", "with negative edge", or 
"with positive edge".

"Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = "with positive 
edge".

Note
"Reset" = "with negative edge"
The behavior of the function element when "Reset" = "with negative edge" is exactly the same 
as when "Reset" = "with positive edge", except that the signal from R is inverted. Negative edge 
"1" > "0" is evaluated here.
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PWR Power supply
IN Function input
Q Function output
R Reset
t1 Delay time
tC Program cycle time

Figure 8-18 Timer function "With OFF delay" when "Reset" = "with positive edge"

"Reset" = "with level 1"
The following diagram shows the behavior of the function element when "Reset" = "with level 1".

Note
Value "0" is present at function input R
If the value "0" is present at function input R, the behavior of the function element is the same 
as for the edge evaluation shown in the first diagram.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Delay time

Figure 8-19 Timer function "With OFF delay" when "Reset" = "with level 1"
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, be 
information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic.

When the parameter is deactivated, the set substitute value is made available at output 
Q.

Function output sub‐
stitute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters t1[s] • You enter the delay time here.
• The maximum value is 655 s, increment: 5 ms
Please note that the delay time specified by you is a multiple of the program cycle time 
specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response times in the 
manual of the safety relay.

Reset
(not in the case of 
MSS 3RK3 Basic)

• deactivated
The timer cannot be reset selectively to the "initial position". 
The output Q is set/reset according to the input signal and the timer function. 

• with positive edge
When a positive edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored in 
this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a positive edge is detected again. 

• with negative edge
When a negative edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored in 
this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a negative edge is detected again. 

• with level 1
When the value "1" is detected at the reset input, all timers and the output Q are reset 
to the value "0" as long as the value "1" is present. The signal status at the timer trigger 
input is ignored in this process. The output Q assumes the value "0" for at least one 
program cycle.
The element starts over with its functionality only when the value "0" is detected 
again at the reset input. 1)

1) "Starts over" applies to timer functions that are started by level 1 at the timer trigger input: The timers are started if the value 
"1" is present at the timer trigger input.
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8.10.6 With OFF delay (trigger)

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Timer functions With OFF delay (trigger) ✓ ✓ ✓

Description     

Note
The time value is not stored. At the start of safety or test mode, all time values begin with their 
initial values.

The safety relay supports the timer function "With OFF delay (trigger)". The function output Q is 
deactivated after the input (with a parameterizable delay time). 
The timer function has:
• 2 inputs: IN, R ‑ Reset
• One function output Q

Note
MSS 3RK3 Basic limitation
MSS 3RK3 Basic does not support a reset input for this function element.
The MSS 3RK3 Basic responds as if the "Reset" parameter has "deactivated" the value.

Functional principle
• If a "1" is detected at input IN and no reset is active, function output Q is set to "1".
• When there is a negative edge "1 → 0" at input IN, delay time "t1" begins.
• When there is a positive edge "0 → 1" at input IN before the the end of delay time "t1", the 

delay time is reset. Function output Q remains active, i.e. set to "1".
• After the delay time, function output Q is deactivated, i.e. set to "0".
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"Reset" = "deactivated" and "Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = 
"deactivated". It also applies for "Reset" = "with positive edge" or "with negative edge", if there is 
no edge change at input R.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Delay time
① Either "1" or "0" is present.

Figure 8-20 Timer function "With OFF delay (trigger)" when "Reset" = "deactivated", "with negative 
edge", or "with positive edge".

"Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = "with positive 
edge".

Note
"Reset" = "with negative edge"
The behavior of the function element when "Reset" = "with negative edge" is exactly the same 
as when "Reset" = "with positive edge", except that the signal from R is inverted. Negative edge 
"1" > "0" is evaluated here.
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PWR Power supply
IN Function input
Q Function output
R Reset
t1 Delay time
tC Program cycle time

Figure 8-21 Timer function "With OFF delay (trigger)" when "Reset" = "with positive edge"

"Reset" = "with level 1"
The following diagram shows the behavior of the function element when "Reset" = "with level 1".

Note
Value "0" is present at function input R
If the value "0" is present at function input R, the behavior of the function element is the same 
as for the edge evaluation shown in the first diagram.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Delay time

Figure 8-22 Timer function "With OFF delay (trigger)" when "Reset" = "with level 1"
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic.

When the parameter is deactivated, the set substitute value is made available at out‐
put Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters t1[s] • You enter the delay time here.
• The maximum value is 655 s, increment: 5 ms
Please note that the delay time specified by you is a multiple of the program cycle time 
specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response times in 
the manual of the safety relay.

Reset
(not in the case of MSS 
3RK3 Basic)

• deactivated
The timer cannot be reset selectively to the "initial position". 
The output Q is set/reset according to the input signal and the timer function. 

• with positive edge
When a positive edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored 
in this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a positive edge is detected again. 

• with negative edge
When a negative edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored 
in this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a negative edge is detected again. 

• with level 1
When the value "1" is detected at the reset input, all timers and the output Q are 
reset to the value "0" as long as the value "1" is present. The signal status at the 
timer trigger input is ignored in this process. The output Q assumes the value "0" 
for at least one program cycle.
The element starts over with its functionality only when the value "0" is detected 
again at the reset input. 1)

1) "Starts over" applies to timer functions that are started by level 1 at the timer trigger input: The timers are started if the value 
"1" is present at the timer trigger input.
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8.10.7 Clocking

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Timer functions Clocking ✓ ✓ ✓

Description     

Note
The time value is not stored. At the start of safety mode, all time values begin with their initial 
values.

The safety relay supports the timer function "Clocking". The output is switched on and off 
periodically based on a parameterizable pulse/interval ratio.
The timer function has:
• 2 inputs: IN, R ‑ Reset
• One function output Q

Note
MSS 3RK3 Basic limitation
MSS 3RK3 Basic does not support a reset input for this function element. 
The MSS 3RK3 Basic responds as if the "Reset" parameter has "deactivated" the value.

Functional principle
• If a "1" is detected at input IN and no reset is active, the clock pulse generator starts. The 

function output Q sends pulses as long as the input is set to "1".
• When there is a negative edge "1 → 0" at input IN, the clock pulse generator stops and sets 

the function output Q to "0".
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"Reset" = "deactivated" and "Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = 
"deactivated". It also applies for "Reset" = "with positive edge" or "with negative edge", if there is 
no edge change at input R.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Pulse time
t2 Pause time
① Either "1" or "0" is present.

Figure 8-23 Timer function "Clocking" when "Reset" = "deactivated", "with negative edge", or "with 
positive edge".

"Reset" = "with positive edge" or "with negative edge"
The following diagram shows the behavior of the function element when "Reset" = "with positive 
edge".

Note
"Reset" = "with negative edge"
The behavior of the function element when "Reset" = "with negative edge" is exactly the same 
as when "Reset" = "with positive edge", except that the signal from R is inverted. Negative edge 
"1" > "0" is evaluated here.
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PWR Power supply
IN Function input
Q Function output
R Reset
t1 Pulse time
t2 Pause time
tC Program cycle time

Figure 8-24 Timer function "Clocking" when "Reset" = "with positive edge"

"Reset" = "with level 1"
The following diagram shows the behavior of the function element when "Reset" = "with level 1".

Note
Value "0" is present at function input R
If the value "0" is present at function input R, the behavior of the function element is the same 
as for the edge evaluation shown in the first diagram.

PWR Power supply
IN Function input
Q Function output
R Reset
t1 Pulse time
t2 Pause time

Figure 8-25 Timer function "Clocking" when "Reset" = "with level 1"
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, be 
information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic.

When the parameter is deactivated, the set substitute value is made available at output 
Q.

Function output sub‐
stitute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters t1[s] • Enter the pulse time t1 and the pause time t2 for the clock-pulse generator.
• The maximum value is 655 s, increment: 5 ms
Please note that the times you specified are a multiple of the program cycle time you 
specified in the properties of the safety relay.
You can find more information on the program cycle time and the response times in the 
manual of the safety relay.

t2[s]

Reset
(not in the case of 
MSS 3RK3 Basic)

• deactivated
The timer cannot be reset selectively to the "initial position". 
The output Q is set/reset according to the input signal and the timer function. 

• with positive edge
When a positive edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored in 
this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a positive edge is detected again. 

• with negative edge
When a negative edge is detected at the reset input, all timers and the output Q are 
reset once to the value "0". The signal status at the timer trigger input is ignored in 
this process. The output Q assumes the value "0" for at least one program cycle.
Afterwards, the element starts over with its functionality.1) The value of the reset 
input only becomes irrelevant when a negative edge is detected again. 

• with level 1
When the value "1" is detected at the reset input, all timers and the output Q are 
reset to the value "0" as long as the value "1" is present. The signal status at the timer 
trigger input is ignored in this process. The output Q assumes the value "0" for at 
least one program cycle.
The element starts over with its functionality only when the value "0" is detected 
again at the reset input. 1)

1) "Starts over" applies to timer functions that are started by level 1 at the timer trigger input: The timers are started if the value 
"1" is present at the timer trigger input.
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8.11 Start functions

8.11.1 Monitored start

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Start functions Monitored start ✓ ✓ ✓

Description     
The "Monitored start" function element requires as start condition status "1" at input IN and input 
START. When this condition is fulfilled, the function output Q is activated, i.e. set to "1".
The start signal at the START input is only valid when the following applies:
• The time sequence of the START signal corresponds to the values "0 → 1 → 0".
• Value "1" must be present for 0.15 to 2 s.

Figure 8-26 Start function "Monitored start"

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic.

When the parameter is deactivated, the set substitute value is made available at out‐
put Q.

Function output substi‐
tute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1
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8.11.2 Manual start

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Start functions Manual start ✓ ✓ ✓

Description     
The "Manual start" function element requires as start condition status "1" at input IN and input 
START. When this condition is fulfilled, the function output Q is activated, i.e. set to "1".
The start signal at the START input is only valid when the following applies:
The time sequence of the START signal corresponds to the values "0 → 1".

Figure 8-27 Manual start

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, be 
information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic.

When the parameter is deactivated, the set substitute value is made available at output 
Q.

Function output sub‐
stitute value

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

8.12 Output functions

8.12.1 Standard output

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Output functions Standard output ✓ ✓ ✓
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Description   
The "Standard output" function element is required to switch the hardware outputs of the 
standard output group.   

WARNING
Automatic system startup following transmission error at fieldbus inputs.
Can Cause Death, Serious Injury or Property Damage
Transmission errors at the fieldbus inputs can result in an erroneous start in which the system 
starts accidentally. To prevent this, the start type must be parameterized as "monitored."

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for example, 
be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activa‐
ted

When this parameter is active, the function element is processed in the safety logic.
When the parameter is deactivated, the set substitute value is made available at out‐
put Q.

Substitute value 
– Q1

"0" or "1" can be assigned to the substitute value when the element is deactivated. 
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Parameters - Out‐
put circuit

Q1 Select the output for the processed signal.
Auxiliary outputs Select whether auxiliary outputs are to be activated:

• No
• One auxiliary output
• Two auxiliary outputs

AUX1 Only available when at least one auxiliary output is activated:
Select the output to which the processed signal is to be output. The auxiliary output 
AUX1 supplies the same signal as Q. It can be interconnected with safety-related or 
standard outputs. 

AUX2 Only available when two auxiliary outputs are activated:
Select the output for the processed signal. The auxiliary output AUX2 supplies the 
same signal as Q. It can be switched with safety-related or standard outputs.

Parameter - 
Start
(not in the case of 
MSS 3RK3 Basic)

Start type • Automatic:
The function output is set as soon as all start conditions are fulfilled.

• Monitored:
Function output Q is set as soon as all start conditions are fulfilled and the start 
signal is changed from "0 → 1 → 0."

• Manual:
Function output Q is set as soon as all start conditions are fulfilled and the start 
signal is changed from "0 → 1."
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8.12.2 F output

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Output functions F output ✓ ✓ ✓

Description     
The "F output" function element can be used to switch the hardware outputs of the safety-
related devices on one or two channels.

WARNING
Automatic system startup following transmission error at fieldbus inputs.
Can Cause Death, Serious Injury or Property Damage
Transmission errors at the fieldbus inputs can result in an erroneous start in which the system 
starts accidentally. To prevent this, the start type must be parameterized as "monitored." This 
is necessary to achieve SILCL 3 as per EN 61508 and PL e/ Cat. 4 as per EN ISO 13849‑1.

Note
On a signal change at function input FEEDBACK, an error is generated immediately if the signal 
at function output Q has not changed.

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for exam‐
ple, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic. 

When this parameter is deactivated, the set substitute value is made available at 
output Q.

Substitute value – 
Q1

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Substitute value – 
Q2

Only available with output type "Redundant F output": 
"0" or "1" can be assigned to the substitute value when the element is deactivated. 

Parameter Output type Select the output type:
• Single F output
• Redundant F output
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Parameter name Description/parameter value
Parameter - Feed‐
back circuit 

Monitoring The signal at the feedback circuit input is monitored with time delay by comparing 
it with the current status of the function output.
Select the type of feedback circuit monitoring:
• Deactivated
• For OFF and ON status
• For OFF status

Switching time [s] Parameters are only available when Parameters - Feedback circuit monitoring "For 
OFF and ON status" or "For OFF status" is activated.
Select the switching time of the "auxiliary contacts" that depends on the function 
element.
Please note that the entered feedback circuit switching time is a multiple of the 
program cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response times 
in the manual of the safety relay.

Parameters - Out‐
put circuit

Q1 Select the output for the processed signal.
Q1 can only be interconnected with the output of a safety-related device.

Q2 Only available with output type "Redundant F output": 
Select the output for the processed signal.
Q2 can only be interconnected with the output of a safety-related device.

Auxiliary outputs Select whether auxiliary outputs are to be activated:
• No
• One auxiliary output
• Two auxiliary outputs

AUX1 Only available when at least one auxiliary output is activated:
Select the output to which the processed signal is to be output. The auxiliary output 
AUX1 supplies the same signal as Q. It can be interconnected with safety-related or 
standard outputs. 

AUX2 Only available when two auxiliary outputs are activated:
Select the output for the processed signal. The auxiliary output AUX2 supplies the 
same signal as Q. It can be switched with safety-related or standard outputs.

FAULT Select the output for the processed signal.
Parameter - 
Start
(not in the case of 
MSS 3RK3 Basic)

Start type • Automatic:
The function output is set as soon as all start conditions are fulfilled.

• Monitored:
Function output Q is set as soon as all start conditions are fulfilled and the start 
signal is changed from "0 → 1 → 0".

• Manual:
Function output Q is set as soon as all start conditions are fulfilled and the start 
signal is changed from "0 → 1".
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8.12.3 Standard output delayed

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Output functions Standard output de‐
layed

- - ✓

Note
The function element is not available in Safety ES for all devices. If a device that does not support 
this function element is configured in the configuration, the function element is hidden in the 
catalog window.

Description 
Applications of "Stop category 1" can be implemented with the function element "Switching 
output delayed". This describes, for example, controlled power-down of a drive with subsequent 
disconnection from the main power source:
• When switching the drive off, control signal Q1 is reset first, and then control signal Q2 is reset 

with a time delay.
• This sequence is reversed when switching the drive on: First, control signal Q2 is set, and then 

control signal Q1 is set with a time delay.
The switching status of the actuators is checked (feedback circuit monitoring) via the auxiliary 
contacts / feedback signals of the two "actuators" (contactor and soft starter).

WARNING
Automatic system startup following transmission error at fieldbus inputs.
Can Cause Death, Serious Injury or Property Damage
Transmission errors at the fieldbus inputs can result in an erroneous start in which the system 
starts accidentally. To prevent this, the start type must be parameterized as "monitored."
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for exam‐
ple, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic. 

When this parameter is deactivated, the set substitute value is made available at 
output Q.

Substitute value – 
Q1

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Substitute value – 
Q2

Only available with output type “Redundant standard output": 
"0" or "1" can be assigned to the substitute value when the element is deactivated. 

Parameters Output type Select the output type:
• Standard output
• Redundant standard output

Parameter - 
Output circuit -
Delay time (t)

On (Q2-t->Q1) [s] ON-delay time
When switching on function outputs Q1 and Q2, function output Q1 is switched on 
with a time delay in relation to output Q2. Set the length of the time delay (ON-
delay time).

Off (Q1-t->Q2) [s] OFF-delay time
When switching off function outputs Q1 and Q2, function output Q2 is switched 
off with a time delay in relation to output Q1. Set the length of the time delay (OFF-
delay time).

Bypass input • No
The delay time function of the element cannot be "overridden".

• Yes, with a pos. edge
When a positive edge is detected at the bypass input, a currently active delay 
time is evaluated as "expired" on a one-off basis, and outputs Q1 and Q2 are set/
reset in accordance with a properly expired delay time.

• Yes, with a neg. edge
When a negative edge is detected at the bypass input, a currently active delay 
time is evaluated as "expired" on a one-off basis, and outputs Q1 and Q2 are set/
reset in accordance with a properly expired delay time.

• Yes, with value "1"
When the value "1" is detected at the bypass input, a currently active delay time 
is evaluated as "expired" on a one-off basis, and outputs Q1 and Q2 are set/reset 
in accordance with a properly expired delay time.

Parameter - 
Output circuit -
Q1

Q1 Select the output for the processed signal.

Parameter - 
Output circuit -
Q2

Q2 Select the output for the processed signal.
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Parameter name Description/parameter value
Parameter - 
Output circuit -
AUX1

Auxiliary output 1 Select whether auxiliary output 1 (AUX1) is to be activated:
• No
• Yes

AUX1 Only available when auxiliary output 1 is activated:
Select the output for the processed signal. Auxiliary output AUX1 sends the same 
signal as Q1.

Parameter - 
Output circuit -
AUX2

Auxiliary output 2 Select whether auxiliary output 2 (AUX2) is to be activated:
• No
• Yes

AUX2 Only available when auxiliary output 2 is activated:
Select the output for the processed signal. Auxiliary output AUX2 sends the same 
signal as Q2. 

Parameter - 
Start

Start type • Automatic:
The function output is set as soon as all start conditions are fulfilled.

• Monitored:
Function output Q is set as soon as all start conditions are fulfilled and the start 
signal is changed from "0 → 1 → 0."

• Manual:
Function output Q is set as soon as all start conditions are fulfilled and the start 
signal is changed from "0 → 1."

8.12.4 F output delayed

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Output functions F output delayed - - ✓

Note
The function element is not available in Safety ES for all devices. If a device that does not support 
this function element is configured in the configuration, the function element is hidden in the 
catalog window.

Description 
Safety applications of "Stop category 1" can be implemented with the function element 
"Switching output delayed". This describes controlled power-down of a drive with subsequent 
disconnection from the main power source: 
• When switching the drive off, control signal Q1 is reset first, and then control signal Q2 is reset 

with a time delay.
• This sequence is reversed when switching the drive on: First, control signal Q2 is set, and then 

control signal Q1 is set with a time delay.

Function elements
8.12 Output functions

SIRIUS engineering Safety ES V1.0
Operating Manual, 12/2021, A5E32640754002A/RS-AF/006 273



It is possible to check the switching state of the two actuators (feedback circuit monitoring) via 
the auxiliary contacts / feedback signals of the two actuators.

WARNING
Reduced diagnostic coverage due to deactivation of the light test
Can Cause Death, Serious Injury, or Damage to Property
The light test can be deactivated in the case of the "F output delayed" output function. 
Deactivating the light test has an impact on diagnostic coverage. This has an impact on the 
category according to EN ISO 13849. Note that Cat. 4 in compliance with EN ISO 13849 at the 
respective terminal is achieved only if the light test has been activated. In addition, the function 
test interval (shutdown test) is reduced to ≤ 1 year for solid-state actuators. You can find further 
information on the test intervals in the Machinery Directive 2006/42/EC.

WARNING
Automatic system startup following transmission error at fieldbus inputs.
Can Cause Death, Serious Injury or Property Damage
Transmission errors at the fieldbus inputs can result in an erroneous start in which the system 
starts accidentally. To prevent this, the start type must be parameterized as "monitored." This 
is necessary to achieve SILCL 3 as per EN 61508 and PL e/ Cat. 4 as per EN ISO 13849‑1.

Note
When a signal is changed at the function input FEEDBACK1... 2, an error is generated 
immediately if the signal at the function output Q1... 2 has not changed.

Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for exam‐
ple, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the number.
Element activated When this parameter is active, the function element is processed in the safety logic. 

When this parameter is deactivated, the set substitute value is made available at 
output Q.

Substitute value – 
Q1

"0" or "1" can be assigned to the substitute value when the element is deactivated.
Substitute value "0" means output Q = 0
substitute value "1" means output Q = 1

Substitute value – 
Q2

Only available with output type "Redundant F output": 
"0" or "1" can be assigned to the substitute value when the element is deactivated. 

Parameter Output type Select the output type:
• Single F output
• Redundant F output
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Parameter name Description/parameter value
Parameter - Feed‐
back circuit 1

Monitoring The signal at the feedback circuit input is monitored with time delay by comparing 
it with the current status of the function output.
Select the type of feedback circuit monitoring:
• Deactivated
• For OFF and ON status
• For OFF status
Note: If the feedback contacts of the two actuators are to be monitored with one 
input, you must use feedback circuit 2.

Switching time [s] Parameters are only available when Parameters - Feedback circuit monitoring "For 
OFF and ON status" or "For OFF status" is activated.
Select the switching time of the "auxiliary contacts" that depends on the function 
element.
Please note that the entered feedback circuit switching time is a multiple of the 
program cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time in the manual of the 
safety relay.

Parameter - Feed‐
back circuit 2
 

Monitoring Only available with output type "Redundant F output":
The signal at the feedback circuit input is monitored with time delay by comparing 
it with the current status of the function output.
Select the type of feedback circuit monitoring:
• deactivated
• For OFF and ON status
• For OFF status
Note: If the feedback contacts of the two actuators are to be monitored with one 
input, you must use feedback circuit 2.

Switching time [s] Only available with output type "Redundant F output":
Parameters are only available when Parameters - Feedback circuit monitoring "For 
OFF and ON status" or "For OFF status" is activated.
Select the switching time of the "auxiliary contacts" that depends on the function 
element.
Please note that the entered feedback circuit switching time is a multiple of the 
program cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time in the manual of the 
safety relay.
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Parameter name Description/parameter value
Parameter - 
Output circuit -
Delay time (t)

On (Q2-t->Q1) [s] ON-delay time
When switching on function outputs Q1 and Q2, function output Q1 is switched on 
with a time delay in relation to output Q2. Set the length of the time delay (ON-
delay time).

Off (Q1-t->Q2) [s] OFF-delay time
When switching off function outputs Q1 and Q2, function output Q2 is switched 
off with a time delay in relation to output Q1. Set the length of the time delay (OFF-
delay time).

Bypass input • No
The delay time function of the element cannot be "overridden".

• Yes, with a pos. edge
When a positive edge is detected at the bypass input, a currently active delay 
time is evaluated as "expired" on a one-off basis, and outputs Q1 and Q2 are set/
reset in accordance with a properly expired delay time.

• Yes, with a neg. edge
When a negative edge is detected at the bypass input, a currently active delay 
time is evaluated as "expired" on a one-off basis, and outputs Q1 and Q2 are set/
reset in accordance with a properly expired delay time.

• Yes, with value "1"
When the value "1" is detected at the bypass input, a currently active delay time 
is evaluated as "expired" on a one-off basis, and outputs Q1 and Q2 are set/reset 
in accordance with a properly expired delay time.

Parameter - 
Output circuit -
Q1

Q1 Select the output for the processed signal.
Maximum read-
back time [ms]

Set the desired maximum read-back time dependent on the connected capacitive 
load.
For additional information on the maximum read-back time, in the "SIRIUS 3SK2 
Safety Relays“ manual, see the chapter "Dark test“.

Light test Select whether the light test is to be carried out:
• activated
• deactivated
For additional information on the light test, in the "SIRIUS 3SK2 Safety Relays” 
manual, see the chapter "Light test“.

Parameter - 
Output circuit -
Q2

Q2 Select the output for the processed signal.
Maximum read-
back time [ms]

Set the desired maximum read-back time dependent on the connected capacitive 
load.
For additional information on the maximum read-back time, in the "SIRIUS 3SK2 
Safety Relays“ manual, see the chapter "Dark test“.

Light test Select whether the light test is to be carried out:
• activated
• deactivated
For additional information on the light test, in the "SIRIUS 3SK2 Safety Relays” 
manual, see the chapter "Light test“.
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Parameter name Description/parameter value
Parameter - 
Output circuit -
AUX1

Auxiliary output 1 Select whether auxiliary output 1 (AUX1) is to be activated:
• No
• Yes

AUX1 Only available when auxiliary output 1 is activated:
Select the output for the processed signal. Auxiliary output AUX1 sends the same 
signal as Q1. 

Maximum read-
back time [ms]

Set the desired maximum read-back time as a function of the connected capacitive 
load.
For additional information on the maximum read-back time, in the manual "SIRIUS 
3SK2 safety relays”, see chapter "Dark test“.

Light test Select whether the light test is to be carried out:
• activated
• deactivated
For additional information on the light test, in the "SIRIUS 3SK2 Safety Relays” 
manual, see the chapter "Light test“.

Parameter - 
Output circuit -
AUX2

Auxiliary output 2 Select whether auxiliary output 2 (AUX2) is to be activated:
• No
• Yes

AUX2 Only available when auxiliary output 2 is activated:
Select the output for the processed signal. Auxiliary output AUX2 sends the same 
signal as Q2. 

Maximum read-
back time [ms]

Set the desired maximum read-back time dependent on the connected capacitive 
load.
For additional information on the maximum read-back time, in the "SIRIUS 3SK2 
Safety Relays“ manual, see the chapter "Dark test“.

Light test Select whether the light test is to be carried out:
• activated
• deactivated
For additional information on the light test, in the "SIRIUS 3SK2 Safety Relays” 
manual, see the chapter "Light test“.

Parameter -
Output circuit

FAULT Select the output for the processed signal.

Parameter - 
Start

Start type • Automatic:
The function output is set as soon as all start conditions are fulfilled.

• Monitored:
Function output Q is set as soon as all start conditions are fulfilled and the start 
signal is changed from "0 → 1 → 0".

• Manual:
Function output Q is set as soon as all start conditions are fulfilled and the start 
signal is changed from "0 → 1".
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8.12.5 AS-i 1..4F-DO

Function element Symbol MSS 3RK3 
Basic

MSS 3RK3 Advanced 
MSS 3RK3 ASIsafe

3SK2 safety relay

Output functions AS-i 1..4F-DO ‑ ✓ -

Note
The function element is not available in Safety ES for all devices. If a device that does not support 
this function element is configured in the configuration, the function element is hidden in the 
catalog window.

Description     
With the "AS-i 1..4F-DO" function element, safety-related AS-i outputs can be switched. A safety-
related AS-i output module can contain up to four safe outputs, wherein only one fail-safe 
output can be active at any given time.   
Up to 12 safety-related AS-i-outputs can be set/reset independently. The element can be placed 
multiple times for this purpose. You connect the F-OUT1 ... 4 signals from the safety-related AS-
i output with the corresponding AS-i address to the "output terminals" of the individual function 
elements.

Properties
The "AS-i 1..4F-DO" function element has the following properties:
• 4 function outputs for setting/resetting the 4 safety-related F-OUT1..4 outputs of an ASIsafe 

output slave. The equipment identifier (BMK) in the terminal address is that of the safety relay 
and not that of the ASIsafe output slave.

• One function input each for setting/resetting the 4 safety-related AS-i outputs. These 
function inputs are monitored in such a way that only one of the function inputs can have the 
value "1" at any one time. If this condition is violated, all safety-related outputs of this 
function element will be shut down and an error message to this effect is generated.

• 2 function inputs with which you can set and reset the two non-safety-related auxiliary 
control signals AUX1 and AUX2.
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Note
Non-safety-related auxiliary control signals (AUX1/AUX2)
In addition to the safety-related control signals (code sequences) of the AS‑i outputs, non-safety-
related auxiliary control signals (AUX1, AUX2) can also be transmitted. These are used, for 
example, to acknowledge a restart inhibit or to release errors at AS‑i outputs. Additional 
information can be found in the relevant documentation of the safety-related AS-i output.
The auxiliary control signals AUX1 and AUX2 are defined as pulses. That is why these terminals 
must not be used for static signals. This pulse is generated as soon as an edge change from zero 
to one is detected at the respective AUX input (an edge change from one to zero is not taken into 
consideration).
If a simultaneous edge change is detected for both inputs, the pulse for AUX2 is output after the 
pulse for AUX1.

Note
Forcing
Only one of the function outputs can have the value "1" at any one time. The other outputs are 
automatically forced to the value "0." If forcing of an output is canceled, forcing of all other 
outputs will also be canceled. If multiple outputs are forced to "1," the code sequence of the 
output with the lowest number will be output.

WARNING
Automatic system startup following transmission error at fieldbus inputs.
Can Cause Death, Serious Injury or Property Damage
Transmission errors at the fieldbus inputs can result in an erroneous start in which the system 
starts accidentally. To prevent this, the start type must be parameterized as "monitored." This 
is necessary to achieve SILCL 3 as per EN 61508 and PL e/ Cat. 4 as per EN ISO 13849‑1.

Note
On a signal change at function input FEEDBACK_1 ... 4, an error is generated immediately if the 
signal at function output Q1 ... 4 has not changed.
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Parameters
Parameter name Description/parameter value
General Name You can enter a name for the element here.

Comment This text appears above the function element in the diagram. This may, for 
example, be information about this function element.

Element number Consecutive number that is automatically assigned. You can change the num‐
ber.

Element activated When this parameter is active, the function element is processed in the safety 
logic. 
When this parameter is deactivated, the set substitute value is made available 
at output Q.

Function output sub‐
stitute value

The substitute value "1" can only be assigned to one output at a time. "0" is 
automatically assigned to all others. "0" or "1" can be assigned to the substitute 
value when the element is deactivated.

Parameter Output type Select the number of safety-related outputs required:
• 1F-DO
• 2F-DO
• 3F-DO
• 4F-DO

Parameter - Feed‐
back circuit - 
for outputs 1 to 4

Monitoring The signal at the feedback circuit input is monitored with time delay by com‐
paring it with the current status of the function output.
Select the type of feedback circuit monitoring:
• Deactivated
• For OFF and ON status
• For OFF status

Switching time [s] Parameters are only available when Parameters - Feedback circuit monitoring 
"For OFF and ON status" or "For OFF status" is activated.
Select the switching time of the "auxiliary contacts" that depends on the func‐
tion element.
Please note that the entered feedback circuit switching time is a multiple of the 
program cycle time specified by you in the properties of the safety relay.
You can find more information on the program cycle time and the response 
times in the manual of the safety relay.

Parameters - Output 
circuit

Q1 Select the output for the processed signal.
Q2-Q4 The fields are activated by the Output type parameter.

The outputs are assigned automatically according to the selected output Q1.
All 4 outputs must be on the same slave.

FAULT Select the output for the processed signal.
Parameter - Start Start type • Automatic:

The function output is set as soon as all start conditions are fulfilled.
• Monitored:

Function output Q is set as soon as all start conditions are fulfilled and the 
start signal is changed from "0 → 1 → 0."

• Manual:
Function output Q is set as soon as all start conditions are fulfilled and the 
start signal is changed from "0 → 1."
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Diagnostics 9
This diagnostics can be used to read the status of each system function element. Diagnostics 
with Safety ES is divided up into "Diagnostics configuration" and "Diagnostics logic".   
The diagnostics configuration provides users with an overview of the module status and the 
device messages. 
Diagnostics logic allows users to monitor system components. It also permits forcing.
Access to the diagnostics is possible via the fieldbus (PROFINET or PROFIBUS) and device 
interface depending on the existing license variant of Safety ES.

Note
A description of the diagnostics of older software versions of Safety ES is provided in the online 
help.

9.1 Diagnostics configuration

9.1.1 Module status

Requirements
The "Target system" > "Diagnostics configuration" > "Module status" menu command can only be 
selected if the main system or the subsystem is activated in the navigation window and if an 
online connection is established between Safety ES and the safety relay.

Module status     
When you choose "Target system" > "Diagnostics configuration" > "Module status", the status of 
the modules is shown in an additional column in the configuration table.
A red square indicates either a faulty module or a module that does not actually exist.

Note
In the main system, all modules after the first defective module can no longer be addressed.

Note
Diagnostics display
The status of the diagnostics display is not displayed.

SIRIUS engineering Safety ES V1.0
Operating Manual, 12/2021, A5E32640754002A/RS-AF/006 281



9.1.2 Dialog "Device messages" > "Overview" tab

Requirements
The menu command "Target system" > "Diagnostics configuration" > "Device messages" > 
"Overview" can only be selected when Safety ES is connected online with the safety relay.
The configuration supports the following messages:   

General
Status Symbol Meaning
Group error red At least one error is present.
Bus error red Communication to the fieldbus master is disturbed.
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present (e.g. "Safety sensor triggered").

Problem / Message - Possible remedial measures
In this window, problems / messages and possible remedial measures for these are shown in two 
columns.

Examples:
Problem / Message Possible remedial measures
Initialization error   • Switch off and switch on again the voltage supply of the device.

• The next time a device error is indicated, the device must be replaced.
Group error • The safety relay has detected at least one application-specific error. 

• More detailed messages will give the precise cause of the error.
Error in configuration   • Check the actual device configuration against the configured target configuration.

• Acknowledge after remedying the error.
AS-i code sequence error   • An incorrect AS-i code sequence was received from at least one safety-related AS-

i slave.
• Check the system for EMC interference and start up the system again.
• If code sequence errors occur again, replace the AS-i slave in question.

Disconnect   • Restore the connection again.
• Check whether another program is using and therefore blocking the interface.

Logic error   • The monitored sensor outputs an invalid signal sequence.
• Operate the monitored sensor in such a way that the start condition is fulfilled. 

Legends
The meaning of the symbols used in the Problem / Message - Possible remedial measures section 
and the urgency level of the colors used is explained in the legends. 
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9.1.3 "Device messages" dialog box > "Status" tab

Requirements
The menu command "Target system" > "Diagnostics configuration" > "Device messages" > 
"Status" can only be selected when Safety ES is connected online to the safety relay.
The configuration supports the following messages:   

General
Status Symbol Meaning
Group error Red At least one error is present.
Bus error Red Communication to the fieldbus master is disturbed.
Group warning Yellow At least one warning is present.
Group prewarning Yellow At least one prewarning is present (e.g. "Safety sensor triggered").

Group error
Status Symbol Meaning
Device fault Red • Faulty input or output

• Defective device
Configuring error   Red An error occurred during the configuring phase.
Configuration error   Red TARGET slot configuration not equal ACTUAL slot configuration.
Safety protocol error   Red • Communication with a safety-relevant communications partner is disrup‐

ted; for example, communications disrupted due to effects of EMC.
• Code sequence error (MSS 3RK3 Advanced, MSS 3RK3 ASIsafe basic and 

MSS 3RK3 ASIsafe extended)
Group error from user program Red At least one error is present.
Wiring error   Red Faulty wiring of a sensor connection or in the sensor itself.
Logic error   Red Protection fault: Processing sequence on the sensor not coherent.
For an element number Issues the number of the lowest element on which the group error is pending.

Bus error   
Status Symbol Meaning
SC bus error Red Communication via the system interface is interrupted.
AS‑i bus error Red The message is displayed for up to 30 s during startup if no AS‑i bus is detected.
Fieldbus error Red Communication via the fieldbus interface is interrupted.
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Group warning
Status Symbol Meaning
Group warning from user pro‐
gram

Yellow At least one warning is present.

For an element number Issues the number of the lowest element on which the group warning is pend‐
ing.

Group prewarning
Status Symbol Meaning
Group prewarning from user pro‐
gram

Yellow At least one prewarning is present.

For an element number Issues the number of the lowest element on which the group prewarning is 
pending.

Fault acknowledgment   
Status Symbol Meaning
Reset performed Green All error sources were eliminated and could be acknowledged.
Reset not possible Yellow At least one error cannot be acknowledged since the error cause still exists.

Operating state   
Status Symbol Meaning
Configuring mode Green The safety relay is in configuring mode.
Test mode Green The safety relay is in test mode.
Safety mode Green The safety relay is in safety mode.
User program is running Green The safety relay is actively processing the safety circuit.
User program stopped Yellow The safety relay is not processing the safety circuit.
Operating state change rejected Yellow No valid password has been entered for switching to test mode.

There is a configuring or device error that is preventing operating mode 
change.

Access path   
Status Symbol Meaning
Access path closed Green No access path is open.
Access path of fieldbus controller 
is open

Green The access path over the fieldbus interface for a control is open.

Fieldbus access path - ES tool is 
open

Green The access path over the fieldbus interface for an ES tool is open.

Access path to device interface is 
open

Green The access path over the device interface is open
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Status Symbol Meaning
Connection abort Yellow The monitoring time has been exceeded. During monitoring time, the safety 

relay has not received any data set from the communication partner with write 
access to the safety relay.

Handshake error Red An error was detected during connection monitoring in test mode.

Password protection   
Status Symbol Meaning
Device access authorization exists Green Device access authorization exists.
Password protection for device ac‐
cess is inactive

Yellow There is no protection against access from a higher-level controller or other 
users.

Incorrect password entry Yellow A password was received that does not match any device access password 
stored in the safety relay.

Device self-test   
Status Symbol Meaning
Self-test active Blue Device self-test running.
Self-test OK Green The device self-test was finished without an error.
Self-test error Red The device has detected a defect during the self-test. This fault can be caused 

by a wiring error at the output or by an internal device fault.
• Check the wiring of the outputs for short-circuit, cross-circuit and capac‐

itive load. 
• To acknowledge the fault, switch the supply voltage of the device off and 

on again. 
• If the fault is reported again, replace the device with a new device.

Legends
The meaning of the symbols used in the Problem / Message - Possible remedial measures section 
and the urgency level of the colors used is explained in the legends.

9.1.4 Dialog "Device messages" > "Engineering" tab

Requirements
The menu command "Target system" > "Diagnostics configuration" > "Device messages" > 
"Configuring" can only be selected when the Safety ES is connected online to the safety relay.
The configuration supports the following messages:   
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General
Status Symbol Meaning
Group error red At least one error is present.
Bus error red Communication to the fieldbus master is disturbed.
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present (e.g. "Safety sensor triggered").

Status Symbol Meaning
Configuring error red An error occurred during the configuring phase.

Configuring   
Status Symbol Meaning
Configuration missing yellow No valid configuration is stored in the safety relay.
Configuration not released yellow A valid configuration is stored but not released yet in the safety relay.
Release canceled yellow An already released configuration was canceled by means of the configuration 

release command.
Release canceled due to incorrect 
configuration release CRC

red The configuration release CRC in the release data has a value other than "0" and 
deviates from the value calculated by the safety relay.

Release denied due to incorrect 
configuration CRC

red The user tried to release a configuration whose configuration CRC does not 
match the configuration CRC to be released.

Configuration released green A valid and released configuration is stored in the safety relay.
Release denied, already released yellow The user is trying to release an already released configuration by means of the 

configuration release command.
Factory settings restored green The factory settings were successfully restored.

Element error   
Status Symbol Meaning
Invalid parameter value red A parameter value is not within the permissible value range.
Interconnection rule violated red At least 1 interconnection rule is violated.
Data structure incorrect red While receiving new configuring data, an inconsistency was detected by the 

safety relay in the structure and content of at least one data structure.
For an element number Specifies the number of the lowest element whose parameters were not ac‐

cepted by the device. 
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Device resources   
Status Symbol Meaning
Max. number of elements excee‐
ded

red More elements than the maximum number of elements were transferred to 
the safety relay.

Max. size of memory exceeded red More element parameters were transferred to the device than can be stored in 
the safety relay memory .

Program cycle time exceeded red The program cycle time set by the user is exceeded, and the safety relay 
changes to configuring mode.

Legends
The meaning of the symbols used in the Problem / Message - Possible remedial measures section 
and the urgency level of the colors used is explained in the legends.  

9.1.5 "Device messages" dialog box > "Configuration" tab

Requirements
The menu command "Target system" > "Diagnostics configuration" > "Device messages" > 
"Configuration" can only be selected when the Safety ES is connected online to the safety relay.
The configuration supports the following messages:   

General
Status Symbol Meaning
Group error red At least one error is present.
Bus error red Communication to the fieldbus master is disturbed.
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present (e.g. "Safety sensor triggered").

Status Symbol Meaning
Error in configuration red A problem has occurred in the memory module.

Device configuration   
Status Symbol Meaning
TARGET configuration equal AC‐
TUAL configuration

green The specified TARGET configuration of the safety relay corresponds to the 
current function and device configuration.

TARGET configuration not equal 
ACTUAL configuration

red The specified TARGET configuration of the safety relay does not correspond 
to the current function and device configuration.
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Status Symbol Meaning
TARGET slot configuration not 
equal ACTUAL slot configuration

red The specified TARGET slot configuration of the safety relay does not corre‐
spond to the ACTUAL slot configuration.

Target subslot configuration not 
equal to actual subslot configura‐
tion

red The specified target subslot configuration (AS‑i configuration) of the safety 
relay does not match the actual subslot configuration.

Memory module   
Status Symbol Meaning
Memory module not plugged in red No memory module is plugged in the safety relay.
Memory module defective red Memory module is defective.
Programming successful green Programming of the memory module was successful.
Programming error red Programming of the memory module was not successful.
User memory too small red More configuration data were transferred to the safety relay than can be 

stored in the user memory.
Memory module deleted green The memory module was deleted by command beforehand.

Legends
The meaning of the symbols used in the Problem / Message - Possible remedial measures section 
and the urgency level of the colors used is explained in the legends.

9.1.6 Dialog "Device messages" > "PROFINET IO" tab

Requirements
The menu command "Target system" > "Diagnostics configuration" > "Device messages" > 
"PROFINET IO" can only be selected when Safety ES is connected online to the safety relay.
The "PROFINET IO" tab is only available when a PROFINET interface module is configured.     
The configuration supports the following messages:

General
Status Symbol Meaning
Group error Red At least one error is present.
Bus error Red Communication with the IO controller is disturbed.
Group warning Yellow At least one warning is present.
Group prewarning Yellow At least one prewarning is present (e.g. "Safety sensor triggered").
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PN Status   
Status Symbol Meaning
CPU/Master STOP Yellow • CPU STOP: The user program in the PLC is not processed any more.

• Master STOP: A disturbed communication with the fieldbus master was 
detected.

Bus error Red Communication via PROFINET IO is interrupted.
Parameterization error Red During parameter assignment in existing communication connection a pa‐

rameter assignment error occurred.
Configuration error Red The actual configuration of an existing communication connection does not 

match the target configuration. This resulted in an error.
Process data exchange stopped Yellow Process data exchange with the IO controller has stopped, for example, be‐

cause the controller is in "STOP" state (= CPU STOP) or the user program in the 
safety relay is not running.

Communication OK Green The communication connection to the IO controller is set up. 
Configuration and parameter assignment of the safety relay have been execu‐
ted successfully.

Legends
The meaning of the symbols used in the Problem / Message and Possible Remedial Measures 
section and the urgency level of the colors used is explained in the legends.

9.1.7 Dialog "Device messages" > "PROFIBUS DP" tab

Requirements
The menu command "Target system" > "Diagnostics configuration" > "Device messages" > 
"PROFIBUS DP" can only be selected when Safety ES is connected online to the safety relay.
The "PROFIBUS DP" tab is only available when there is a configured DP interface module.     
The configuration supports the following messages:

General
Status Symbol Meaning
Group error red At least one error is present.
Bus error red Communication to the fieldbus master is disturbed.
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present (e.g. "Safety sensor triggered").
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DP status   
Status Symbol Meaning
CPU/Master STOP yellow • CPU STOP: The user program in the PLC is not processed any more.

• Master STOP: A disturbed communication with the fieldbus master was 
detected.

DP bus error red Communication via PROFIBUS DP has been interrupted.
DP parameter assignment error red During parameter assignment in existing communication connection a pa‐

rameter assignment error occurred.
DP configuration error red The actual configuration of an existing communication connection does not 

match the target configuration. This resulted in an error.
DP process data exchange stop‐
ped

yellow Process data exchange with the DP master has stopped, for example, because 
the controller is in the "STOP" state (= CPU STOP) or because the user program 
in the safety relay is not running.

DP communication ok green The communication connection to the fieldbus master is set up. 
Configuration and parameter assignment of the safety relay have been execu‐
ted successfully.

Legends
The meaning of the symbols used in the Problem / Message - Possible remedial measures section 
and the urgency level of the colors used is explained in the legends.

9.1.8 Dialog "Device messages" > "Device bus interface" tab

Requirements
The menu command "Target system" > "Diagnostics configuration" > "Device messages" > 
"Device bus interface" can only be selected when Safety ES is connected online to the safety relay.
The configuration supports the following SC status messages (SC = system interface):   

General
Status Symbol Meaning
Group error Red At least one error is present.
Bus error Red There is at least one communication fault of a bus system.
Group warning Yellow At least one warning is present.
Group prewarning Yellow At least one prewarning is present (e.g. "Safety sensor triggered").

SC status
Status Symbol Meaning
SC communication OK Green The internal communication link is set up.
SC bus error Red Communication via the system interface is interrupted.
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Status Symbol Meaning
SC parameterization error Red An error occurred during parameter assignment for an existing communica‐

tion connection.
SC configuration error Red The actual configuration of an existing communication connection does not 

match the target configuration. This resulted in an error. 
• More than the maximum permissible expansion modules for the basic unit 

are connected. 
• An expansion module has been inserted/removed during operation.
• No supply voltage is applied to at least one EM. 
• The basic unit or an expansion module is defective. 
• High electromagnetic interference in control cabinet.

SC process data exchange stop‐
ped

Yellow No more process data is exchanged.

Legends
The meaning of the symbols used in the Problem / Message and Possible Remedial Measures 
section and the urgency level of the colors used is explained in the legends.

9.1.9 "Device messages" dialog box > "AS-Interface" tab

Requirements
The "AS-Interface" tab appears only if AS-Interface is configured for MSS 3RK3 Advanced, 
MSS 3RK3 ASIsafe basic or MSS 3RK3 ASIsafe extended.     
The configuration supports the following messages:

General
Status Symbol Meaning
Group error red At least one error is present.
Bus error red Communication to the fieldbus master is disturbed.
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present (e.g. "Safety sensor triggered").

AS-i interface   
Status Symbol Meaning
AS‑i communication ok green • The communications link to the AS-i slaves exists.

• The AS-i slaves have been successfully configured and parameterized.
AS‑i configuration error red The actual configuration of an existing communication connection does not 

match the target configuration. This resulted in an error. Communication via 
the AS‑i fieldbus interface is interrupted.
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Status Symbol Meaning
For AS-i address States the lowest of the affected addresses.
AS-i parameterization error red A simulated AS-i slave was not included in the data traffic by the AS-i master.
For AS-i address States the lowest of the affected addresses.
AS-i bus error red The message is displayed for up to 30 s during startup if no AS‑i bus is detected.

AS-i slave function   
Status Symbol Meaning
AS-i slave function active green The AS‑i slave function is active, i.e. non-safety-related AS‑i slaves are simula‐

ted by the safety relay.

AS-i monitor function   
Status Symbol Meaning
AS-i monitor function active green The AS‑i monitor function is active, i.e. non-safety-related AS‑i slaves are moni‐

tored.

ASIsafe   
Status Symbol Meaning
Safety protocol error red Fault in safety-related communication, for example, resulting from ASIsafe 

code sequence error due to effects of EMC.
ASIsafe 7x4-bit code sequence 
monitor active

green At least one 7x4-bit code sequence monitor is monitoring data on the AS-i bus.

ASIsafe 7x4-bit code sequence er‐
ror

red During data transmission, an error in the 7x4-bit code sequence was detected 
in at least one AS‑i address.

For AS-i address States the lowest of the affected addresses.
ASIsafe 8x4-bit code sequence 
monitor active

green At least one 8x4-bit code sequence monitor is active.

ASIsafe 8x4-bit code sequence er‐
ror

red During data transmission, an error in the 8x4-bit code sequence was detected 
in at least one AS‑i address.

ASIsafe code table teaching active blue Monitoring of ASIsafe code sequences that have not yet been taught is active.
Code tables missing red The code table is missing for at least one of the configured safety-related input 

slaves.
Multiple code tables red At least two safety-related AS-i slaves with the same code table have been 

detected.
New codes tables yellow The code table of at least one configured safety-related input slave has not yet 

been transferred.
Code tables known green A valid code table has been taught and applied for all configured safety-related 

AS‑i input slaves detected on the AS‑i bus.
For AS-i address States the lowest of the affected addresses.
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Status Symbol Meaning
ASIsafe 7x4-bit code sequence 
generator active

green At least one 7x4-bit code sequence generator is involved in the AS‑i commu‐
nication, i.e. it is transmitting a certain 7x4-bit code sequence for a particular 
parameterized AS-i address.

ASIsafe 8x4-bit code sequence 
generator active

green At least one 8x4-bit code sequence generator is involved in the AS‑i commu‐
nication, i.e. it is transmitting a certain 8x4-bit code sequence for a particular 
parameterized AS-i address.

Legends
The meaning of the symbols used in the Problem / Message - Possible remedial measures section 
and the urgency level of the colors used is explained in the legends. 

9.2 Diagnostics logic

9.2.1 Monitoring
The "Target system" > "Diagnostics logic" > "Monitor" menu command shows the status of the 
inputs / outputs, of the function elements, and of the connections between the functions.       
The status of the connections is determined based on the status of the respective function 
output Q.

Requirements
• The safety relay is opened online.
• The logic diagram with the safety circuit is active.
• The safety relay is in safety mode / test mode

General element status   
Symbol Color Meaning

gray Function element is deactivated

green At least one function output is active

green flashing Function element is ready and is waiting for a start signal.

yellow flashing Function element waiting for startup test

blue Timer is active
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Symbol Color Meaning
red Wiring error 

Note
For input cells this means that the input substitute value is 
active.  

flashing red Logic error, e.g. status of the feedback contact, does not 
match the setpoint value

Status of the function inputs/function outputs     
Symbol Color Meaning

green Function input active

blue Function input inactive

green Function output active

blue Function output inactive

9.2.2 Messages of the function elements

9.2.2.1 Element messages
The menu command "Target system" > "Diagnostics logic" > "Element messages" shows the 
messages for a function that is selected in the logic diagram. You can monitor status messages 
of several functions simultaneously.     
The element messages can be read out from the user program.

Requirements
• The safety relay is opened online.
• The logic diagram with the safety circuit is active.
• At least one function must be selected.

9.2.2.2 Messages for Monitoring Universal
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   

Diagnostics
9.2 Diagnostics logic

SIRIUS engineering Safety ES V1.0
294 Operating Manual, 12/2021, A5E32640754002A/RS-AF/006



"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is divided into the sections "General," "Sensor," and "Start."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Status Symbol Meaning
Start condition not fulfilled yellow is set if:

• A sensor test was not executed in the case of an active startup test function
• A discrepancy condition violation is present
• The value "1" is not present simultaneously at all available (parameterized) 

function inputs (IN1, ...)
• A signal sequence violation is present
• A cross-circuit is present in the case of cross-circuit monitoring

Sensor
Status Symbol Meaning
Safety sensor triggered yellow The safety sensor has been actuated. This message is automatically 

reset if the value "1" is pending at all IN1 / 2 function inputs monitored.
Startup test required yellow This message is set in a parameterized startup test on each restart and 

each time the substitute value is changed to a real value until the user 
has actuated the connected sensor at least once.

Sequence condition not fulfilled red The sequence condition was not fulfilled in accordance with the pa‐
rameter assignment.
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Status Symbol Meaning
Discrepancy condition violated red is set if:

• After the discrepancy time has elapsed, the signal states at the in‐
puts monitored are different

• The signal states of the inputs monitored had not all previously been 
reset simultaneously to the value "0" when they are set to "1"

Cross-circuit at input x red A cross-circuit was detected at input x. 

Start
Status Symbol Meaning
Start signal duration invalid yellow Only with start type "Monitored start":

The start signal time monitoring element detected a violation.

9.2.2.3 EMERGENCY STOP messages
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   

"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is divided into the sections "General," "Sensor," and "Start."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.
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Status Symbol Meaning
Start condition not fulfilled yellow is set if:

• A sensor test was not executed in the case of an active startup test function
• A discrepancy condition violation is present
• A cross-circuit is present in the case of cross-circuit monitoring
• The value "1" is not present simultaneously at all available (parameterized) 

function inputs (IN1, ...)

Sensor
Status Symbol Meaning
Safety sensor triggered yellow The safety sensor has been actuated. This message is automatically reset if 

the value "1" is pending at all IN1 / IN2 function inputs monitored.
Startup test required yellow This message is set in a parameterized startup test on each restart and each 

time the substitute value is changed to a real value until the connected 
sensor is actuated at least once.

Discrepancy condition violated red is set if:
• After the discrepancy time has elapsed, the signal states at the inputs 

monitored are different
• The signal states of the inputs monitored had not all previously been 

reset simultaneously to the value "0" when they are set to "1"
Cross-circuit at input x red A cross-circuit was detected at input x. 

Start
Status Symbol Meaning
Start signal duration invalid yellow Only with start type "Monitored start":

The start signal time monitoring element detected a violation.

9.2.2.4 Messages for ESPE
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   
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"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is divided into the sections "General," "Sensor," and "Start."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Status Symbol Meaning
Start condition not fulfilled yellow is set if:

• A sensor test was not executed in the case of an active startup test func‐
tion

• A discrepancy condition violation is present
• A cross-circuit is present in the case of cross-circuit monitoring
• The value "1" is not present simultaneously at all available (parameter‐

ized) function inputs (IN1, ...)

Sensor
Status Symbol Meaning
Safety sensor triggered yellow The safety sensor has been actuated. This message is automatically reset if 

the value "1" is pending at all IN1 / IN2 function inputs monitored.
Discrepancy condition violated red is set if:

• The signal states of the inputs monitored had not all previously been 
reset simultaneously to the value "0" when they are set to "1"

Startup test required yellow This message is set in a parameterized startup test on each restart and each 
time the substitute value is changed to a real value until the connected 
sensor is actuated at least once.

Cross-circuit at input x red A cross-circuit was detected at input x. 
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Start
Status Symbol Meaning
Start signal duration invalid yellow Only with start type "Monitored start":

The start signal time monitoring element detected a violation.

9.2.2.5 Messages for safety shutdown mat (NC principle)
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   

"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is divided into the sections "General," "Sensor," and "Start."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Status Symbol Meaning
Start condition not fulfilled yellow is set if:

• A sensor test was not executed in the case of an active startup test function
• A discrepancy condition violation is present
• A cross-circuit is present in the case of cross-circuit monitoring
• The value "1" is not present simultaneously at all available (parameterized) 

function inputs (IN1, ...)
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Sensor
Status Symbol Meaning
Safety sensor triggered yellow The safety sensor has been actuated. This message is automatically reset 

if the value "1" is pending at all IN1 / IN2 function inputs monitored.
Startup test required yellow This message is set in a parameterized startup test on each restart and 

each time the substitute value is changed to a real value until the con‐
nected sensor is actuated at least once.

Discrepancy condition violated red is set if:
• The signal states of the inputs monitored had not all previously been 

reset simultaneously to the value "0" when they are set to "1"
Cross-circuit at input x red A cross-circuit was detected at input x. 

Start
Status Symbol Meaning
Start signal duration invalid yellow Only with start type "Monitored start":

The start signal time monitoring element detected a violation.

9.2.2.6 Messages for safety shutdown mat (cross-circuit principle)
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   

"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is divided into the sections "General," "Sensor," and "Start."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
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Status Symbol Meaning
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Status Symbol Meaning
Start condition not fulfilled yellow is set if:

• A sensor test was not executed in the case of an active startup test func‐
tion

• A cross-circuit is present
• The value "1" is not present simultaneously at all available (parameter‐

ized) function inputs (IN1, ...)

Sensor
Status Symbol Meaning
Safety sensor triggered yellow The safety sensor has been actuated. This message is automatically reset 

if the value "1" is pending at all IN1 / IN2 function inputs monitored.
Startup test required yellow This message is set in a parameterized startup test on each restart and 

each time the substitute value is changed to a real value until the con‐
nected sensor is actuated at least once.

Wire break at input x red Value "0" detected at input x.
Short circuit to P at input x red A short-circuit to P was detected at input x.

Start
Status Symbol Meaning
Start signal duration invalid yellow Only with start type "Monitored start":

The start signal time monitoring element detected a violation.

9.2.2.7 Messages for protective door
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.  

"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.
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"Messages" tab
The view of the "Messages" tab is divided into the sections "General," "Sensor," and "Start."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Status Symbol Meaning
Start condition not fulfilled yellow is set if:

• A sensor test was not executed in the case of an active startup test 
function

• A discrepancy condition violation is present
• The value "1" is not present simultaneously at all available (parame‐

terized) function inputs (IN1, ...)
• A signal sequence violation is present
• A cross-circuit is present in the case of cross-circuit monitoring

Sensor
Status Symbol Meaning
Safety sensor triggered yellow The safety sensor has been actuated. This message is automatically reset if the 

value "1" is pending at all IN1 / IN2 function inputs monitored.
Startup test required yellow This message is set in a parameterized startup test on each restart and each 

time the substitute value is changed to a real value until the connected sensor 
is actuated at least once.

Sequence condition not fulfilled red The sequence condition was not fulfilled in accordance with the parameter 
assignment.

Discrepancy condition violated red is set if:
• After the discrepancy time has elapsed, the signal states at the inputs 

monitored are different
• The signal states of all inputs to be monitored had not all previously been 

reset simultaneously to the value "0" when they are set to "1."
Cross-circuit at input x red A cross-circuit was detected at input x. 
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Start
Status Symbol Meaning
Start signal duration invalid yellow Only with start type "Monitored start":

The start signal time monitoring element detected a violation.

9.2.2.8 Messages for protective door with lock
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   

"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is divided into the sections "General," "Sensor / Protective Door," 
"Lock," and "Start."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Status Symbol Meaning
Start condition not fulfilled yellow is set if:

• A sensor test was not executed in the case of an active startup test function
• A discrepancy condition violation is present
• The value "1" is not present simultaneously at all available (parameterized) 

function inputs (IN1, ...)
• A signal sequence violation is present
• A cross-circuit is present in the case of cross-circuit monitoring
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Sensor
Status Symbol Meaning
Safety sensor triggered yellow The safety sensor has been actuated. This message is automatically reset 

if the value "1" is pending at all IN1 / IN2 function inputs monitored.
Protective door closed green The protective door is closed.
Startup test required yellow This message is set in a parameterized startup test on each restart and 

each time the substitute value is changed to a real value until the con‐
nected sensor is actuated at least once.

Sequence condition not fulfilled red The sequence condition was not fulfilled in accordance with the parame‐
ter assignment.

Discrepancy condition violated red is set if:
• After the discrepancy time has elapsed, the signal states at the inputs 

monitored are different
• The signal states of the inputs monitored had not all previously been 

reset simultaneously to the value "0" when they are set to "1"
Cross-circuit at input x red A cross-circuit was detected at input x. 

Lock
Status Symbol Meaning
Lock engaged green The lock is engaged.
Lock released green The lock is released.
Feedback circuit signal and switch‐
ing status do not match

red The feedback circuit signal does not match the interlock status. 

Protective door opened when lock 
was active

red The protective door opened when lock was active.

Locking not possible because the 
protective door is open

red Locking not possible because the protective door is open.

Start override active blue The start override time is running.

Start
Status Symbol Meaning
Start signal duration invalid yellow Only with start type "Monitored start":

The start signal time monitoring element detected a violation.

9.2.2.9 Messages for enabling button
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   
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"Overview" tab
The view of the "Overview" tab is divided into the following sections:

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is divided into the sections "General" and "Sensor."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Status Symbol Meaning
Start condition not fulfilled yellow Is set if:

• A discrepancy condition violation is present
• A cross-circuit is present
• The value "1" is not present simultaneously at all available (parameterized) 

function inputs (IN1, ...)
• A jammed button error is present

Sensor
Status Symbol Meaning
Enabling button OFF green The enabling button has the status OFF.
Enabling button ON green The enabling button has the status ON.
Pushbutton jammed red The pushbutton is jammed.
Discrepancy condition violated red Is set if:

• The signal states of the inputs monitored had not all previously been 
reset simultaneously to the value "0" when they are set to "1"

Cross-circuit at input x red A cross-circuit was detected at input x. 
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9.2.2.10 Messages for two-hand operation
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   

"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is divided into the sections "General" and "Sensor."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Status Symbol Meaning
Start condition not fulfilled yellow is set if:

• A discrepancy condition violation is present
• A cross-circuit is present
• If both pushbuttons were not pressed "synchronously", that is, they were 

pressed with a time offset greater than 0.5 s
• The value "1" is not present simultaneously at IN1 / 3, IN2 / 4 
• The two pushbuttons were not released simultaneously
• A jammed button error is present

Sensor
Status Symbol Meaning
Pushbutton jammed red The pushbutton is jammed.
Do not release both pushbuttons red The two pushbuttons were not released simultaneously.
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Status Symbol Meaning
Discrepancy condition violated red is set if:

• After the discrepancy time has elapsed, the signal states at the inputs 
monitored are different within one or both pushbuttons

• The signal states of the inputs monitored had not all previously been 
reset simultaneously to the value "0" when they are set to "1"

Cross-circuit at input x red A cross-circuit was detected at input x. 

9.2.2.11 Messages for mode selector switch
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   

"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is contains the sections "General" and "Mode selector switch."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Mode selector switch
Status Symbol Meaning
Switchover time exceeded yellow The "1 out of 2 ... 5 selection monitoring" detected the value "0" at all inputs 

after the contact switchover time had elapsed.
Invalid operating mode selection red The "1 out of 2 ... 5 selection monitoring" detected after the contact 

switchover time had elapsed:
The value "1" is present at more than one input.

Diagnostics
9.2 Diagnostics logic

SIRIUS engineering Safety ES V1.0
Operating Manual, 12/2021, A5E32640754002A/RS-AF/006 307



9.2.2.12 Messages for the muting functions
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   

"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is divided into the sections "General", "Muting sensors", and 
"Restart."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. muting indicator light fault).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Status Symbol Meaning
Start muting condition not met yellow Not all conditions for operational starting of muting using muting sensors 

are met.

Muting sensors
Status Symbol Meaning
Muting operation active green Muting mode is activated.
Muting operation not active green Muting mode is not activated.
Protective field not free yellow The value "0" is present at the "FREE" function input.
System not running yellow The value "1" is present at the "STOP" function input.
Sequence condition not fulfilled red The sequence condition was not observed.
Discrepancy condition sensor pair x 
not fulfilled

red A discrepancy violation was detected in the signals of muting sensor 
pair x.
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Status Symbol Meaning
Max. muting time elapsed red Muting operation terminated because "max. muting time" expired.
Muting indicator light fault red The muting indicator light monitoring function has detected an error.

Restart
Status Symbol Meaning
Muting restart possible green Muting mode was not terminated correctly, i.e. at least one muting 

sensor is still being triggered.
Restart signal duration invalid yellow The "Muting restart possible" message is set and, the first time the 

RESTART button is pressed, the expected operating sequence does 
not follow.

9.2.2.13 Messages for counter functions
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.  

"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is contains the sections "General" and "Counter function."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.
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Counter function
Status Symbol Meaning
Counter limit value exceeded yellow The parameterized counter limit value was exceeded.
Counter limit value undershot green The parameterized counter limit value was undershot.
Last count pulse was up green Last count pulse was up
Last count pulse was down green Last count pulse was down.

9.2.2.14 Messages for timer functions
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   

"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is contains the sections "General" and "Timer function."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Time function
Status Symbol Meaning
OFF delay active blue The parameterized time t1 runs "with OFF delay".
ON delay active blue The parameterized time t1 runs "with ON delay".
Passing make pulse contact active blue The parameterized time t1 runs "with ON delay."
Clock-pulse generator active green The parameterized times t1 and t2 run "with clocking".
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9.2.2.15 Messages for start functions
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   

"Overview" tab
The view of the "Overview" tab is divided into the following sections: 

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is contains the sections "General" and "Start."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Status Symbol Meaning
Start condition not fulfilled yellow The value "0" is present at the "Start condition input (IN)".

Start
Status Symbol Meaning
Start signal duration invalid yellow Only with start type "Monitored start":

The start signal time monitoring element detected a violation.

9.2.2.16 Messages for output functions
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.  

Diagnostics
9.2 Diagnostics logic

SIRIUS engineering Safety ES V1.0
Operating Manual, 12/2021, A5E32640754002A/RS-AF/006 311



"Overview" tab
The view of the "Overview" tab is divided into the following sections:

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is divided into the sections "General," "Output," "Feedback 
circuit," and "Start."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. cross-circuit).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.

Status Symbol Meaning
Start condition not fulfilled yellow is set if:

• there is a feedback circuit error when feedback circuit monitoring is acti‐
vated.  

• the value "0" is pending at the function input (IN).

Output
Status Symbol Meaning
Output x active green Function output x is switched on.
Auxiliary output x active green Auxiliary output x is switched on.

Feedback circuit
Status Symbol Meaning
Feedback circuit signal x and switching 
status do not match

red The signal at feedback circuit input x does not match the switching status 
of the function outputs.
The output function immediately deactivates all its outputs in case of in‐
consistencies.
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Start
Status Symbol Meaning
Start signal duration invalid yellow Only with start type "Monitored start":

The start signal time monitoring element detected a violation.

Delay
Status Symbol Meaning
Bypass active blue Bypassing is active.
ON-delay time active at Q1 blue The ON-delay time at output Q1 is active.
OFF-delay time active at Q2 blue The OFF-delay time at output Q2 is active.

9.2.2.17 Messages for AS-i 1..4F-DO
The "Element Messages" dialog box contains two tabs named "Overview" and "Messages" and 
provides information, remedial measures, and messages about pending problems and errors.   

"Overview" tab
The view of the "Overview" tab is divided into the following sections:

Section Content and meaning
General The color indicates the type of error.
Problem / Message
Possible remedial measures

Defines remedial measures for the displayed problem.

Legend Explains the meaning of the symbols used in the Problem / Message - Possible reme‐
dial measures section.

"Messages" tab
The view of the "Messages" tab is divided into the sections "General," "Output," "Start," and 
"Feedback circuit."

General
Status Symbol Meaning
Logic error red At least one logic error is present (e.g. discrepancy error / sequence error).
Wiring error red At least one wiring error is present (e.g. feedback circuit error).
Group warning yellow At least one warning is present.
Group prewarning yellow At least one prewarning is present.
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Status Symbol Meaning
Start condition not fulfilled yellow is set if:

• there is a feedback circuit error when feedback circuit monitoring is active  
• the logic error "Invalid output selection" is present
• the value "1" is present at more than one of the existing (parameterized) 

function inputs

Output
Status Symbol Meaning
Output x active green Function output x is switched on.
Auxiliary control signal x sent green The auxiliary control signal x was transmitted completely by the code se‐

quence that is currently active.
Invalid output selection red The value "1" was detected on more than one input IN1 ... 4 by the "1 out 

of 4 - selection monitoring."

Start
Status Symbol Meaning
Start signal duration invalid yellow Only with start type "Monitored start":

The start signal time monitoring element detected a violation.

Feedback circuit
Status Symbol Meaning
Feedback circuit signal x and switching 
status do not match

red The signal at feedback circuit input x and the switching status of function 
output x do not match. 
In case of inconsistencies, the output function immediately switches off all 
its outputs. 

9.3 Messages during the consistency check

9.3.1 Messages during the consistency check - Identification
The consistency check is used to check whether the configuration is correct and complete.    
A consistency check is carried out for the following actions:
• With the "Edit" > "Check consistency" menu command
• When a configuration is saved
• With the "Target system" > "Prepare configuration test..." menu command
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The messages are displayed in the output window. By clicking on a message in the output 
window, you can jump to the corresponding error location.
The following messages may appear during the consistency check:

Message Kind Message text Remedy
Name of configuration engi‐
neer is missing

Error "General configuration: Name of con‐
figuration engineer is missing."

Enter the name of the configuration en‐
gineer in the "Project" parameter as‐
signment view

Name of the the configuration 
engineer's company is missing

Error "General configuration: Name of con‐
figuration engineer's company is miss‐
ing."

Enter the name of the company of the 
configuration engineer in the "Project" 
parameter assignment view

Project name is missing Error "General configuration: Project name 
is missing."

Enter the project name in the "Project" 
parameter assignment view

The user memory is full Error "General configuration: The user mem‐
ory is overloaded. Reduce the system 
documentation (under Options > Set‐
tings of Safety ES) or optimize the logic 
if necessary!"

Reduce the memory requirements on 
the memory module
You will find more information in chap‐
ter "Settings of Safety ES - "Download 
options" tab (Page 94)"

9.3.2 Messages during the consistency check - Configuration
The consistency check is used to check whether the configuration is correct and complete.    
A consistency check is carried out for the following actions:
• With the "Edit" > "Check consistency" menu command
• When a configuration is saved
• With the "Target system" > "Prepare configuration test..." menu command
The messages are displayed in the output window. By clicking on a message in the output 
window, you can jump to the corresponding error location.
The following messages may appear during the consistency check:

Message Kind Message text Remedy
The expansion modules must 
be configured in succession.

Error "Configuration: There is a gap in front of 
an expansion module."

Correct the configuration "manually," 
possibly using the "Delete blank rows 
automatically" function from the con‐
text menu.

The safety relay must be availa‐
ble.

Error "Configuration: A safety relay always 
needs to be configured at slot 3."

Drag the safety relay from the catalog 
window to slot 3 in the configuration 
table. 

9.3.3 Messages during the consistency check - Logic
The consistency check is used to check whether the configuration is correct and complete.     
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A consistency check is carried out for the following actions:
• With the "Edit" > "Check consistency" menu command
• When a configuration is saved
• With the "Target system" > "Prepare configuration test..." menu command
The messages are displayed in the output window. By clicking on a message in the output 
window, you can jump to the corresponding error location.

Logic diagram
The following messages exist for the logic diagram:

Rule Kind Message Remedy
All address elements must be 
assigned to valid addresses. 
(Exception: FAULT output)

Error Logic: Terminal not connected <[ele‐
ment type]> (no. [element number]).

Assign a valid address in the object 
properties dialog of the address ele‐
ment or of the associated input/output 
element.

Non-fail-safe input signals 
can only be added to a safety 
circuit if they are ANDed with 
a safe signal.

Warning Logic: Signal flow terminal <[element 
type]> (no. [element number]): Non-
safety-relevant signal is connected 
with a safety-relevant signal to a safety 
output without ANDing.

Change the safety circuit accordingly.

Inputs of logic elements must 
be connected.
(Exceptions: 
• STOP and RESTART of the 

muting functions
• AUX1/2 for AS‑i 1 to 

4F‑DO)

Error Logic: Input <[element type]> (no. [el‐
ement number]) not connected.

Change the safety circuit accordingly.

Outputs of logic elements 
must be connected. 
(Exception: FAULT output)

Error Logic: Output <[element type]> (no. 
[element number]) not connected.

Change the safety circuit accordingly.

A function element must not 
overlap a page limit.

Warning Logic: The function element <function 
name> (no. [element number]) over‐
laps the page limit.

Move the function element or execute 
the "Realign graphic" command.

A function element must not 
overlap a connection.

Warning Logic: The function element <\1> [no. 
\2] overlaps a connection.

Move the function element or execute 
"Realign graphic."

A function element must not 
overlap another function ele‐
ment.

Warning Logic: The function element <function 
name> (no. [element number]) over‐
laps another function element.

Move the function element or execute 
"Realign graphic."

A connection must not over‐
lap another one.

Warning Logic: A connection overlaps another 
connection.

Move the connection or associated 
function element, or execute "Realign 
graphic."

A comment field overlaps a 
page limit.

Warning Logic: A comment field overlaps the 
page limit.

Move the comment.

A comment field overlaps an‐
other comment field.

Warning Logic: A comment field overlaps anoth‐
er comment field.

Move the comment.

A comment field overlaps a 
connection.

Warning Logic: A comment field overlaps a con‐
nection.

Move the comment/connection.
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Rule Kind Message Remedy
A function element overlaps a 
comment field.

Warning Logic: The function element <\1> [no. 
\2] overlaps a comment field.

Move the function element/comment 
field.

A reference point of an inter‐
rupted connection overlaps a 
connection.

Warning Logic: A reference point of an interrup‐
ted connection overlaps another con‐
nection.

Move the connection or execute "Re‐
align graphic".

A reference point of an inter‐
rupted connection overlaps 
another reference point.

Warning Logic: A reference point of an interrup‐
ted connection overlaps with another 
reference point.

Change the safety circuit accordingly or 
execute "Realign graphic."

A function element overlaps a 
reference point of an interrup‐
ted connection.

Warning Logic: The function element <\1> [no. 
\2] overlaps a reference point of an in‐
terrupted connection.

Change the safety circuit accordingly or 
execute "Realign graphic."

A reference point of an inter‐
rupted connection overlaps 
the page limit.

Warning Logic: A reference point of an interrup‐
ted connection overlaps the page limit.

Change the safety circuit accordingly or 
execute "Realign graphic."

A comment field element 
overlaps a reference point of 
an interrupted connection.

Warning Logic: A comment field overlaps a ref‐
erence point of an interrupted connec‐
tion.

Change the safety circuit accordingly or 
execute "Realign graphic."

The set program cycle time 
has been exceeded   

Error Logic: The set program cycle time has 
been exceeded. Reduce the number of 
function elements.

Alter safety circuit accordingly or in‐
crease program cycle time

If the channels of a device are 
wired to the "Safety shutdown 
mat (cross-circuit principle)" 
monitoring function, the oth‐
er channels of this device 
should not be used with:
• another monitoring func‐

tion "Safety shutdown 
mat (cross-circuit princi‐
ple)"

• another monitoring func‐
tion with activated cross-
circuit.

Warning Logic: <[element type]> (no. [element 
number]) - cross-circuit detection acti‐
vated (channels of <[BMK/slot/subslot 
no.]> are wired to the monitoring func‐
tion <safety shutdown mat (cross-cir‐
cuit principle)> <[element type]> (no. 
[element number]> wired).

Change the safety circuit accordingly.

The internal memory on the 
safety relay is full

Error "General configuration: The internal 
memory of the safety relay is full. Re‐
duce the scope of the logic"

Reduce the scope of the logic (by opti‐
mization, for example).

A function element has an in‐
terconnection level larger 
than 255 (parameter is only 1 
byte in size)

Error Logic: No more than 255 function ele‐
ments can be connected one behind 
the other. The rule is violated by the 
function element with the number \1.

Optimize the logic in such a way that no 
more than 255 interconnection levels 
are required (e.g. by use of output and 
input cells in pairs).
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9.4 Safety ES messages

9.4.1 Error reading a data set

Message: "Error reading a data set"

Description
Error reading a data set from the safety relay or from the parameter file.

Possible causes
• The connection to the safety relay is interrupted.
• The cable has not been connected to the specified COM/USB interface.
• The cable has not been connected to the safety relay.
• The cable is defective.
• The COM/USB interface has been assigned to another program.
• The parameter file is damaged.

Remedy
• Check the connection to the safety relay.
• Redo the configuration.

9.4.2 The file <file name> cannot be opened

Message: "The file <file name> cannot be opened"

Description
The specified file cannot be opened.

Possible causes
• Missing access rights
• The file does not exist.
• The file is already opened at a different location.
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Remedy
• Check the access rights.
• Check whether the file exists
• Close the application where the file is opened.

9.4.3 The file <file name> cannot be written

Message: "The file <file name> cannot be written"

Description
The specified file cannot be written.

Possible causes
• Missing access rights
• The file does not exist.
• The file is already exclusively opened by another application.
• Not sufficient memory on the hard disk.
• The PC has no network access.

Remedy
• Check the access rights
• Check whether the file exists
• Close the application where the file is opened.
• Check whether there is sufficient storage space on the hard disk and delete any not needed 

data, if applicable.
• Check the network access.

9.4.4 The file <file name> cannot be read

Message: "The file <file name> cannot be read"

Description
The specified file cannot be read.
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Possible causes
• Missing access rights
• The file does not exist
• The file is already exclusively opened by another application
• There is no network access
• The file is damaged.

Remedy
• Check the access rights
• Check whether the file exists
• Close the application that has opened the file
• Check the network access
• Recreate the file.

9.4.5 Online function not available

Message: "Online function not available"

Description
An online function could not be executed.

Remedy
• Close the application, restart it, and execute the function again.
• If this measure does not help, reinstall Safety ES.

9.4.6 Error while executing the action

Message: "Error while executing the action"

Description
An error occurred while executing the action.
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Remedy
• Close the application, restart it, and execute the function again.
• If this measure does not help, reinstall Safety ES.

9.4.7 Error during download to safety relay

Message: "Error during download to safety relay"

Description
An error occurred while loading the configuration to the connected safety relay.

Possible causes
• The configuration is erroneous.
• The connection to the safety relay is interrupted.
• The safety relay is defective.

Remedy
• Check the connection to the safety relay.
• Repeat the download.
• Read out the diagnostics (via the menu command "Target system > Device diagnostics")
• Replace the safety relay.

9.4.8 Error during download to PC

Message: "Error during download to PC"

Description
An error occurred while loading the configuration from the connected safety relay to the PC.

Possible causes
• The configuration is erroneous.
• The connection to the safety relay is interrupted.
• The safety relay is defective.
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Remedy
• Check the connection to the safety relay.
• Repeat the download to the PC.
• Read out the diagnostics (via the menu command "Target system > Device diagnostics").

9.4.9 Printout could not be created

Message: "Printout could not be created"

Description
An error occurred while generating the printout.

Possible causes
• No connection to the printer could be established.
• The Safety ES installation is damaged.

Remedy
• Check the connection to the printer.
• Reinstall Safety ES.

9.4.10 Print preview could not be generated

Message: "Print preview could not be generated"

Description
An error occurred while generating the print preview.

Possible causes
• The Safety ES installation is damaged.

Diagnostics
9.4 Safety ES messages

SIRIUS engineering Safety ES V1.0
322 Operating Manual, 12/2021, A5E32640754002A/RS-AF/006



Remedy
• Reinstall Safety ES.

9.4.11 Imported activation code is incorrect

Message: "Imported activation code is incorrect"

Description
You have tried to import an incorrect code for activating the project access password.

Possible causes
• You have selected the wrong file.
• The file is damaged.

Remedy
• Repeat the action.
• If this measure does not help, contact Technical Support.

9.4.12 The file with the activation code for resetting...

Message: "File with activation code for resetting password for project access could not be opened"

Description
File with activation code for resetting password for project access could not be opened.

Possible causes
• Missing access rights.
• The file does not exist.
• The file is already exclusively opened by another application.
• There is no network access.
• The file is damaged.
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Remedy
• Check the access rights.
• Check whether the file exists
• Close the application that has opened the file.
• Check the network access.
• Repeat the action.
• If this measure does not help, contact Technical Support.

9.4.13 Connection to the safety relay could not be established...

Message: No connection to safety relay could be established. The action is canceled"

Description
A printout of the configuration data on a safety relay is created, for example, within the 
framework of the function "Prepare configuration test". For this purpose, an online connection 
to a safety relay needs to be established.

Possible causes
• No connection path is possible.
• The connection to the safety relay is interrupted.
• The cable has not been connected to the specified COM/USB interface.
• The cable has not been connected to the safety relay.
• The cable is defective.
• The COM/USB interface has been assigned to another program.

Remedy
• Restore the connection to the safety relay.
• Check the connection to the safety relay.
• Repeat the action.
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9.4.14 Connection to device cannot be opened! Please check...

Message: "Connection to device cannot be opened!" Please check whether the cable connection is 
interrupted or another program is blocking the serial interface."

Description
This message appears in conjunction with the commands "Open online", "Load to PC" and "Load 
to switching device".

Possible causes
• No connection path is possible.
• The connection to the safety relay is interrupted.
• The cable has not been connected to the specified COM/USB interface.
• The cable has not been connected to the safety relay.
• The cable is defective.
• The COM/USB interface has been assigned to another program.

Remedy
• Restore the connection to the safety relay.
• Check the connection to the safety relay.
• Repeat the action.

9.4.15 The configuration on the connected safety relay...

Message: "Configuration of connected safety relay does not match configuration shown in the 
editor. The action is canceled"

Description
Within the framework of the function "Prepare configuration test", a printout of the 
configuration data on a safety relay is created. If there is no associated offline project, the circuit 
elements are automatically arranged in the logic diagram and it is possible that not all 
documentation data (e.g. equipment identifier, terminal identifiers, element identifiers) are 
available.
To implement the "Prepare configuration test" function, the offline configuration that matches 
the configuration in the safety relay must always be open.
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Remedy
Open the file with the configuration that matches the configuration in the safety relay and repeat 
the action.

9.4.16 No consistency check could be executed...

Message: "No consistency check could be executed. The action is canceled"

Description
An error occurred during the consistency check.

Remedy
• Close the application, restart it, and execute the function again.
• If this measure does not help, reinstall Safety ES.

9.4.17 Printout or print preview could not be created

Message: "Printout or print preview could not be created"

Description
An error occurred while generating the printout or print preview.

Possible causes
• No connection to the printer could be established.
• The Safety ES installation is damaged.

Remedy
Implement the following measures one after another:
• Check the connection to the printer.
• Repeat the action.
• Reinstall Safety ES.
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9.4.18 The configuration on the connected safety relay...

Message: Configuration of connected safety relay does not match configuration shown in the 
editor. Release is not possible"

Description
To execute the function "Release configuration", it is absolutely necessary that the offline 
configuration that matches the configuration on the safety relay is displayed in Safety ES.

Remedy
Open the file with the configuration that matches the configuration in the safety relay and repeat 
the action.

9.4.19 Data set with release data could not be read...

Message: "Data set with release data could not be read. Release is not possible"

Description
An error occurred while reading the release data set from the safety relay.

Possible causes
• The connection to the safety relay is interrupted.
• The cable has not been connected to the specified COM/USB interface.
• The cable has not been connected to the safety relay.
• The cable is defective.
• The COM/USB interface has been assigned to another program.

Remedy
• Check the connection to the safety relay.
• Repeat the action.
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9.4.20 Data set with release data could not...

Message: "Data set with release data could not be written. Release is not possible"

Description
An error occurred while writing the release data set to the safety relay.

Possible causes
• The connection to the safety relay is interrupted.
• The cable has not been connected to the specified COM/USB interface.
• The cable has not been connected to the safety relay.
• The cable is defective.
• The COM/USB interface has been assigned to another program.

Remedy
• Check the connection to the safety relay.
• Repeat the action.

9.4.21 Error during download to safety relay...

Message: "Error during download to safety relay" Maximum memory size was exceeded"

Description
There are too many configuration data to be downloaded.

Possible cause
There is not enough storage space on the connected safety relay.

Remedy
• Install a larger memory in the safety relay.
• Reduce the scope of documentation data (e.g. equipment identifier, terminal identifier, 

element identifier) or do not download these data to the safety relay.
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9.4.22 Safety System ES cannot read required status information...

Message: "Safety ES cannot read required status information from the connected safety relay. The 
action is canceled"

Description
An error occurred while reading the release data set from the safety relay.

Possible cause
• The connection to the safety relay is interrupted.
• The cable has not been connected to the specified COM/USB interface.
• The cable has not been connected to the safety relay.
• The cable is defective.
• The COM/USB interface has been assigned to another program.

Remedy
• Check the connection to the safety relay.
• Repeat the action.

9.4.23 An access path to the connected safety relay cannot...

Message: "No access path to connected safety relay can be opened. The action is canceled"

Description
The safety relay must first open up an access path to permit write access (e.g. commands) to a 
connected safety relay. This is not possible at the moment.

Possible causes
• A connection has not been established with the safety relay.
• The cable has not been connected to the specified COM/USB interface.
• The cable has not been connected to the safety relay.
• The cable is defective.
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• The COM/USB interface has been assigned to another program.
• The access path to the safety relay is already being used (e.g. by another application or a 

PROFIBUS/PROFINET master).

Remedy
• Check the connection to the safety relay.
• Make an already used access path available again.

9.4.24 Device error. For this reason, change to test mode is...

Message: "Device error. Switching to test mode is therefore not possible"

Description
There is an error in the connected safety relay. Switching to test mode is therefore not possible.

Possible causes
Device error.

Remedy
• Reset the safety relay by restoring the factory settings.
• Replace the safety relay.

9.4.25 Logic diagram could not be initialized. Reason: ...

Message: "Logic diagram could not be initialized. Reason: ..."

Possible causes
An error occurred during the initialization of the graphical user interface.

Remedy
• Close the application, restart it, and execute the function again.
• If this measure does not help, reinstall Safety ES.
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9.4.26 Inconsistencies were detected while reading data set xxx.

Message: "Inconsistencies were detected while reading data set xxx"

Description
Inconsistencies were detected while reading a data set from the parameter file or while 
transferring a data set from the connected safety relay. 

Possible causes
• The parameter file is damaged.
• The connection to the safety relay is disturbed.

Remedy
1. Close Safety ES and repeat the action.
2. Check the connection to the safety relay.

9.4.27 Do you want to activate test mode for the safety relay that contains the 
configuration with the...

Message: "Do you want to activate test mode for the safety relay that contains the configuration 
with the configuration CRC xxx (hex.)?"

Description
This command activates the test mode on the target system.

Note
For this purpose, it is important that you observe the notes in the Online Help of Safety ES or in 
the system manual.
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9.4.28 An error occurred during transfer of configuration from safety relay...

Message: "An error occurred during transfer of configuration from safety relay or an incorrect 
configuration was downloaded from safety relay. The action is canceled"

Description
An error occurred during the transfer of a configuration from the connected safety relay. The 
configuration could not be transferred completely. 

Possible causes
• The connection to the safety relay is disturbed.
• The configuration on the safety relay is damaged.
• The safety relay is defective.

Remedy
• Close Safety ES and repeat the action.
• Check the connection to the safety relay.
• Check the configuration on the safety relay or the safety relay itself.

9.4.29 Error reading configuration data...

Message: "Error reading configuration data. Configuration CRC and configuration data do not 
match"

Description
The data in the configuration file to be opened do not match the associated configuration CRC.

Possible causes
• The configuration data were changed outside of Safety ES.
• Error reading configuration data.

Remedy
• Close Safety ES and repeat the action.
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9.4.30 Error during communication with the connected safety relay...

Message: "Error during communication with the connected safety relay (data set: <Data set 
number>)! The application is ended."

Description
An error occurred during communication with the safety relay (reading or writing of data sets).

Possible causes
• The connection to the safety relay is interrupted.
• Incorrect operating mode on the safety relay.
• Lack of resources on the safety relay.

Remedy
• Check the connection to the safety relay.
• Check the safety relay itself.
• Repeat the action, if required.
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Glossary

*.sdp file
File for storing parameterization data of a device (switching device parameters) on a 
programming device / PC. Safety ES projects are saved in files with this extension (*.sdp).

7 x 4-bit code sequence generator   
A 7 x 4-bit code sequence generator is an AS-i slave simulated by a safety monitor with a 
dedicated AS-i address and a special 7 x 4-bit code sequence. It sets and resets AS-i actuators 
safely.

7 x 4-bit code sequence monitor   
A 7 x 4-bit code sequence monitor is a safety-related AS-i output that listens to the 7 x 4-bit code 
sequences of a 7 x 4-bit code sequence generator. It is not assigned to a dedicated AS-i address.

7 x 4-bit code sequences (safety-related signals to actuators)
These safety-related signals are transmitted to the safety-related AS-i outputs as 7 x 4-bit code 
sequences. For this purpose, the safety monitor simulates a safety-related AS-i slave with an AS-
i address and a special 7 x 4-bit code sequence. The safety-related output listens to this 7 x 4-bit 
code sequence without assigning a safe address itself, i.e. it behaves like a monitor. The safety-
related output evaluates the 7 x 4-bit code sequences and switches the connected actuators 
accordingly.

8 x 4-bit code sequences (safety-related signals from sensors)
Each safety-related AS‑i input slave has its own unique 8 x 4-bit code sequence to be able to 
transmit safety-related signals to a safety monitor. These code sequences must be made known 
to the MSS 3RK3 by teaching. The integrated safety monitor listens in to the 8 x 4-bit code 
sequences of all safety-related AS‑i input slaves as a passive participant and evaluates them 
safely. 

8 x 4-bit code sequence generator   
Safety-related AS‑i input slave (sensor) with its own unique 8 x 4-bit code sequence. It transmits 
safety-related signals to an AS-i safety monitor.

8 x 4-bit code sequence monitor   
An 8 x 4-bit code sequence monitor is an AS-i safety monitor that monitors safety-related AS‑i 
input slaves (8 x 4-bit code sequence generators) and evaluates them safely. It is not assigned 
to a dedicated AS-i address.
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AS-Interface (AS-i)
AS-Interface (actuator-sensor interface) is the fieldbus communication standard.

ASIsafe
Safety-related version of AS-Interface from SIEMENS AG.

Catalog window
View in the Safety ES interface; tree representation of elements that can be dragged and 
dropped into the work space (in the configuration view: Modules; logical view: Function 
elements).

Combined Transaction Type 2 (CTT2)
Communication protocol on AS-Interface in accordance with Specification V3.0 for the 
transmission of large volumes of data (analog values, strings, etc.).

Configuration
Defines the configuration of a device or system and the arrangement of the components.

CPU
The central processing unit (CPU) or the main processor is the main processing element of a 
computer system.

CTT (Combined Transaction Type)
Special AS-i slave profile: In addition to the "Standard AS-i Slave" type, which transfers the 
process image of its inputs and outputs as a 4-bit message frame, whose bit position reflects the 
value of the associated input and output terminals, there are also further types of AS-i slaves. 
These types of slaves are named "Combined Transaction Types". In these types, the bit position 
of the process data bits does not correspond to the values of the input and output terminals of 
the AS-i slave.

Current-source short circuit
In the direct voltage system of the safety relays, current-source short circuit means a short circuit 
between a conductor and a positive potential (+ 5 V or + 24 V).

Cyclic redundancy check (CRC)
CRC is a test procedure for checking for data corruption. A generator polynomial is used to 
generate a checksum from the monitored data that then acts as a signature for it. There are 
different algorithms for calculating the polynomial generator.
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Dark period
Dark periods occur during shutdown tests and complete bit pattern tests. Test-related 0 signals 
are switched from the fail-safe output module to the output bit while the output is active. This 
output is then briefly disabled (= dark period). A sufficiently slow actuator does not respond to 
this and remains switched on.

Data set (DS)
A data set groups together data that belong to a single unit by virtue of logic or content.

Device name
Before an IO device can be addressed by an IO controller, the IO device must have a device name 
because the IP address is permanently assigned to the device name.
In the case of PROFINET, this method was chosen because names are easier to handle than 
complex IP addresses. Assignment of a device name for a specific IO device can be compared to 
setting the PROFIBUS address on a DP slave. An IO device does not have a device name when it 
is delivered. It can only be addressed by an IO controller once a device name has been assigned 
to it, e.g. for transmission of the configuration data during startup or for exchanging useful data 
in cyclic operation.

Discrepancy monitoring
A two-channel or multi-channel sensor can be monitored for signal discrepancy (= discrepancy 
monitoring). Discrepancy monitoring is possible with the following monitoring criteria:
• Discrepancy monitoring monitors the values of the input signals when changing from 1->0 

or 0->1 at at least one input to check that they are the same after a certain time, the 
"discrepancy time".

• Discrepancy monitoring monitors the values of the input signals for the simultaneous 
presence of the value "0".

While a discrepancy error is active, it is impossible to set the function output Q to the value "1".

Discrepancy time
Parameterizable time for the discrepancy analysis. 
The discrepancy time monitoring tolerates associated signals not being available at the same 
time within a defined time window. The signal transmitters are monitored to increase the 
functional reliability. The signal change of the signal transmitters is checked within the defined 
time. If this time is exceeded, an enable signal is not output. This type of monitoring is 
mandatory for a number of protective safety devices.
If the discrepancy time is set too high, the error detection time and error response time will be 
prolonged to no useful effect. If the discrepancy time is set too low, the availability is reduced to 
no useful effect because a discrepancy error will be detected even if there is no real error.
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Distributed Peripheral
The safety relay can be connected in a distributed configuration to a higher-level controller with 
the help of a fieldbus (e.g. PROFINET IO or PROFIBUS DP)
The controller is the master and the safety relay is the slave.

DP address
Unique address of a bus node in a PROFIBUS network. Settable values are 0 ... 126.

DP interface
Communication module for connecting an MSS 3RK3 central unit to the PROFIBUS fieldbus 
system.

DP slave
A slave that is operated on PROFIBUS with the PROFIBUS DP protocol and works according to the 
EN 50 170 standard, Volume 2, PROFIBUS.

DPV1
PROFIBUS specification with added interrupts and acyclic services.

Element identifier
Parameterizable name for a circuit element. 

Element number
Unique and type-independent identification numbers for switching elements that are assigned 
by the system and can be parameterized.

ESPE (electro-sensitive protective equipment)
Unit comprising devices and/or components that are actuated non-mechanically and that work 
together for the purpose of detecting the approach or presence of persons. The unit contains at 
least a detection function, a control/monitoring function, and one or more output signal 
switching devices.
Examples include light barriers, capacitive, active infrared, ultrasonic, and camera systems. The 
safety-related control system combined with the ESPE, or the ESPE itself, can additionally 
contain a second shutdown device, multifunctions, standstill monitoring, start inhibit, restart 
inhibit, etc. 

EUC
Abbreviation for equipment under control
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Feedback circuit
The feedback circuit of a safety function monitors the connected actuators with positively-
driven contacts. The normally closed contacts of the actuators with positively-driven contacts 
are used to check whether these have assumed their safe state before being activated again. 

Fieldbus
Industrial communication system that connects a large number of field devices such as probes 
(sensors), final controlling elements, and drives (actuators) to a control device.

Forcing
Signal state of an output is set to a fixed value irrespective of the actual signal state value.
This function overwrites a variable (e.g. flag, output) with a defined value. The variable is also 
write-protected so that this value cannot be changed from any source (including the user 
program). The value is retained even after the PG has been removed. The write protection can 
only be removed in error-free operation by calling the "unforce" function and assigning the value 
defined by the user program to the variable again. In the event of a fault (e.g. connection loss, 
device fault, etc.), write protection is revoked early.
The "force" function can be used, for example, to set certain outputs to the "ON" state for any 
length of time during the commissioning phase if the conditions of logic operations of the user 
program are not fulfilled (for example, because inputs have not yet been wired).

Function / function element
Blocks in the logic diagram of the software (e.g. EMERGENCY STOP function, ESPE, etc.)

FW
Abbreviation for firmware

Group warning
For all device diagnostic buffer entries that can result in internal tripping, a group warning is 
generated if the relevant message (e.g. unbalance) is set and the associated internal trip signal 
(e.g. unbalance trip) is not set. This warning is entered in the I/O area. The bit for group errors 
in the I/O area is not set.

GSD file (device master file) 
File that describes the properties of a PROFIBUS DP slave or a PROFINET IO device. Standardized 
description of a DP standard slave for connection to a higher-level engineering system (e.g. STEP 
7).
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GSDML
The GSDML language is defined by the GSDML scheme. A GSDML scheme contains validity rules 
that allow you to check the syntax of a GSD file, for example. Manufacturers of IO devices can 
obtain GSDML schemes (in the form of scheme files) from PROFIBUS International.

GSDML file
The properties of a PROFINET device are described in a GSD (General Station Description or 
device master data) file. You can link a PROFINET device into an automation system via the GSD 
file. The GSD file contains all information required for configuration.
In the case of PROFINET IO, the GSD file is in XML format and will therefore be referred to as a 
GSDML file in this documentation. The structure of the GSDML file conforms to ISO 15734, the 
worldwide standard for device descriptions.

HW
Abbreviation for hardware

I&M data
Identification and maintenance data. Identification data (I data) is information about the 
module, some of which is also printed on the module housing.
I data is only read. Maintenance data (M data) is plant-specific information, such as the 
installation location, installation date, etc. M data is created and written to the module during 
commissioning. Identification and maintenance data (I&M) is information stored in a module 
that supports you with 
• Checking the system configuration
• Locating modified system hardware
• Troubleshooting a system.
I&M data can be used to identify modules uniquely on the network.

IBS
Abbreviation for commissioning

Input delay
Parameter that is used to suppress interference pulses of 0 ms up to a set input delay time.
The set input delay is subject to a tolerance that can be looked up in the technical data of the 
module. A long input delay will suppress longer interference pulses; a short delay will suppress 
shorter interference pulses. The permissible input delay depends on the cable length between 
the transmitter and module.
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IP address
To enable a PROFINET device to be addressed as a node on Industrial Ethernet, the PROFINET 
device requires an IP address that is unique within the network. The IP address is made up of 
4 decimal numbers with a range of values from 0 through 255. The decimal numbers are 
separated by a decimal point.
The IP address is made up as follows:
• Address of the (sub)net
• Address of the station (host or network node)

LLDP
LLDP (Link Layer Discovery Protocol) is a protocol that allows the next neighbor to be detected. 
LLDP enables a device to send information about itself and receive information from 
neighboring devices.

Lock (tumbler mechanism)
According to EN 1088, the objective of a tumbler mechanism is to maintain a guard in the closed 
position. It is also connected to the control so that the machine cannot operate if the guard is not 
closed and that the guard is kept closed until the risk of injury is no longer present.

Logical input/output terminal
Inputs and outputs whose signals are transferred over a fieldbus system (e.g. PROFINET, AS-i) are 
termed "logical input and output terminals" in the manual.

MAC address
The MAC address is a worldwide unique device identification and is assigned to each PROFINET 
device during production. The PROFINET device can be accessed via the MAC address via LAN.
The MAC address is 6 bytes long and has the following structure:
• 3 bytes for the manufacturer ID
• 3 bytes with a device identifier (consecutive number).
The MAC address can generally be read from the front on the device, e.g.: 08-00-06-6B-80-C0.

Muting
Muting is the temporary deactivation or cancellation of a safety function, e.g. light array, that 
must be passed through.
EN 61946-1:
Override function: Temporary automatic overriding of the protection function with additional 
sensors to distinguish between people and objects.
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Navigation window
Representation in the Safety ES interface; tree structure with which the view shown in the work 
space can be selected ("Configuration" view, "Logic" view).

Offline project
The safety circuit is provided in the form of a program file and can be opened using the software.

Online project
A safety circuit is present in the safety relay and can be read out using the software.

Output window
View in the software interface in which messages or similar are displayed.

Parameterization
Parameterization is the definition of parameters using the parameterization software.

Parameters
Parameters are values that can be used to control the behavior of the devices.

PELV
Protective Extra-Low Voltage. PELV (Protective Extra-Low Voltage, formerly referred to as 
"protective extra low voltage with safe isolation") offers protection against electric shock. It is 
dealt with in EN 50178.

PELV power section
Ensures a circuit with a voltage that does not exceed the PELV with safe isolation from other 
circuits (not PELV circuits). In addition, grounding facilities are provided for PELV circuits and/or 
their accessible conducting parts.

PII/PIQ
Process image input/process image output

PLC
Abbreviation for programmable logic controller (e.g. SIMATIC S7)

Process response time
The process response time is synonymous with the process safety time.
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Process safety time
The period of time between the failure of the EUC (equipment under control) or of the EUC 
higher-level control or control system with the potential to cause a dangerous incident, and the 
time when the response in the EUC must be completed to prevent the occurrence of the 
dangerous incident (definition from EN 61508-4 3.6.20).

PROFIBUS
Fieldbus of Profibus International (PI), open fieldbus, standardized in accordance with EN/IEC.

PROFIenergy
Profile for power management in production plants. PROFIenergy uses the PROFINET 
communication protocol. It controls the power consumption of automation equipment used in 
production via a PROFINET network.

PROFINET
PROFINET (Process Field Network) is the open Industrial Ethernet standard of Profibus & Profinet 
International (PI) for automation.
Within the framework of Totally Integrated Automation (TIA), PROFINET is a consistent 
continuation of:
• PROFIBUS DP, the established fieldbus
• Industrial Ethernet, the communication bus for the cell level.
Experiences from both systems have been and are being integrated in PROFINET.

PROFINET IO controller
Device via which the connected IO devices are addressed. The IO controller exchanges input and 
output signals with assigned field devices. The IO controller is often the controller on which the 
automation program runs.

PROFINET IO device
Distributed field device assigned to one of the IO controllers.

Programmable controller (PLC)
Controller whose functionality is defined by a user program stored in the controller. The PLC 
comprises a CPU, memory, input/output modules and internal bus system. The I/O and the 
programming language are oriented to control engineering needs.

Programming device (PG)
A PG is a PC that is suitable for use in industry, compact, and portable. Its distinguishing feature 
is the special hardware and software for programmable controllers (SIMATIC).
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Reference designation (BMK)
Inputs and outputs or terminals of different devices within a system can be addressed uniquely 
using the reference designation.
The current reference designations (previously known as equipment identifiers) can be found in 
EN 61346-2. The standard EN 61346-2 replaces DIN 40719-2 and has been valid since June 1, 
2001. The 3-year transition deadline expired on June 1, 2003.

Reset
Tripping, i.e. disconnection and prevention of reclosure of an affected output due to a fault (e.g. 
cross-circuit, discrepancy time violation) can be acknowledged with Reset.

Restart
The device carries out a complete restart as with Power‑ON. However, the auxiliary power for the 
electronics does not have to be switched off; something that is often difficult in practice in the 
installed state. A restart can be forced by the command "Restart", for example.

Result of logic operation (RLO)
Binary result of a logical combining of several items of data.

S7 routing
The term routing denotes a transition from one subnet to one or several other subnets in a 
SIMATIC station that possesses interfaces to the applicable subnets.
Routing makes it possible to reach S7 stations online across subnet boundaries using a PG/PC, for 
example to download user programs or a hardware configuration or to be able to execute testing 
and diagnostic functions.
You can connect a PG/PC anywhere on the network and establish an online connection to all 
stations reachable via network transitions.

Safe state
The basis of the safety concept in safety-related systems is that a safe state exists for all process 
variables that can also be specified by the user. (Substitute value for failed inputs; initial state in 
the event of a "safety-related incident"). Generally, the safe state signifies signal level = 0 in the 
case of inputs and deactivation of the output in the case of outputs.

Safety circuit
A safety circuit encompasses the section of a safety system that is located before a safe output 
and sets this output.
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Safety systems
Safety systems are intended to play their role in keeping potential hazards for both people and 
the environment as low as possible by using suitable technical equipment, without restricting, 
more than absolutely necessary, industrial production and the use of machines. The protection 
of man and environment has to be put on an equal footing in all countries by applying rules/
regulations that have been internationally harmonized. These regulations are also intended to 
avoid the distortion of competition due to differing safety requirements in international trade.

Safety-related slave
Slave for connecting safety-related sensors, actuators, and other devices.

SC
Abbreviation used for semiconductor. Used in conjunction with inputs and outputs (e.g. "SC 
outputs").

Sequence monitoring
If at least two function inputs are parameterized on an input element, sequence monitoring is 
possible. Sequence monitoring monitors the sequence of the remaining input signals in the case 
of a signal change from 0 -> 1 at an input. The simultaneous response of input signals constitutes 
a sequence violation. While a sequence error is active, it is impossible to set the function output 
Q to the value "1".

Short circuit to ground
Short circuit to ground: A short circuit between a conductor and ground in a DC voltage system.

Simple Network Management Protocol (SNMP)
Network protocol for monitoring and controlling network elements (e.g. switches).

Slave
Some fieldbuses (e.g. PROFIBUS DP) are based on a master-slave architecture. Message frames 
are sent by the master to the addressed station (slave) and responded to by the slave.

Startup test
Manually or automatically conducted test of the safety-related evaluation device after the 
supply voltage has been applied to the safety-related evaluation device.
One example of such a test is manually opening and closing a guard after the supply voltage has 
been switched on.
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STEP 7
The basic STEP 7 software is the standard tool for the SIMATIC S7, SIMATIC C7, and 
SIMATIC WinAC automation systems.

STOP category 0
EN 60204-1: Uncontrolled stop by means of immediate power shutdown.

STOP category 1
EN 60204-1: Controlled stop by means of interrupting the power supply when standstill has 
been reached

Substitute value
Substitute values are, for example, values that are output to the process if signal output modules 
or signal input modules are defective.
Substitute values are used in the user program instead of a process value. In some cases, the 
substitute values can be preset. These are values that the outputs or output will output in case 
of CPU STOP.
On the safety relay, a substitute value can be set as a fixed value for a deactivated function 
element.

SW
Abbreviation for software

Synchronous operation time
Two input signals are monitored for simultaneity especially at signal change. Any deviation of 
the signal from the setpoint is tolerated for the duration of the synchronous operation time 
without a fault being generated.

Target/actual comparison
Comparison of configured and actual system configuration.

Teaching (of the code sequences)
During the "teaching," the code sequences of a safety-related AS-i slave (8x4-bit code 
sequences) for the signal processing are read in. The operation comprises the following phases:
1. Recording the code sequences from the AS-i bus. (The user must operate the sensor 
depending on the type of AS-i slave in this case.)
2. Validating the code sequences: the validity and the one-to-one assignment of the code 
sequence in the system is checked.
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3. Storage of the recorded code sequences. Storage of the recorded code sequences completes 
the teaching operation and the system processes the code sequences received from the AS-i 
slave in its internal logic.

Terminal comments
Parameterizable remarks referring to an input or output terminal.

Terminal identifier
Symbolic name for an input or output terminal that can be parameterized.

Work space
View in the software interface in which the configuration is created.
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3RM1 motor starter, 152
3SK1 output expansion, 19
3SK1 output expansions, 152
3ZY12 device connectors, 19
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AS-i slaves, 113
PROFIBUS DP, 50
PROFINET IO, 51
Simulated AS-i slaves, 115

AND, 228
Apply code tables, 80
Approve configuration..., 76
Article number, 11, 12
AS-i 1..4F-DO, 278

Messages, 313
AS-i 2F-DI, 206
AS-i code sequence error, 282
AS-i interface, 112, 291
AS-i monitor function, 292
AS-i output, 278
AS-i slave function, 292
AS-i slaves, 115, 151
AS-i subsystem, 114
AS-Interface, 114, 291
AS-Interface signals, 146
ASIsafe, 292
ATEX, 24
Automation License Manager, 41

Installation, 42
Automation License Manager, 43

B
Basic Settings..., 92
Basic unit, 102
Baud rate, 110, 111
BMK, 94, 107
Bus error, 283

C
Cancel access rights, 80
Cancel configuration release, 77
Catalog window, 38, 91
Cell function

Input cell, 178
Output cell, 179

Check consistency, 64, 108
Clocking, 262
Close, 52
Code sequences, 74
Commands, 80
Commissioning, 141, 153, 154, 166
Communication, 30
Compare with file, 69, 162
Compare with switching device, 162
Compare with switching device..., 70
Comparison function, 161
Comparison of configurations, 162
Conductive contamination, 19
Configuration, 106

Main system, 143
Subsystem, 143

Configuration approval, 75, 76, 159
Configuration CRC, 105, 156, 160
Configuration error, 283
Configuration release, 77
Configuration test, 141, 153
Configuring, 143, 167, 286
Configuring error, 283
Configuring mode, 77, 141
Connecting, 147
Consistency check

Messages, 314, 315
Control function

Device command, 227
Copy, 58
Counter function

Counter (0 -> 1 / 1 -> 0), 236
Counter (0 -> 1), 233
Counter (1 -> 0), 235
Messages, 309

Create macro, 62
Cross references, 97, 163
Cross-circuit detection, 149, 176
CTT2 protocol, 115
CTT2 slave, 115
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Cut, 58

D
Delay time, 174
DELAYED, 152
Delete, 59, 121
Delete highlighting, 90, 131
Determine online, 108

AS-Interface, 114
Device command, 227
Device configuration, 287
Device connector, 113, 152
Device connectors, 147
Device logbooks..., 83
Device messages, 81

AS-Interface, 291
Configuration, 287
Configuring, 285
Device bus interface, 290
Overview, 282
PROFIBUS DP, 288, 289
Status, 283

Device resources, 287
Device self-test, 285
Device status, 225
Diagnostics, 28, 29, 281
Diagnostics configuration, 81, 281
Diagnostics display, 29, 109
Diagnostics logic, 82, 293
Diagnostics software, 27
Diagnostics using PROFIBUS, 110, 111
Disconnect, 282
Discrepancy monitoring, 175, 212
Discrepancy time, 175
Display settings, 89, 96, 131
Displaying all the switching devices in the PROFIBUS 
segment, 72
Documentation, 28, 104, 117, 156, 160
DP interface, 109
DP interface module, 28
DP status, 289, 290

E
Edit terminal identifier..., 63
Electromagnetic interference, 20
Electrostatic charge, 20
Element comment, 94, 95
Element error, 286
Element messages, 82, 293, 294

Element name, 94
Element numbers in macros, 95
Element positions, 94
Element reset, 82
Element status, 226, 293
EMC Directive, 20
EMERGENCY STOP, 182

Messages, 296
EN 62061, 19
EN ISO 13849-1, 19
Enabling button, 200

Interconnecting, 149
Messages, 304

Engineering system (ES), 30
Error in configuration, 282
Error messages, 134
ESPE, 184

Messages, 297
Exit, 57
Expansion modules, 113
Export macro..., 100, 136
Export..., 52

F
F output, 269
F output delayed, 271, 273
Factory settings, 80
FAQs, 13
FAULT, 177
Fault acknowledgment, 284
Fault signaling output (FAULT), 177
Flags, 146, 150, 166
Flip-flop

FF-SR, 232
Floating license, 43
Footer, 54
Forcing, 27, 83, 158, 161
Function elements, 119

Connections, 119
Function test, 22, 23
Functional extra-low voltage, 20

G
Go Offline, 72
Go to, 162
Go to..., 59
Grid settings, 89, 132
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Header, 53
Help file, 101
Help topics, 101
Highlight signal flow, 90, 130
HMI module, 109

I
Identification, 102, 104, 105
Import macro..., 100, 136
Import..., 48
Info, 102
Information window, 38
Initialization error, 282
Input cell, 178
Input delay, 174
Input terminals, 148
Insert comment, 60, 126
Installation, 44

Automation License Manager, 42
Intended use, 21
Interconnecting, 147, 151

Monitoring function, 149
Interface module, 28, 109
Interfaces, 153
Interrupt connection, 61, 127

L
Language, 92
Learn ASIsafe code tables..., 73
License key, 41, 43
License Manager, 41
Licenses, 31, 32
Line view, 72
Load to PC..., 71
Load to switching device..., 70, 154
Local device interface, 49
Logic diagram, 117, 118, 144
Logic error, 282, 283
Logic function

AND, 228
NAND, 230
NEGATION, 231
NOR, 231
OR, 229
XOR, 229

M
Machine safety, 21
Macrofunction, 134
Manual start, 174, 267
Marking, 104
Memory module, 154, 288

Delete, 80
Menu bar, 38
Menu commands, 32
Messages

Consistency check, 314, 315
Logic diagram, 134

Minimize / restore online dialogs, 92
Mode selector switch, 205

Interconnecting, 149
Messages, 307

Modification of the configuration, 167
Modular Safety System ES settings, 94
Module list of the device connector, 94
Module status, 81, 281
Monitored start, 174, 266
Monitoring, 79, 82, 293
Monitoring function

AS-i 2F-DI, 206
EMERGENCY STOP, 182
Enabling button, 200
ESPE, 184
Mode selector switch, 205
Protective door, 190
Protective door with tumbler, 193
Safety shutdown mat (cross-circuit principle), 188
Safety shutdown mat (NC principle), 186
Two-hand operation, 202
Universal, 179

Monitoring Universal, 179
Messages, 294

Most recently used files, 56
Move diagram, 90
Move mode, 125
Muting, 208, 211, 216

Discrepancy monitoring, 212
Messages, 308
Sequence monitoring, 213
Time limit, 213

Muting (2-sensor-parallel), 217
Muting (4-sensor-parallel), 220
Muting (4-sensor-sequential), 223
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NAND, 230
Navigation window, 38, 91
NEGATION, 231
New..., 47
Newsletters, 24
Noise immunity, 20
NOR, 231

O
Object properties, 63
Offline logbook viewer..., 68
Open online..., 49
Open..., 48
Operating state, 284
Operating system, 41
Operational safety, 24
OR, 229
Output cell, 179
Output function

AS-i 1..4F-DO, 278
F output, 269
F output delayed, 271, 273
Standard output, 268

Output functions
Messages, 311

Output terminals, 148
Output window, 38, 91
Overall response time, 174
Overall view, 89, 126

P
Page Setup..., 52, 53, 54, 55
Parameter "Input type", 177
Parameterization software, 27
Passing make contact, 246
Passing make contact (trigger), 250
Password, 136

Default password, 157
forgot, 65, 140
Reset, 65

Password for device access..., 67
Password for project access..., 64
Password for test mode..., 67
Password protection, 285
Paste, 58
PELV, 20

Prepare configuration test..., 75
Print, 53, 55, 76, 101, 156, 160, 163

DIN A3, 52
Print Preview..., 55
Print..., 56
PROFIBUS

Grounding, 20
PROFIBUS signals, 145
PROFIBUS DP, 49, 110, 111, 288, 289

Line view, 72
PROFINET IO, 50

Line view, 73
Program cycle time, 112, 317
Programming device, 41
Project, 105
Properties

AS-i slaves, 116
Basic units, 112
Expansion module, 113
HMI modules, 109
Interface modules, 109

Protective door, 190
Messages, 301

Protective door with lock
Messages, 303

Protective door with tumbler, 193

R
Realign graphic, 60, 122, 124
Redraw partial connection, 61, 129
Reference points, 128
References, 12
Release information, 100, 160
Release information..., 100
Remove diagram, 62
Report printout, 75, 76, 156, 160
Reset, 80
Response time, 174
Restart, 80
Restore, 57
Rules

Interconnecting / wiring / connecting, 147

S
Safe state, 22
Safety concept, 22
Safety function, 28
Safety guidelines, 159
Safety information, 19
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Safety mode, 79, 142, 160
Safety protocol error, 283
Safety regulations, 147
Safety shutdown mat (cross-circuit principle), 188

Messages, 300
Safety shutdown mat (NC principle), 186

Messages, 299
Safety shutdown mat cross-circuit principle

Interconnecting, 149, 189
Safety systems, 27
Safety ES, 27, 30
Save, 51
Save as..., 51
Save memory space, 95
Screen grid, 96, 132
Select all, 59, 121
SELV, 20
Settings of Safety ES, 95
Settings of Safety ES..., 93
Show hardware configuration, 108
Signals, 144

AS-Interface, 146
PROFIBUS, 145

Simulated slaves, 112, 115, 144
SIRIUS ES, 47
Slave status, 74
Slide switch, 152
Slot, 106, 108
Software versions, 35
Standard output, 268
Standards, 19

DIN EN ISO 7200, 54
EN 61496-1-A.7, 208

Start
Manual, 174
monitored, 174

Start conditions, 174
Start functions

Manual start, 267
Messages, 311
Monitored start, 266

Start wizard, 45, 93
Starting the program, 44
Startup test, 174
Status bar, 38, 39, 87
Status function

Device status, 225
Element status, 226

Status of function inputs, 294
Status of function outputs, 294
Substitute value, 294
Symbol list, 97, 164

System interfaces, 21
System test, 141, 153

T
Terminal identifier, 94, 95, 99, 107, 165
Terminal list, 99, 165
Terminals

Interconnecting, 144
Test interval, 23
Test mode, 78, 142, 157
Timer functions

Clocking, 262
Messages, 310
Passing make contact, 246
Passing make contact (trigger), 250
With OFF delay, 254
With OFF delay (trigger), 258
With ON delay, 238
With ON delay (trigger), 242

Title line, 38
Toolbar, 38, 39, 86
Two-hand operation, 202

Messages, 306

U
UNDELAYED, 152
Undo, 57
Undo the fixed assignment of the interface, 72

W
Wiring, 147
Wiring error, 283
With OFF delay, 254
With OFF delay (trigger), 258
With ON delay, 238
With ON delay (trigger), 242
Work space, 38

X
XOR, 229

Z
Zoom dialog, 88, 126
Zoom in, 88, 126
Zoom out, 88, 126
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