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Legal information 
Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

 DANGER 
indicates that death or severe personal injury will result if proper precautions are not taken. 

 

 WARNING 
indicates that death or severe personal injury may result if proper precautions are not taken. 

 

 CAUTION 
indicates that minor personal injury can result if proper precautions are not taken. 

 

 NOTICE 
indicates that property damage can result if proper precautions are not taken. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems. 

Proper use of Siemens products 
Note the following: 

 WARNING 
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 

   Siemens AG 
Division Digital Factory 
Postfach 48 48 
90026 NÜRNBERG 
GERMANY 

A5E35727153-AA 
Ⓟ 04/2015 Subject to change 

Copyright © Siemens AG 2015. 
All rights reserved 



 

Table of contents  
 

1 Using Audit ............................................................................................................................................. 5 

2 Important information about the Audit Viewer .......................................................................................... 7 

3 Audit basics ............................................................................................................................................ 9 

3.1 Logon ........................................................................................................................................ 9 

3.2 Changing the interface language ............................................................................................ 10 

3.3 Audit components ................................................................................................................... 11 
3.3.1 Audit Editor ............................................................................................................................. 11 
3.3.2 Audit Viewer ............................................................................................................................ 14 
3.3.3 Audit Viewer Control ............................................................................................................... 19 
3.3.4 Audit Document Control and Project Versioning .................................................................... 19 

4 Basic procedure .................................................................................................................................... 23 

4.1 Working with WinCC/Audit ...................................................................................................... 23 

4.2 Working with the Audit Viewer ................................................................................................ 28 

4.3 Working with Document Control and Project Versioning ........................................................ 30 

5 Working with Audit ................................................................................................................................ 33 

5.1 Configuring the Audit Trail database ...................................................................................... 33 
5.1.1 Audit Trail multi project database ........................................................................................... 33 
5.1.2 Audit Trail single project database .......................................................................................... 34 

5.2 Monitoring a WinCC project with Audit ................................................................................... 36 
5.2.1 Making Audit settings .............................................................................................................. 36 
5.2.2 Specify WinCC components for auditing ................................................................................ 37 
5.2.3 Activate document monitoring ................................................................................................ 38 
5.2.4 Monitoring user actions with Audit .......................................................................................... 40 
5.2.4.1 User actions monitored with Audit .......................................................................................... 40 
5.2.4.2 Standard operator messages ................................................................................................. 40 
5.2.4.3 User operator messages ........................................................................................................ 42 
5.2.4.4 Messages from a message number range ............................................................................. 43 
5.2.4.5 System events ........................................................................................................................ 44 
5.2.4.6 InsertAuditEntryNew ............................................................................................................... 44 
5.2.4.7 Monitoring user actions with Audit .......................................................................................... 46 
5.2.4.8 Activate / deactivate the Operator Message and Operator Activities Report property ........... 46 

5.3 Saving and versioning WinCC project data. ........................................................................... 48 
5.3.1 Enable Document Control ....................................................................................................... 51 
5.3.2 Configuring the version number .............................................................................................. 52 
5.3.3 WinCC project files ................................................................................................................. 54 
5.3.3.1 Checking out project files ........................................................................................................ 54 
5.3.3.2 Check in project files ............................................................................................................... 55 
5.3.3.3 View File History ..................................................................................................................... 56 
5.3.3.4 Restoring previous versions of archived project files ............................................................. 56 
5.3.3.5 Comparing file versions with one another............................................................................... 58 

WinCC/Audit - Documentation 
System Manual, 03/2015, A5E35727153-AA 3 



Table of contents  
 

5.3.4 Saving and versioning external data ...................................................................................... 58 
5.3.5 WinCC projects ...................................................................................................................... 59 
5.3.5.1 Archiving and versioning an open WinCC project ................................................................. 59 
5.3.5.2 Archiving and versioning a closed WinCC project ................................................................. 60 
5.3.5.3 View Project History ............................................................................................................... 60 
5.3.5.4 Restoring previous versions of archived projects .................................................................. 61 

5.4 Viewing audit trails in the Audit Viewer .................................................................................. 62 
5.4.1 Viewing audit trails in the Audit Viewer .................................................................................. 62 
5.4.2 Audit Trail queries .................................................................................................................. 64 
5.4.3 Displaying exported audit trails .............................................................................................. 66 

5.5 Displaying audit trails in the Audit Viewer Control ................................................................. 67 
5.5.1 Adding Audit Viewer Control in the Graphics Designer ......................................................... 67 
5.5.2 Configuring the Audit Viewer Control ..................................................................................... 68 
5.5.3 Displaying audit trails in the Audit Viewer Control ................................................................. 69 

5.6 Exporting audit trails to a CSV file ......................................................................................... 70 

5.7 Data conversion ..................................................................................................................... 71 

6 Migration ............................................................................................................................................... 73 

6.1 Migrating audit data ............................................................................................................... 73 

6.2 Viewing Audit V7.2 multi-project database ............................................................................ 74 

6.3 Migrating Document Control and Project Versioning ............................................................. 75 

6.4 Migrating user administration ................................................................................................. 76 

6.5 InsertAuditEntry...................................................................................................................... 77 

 WinCC/Audit - Documentation 
4 System Manual, 03/2015, A5E35727153-AA 



 

 Using Audit 1 
 

 

Introduction 
WinCC/Audit is a WinCC option for monitoring WinCC configurations and user activities in 
WinCC Runtime.  

Approved configurations 
The following restrictions apply to Audit V7.3: 

● The project opened in WinCC Explorer must be stored on a local PC drive. 

● The "Client without own project" is not approved for Audit V7.3. 

Components of Audit 
Audit contains the following components: 

 
Component Description 
Audit Editor Specify Audit configurations.  
Audit Runtime (RT) Record events from the WinCC configuration and WinCC Runtime and save 

them as Audit Trails. 
Audit Viewer 
Audit Viewer Control 

Show exported Audit Trails and Audit Trails from a database. 
Display audit trails from a database in WinCC Runtime. 

Audit Document Control and  
Project Versioning 

Save and version WinCC project data. 
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Using Audit  
 

Using Audit 
Audit records WinCC engineering changes and user actions in runtime in so-called audit 
trails (audited events). The Audit Viewer allows the specific display and analysis of audit 
trails. 

The document control allows the document management of WinCC screens, C and VBS 
functions, reports and user documents. You can use project versioning to archive complete 
WinCC projects and restore project versions. 

Application examples 

Audit supports operation and maintenance for the following users: 

● Operators of validated plants in the pharmaceutical industry. 

● Tracking & tracing for plant operators, for example, in the food and beverage industry. 

● Serial equipment manufacturer with different versions of a central project. 

● OEMs who maintain plants for their customers worldwide. 

● Users who need to ensure gapless recording of operator actions for the purpose of 
traceability. 

● Users who need to implement the requirements of the FDA (Food and Drug 
Administration). 
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 Important information about the Audit Viewer 2 
 

 

Notes on the Audit Viewer 
The Audit Viewer requires special Windows rights.  

The Windows user using the Audit Viewer must be a member of the user group  
"SIMATIC HMI". 

If WinCC is installed on a PC in addition to the Audit Viewer, the user group exists already. 

"Standalone" Audit Viewer 

The Audit Viewer can also be used as a "stand-alone installation" on a PC without WinCC.  

The "SIMATIC HMI" user group is created locally with this installation in the Windows user 
and group management.  

 

 Note 

The Windows user performing the Audit installation is automatically registered as a member 
of the "SIMATIC HMI" user group.  

Additional Windows user using the Audit Viewer must be subsequently registered as 
members of the user group. 

After registration in the user group, the Windows user has to log on again in Windows. 
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 Audit basics 3 
3.1 Logon 

Introduction 
Logging on in Audit is performed through an authentication in "SIMATIC Logon".  

Each Audit user has the same rights.  

The following audit components require authentication: 

● Audit Editor 

● Audit Document Control and Project Versioning 

If you do not authenticate yourself, the Audit components are opened read-only. This means 
that the not all of the Audit functions will be available. 

You can authenticate yourself later via the shortcut menu in Audit Editor.  

You can authenticate yourself later via the menu bar in Audit Document Control and  
Project Versioning.  

Requirement 
● "SIMATIC Logon" is installed on your computer. 

● You are a member of the "SIMATIC HMI AUDIT" user group. 

Procedure 
1. Open the desired audit component. 

A SIMATIC Logon dialog appears. 

2. Enter your user name and password. 

3. Confirm your entries with "OK". 

Result 
You have authenticated yourself and can use all Audit functions. 
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Audit basics  
3.2 Changing the interface language 

3.2 Changing the interface language 

Audit Editor 
The interface language of the Audit Editor depends on the WinCC user interface language. 

To change the interface language, select your desired language with  
"Options > Language..." in the WinCC Explorer menu bar. 

Audit Viewer, and Audit Document Control and Project Versioning 
The user interface of the Audit Viewer, and Audit Document Control and Project Versioning 
can be set directly in the editors.  

To change the interface language, select your desired language with "Options > Language" 
menu bar. 
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 Audit basics 
 3.3 Audit components 

3.3 Audit components 

3.3.1 Audit Editor 

Function 
You can use the Audit Editor to define the activities you would like to audit in your  
WinCC project: 

● Activities in the individual WinCC components 

● Activities in user and configuration files 

● Runtime operation of objects 

The settings in the Audit Editor are made with check boxes that you can select or clear.  

The server of the Audit Trail database is also selected in the Audit Editor. The audit trails are 
stored in the Audit Trail database.  

The configuration changes within the Audit Editor are also saved as audit trails in the  
Audit Trail database. 

Open Audit Editor 
When you open a WinCC project after installing the Audit Editor, the Audit icon  appears 
in the navigation area. Double-click the Audit icon or open the Audit Editor from the shortcut 
menu. 
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Audit basics  
3.3 Audit components 

Layout 
The Audit Editor has the following layout: 

 
① Menu bar: 

The menu bar contains commands to perform common functions in the Audit Editor. 
② Quick search in the table area: 

The quick search enables you to search the table area for entries.  
③ Navigation area: 

The navigation area displays objects of the Audit Editor in a tree view.  
④ Table area: 

The table area displays the data records of the objects that are selected in the navigation area. 
⑤ "Properties" window: 

The "Properties" window displays the properties of a data record. 
⑥ Navigation bar: 

You can switch between the WinCC editors in the navigation bar. 
⑦ Status bar: 

The status bar shows the various states of the Audit Editor. 
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 Audit basics 
 3.3 Audit components 

Menu commands in the menu bar 
The menu bar contains some of the commands that you can call in the Audit Editor. 
Commands that you cannot use in the current situation are disabled (displayed in gray). 
Commands that you can call from the shortcut menu are described in the individual sections 
in which they are used. 

The following tables show the commands in the menu bar and their functions: 

The "File" menu contains the following commands: 
 
Command Function 
Project Documentation - Setup No function. 
Project Documentation - Preview No function. 
Project Documentation - Print No function. 
Close Closes the Audit Editor. 

 

The "Edit" menu contains the following commands: 
 
Command Function 
Copy No function. 
Paste No function. 
Undo No function. 
Redo No function. 
Import No function. 
Export No function. 

 

The "View" menu contains the following commands: 
 
Command Function 
Input language No function. 
Color scheme Changes the color setting in the Audit Editor. 

 

The "Help" menu contains the following commands: 
 
Command Function 
Contents and Index  Opens the online help of the Audit Editor. 
Info about WinCC Configuration Studio Opens an information window for the  

WinCC Configuration Studio. 
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Audit basics  
3.3 Audit components 

3.3.2 Audit Viewer 

Function 
The Audit Viewer is a viewer program for audit trails. You can view following with the  
Audit Viewer: 

● Audit trails that are saved in an Audit Trail database 

● Exported audit trails 

You can limit your Audit Trail views using pre-defined queries. You can create and save your 
own queries. 

Open Audit Viewer 
Open the Audit Viewer by double-clicking on the Audit Viewer icon  on your desktop. As 
an alternative, open the Audit Viewer via the Windows Start menu or "Apps". 

Opening the Audit Viewer in the WinCC Explorer 

When you open a WinCC project after installing the Audit Viewer, the Audit icon  appears 
in the navigation area. Open the Audit Viewer from the shortcut menu. 
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 Audit basics 
 3.3 Audit components 

Layout 
The Audit Viewer has the following layout: 

 
① Menu bar: 

The menu bar contains commands to perform special functions in the Audit Viewer.  
② Toolbar: 

The toolbar contains buttons to perform special functions in the Audit Viewer. 
③ Quick search in the table area: 

The quick search enables you to search the table area for entries. 
④ Navigation area: 

The navigation area displays objects of the Audit Viewer in a tree view. 
⑤ Table area: 

The table area displays the data records of the objects that are selected in the navigation area. 
⑥ Navigation bar: 

The navigation bar shows the editor you are in. 
⑦ Status bar: 

The status bar displays various information about the Audit Viewer. 
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Audit basics  
3.3 Audit components 

Menu commands in the menu bar 
The menu bar of Audit contains most of the commands that you can use in the Audit Viewer. 
Commands that you cannot use in the current situation are disabled (displayed in gray). 
Commands that you can call from the shortcut menu are described in the individual sections 
in which they are used. 

The following tables show the commands in the menu bar and their functions: 

The "File" menu contains the following commands: 
 
Command Function 
Refresh Refreshes the view in the table area. 
Print Prints the contents of the category or query that 

is selected in the navigation area.  
Export to CSV file Exports the selected audit trails to a CSV file. 
Show Audit File Displays a selected Audit file in the Audit Viewer. 
Recent Servers Lists the servers already in use. 
Recent Files Opens a list of recently opened files. 
Close Closes the Audit Viewer. 

 

The "Queries" menu contains the following commands: 
 
Command Function 
New Query Creates a new query. 
Delete Deletes the selected query. 
Rename Renames the selected query. 
Execute Executes the selected query. 

 

The "Options" menu contains the following commands: 
 
Command Function 
Language Changes the user interface language of the  

Audit Viewer. 
Settings The following settings can be made: 

• Maximum number of data records that can be 
saved in the table area. 

• Path to the user-defined queries. 
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 Audit basics 
 3.3 Audit components 

The "Help" menu contains the following commands: 
 
Command Function 
Contents and Index Opens the online help of the Audit Viewer. 
About Opens an information window for the  

Audit Viewer. 

Buttons in the toolbar 
The toolbar in the Audit Viewer contains the following functions: 

 
Icon Tooltip Function 

 
Refresh Refreshes the view in the table area. 

 
New Query Creates a new query. 

 
Delete Deletes the selected query. 

 
Rename Renames the selected query. 

 
Execute Executes the selected query. 

 
Settings The following settings can be made: 

• Maximum number of data records that can be saved in the table area. 
• Path to the user-defined queries. 

 
Close result view Closes the result view in the table area after executing a query. 

 
Export to CSV file Exports the selected audit trails to a CSV file. 

 
Show Audit File Displays a selected Audit file in the Audit Viewer. 

 
Print Prints the contents of the category or query that is selected in the navigation area. 

 
Help Opens the online help of the Audit Viewer. 
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Audit basics  
3.3 Audit components 

Meaning of the columns 
Audit trails have a defined structure that is displayed in the Audit Viewer.  
 
Column header Meaning 
ID Sequential ID of the recorded audit trails. 
Project ID Audit ID of the audited WinCC project. 
Project Name Project name of the audited WinCC project. 
Audit Type Area from which the event originates. 
Category ID Change category 
Subcategory ID Subcategory of the change. 
Target ID ID from a WinCC database. 
Target Name Name of the changed element. 
Specific Change ID Type of change made. 
Modification ID Performed change. 
Old Value If a data change was made, the old value is displayed here. 
New Value If a data change was made, the new value is displayed here. 
Date Time Date and time information (local time) when the change was made. 
Time Zone Offset Time difference to Coordinated Universal Time (UTC). 
Windows User Name of the Windows user who performed the change. 
Application User Name of the application user who performed the change. 
Computer Name Computer name on which the change was made. 
Operator Message ID Message number 
Reason Comments or further information about the event. 

Migrated audit trails are displayed in the following columns: 
 
Column header Meaning 
Legacy Project GUID Project ID of the audited WinCC project prior to V7.3. 
Legacy Database Name WinCC database name of the previous version of V7.3. 
Legacy Application Name Name of the application of the previous version of V7.3. 
Legacy Table Name Name of the SQL table of the previous version of V7.3. 
Legacy Field Name Field name of the previous version of V7.3. 
Legacy Event Type Performed change of the previous version of V7.3. 
Legacy Event Item Changed item of the previous version of V7.3. 
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 Audit basics 
 3.3 Audit components 

3.3.3 Audit Viewer Control 

Function 
The Audit Viewer Control is an ActiveX control that is embedded in the Graphics Designer as 
an OCX file. 

You can use the Audit Viewer Control in a process picture (.pdl) to view the stored audit trails 
and evaluate them in Runtime. The user interface is identical to the one in Audit Viewer. 
There is no menu bar, only the toolbar with a reduced number of icons. Exported audit trails 
cannot be displayed in the Audit Viewer Control. 

 

You can find additional information under: 

● Audit Viewer (Page 14) 

3.3.4 Audit Document Control and Project Versioning 

Function 
Audit Document Control and Project Versioning contains the following functions: 

● Versioning of projects and files 

● Checking in and checking out individual files 

● Restoring previous versions 

All activities performed in Audit Document Control and Project Versioning can be saved as 
audit trails in the Audit Trail database. They first have to be configured in the Audit Editor. 

Opening Audit Document Control and Project Versioning 
When you open a WinCC project after installing the Audit Document Control and Project 
Versioning, the Audit icon  appears in the navigation area. Open Audit Document Control 
and Project Versioning in the shortcut menu, or double-click the Audit DCPV icon  on your 
desktop. 

As an alternative, open Audit Document Control and Project Versioning with the Windows 
Start menu or "Apps". 

Opening Audit Document Control and Project Versioning in the Audit Editor 

You can also open the Audit Document Control and Project Versioning from the Audit Editor: 

1. In the Audit Editor, click "Document Control and Project Versioning" under "Audit 
Settings" in the navigation area. 

2. Select "Open" from the shortcut menu. 
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Audit basics  
3.3 Audit components 

Layout 
Audit Document Control and Project Versioning has the following layout: 

 
① Menu bar: 

The menu bar contains commands to perform special functions in Audit Document Control and Project Versioning.  
② Toolbar: 

The toolbar contains buttons to perform special functions in Audit Document Control and Project Versioning. 
③ Quick search in the table area: 

The quick search enables you to search the table area for entries. 
④ Navigation area: 

The navigation area displays the objects of the editor in a tree view. 
⑤ Table area: 

The table area displays the data records of the objects that are selected in the navigation area. 
⑥ Navigation bar: 

The navigation bar shows the editor you are in. 
⑦ Status bar: 

The status bar displays various information about Audit Document Control and Project Versioning. 
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 Audit basics 
 3.3 Audit components 

Menu commands in the menu bar 
The menu bar of Audit contains most of the commands that you can use in the  
Audit Document Control and Project Versioning. Commands that you cannot use in the 
current situation are disabled (displayed in gray). Commands that you can call from the 
shortcut menu are described in the individual sections in which they are used. 

The following tables show the commands in the menu bar and their functions: 

The "Document" menu contains the following commands: 
 
Command Function 
Enable Document Control Activates the document control. 
Disable Document Control Deactivates the document control. 
Close Closes Audit Document Control and  

Project Versioning. 

 

The "Project" menu contains the following commands: 
 
Command Function 
Archive Project Archives a WinCC project. 
Current Project History Displays the project history of the current  

WinCC project.  
Complete Project History Displays the project history of all archived  

WinCC projects.  

 

The "Options" menu contains the following commands: 
 
Command Function 
User Login Login of the user. 
User Logout Logout of the user. 
Language Changes the user interface language of  

Audit Document Control and Project Versioning. 

 

The "Help" menu contains the following commands: 
 
Command Function 
Contents and Index Opens the online help of Audit Document Control 

and Project Versioning. 
About Opens an information window for Audit Document 

Control and Project Versioning. 
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3.3 Audit components 

Buttons in the toolbar 
The toolbar in Audit Document Control and Project Versioning contains the following 
functions: 

 
Icon Tooltip Meaning 

 

 

Enable Document Control 
Disable Document Control 

Activates the document control. 
Deactivates the document control. 

 
Archive Project Archives a WinCC project. 

 
Current Project History Displays the project history of the current WinCC project.  

 
Complete Project History Displays the complete project history of all archived WinCC projects.  

 

 

User Login 
User Logout 

Login of the user. 
Logout of the user. 

 

 

Show/hide system pictures  
(@ prefix) 

Show WinCC project files that have the "@" prefix. 
Hide WinCC project files that have the "@" prefix. 

 
Help Opens the online help of Audit Document Control and Project Versioning. 
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 Basic procedure 4 
4.1 Working with WinCC/Audit 

Procedure 
In Audit Editor, the direct help for the selected field is available in the "Properties" window. 

To manage and monitor a WinCC project or project data in Audit, follow the steps of the 
procedure.  

You must be authenticated to work with the Audit Editor. 
 

 Note 
WinCC Audit ChangeControl CC license 

If you have installed only the WinCC Audit ChangeControl CC license, the Audit Editor 
includes only the "WinCC Configuration" and "WinCC Documents" components under  
"Audit Settings".  

 

Step 1: Connect the Audit Trail server 
1. To display the Audit Trail servers, click "Select Audit Trail server" in the navigation area. 

2. Select the Audit Trail server on which the Audit Trail Database is located or is going to be 
created. 

To do so, select the entire table row. 

3. Select "Select Server" in the shortcut menu. 

Step 2: Specify WinCC components for auditing 
1. Click "Audit Settings" in the navigation area. 

2. In the "WinCC Configuration" line, select the check box in the "Activated" column. 

3. To specify the monitoring for individual WinCC components, click "WinCC Configuration" 
under "Audit Settings" in the navigation area. 

4. Select or clear the check box for the respective component in the "Activated" column. 

To activate or deactivate all components, select the column "Activated" and select  
"Select all" or "Deselect all" in the shortcut menu. 
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Basic procedure  
4.1 Working with WinCC/Audit 

Step 3: Activate document monitoring 
1. Activate the "WinCC Documents" component under "Audit Settings". 

The following events are saved in the Audit Trail database for the monitored documents: 

● Create 

● Edit 

● Delete 

Step 4: Enable document control and archive WinCC projects 
1. To open the editor, under "Audit Settings" in the navigation area select the "Open" 

command in the shortcut menu of "Audit Document Control and Project Versioning". 

2. Log in with your user name and password. 

3. In the open editor, select "Document > Enable document control". 

4. In the "Version configuration" dialog, configure the version number in the fields  
"Version mask" and "Special characters". 

5. Select the required category under "Document Control" in the navigation area. 

The WinCC files are listed in the table area and can be checked in or out. 

6. To create a WinCC project, select "Project > Archive Project" in the menu bar. 

You can display all WinCC projects and project versions. To do so, select  
"Project > Complete project history" in the menu bar. 

You can find additional information in the online help of the "Audit Document Control and 
Project Versioning" editor. 

Use the Audit Editor again for the following steps. 

Step 5: Activate User Archive Runtime for auditing 
Requirement: You are using the WinCC option "User Archive". 

1. To monitor the value change in the user archives, activate the "User Archive (RT)" 
component under "Audit Settings". 
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 Basic procedure 
 4.1 Working with WinCC/Audit 

Step 6: Monitoring user actions 
1. Activate the "User Actions (RT)" component under "Audit Settings". 

The following actions are audited: 

● Messages 

– Standard operator messages that are output with process picture operations if the 
"Operator Message" property is activated or a direct connection is configured. 

– User operator messages which are triggered by message tags, C script or VB script 
(standard "GCreateMyOperationMsg" function or "HMIRuntime.Alarms" method). 

– System events (e.g., login, logout, login failed) 

– Messages from the message number range from 1900000 to 1901000 

● Scripting 

– InsertAuditEntryNew 

Audit saves all events directly to the Audit Trail Database with the 
"InsertAuditEntryNew" function. 

Additional information can be found in the Audit documentation and the  
WinCC documentation. 

Step 7: Activate / deactivate the "Operator Message" and "Operator Activities Report" property 
You can activate or deactivate the property "Operator Message" and  
"Operator Activities Report" for specific graphic objects. You activate or deactivate the 
properties in the Graphics Designer or in the Audit Editor as follows: 

1. Activate the "User Actions (RT)" component under "Audit Settings". 

2. Select "Audit Settings > User Actions (RT)" in the navigation area. 

3. Select the required process pictures in the table area. 

4. Select the required process picture under "User actions (RT)" in the navigation area. 

5. In the table area, activate or deactivate the required option for the displayed objects. 

To apply the change, click on another area in the navigation area or close the  
Audit Editor. 

These settings are applied to the object properties in the Graphics Designer. 

When you change the setting in the Graphics Designer, the option is also activated or 
deactivated in the Audit Editor. 
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 Note 
Update view 

When a new process picture is created or new objects are inserted in a process picture, the 
view is not automatically updated in the Audit Editor. 

To update the view, follow these steps: 
• Display new process picture: Select the "Refresh" command in the "User Actions (RT)" 

shortcut menu. 
• Display new object in the process picture: Right-click the modified process picture under 

"User Actions (RT)". 
 

Additional information can be found in the Audit documentation and the  
WinCC documentation. 

Step 8: Displaying Audit Trails 
1. Select the command "Open Audit Viewer" in the "Audit" shortcut menu of the WinCC 

Explorer or click the "Audit Viewer" desktop icon. 

2. In the table area, select the server with the required Audit Trail database under "Audit 
DB" in the open viewer. 

To do so, select the entire table row. 

3. Select "Select Server" in the shortcut menu. 

4. To limit the display to specific events, for example, use the offered queries under "System 
queries" or create your own query. 

You can find additional information in the online help of the Audit Viewer. 

Step 9: Configuring Audit Viewer Control for display in WinCC Runtime 
To display the content of the Audit Trail Database in WinCC Runtime, add the  
"Audit Viewer Control" in a process picture in the WinCC Graphics Designer. 

 WinCC/Audit - Documentation 
26 System Manual, 03/2015, A5E35727153-AA 



 Basic procedure 
 4.1 Working with WinCC/Audit 

Notes on the Audit Editor 
Compared to the default behavior of the WinCC Configuration Studio, the Audit Editor has 
the following modified behavior: 
 
Navigation Entry Behavior in the Audit Editor 
Menu bar Edit > Import No function 
Menu bar Edit > Export No function 
Menu bar Edit > Paste No function 
Menu bar View > Input language No function 
Table area, e.g., Audit Trail 
Server 

"Delete" shortcut menu No function 

Table area: Selected row or 
column 

"Cut" / "Paste" shortcut menu No function 

Table area: Selected row or 
column 

"Find and replace" shortcut 
menu 

"Find" can be used. 
No function: "Replace" 

Table area Automatic continuation ("drag-
down") 

No function 
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4.2 Working with the Audit Viewer 

Procedure 
To display the events saved in the Audit Trail database in the Audit Viewer, follow the steps 
in the procedure. 

Step 1: Connect the Audit Trail database 
1. In the navigation area, select "Audit DB". 

2. In the table area, select the server with the required Audit Trail Database. 

To do so, select the entire table row. 

3. Select "Select Server" in the shortcut menu. 

The selected Audit Trail server with the connected database is displayed under "Audit DB" in 
the navigation area. 

Step 2: Display audit trails 
1. Click the connected server with the Audit Trail database under "Audit DB" in the 

navigation area. 

You can see the events of the Audit Trail database in the table area. 

2. To configure the number of displayed rows, select "Options > Settings" in the menu bar. 

3. To display the events in a sorted manner, select the required category below the  
Audit Trail database. 

Step 3: Filter audit trails with system queries 
1. Select "Audit DB > <Audit Trail Server\Database> > Query > System Query" in the 

navigation area. 

2. Select the required system query. 

3. Select "Execute" in the shortcut menu. 

Step 4: Filter audit trails with user queries 
1. Select "Audit DB > <Audit Trail Server\Database> > Query > User Query" in the 

navigation area. 

2. In the shortcut menu, select "New Query". 

3. Define your query in the table area. 

The next field to be processes is always identified by an asterisk. The Audit Viewer 
supports you in creating the query using drop-down lists in the fields. 

4. Select your created query in the navigation area. 

5. Select "Execute" in the shortcut menu. 
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Notes on the Audit Viewer 
Compared to the default behavior of the WinCC Configuration Studio, the Audit Viewer has 
the following modified behavior: 
 
Navigation Entry Behavior in the Audit Viewer 
Menu bar File > Print No function 
Table area: Selected row or 
column 

"Delete" shortcut menu No function 

Table area: Selected row or 
column 

"Cut" / "Paste" shortcut menu No function 

Table area: Selected row or 
column 

"Find and replace" shortcut 
menu 

"Find" can be used. 
No function: "Replace" 

Table area Automatic continuation ("drag-
down") 

No function 
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4.3 Working with Document Control and Project Versioning 

Procedure 
To create and manage file versions and project versions, follow the steps of the procedure.  

You must be authenticated to work with Audit Document Control and Project Versioning. 

Step 1: Enable document control and configure versioning 
1. Select "Document > Enable document control" in the menu bar. 

2. In the "Version configuration" dialog, configure the version number in the fields  
"Version mask" and "Special characters". 

The files included in the open WinCC project are checked in and must be checked out for 
editing. 

Step 2: Check out file 
1. Select the required category under "Document Control" in the navigation area. 

2. In the table row, select the file you want to check out. 

3. Select "Check Out" in the shortcut menu. 

4. You have the option to enter a comment and confirm with "Check out". 

Step 3: Check in file 
1. Select the required category under "Document Control" in the navigation area. 

2. In the table row, select the file you want to check in. 

3. Select "Check In" in the shortcut menu. 

4. Enter a comment or apply the existing comment. 

5. Confirm with "Check in" to apply the automatically incremented version number. 

If you want to continue versioning with a new, higher-level segment, deactivate the 
"Automatic versioning" option and select the corresponding segment. 
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Step 4: Archiving and versioning an open WinCC project 
1. Select "Project > Archive Project" in the menu bar. 

2. Make sure that the "Archive Current Project" option is activated. 

If versioning has not been configured yet, the "Version configuration" dialog opens. 
Configure the versioning. 

3. Enter a comment. 

4. Confirm with "Archive" to apply the automatically incremented version number. 

If you want to continue versioning with a new, higher-level segment, deactivate the 
"Automatic versioning" option and select the corresponding segment. 

Step 5: Archiving and versioning a closed WinCC project 
Requirement: The version configuration for the closed WinCC project has already been 
completed. 

1. Select "Project > Archive Project" in the menu bar. 

2. Deactivate the "Archive Current Project" option and navigate to the storage path of the 
required WinCC project. 

3. Enter a comment. 

4. Confirm with "Archive" to apply the automatically incremented version number. 

If you want to continue versioning with a new, higher-level segment, deactivate the 
"Automatic versioning" option and select the corresponding segment. 

Step 6: Restore version 
1. To restore an archived project version, for example, select "Project Versioning" in the 

navigation area. 

2. Select the table row of the required project. 

3. Select "View Project History" from the shortcut menu. 

4. Select the table row of the required version. 

5. Select "Restore" from the shortcut menu. 

6. Select the storage location and confirm with "OK". 
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Notes on Audit Document Control and Project Versioning 
Compared to the default behavior of the WinCC Configuration Studio, the Audit Document 
Control and Project Versioning editor has the following modified behavior: 
 
Navigation Entry Behavior in Audit Document 

Control and Project Versioning 
Table area: Selected row or 
column 

"Delete" shortcut menu No function 

Table area: Selected row or 
column 

"Cut" / "Paste" shortcut menu No function 

Table area: Selected row or 
column 

"Find and replace" 
 shortcut menu 

"Find" can be used. 
No function: "Replace" 

Table area: Selected row or 
column 

"Configuration dialog"  
shortcut menu 

Same behavior as the  
"Check Out and Edit" function. 

Table area: Double-click select-
ed row 

- Same behavior as the  
"Check Out and Edit" function. 

Table area Automatic continuation  
("drag-down") 

No function 
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 Working with Audit 5 
5.1 Configuring the Audit Trail database 

5.1.1 Audit Trail multi project database 

Audit Trail multi project database 
You have one or more PCs running one or more WinCC projects that you want to audit.  

In this case, create an Audit Trail multi project database. All audit trails are stored in one 
database. 

If there is no network connection between the PCs over a certain period, your audit data is 
not lost. Audit stores the audit trails in a local cache. When the network connection is re-
established, the audit trails are automatically transferred to the multi project database.  

You can also set up a central Audit multi project database on a PC on which there is no 
WinCC project. At least a minimal installation of WinCC and Audit Runtime must be installed 
on this PC.  

 

 Note 
Switching the Audit Trail multi project database to another Audit Trail multi project database  

If you switch from one Audit Trail multi project database to another Audit Trail multi project 
database, your recorded audit trails are not transferred. 
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Requirement 
● Audit is fully installed and licensed. 

● A network connection is available. 

Procedure 
1. Open the WinCC project that you want to audit. 

2. Open the Audit Editor and authenticate yourself. 

3. In the navigation area, select "Select Audit Trail Server". 

The table area displays all Audit Trail servers on which at least Audit Runtime is installed.  

4. Select the table row of the desired Audit Trail server in which the database type is  
"Multi project database". 

5. Select "Select Server" in the shortcut menu. 

Result 
Your PC is connected to the desired Audit Trail server on which there is a  
multi project database.  

5.1.2 Audit Trail single project database 

Audit Trail single project database 
You have a PC running a single WinCC project (single project) that you want to audit. Your 
WinCC project is not additionally running on another PC.  

In this case, create an Audit Trail single project database.  
 

 Note 
Audit Trail multi project database 

If you want to access from multiple PCs or access multiple WinCC projects in the same 
database, connect to an Audit multi project database.  

You can find additional information under: 
• Audit Trail multi project database (Page 33) 

 

Changing the Audit Trail database  

If you switch from one Audit Trail single project database to an Audit Trail multi project 
database, your recorded audit trails are not transferred. 
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 5.1 Configuring the Audit Trail database 

Requirement 
● Audit is fully installed. 

Procedure 
1. Open the WinCC project that you want to audit. 

2. Open the Audit Editor and authenticate yourself. 

3. In the navigation area, select "Select Audit Trail Server". 

The table area displays all Audit Trail servers on which at least Audit Runtime is installed.  

4. Select the table row of the desired Audit Trail server in which the database type is  
"Single Project Database". 

5. Select "Select Server" in the shortcut menu. 

Result 
Your PC is connected to the desired Audit Trail server on which there is a  
single project database.  
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5.2 Monitoring a WinCC project with Audit 
Specify the components that you want to audit in the Audit Editor.  

All settings in the Audit Editor are also saved as audit trails in the Audit Trail database. 

If you have not yet configured an Audit Trail database and have already made settings in the 
Audit Editor, these activities are not audited. 

First, configure the Audit Trail database to record future activities in the Audit Editor in the 
Audit Trail database. 

You can find additional information under: 

● Configuring the Audit Trail database (Page 33) 

5.2.1 Making Audit settings 

Introduction 
Specify what you want to monitor with Audit in the Audit Editor under "Audit Settings". To 
enable the settings, select the check boxes.  

 
Audit settings Description 
WinCC configuration Monitor a WinCC configuration in Audit. 
WinCC documents Monitor changes to the WinCC project files. 
User archives (RT) Monitor changes within a user archive, such as value changes. 
User Actions (RT) Monitor user actions in WinCC Runtime. 

Requirement 
● Your WinCC project is open. 

● The Audit Editor is open and you have authenticated yourself. 

Procedure 
1. Click "Audit Settings" in the navigation area. 

2. Select the check box for the respective component in the "Activated" column. To activate 
or deactivate all components, select the "Activated" column and then select "Select all" in 
the shortcut menu. 

Result 
You have made the Audit settings. You can to deactivate the respective components by 
clearing the check box in the "Activated" column. 

In the next step, you specify which WinCC editors or WinCC components are to be 
monitored.  
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5.2.2 Specify WinCC components for auditing 

Introduction 
Specify the WinCC components that you want to monitor in the Audit Editor. 

Select the following WinCC components: 

● WinCC Project Properties 

● Computer Properties 

● Tag Management 

● Alarm Logging 

● Tag Logging 

● Text Library 

● User Administration 

● User Archives 1) 

● Report Designer 

● Redundancy 

● Time Synchronization 

● Picture Tree Manager 
1) Only the configuration is monitored, not the data input. 

Requirement 
● Your WinCC project is open. 

● The Audit Editor is open and you have authenticated yourself. 

● Activate the "WinCC Configuration" component under "Audit Settings". 

Procedure 
1. Click "WinCC Configuration" under "Audit Settings" in the navigation area. 

2. Select the check box for the respective WinCC component in the "Activated" column. To 
activate or deactivate all WinCC components, select the "Activated" column and then 
select "Select all" in the shortcut menu. 

Result 
You have specified the WinCC components for auditing. You can to deactivate the 
respective WinCC components by clearing the check box in the "Activated" column. 
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5.2.3 Activate document monitoring 

Introduction 
When you activate document monitoring, all activities in user and configuration files are 
recorded as an events in the Audit Trail database. 

Audit monitors the following: 

● Creation of a document 

● Changes to a document 

● Deletion of a document 

Overview 
The following table shows the user and configuration files for which document monitoring 
can be performed: 
 
User files and configuration files Formats, file types 
Computer properties Gracs.ini 
Picture files PDL 
Menus and toolbars MTL 
Report layouts RPL 
C scripts PAS (actions) 

FCT (project functions) 
VB Scripts BAC (actions) 

BMO (project modules) 
Redundancy path settings Data.cs 
Alarm logging settings  CCAlarmFilterStorage.xml 
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Requirement 
● Your WinCC project is open. 

● The Audit Editor is open and you have authenticated yourself. 

Procedure 
1. Click "Audit Settings" in the navigation area. 

2. Select the check box for the "WinCC Documents" component in the "Activated" column of 
the table area. 

Result 
You have activated document monitoring. You can to deactivate the document monitoring by 
clearing the check box in the "Activated" column. 

See also 
Saving and versioning external data (Page 58) 
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5.2.4 Monitoring user actions with Audit 

5.2.4.1 User actions monitored with Audit 
Audit allows you to monitor user activity in WinCC Runtime. 

 

Audit monitors the following actions: 

● Messages 

– Standard and user operator messages 

– Messages from a message number range 

– System events 

● Scripting 

– InsertAuditEntryNew 

 

5.2.4.2 Standard operator messages 
Standard operator messages are messages that are pre-defined in a WinCC project in Alarm 
Logging by default.  

Standard operator messages have the following properties: 

● Message class: System, without acknowledgment 

● Message type: Operator message 

● Message number: 12508141 

 

You can trigger a standard operator message for a process picture operation via: 

● "Operator message" property 

● Direct connection 
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"Operator message" property 
You can enable the "Operator message" property for a required object in the  
Graphics Designer. 

You can enable the "Operator message" property for the following object types: 

● I/O field 

● Text list 

● Combo box 

● List box 

● Check box 

● Radio box 

● Slider 

Message number 12508141 is generated when the configured object is operated in  
WinCC Runtime.  

Audit stores this event in the Audit Trail database. 

"Operator activities report" property 

In addition to "Operator Message" property, you can set the "Operator Activities Report" 
property for the following object types: 

● I/O field 

● Text list 

● Combo box 

● List box 

● Slider 

When the configured object is operated in WinCC Runtime, the operator is prompted to enter 
a comment regarding the change. Message number 12508141 is generated with the 
comment.  

Audit stores this event in the Audit Trail database. 

Direct connection 
For all other types of objects in the Graphics Designer, there is no "Operator message" or 
"Operator activities report" property. Set an action with a direct connection to a tag for the 
desired object. Select the "Operator message" option in the direct connection dialog. 

Message number 12508141 is generated when the configured object is operated in  
WinCC Runtime. 

Audit stores this event in the Audit Trail database. 
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5.2.4.3 User operator messages 
User operator messages are messages that you create in Alarm Logging. 

Audit monitors user operator messages with the following properties: 

● Message class: System, without acknowledgment 

● Message type: Operator message 

● Message number: any 

 

You can trigger a user operator message for a process picture operation via: 

● Message tag 

● C script function "GCreateMyOperationMsg" 

● VB script function "HMIRuntime.Alarms" 

You can find additional information in the WinCC Information System under Working with 
WinCC". 

 

The message number of the created user operator message is generated when the 
configured object is operated in WinCC Runtime.  

Audit stores this event in the Audit Trail database. 

Message tag 
Assign a "Message tag" to the user operator message. Connect the required object to the 
message tag in Alarm Logging.  

C script function "GCreateMyOperationMsg" 
Define an action with a C script for a desired object in the Graphics Designer. Use the 
"GCreateMyOperationMsg" function. 

Example for "GCreateMyOperationMsg" 
 
 
GCreateMyOperationMsg(0x00000001,1,lpszPictureName,lpszObjectName,15,1,2,"mycomment"); 
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VB script function "HMIRuntime.Alarms" 
Define an action with a VB script for a desired object in the Graphics Designer. Use the 
"HMIRuntime.Alarms" function. 

Example for "HMIRuntime.Alarms" 
 
 
'VBS360 
Dim MyAlarm 
Set MyAlarm = HMIRuntime.Alarms(1) 
MyAlarm.State = 5 'hmiAlarmStateCome + hmiAlarmStateComment 
MyAlarm.Comment = "MyComment" 
MyAlarm.UserName = "Hans-Peter" 
MyAlarm.ProcessValues(1) = "Process Value 1" 
MyAlarm.ProcessValues(4) = "Process Value 4" 
MyAlarm.Create "MyApplication" 

5.2.4.4 Messages from a message number range 
Audit monitoring messages from 1900000 to 1901000. 

Message numbers from 1900000 to 1900050 
The message numbers 1900000 to 1900050 are reserved for WinCC options and add-ins. 
This includes, for example, the electronic signature. 

These message numbers cannot be edited. 

 

You can find additional information in the WinCC Information System under: 

● "Working with WinCC > Structure of the User Administration > Central user administration 
with SIMATIC Logon". 

Message numbers from 1900051 to 1901000 
Audit controls messages with message numbers from 1900051 to 1901000 of any message 
type. 

You can trigger a message for a process picture operation via: 

● Message tag 

● C script function "GCreateMyOperationMsg" 

● VB script function "HMIRuntime.Alarms" 

 

You can find additional information under: 

● User operator messages (Page 42) 
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5.2.4.5 System events 
System events are messages that are pre-defined in a WinCC project in Alarm Logging by 
default.  

System events have the following properties: 

● Message class: System, without acknowledgment 

● Message type: Process control system 

 

Audit monitors the system events: 
 
Message number Description 
1008000 Connection to chipcard-terminal has been interrupted 
1008001 Incorrect login name/password 
1008002 Invalid login name/password by chipcard 
1008003 Manual login 
1008004 Login by chipcard 
1008005 Manual logout 
1008006 Logout by chipcard 
1008007 Automatic logout by timeout 
1008008 Notification of service user/group '@102%s@' in effect 

5.2.4.6 InsertAuditEntryNew 
"InsertAuditEntryNew" is a script function that is used in an object in the Graphics Designer. 
When the object is operated in WinCC Runtime, the event is immediately saved in the  
Audit Trail database.  

InsertAuditEntryNew functions 
Use the following InsertAuditEntryNew functions: 
 
Function Description 
InsertAuditEntryNew.fct Function for C script. 
InsertAuditEntryNew.bmo Function for VB script. 

InsertAuditEntryNew in the Script Editor or in the Graphics Designer 

C Editor/Graphics Designer 

You can find the InsertAuditEntryNew function in the navigation area under  
"Standard Functions > Options". 

VBS Editor/Graphics Designer 

You can find the InsertAuditEntryNew function in the navigation area under  
"Standard Modules". 
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Example of a simple script  

Comment in Runtime 

You can use a script to decide whether to open a comment dialog in runtime or use the 
comment directly from the scripting. 

When a comment dialog is used, the user is prompted to enter a comment in runtime. Enter 
"1" after the "Comment" parameter to do this. 

To use the comment directly from the script, write a comment at the "Comment" parameter 
and enter "0" after the parameter. 

 

The following table shows the various script options and the view in Audit Trail:  
 
Comment Show in Audit Trail Example script 
Show comment dialog in runtime. The comment entered in the dialog is recorded 

in Audit Trail. 
"Comment", 1 

Use comment from script. The comment entered for the "Comment" pa-
rameter is recorded in Audit Trail. 

"Comment", 0 

C script: InsertAuditEntryNew.fct  
 
 
char* szBuf = (char*)SysMalloc(128); 
InsertAuditEntryNew("old Value","new Value", "Comment", 0, szBuf); 
SysFree(szBuf ); 

VBS script: InsertAuditEntryNew.bmo 
 
 
InsertAuditEntryNew "old Value", "new Value", "Comment", 0 
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5.2.4.7 Monitoring user actions with Audit 

Introduction 
Monitor user activities in WinCC Runtime. 

 

You can find additional information under: 

● User actions monitored with Audit (Page 40) 

Requirement 
● Your WinCC project is open. 

● The required configurations have been made in the Alarm Logging or Tag Logging, for 
example, system events have been enabled, operator messages have been configured, 
etc. 

● "Alarm Logging Runtime" is enabled under "Computer Properties > Startup" in the  
WinCC Explorer. 

● The Audit Editor is open and you have authenticated yourself. 

Procedure 
1. Click "Audit Settings" in the navigation area. 

2. Select the check box for the "User Actions (RT)" component in the "Activated" column of 
the table area. 

Result 
You have activated the "User Actions (RT)" component. You can deactivate the component 
by re-selecting the check box in the "Activated" column. 

5.2.4.8 Activate / deactivate the Operator Message and Operator Activities Report property 

Introduction 
Audit provides an additional function for the activation and deactivation of the "Operator 
message" and "Operator activities report" property for the standard operator messages.  

You get an overview of all of the Audit Editor process pictures and their configured objects in 
your WinCC project. 

 

You can find additional information under: 

● Standard operator messages (Page 40) 
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Requirement 
● Your WinCC project is open. 

● "Alarm Logging Runtime" is enabled under "Computer Properties > Startup" in the  
WinCC Explorer. 

● The Audit Editor is open and you have authenticated yourself. 

Procedure 
1. Click "Audit Settings" in the navigation area. 

2. Select the check box for the "User Actions (RT)" component in the "Activated" column of 
the table area. 

3. Select "User Actions (RT)" in the navigation area. 

The table area shows all process pictures that have been created in the open  
WinCC project. 

If a newly created process picture does not appear in the table area, select the "Refresh" 
command in the "User Actions (RT)" shortcut menu. 

4. Select the process picture that contains the object type of a standard operator message. 

The activated process picture is displayed under "User Actions (RT)" in the navigation 
area.  

5. Select the process picture in the navigation area. 

The configured objects in the process picture are displayed in the table area. 

6. Select or clear the check boxes of the "Operator message" and  
"Operator Activities Report" column. 

If a newly created object does not appear in the Audit Editor, right-click on the change 
process picture under "User Actions (RT)". 

To apply the change in the check box, click on another area in the navigation area or 
close the Audit Editor. 

If no object type of a standard operator message is present in the process picture, this option 
has no effect. 

 

 Note 
Saving an open PDL in the Graphics Designer 

If the PDL is open in the Graphics Designer when a change is being made in the  
Audit Editor, save the picture to keep the changes.  

 

Result 
These changes are transferred and saved in the PDL.  
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5.3 Saving and versioning WinCC project data. 

Introduction 
Audit Document Control and Project Versioning allows you to back up your  
WinCC project files and archive your WinCC projects. 

To back up your WinCC project files, you first need to enable document control. 

When you enable document control or archive an open project the first time, you must set 
the version number. 

Principle of document control 
You can perform the following functions after enabling document control: 

● Check in WinCC project files 

● Check out WinCC project files 

● Restore WinCC project files 

● Compare WinCC project files with each other 

When you enable document control, all WinCC project files are automatically checked into 
your open WinCC project.  

 

 Note 
Restoring WinCC project files 

Restoring overwrites the current version with the new version. 
 

Editing and creating files in WinCC  

To edit a file, you must first check it out in Audit Document Control and Project Versioning. 
Only then can the file be edited with the appropriate WinCC editors. 

When you create a new file, the file is displayed as "Unversioned" in the  
Audit Document Control and Project Versioning. Check in the file to save it. 

All check-in operations as well as file restorations are displayed in the file history. 
 

 NOTICE 

Loss of data with deactivation of the document control 

When you deactivate document control, all archived WinCC project files are lost. 
 

Changing computer properties 

If you want to change the computer properties when document control is activated, you need 
to check out the "GraCS.ini" file in the navigation area under  
"Document Control > Computer". Only then can you make changes in the  
"Graphics Runtime" and "Runtime" tabs. 
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User and configuration files 

The following table shows the user and configuration files for which document control can be 
performed: 
 
User files and configuration files Formats, file types 
Computer properties Gracs.ini 
Picture files PDL 
Menus and toolbars MTL 
Report layouts RPL 
C scripts PAS (actions) 

FCT (project functions) 
VB Scripts BAC (actions) 

BMO (project modules) 
Miscellaneous files Custom files that are stored in the project path 

under "Misc Docs (Document Control)".1)  

1) You can find additional information under: 

● Saving and versioning external data (Page 58) 

Principle of project versioning 
You can perform the following actions using project versioning: 

● Archive WinCC projects 

● Restore WinCC projects 

 

 Note 
Restoring WinCC projects 

Restoring copies the selected version of the archived WinCC project to the destination path. 
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Storage paths of archive files 

Archive files of the WinCC project files 

When a WinCC project file is checked in, Audit creates a compressed GZ file and stores it in 
the "Document Control" folder. This folder is created automatically in your WinCC project 
folder. 

Archive files of the WinCC projects 

When a WinCC project is archived, Audit creates a compressed GZ file and stores it locally 
in the following path: 

● <Public Documents>\Siemens\Audit\AuditDCV 

You can navigate to another archive path when archiving a WinCC project. 
 

 NOTICE 

Data loss when changing archive files 

When you make changes to the archive files, data loss will occur. This means it is no longer 
possible to restore the WinCC project files or WinCC projects in Audit Document Control 
and Project Versioning. 

You may not make the following changes: 
• Delete 
• Rename 
• Move 

 

See also 
WinCC project files (Page 54) 

WinCC projects (Page 59) 
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5.3.1 Enable Document Control 

Introduction 
If you enable document control, you will be prompted once to configure the version number.  

 

First read the following section carefully: 

● Configuring the version number (Page 52) 

Requirement 
● Your WinCC project is open. 

● Audit Document Control and Project Versioning is open and you have authenticated 
yourself. 

Procedure 
1. Select "Document > Enable Document Control" from the menu bar or click on the  

"Enable document control" icon in the toolbar. 

The "Version configuration" dialog opens. 

2. Select the version mask and the special characters. 

3. Confirm your entries with "OK". 

Result 
All the files in your WinCC project are automatically checked in according to the versioning 
mask in Audit Document Control and Project Versioning. 
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5.3.2 Configuring the version number 

Introduction 
In Document Control and Project Versioning, you define the version number that is used with 
every versioning of files and projects. The version number consists of 4 segments. When a 
file is checked in or when a project is archived, the segments of the version number are 
incremented, depending on which version mask you have selected. 

 

 Note 

The versioning is configured only once for each WinCC project and cannot be changed. 
 

Defining the version mask and delimiter 
When you enable document control, you are prompted to configure the version number. 
Select from the following version masks: 
 
Version mask Definition 
PP.DD.DD.DD Project_version.Document_version.Document_version.Document_version 
PP.PP.DD.DD Project_version.Project_version.Document_version.Document_version 
PP.PP.PP.DD Project_version.Project_version.Project_version.Document_version 

Select the delimiter from the following special characters:  

. , : ; - + * # 

File versioning 
File versioning depends on your open WinCC project. Document Control and  
Project Versioning displays all existing files in the project. If you have not enabled document 
control, you will see your files in the table area with the "Unversioned" status. If you enable 
document control via the menu bar, you are prompted to configure the version number. 
When the configuration is complete, all WinCC files are checked in automatically. The back 
segment of each file gets a 1. 

If you check in a file again, the segment of the file version is increased. You can select which 
segment of the file version should be increased. 

Examples with version mask PP.PP.DD.DD: 
 
Example Old version New version 
Back segment of the file version is increased during  
checking in. 

0.0.0.1 0.0.0.2 

Front segment of the file version is increased during  
checking in. 

0.0.0.1 0.0.1.0 
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Example Old version New version 
The WinCC project was archived. After checking out the file 
and then checking it back in, the file version starts again at 
1. 

0.0.0.5 0.1.0.1 

Multiple files with different version number are checked in at 
the same time. The file with the highest version number is 
used as a base. 

File_xy: 0.0.0.4 
File_yz: 0.0.0.8 

File_xy: 0.0.0.9 
File_yz: 0.0.0.9 

Maximum number of file versions reached 

When all segments of the file versions have reached 99, you must archive the WinCC project 
again. The file version starts again at 1 when it is checked in again. 

When a file is checked out and a new project version is archived, the file remains checked 
out. After the file is checked in again, it gets the new version number. 

 

You can find additional information under: 

● WinCC project files (Page 54) 

Project versioning 
Project versioning depends on your open WinCC project.  

When you archive the project for the first time, the segment of the project version starts at 1. 
You can select which segment of the project version should be increased. 

Examples with version mask PP.PP.DD.DD: 
 
Example Old version New version 
Back segment of the project version is increased during 
checking in. 

0.1.0.0 0.2.0.0 

Front segment of the project version is increased during 
checking in. 

0.2.0.0 1.0.0.0 

Maximum number of project versions reached 

When all segments of the project versions have reached 99, you must save the  
WinCC project with a new name using the Project Duplicator. Then, archive the  
WinCC project again in Document Control and Project Versioning. The project version starts 
again at 1. 

 

You can find additional information under: 

● WinCC projects (Page 59) 
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5.3.3 WinCC project files 

5.3.3.1 Checking out project files 

Requirement 
● Your WinCC project is open. 

● Audit Document Control and Project Versioning is open and you have authenticated 
yourself. 

● Document control is enabled. 

● The version number has been configured. 

Procedure 
1. Select the category of your required file under "Document Control" in the navigation area. 

2. Select the row of the file you want to check out in the table area. 

3. Select "Check Out" in the shortcut menu to check out the file. 

4. To check out the file and immediately begin editing with the associated application, select 
"Check Out and Edit" in the shortcut menu. 

5. Enter a checkout comment if you wish. 

Result 
Your file is checked out. The status of the file in the Audit Document Control and Project 
Versioning is "Checked out". The user who authenticated the Audit Document Control and 
Project Versioning appears in the "Checked out by" column. 
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5.3.3.2 Check in project files 

Requirement 
● Your WinCC project is open. 

● Audit Document Control and Project Versioning is open and you have authenticated 
yourself. 

● Document control is enabled. 

● The version number has been configured. 

Procedure 
1. Select the category of your required file under "Document Control" in the navigation area. 

2. In the table area, select the row of the file you want to check in. 

3. Select "Check In" in the shortcut menu. 

4. To use the checkout comments for the check in, leave the  
"Continue with the existing check out comment" check box selected. 

5. To use a different comment for checking in, clear the "Continue with the existing check 
out comment" check box and enter a comment. The check-in comment is mandatory. 

6. To begin or increase the file version with the last defined segment, leave the check mark 
in the "Automatic versioning" check box. 

7. To begin or increase the file version with another segment, clear the check mark in the 
"Automatic versioning" check box. Select your required segment under "Increase 
segment version". 

8. Click "Check in". 

 

 Note 
Preventing unauthorized access to a WinCC file 

Check the file back in immediately after editing. This will prevent unauthorized persons from 
making changes to the checked-out file. 

 

Result 
Your file is checked in. The status of the file in the Audit Document Control and  
Project Versioning is "Checked in". You can find the check-in comment in the file history. 
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5.3.3.3 View File History 

Requirement 
● Your WinCC project is open. 

● Audit Document Control and Project Versioning is open and you have authenticated 
yourself. 

● Document control is enabled. 

Procedure 
1. Select the category of your required file under "Document Control" in the navigation area. 

2. Select the row of the file for which you want to display the file history. 

3. Select "View History" from the shortcut menu. 

Result 
The file history shows the user who checked in or restored the file. In addition, the check-in 
date is displayed with the time and comment. 

5.3.3.4 Restoring previous versions of archived project files 

Introduction 
If you have a versioned a WinCC project file, it is possible to restore a previous version. 

 

 NOTICE 

Do not delete project files 

If you delete the project files in your WinCC project, you cannot restore the project files in 
Audit Document Control and Project Versioning. 

To be able to restore deleted project files, create a local backup of your WinCC project. 
Connections and dynamization in the restored project files 

When you restore a previous version, connections to existing tags may no longer available, 
for example.  

Reconfigure the connections if necessary. 
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Requirement 
● Your WinCC project is open. 

● Audit Document Control and Project Versioning is open and you have authenticated 
yourself. 

● Document control is enabled. 

Procedure 
1. Select "Document Control" in the navigation area. 

2. In the table area, select the row of the file whose previous version you want to restore. 

3. Select "View History" from the shortcut menu. 

4. Select the row of the previous version in the table area. 

5. Select "Restore" from the shortcut menu. 

6. Enter a mandatory comment. 

7. To begin or increase the file version with the last defined segment, leave the "Automatic 
versioning" check box selected. 

8. To begin or increase the file version with another segment, clear the check mark in the 
"Automatic versioning" check box. Select your required segment under "Increase 
segment version". 

9. Click "Restore". 

Result 
You have restored the previous version. In the file history, you can see the version from 
which the file was restored in the comment column. 

WinCC/Audit - Documentation 
System Manual, 03/2015, A5E35727153-AA 57 



Working with Audit  
5.3 Saving and versioning WinCC project data. 

5.3.3.5 Comparing file versions with one another 

Introduction 
You can compare the current version of the file with a previous version. Using this function, 
you can see whether substantive changes have been made (binary comparison).  

Requirement 
● Your WinCC project is open. 

● Audit Document Control and Project Versioning is open and you have authenticated 
yourself. 

● Document control is enabled. 

Procedure 
1. Select "Document Control" in the navigation area. 

2. Select the row of the desired file in the table area. 

3. Select "View History" from the shortcut menu. 

4. In the table area, select the row of the previous version that you want to compare with the 
current version. 

5. Select "Compare" from the shortcut menu. 

Result 
Audit shows a dialog which indicates whether or not the two files are identical. 

5.3.4 Saving and versioning external data 
Once document control is enabled for a WinCC project, Audit creates the  
"Misc Docs (Document Control)" folder in the WinCC project directory. In this folder, you can 
save files that are not contained in your WinCC project.  

By saving them to the "Misc Docs (Document Control)" folder, the files become visible under 
"Document Control" in the navigation area. Check in the file to save it. 

You can version the files exactly as do WinCC project files. 

 

You can find additional information under: 

● WinCC project files (Page 54) 
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5.3.5 WinCC projects 

5.3.5.1 Archiving and versioning an open WinCC project 

Introduction 
The WinCC projects must be located locally on the PC on which Audit Document Control 
and Project Versioning is started. 

Requirement 
● Your WinCC project is open. 

● Audit Document Control and Project Versioning is open and you have authenticated 
yourself. 

Procedure 
1. Select "Project > Archive Project" in the menu bar. 

2. Make sure that the "Archive Current Project" option is activated. 

3. If you want a different archive path, select it using the button. 

4. Enter a comment. 

5. To begin or increase project file version with the suggested segment, leave the 
"Automatic versioning" check box selected. 

To begin or increase the project version with another segment, clear the check mark in 
the "Automatic versioning" check box. Select your required segment under  
"Increase segment version". 

6. Click "Archive." 

The WinCC project is automatically closed and re-opened after archiving. 
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5.3.5.2 Archiving and versioning a closed WinCC project 

Introduction 
The WinCC projects must be located locally on the PC on which Audit Document Control 
and Project Versioning is started. 

Requirement 
● Audit Document Control and Project Versioning is open and you have authenticated 

yourself. 

● The versioning of the closed WinCC project is configured. 

Procedure 
1. Select "Project > Archive Project" in the menu bar. 

2. Deactivate the "Archive Current Project" option and navigate to the storage path of the 
required WinCC project. 

3. If you want a different archive path, select it using the button. 

4. Enter a comment. 

5. To begin or increase project file version with the suggested segment, leave the 
"Automatic versioning" check box selected. 

To begin or increase the project version with another segment, clear the check mark in 
the "Automatic versioning" check box. Select your required segment under "Increase 
segment version". 

6. Click "Archive." 

5.3.5.3 View Project History 
There are three views for project versioning: 

 
Views Description Navigation 
Project History Project history of an archived WinCC project. Navigation area "Project Versioning" >  

in the row of the project in the table area, select > 
"View Project History" shortcut menu 

Current Project History Project history of the currently open  
WinCC project. 

Menu bar > "Project > Current Project History" 

Complete Project 
History 

Project history of all archived WinCC projects. Menu bar > "Project > Complete Project History" 

All views indicate the user who archived the projects. In addition, the archive date is 
displayed with the time and comment. 

 WinCC/Audit - Documentation 
60 System Manual, 03/2015, A5E35727153-AA 



 Working with Audit 
 5.3 Saving and versioning WinCC project data. 

5.3.5.4 Restoring previous versions of archived projects 

Introduction 
If you have versioned a WinCC project, it is possible to restore a previous version.  

Requirement 
● Your WinCC project is open. 

● Audit Document Control and Project Versioning is open and you have authenticated 
yourself. 

● The version number has been configured. 

Procedure 
1. Select "Project Versioning" in the navigation area. 

2. In the table area, select the row of the project whose previous version you want to 
restore. 

3. Select "View Project History" from the shortcut menu. 

4. Select the row of the previous version in the table area. 

5. Select "Restore" from the shortcut menu. 

A dialog box opens. 

6. Select the storage location. 

7. Confirm your entries with "OK". 
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5.4 Viewing audit trails in the Audit Viewer 

5.4.1 Viewing audit trails in the Audit Viewer 

Introduction 
You can view the audit trails from an Audit Trail single project database or from a  
Audit Trail multi-project database. 

● The audit trails of an Audit Trail multi-project database can contain different project IDs, 
since several WinCC projects use this database. 

● The audit trails of an Audit Trail single project database can also contain different project 
IDs. 

The project ID is changed in the following scenarios: 

● Copying and pasting the WinCC project to a different storage location. 

● Moving the WinCC project to a different storage location. 

● Saving the WinCC project with the Project Duplicator (with or without a name change of 
the WinCC project). 

● Restoring an archived WinCC project in Audit Document Control and Project Versioning. 
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Requirement 
● The Audit Viewer is open. 

Procedure 
1. In the navigation area, select "Audit DB". 

The table area displays all Audit Trail servers to which an Audit Trail database is 
connected.  

2. Select the required row of the Audit Trail server. 

3. Select "Select Server" in the shortcut menu. 

The selected Audit Trail server with the created database is displayed under "Audit DB" in 
the navigation area. 

The table area shows all stored audit trails. 

4. Expand the section of the navigation area below the Audit Trail server with the created 
database. 

Categories which you can use to browse the Audit Trail database are shown. 

5. Select the desired category to view the audit trail. 

Result 
The audit trails are displayed in the table area.  
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5.4.2 Audit Trail queries 
You can use Audit Trail queries to browse and filter your stored audit trails. You can perform 
the following queries: 
 
Audit Trail queries Description 
System queries System queries are pre-defined in the Audit Viewer. 
User queries You yourself define user queries. These queries are not case-

sensitive. 

"Audit type" field 

When you create a user query, enter the area from where the events come in the  
"Audit type" field. 

Use the following abbreviations: 
 
Abbreviations Meaning 
Audit DCV Audit Document Control and Project Versioning 
AU Audit Editor 
CS Configuration system 
OA User actions 
RT WinCC Runtime 

Requirement 
● The Audit Viewer is open. 

● The database containing the stored audit trails is selected. 

Procedure for system queries 
1. Select "Audit DB > Audit Trail server with the database > Query > System Query" in the 

navigation area. 

2. Select the required system query. 

3. Select "Execute" in the shortcut menu. 

 WinCC/Audit - Documentation 
64 System Manual, 03/2015, A5E35727153-AA 



 Working with Audit 
 5.4 Viewing audit trails in the Audit Viewer 

Procedure for user queries 
1. Select "Audit DB > Audit Trail server with the database > Query > User Query" in the 

navigation area. 

2. In the shortcut menu, select "New Query". 

A new query is created under "User queries". Enter an appropriate name for the query. 

3. Define the query in the table area. 

4. Select "Run" from the shortcut menu of the query. 

 

 Note 
Validating a user query 

The "Validate" command in the shortcut menu of the query has no function. 
 

Result 
You see your filtered audit trails under "<Query> - Result" in the table area. 
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5.4.3 Displaying exported audit trails 

Introduction 
You can view exported audit trails in the Audit Viewer.  

The Audit Viewer can read the following file formats: 
 
File format Product Version 
XML Audit V7.2 

V7.3 
TXT WinCC flexible 2008 or later 
CSV WinCC flexible 2008 or later 
RDB TIA V12 or later 

 

 

 Note 
Audit trail manipulations  

If there is suspicion that an export XML file has been manipulated, the Audit Viewer displays 
all audit trails of the XML file with a red background. 

 

Requirement 
● The Audit Viewer is open. 

Procedure 
1. In the navigation area, select "Audit File". 

2. Select "Show Audit File" from the shortcut menu. 

A query dialog opens. 

3. Select your file. 

4. Click "Open". 

Result 
The selected file appears under "Audit File" in the navigation area. The content of the file is 
displayed in the table area.  
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5.5 Displaying audit trails in the Audit Viewer Control 

5.5.1 Adding Audit Viewer Control in the Graphics Designer 

Introduction 
To be able to use the Audit Viewer Control in a process picture, you must first add it to the 
selection of controls in the Graphics Designer. 

Requirement 
● An Audit Trail database is connected. 

● The process picture is open in the WinCC Graphics Designer. 

Procedure 
1. Open the "Controls" tab and select the entry "Add/Remove" in the shortcut menu of the 

"ActiveX Controls" folder. 

The "Select OCX Controls" dialog is opened. 

2. Activate the "WinCC Audit Viewer Control" control in the "Available OCX Controls" area 
and confirm with "OK". 

Result 
The "WinCC AuditViewer Control" is displayed in the "Controls" tab of the "ActiveX Controls" 
folder. 
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5.5.2 Configuring the Audit Viewer Control 

Introduction 
To be able to use the Audit Viewer Control in a process picture, you need to define the 
following: 

Database names 

Select a database name. You have two database names to choose from: 
 
Database name Description 
CC_AUDIT_DATABASE Name of the Audit Trail single project database. 
AUDIT_DATABASE_MP Name of the Audit Trail multi-project database. 

Permissions 

You can specify the permissions for the Runtime operation in the Audit Viewer Control.  

Under "Properties > AuthorizationLevel", you can specify the user queries allowed for each 
user.  
 
Description Permissions in the Audit 

Viewer Control 
AuthorizationLevel 

Each user can use all functions of user 
queries.  

• Run user queries. 
• Edit user queries. 
• Delete user queries. 

Value = 0,  
no access protection 

The user logged on to WinCC Runtime 
has the permissions assigned in the User 
Administrator. The permission in the User 
Administrator corresponds to the value of 
the "AuthorizationLevel" property. 

• Run user queries. 
• Edit user queries. 
• Delete user queries. 

Value > 0 

The users logged on to WinCC Runtime 
do not have the assigned permissions in 
the User Administrator that correspond to 
the value of the "AuthorizationLevel" 
property . 

• Run user queries. Value > 0 

 WinCC/Audit - Documentation 
68 System Manual, 03/2015, A5E35727153-AA 



 Working with Audit 
 5.5 Displaying audit trails in the Audit Viewer Control 

Procedure 
1. Insert the "Audit Viewer Control" into a process picture. 

2. Double-click in the "Audit Viewer Control". 

The "Properties of WinCC AuditViewer Control" dialog opens. 

3. Enter the Audit Trail server name, for example, "VM-WIN7X86". 

4. Select the database name. 

5. Enter the maximum number of displayed audit trails. 

6. If needed, define the permission value under "AuthorizationLevel" in the properties. 

7. Confirm your entries with "OK". 

5.5.3 Displaying audit trails in the Audit Viewer Control 

Introduction 
You can browse the stored audit trails of an Audit Trail database in WinCC Runtime.  

Audit Trail queries 
You can use Audit Trail queries to browse and filter your stored audit trails.  

You can find additional information under: 

● Audit Trail queries (Page 64) 

Requirement 
● The Audit Viewer Control is configured. 

● WinCC Runtime is active. 

Procedure 
1. In the navigation area under "Audit DB", click the Audit Trail server with the created 

database . 

The table area shows all stored audit trails. 

2. Expand the section of the navigation area below the Audit Trail server with the created 
database. 

Categories which you can use to browse the Audit Trail database are shown. 

3. Select the desired category to view the audit trails or run a query. 

Result 
The audit trails are displayed in the table area.  
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5.6 Exporting audit trails to a CSV file 

Introduction 
You can export filtered audit trails to a CSV file. 

Requirement 
● The Audit Viewer is open. 

Procedure 
1. Perform a query or select a category. 

2. In the menu bar, select "File > Export to CSV". 

A query window opens. 

3. Select the storage location. 

4. Click "Export". 
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5.7 Data conversion 

Introduction 
You have the option of converting data in order to use your stored audit trails in another 
system. The Audit Editor allows you to export entries from a limited time range or a complete 
Audit Trail database. 

To export a limited time range, specify a start date and an end date with the time information. 

If you want to export the complete Audit Trail database, you do not need to specify a start 
date and an end date with time information. 

Requirement 
● Your WinCC project is open. 

● The Audit Editor is open and you have authenticated yourself. 

Procedure 
1. Open the shortcut menu under "Audit Trail" in the navigation area. 

2. Click "Export Database". 

A query window opens. 

3. Select a storage location under "Select file". 

4. To apply a date and time filter, select the "Use date filter" option under "Date filter". Enter 
the required information. 

5. To export the complete Audit Trail database, select the "Do not use date filter" option 
under "Date filter". 

6. Confirm your entries with "OK". 

Result 
The Audit Trail database is exported as an XML file. 
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 Migration 6 
6.1 Migrating audit data 

Introduction 
If you are already using Audit V7.2, you can migrate your audit configurations and your 
stored audit trails to Audit V7.3.  

 

 Note 
Migration of Audit V7.2 databases 

You can migrate the following from your Audit V7.2 single-project database to Audit V7.3: 
• Audit configuration 
• Audit trails 

You can migrate the following from your Audit V7.2 multi-project database to Audit V7.3: 
• Audit configuration 
One-time migration  

Migration can only be started once. If you do not perform the migration, the option is not 
offered again. 

If you reject a migration step, you will not have the opportunity to repeat this step. 
 

Migrating audit configurations and audit trails 
1. Open your WinCC project. 

2. Open the Audit Editor and authenticate yourself. 

The migration prompt appears asking if you want to migrate the Audit configuration of the 
previous version. 

3. Confirm with "Yes". 

4. Connect to the Audit Trail database below "Select Server". 

The migration prompt appears asking if you want to migrate the Audit database of the 
previous version. 

5. Confirm with "Yes". 

Result 
Your configuration settings are migrated in the Audit Editor. The stored audit trails of the 
previous version are migrated to the current Audit Trail database. Some of the values are 
shown in the columns whose names start with "Legacy". 
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6.2 Viewing Audit V7.2 multi-project database 

Introduction 
You have two options for viewing the audit trail of an Audit V7.2 multi-project database. 

WinCC and Audit V7.2 are still installed on your PC 
1. Export the Audit Trails from the multi project database in Audit Editor V7.2. 

2. Upgrade to WinCC and Audit V7.3. 

3. View the exported Audit Trails in Audit Viewer V7.3. 

WinCC and Audit V7.3 are already installed on your PC 
If you have already installed WinCC and Audit V7.3 on your PC, follow these steps: 

1. Do not uninstall Audit Viewer V7.2 and Audit Viewer Control V7.2. 

2. View the multi-project database in Audit Viewer V7.2 or Audit Viewer Control V7.2. 
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6.3 Migrating Document Control and Project Versioning 
The archive of Document Control and Project Versioning from Audit V7.2 cannot be migrated 
to Audit V7.3. 

You must rebuild the document control again after the Audit V7.3 installation: 

● Enable document control in the Audit Document Control and Project Versioning. 

This checks in and saves all the WinCC project files of your opened WinCC project. 

● Archive your WinCC project in Audit Document Control and Project Versioning. 

 

You can find additional information under: 

● Saving and versioning WinCC project data. (Page 48) 
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6.4 Migrating user administration 
Internal user administration can no longer be performed in the Audit Editor in Audit V7.3.  

If you have enabled "SIMATIC Logon" in Audit V7.2, you can also use the configuration in 
the Windows User Management in Audit 7.3. 

The "Audit-Admin" and "Audit-DocControl" groups are no longer relevant in Audit V7.3, only 
the "SIMATIC HMI AUDIT" user group.  

Therefore, move all members of the "Audit-Admin" and "Audit-DocControl" groups in the 
Windows User and Group Management to the "SIMATIC HMI AUDIT" user group. 

 

You can find additional information in the installation notes under "User Authentication". 
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6.5 InsertAuditEntry 

Introduction 
If you use the "InsertAuditEntry" function of Audit V7.2 in a WinCC project, you can continue 
to use the function with Audit V7.3. 

It is not necessary to change your scripts. 

Some of the values from the "InsertAuditEntry" will appear in the Audit Trail database in 
columns whose names begin with "Legacy".  

InsertAuditEntryNew 

For all new WinCC projects, use the "InserAuditEntryNew" function. 

 

You can find additional information under: 

● InsertAuditEntryNew (Page 44) 

InsertAuditEntry in the Script Editor or in the Graphics Designer 

C Editor/Graphics Designer 

You can find the InsertAuditEntry function in the navigation area under "Project Functions". 
 

 Note 
Regenerating the header 

If the "InsertAuditEntry" function is not visible, you need to re-generate the header in the  
C Editor. 

 

VBS Editor/Graphics Designer 

You can find the InsertAuditEntry function in the navigation area under "Project Modules". 
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